Quick Question on 2 VLANs and One Router

Discussion in 'Cisco' started by Peter Rowe, Oct 27, 2003.

  1. Peter Rowe

    Peter Rowe Guest

    Hi There,

    I have a client who has 2 2950 Catalyst switches (not used yet) and one Internet router (a 1601 I believe just now)

    Now, what he wants set up is 2 completely seperate VLANs (not a problem) But they need to access the Internet via the router but never be able to 'speak' to each other.

    From what I have read I can create a 'router on a stick' whereby i create an ISL link to a fastethernet interface on a router (so I'll have to add a 1710 or better?)

    Does anyone have any guidelines here or even better a sample config to show a good way of doing this? (I am new to Cisco switching but can do basic router setup.)

    thanks.
    Peter Rowe, Oct 27, 2003
    #1
    1. Advertising

  2. Peter Rowe

    Chad Whitten Guest

    yes, you will need another router that supports trunking on the fast
    ethernet interface. i know that the 1760's support this but dont have any
    experience with anything less

    anyway here is how you do it
    vlans are 10 and 20 in this instance

    on the switch side, configure a port for the router like
    (i use dot1q and not ISL trunking)
    interface FastEthernet0/1
    description Uplink to 1760 Router
    duplex full
    speed 100
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20
    switchport mode trunk

    you will also need to configure a port for trunking between the two switches
    like this

    interface FastEthernet0/24
    description Uplink to Switch
    duplex full
    speed 100
    switchport trunk encapsulation dot1q
    switchport mode trunk

    you will also need to create your vlans in the vlan database, create and "no
    shut" the vlan interfaces on the switch

    on the router, configure the ethernet port like
    interface FastEthernet0/0
    description Lan
    no ip address
    load-interval 30
    speed 100
    full-duplex
    !
    interface FastEthernet0/0.1
    description Vlan_20
    encapsulation dot1Q 20
    ip address 192.168.2.1 255.255.255.0
    !
    interface FastEthernet0/0.2
    description Vlan_10
    encapsulation dot1Q 10
    ip address 192.168.1.1 255.255.255.0


    you can add any ip helper or other ip commands to the subinterfaces.
    finally, setup your routing just like you would if you had two interfaces.


    Peter Rowe wrote:

    > Hi There,
    >
    > I have a client who has 2 2950 Catalyst switches (not used yet) and one
    > Internet router (a 1601 I believe just now)
    >
    > Now, what he wants set up is 2 completely seperate VLANs (not a problem)
    > But they need to access the Internet via the router but never be able to
    > 'speak' to each other.
    >
    > From what I have read I can create a 'router on a stick' whereby i create
    > an ISL link to a fastethernet interface on a router (so I'll have to add a
    > 1710 or better?)
    >
    > Does anyone have any guidelines here or even better a sample config to
    > show a good way of doing this? (I am new to Cisco switching but can do
    > basic router setup.)
    >
    > thanks.


    --
    Chad Whitten
    Network/Systems Administrator
    neXband Communications

    601-944-4801
    Chad Whitten, Oct 27, 2003
    #2
    1. Advertising

  3. Peter Rowe

    Peter Rowe Guest

    Brilliant Chad,

    many thanks, exactly what I was looking for.

    All the best,
    Peter.

    >>> Chad Whitten<> 27/10/2003 18:56:58 >>>

    yes, you will need another router that supports trunking on the fast
    ethernet interface. i know that the 1760's support this but dont have any
    experience with anything less

    anyway here is how you do it
    vlans are 10 and 20 in this instance

    on the switch side, configure a port for the router like
    (i use dot1q and not ISL trunking)
    interface FastEthernet0/1
    description Uplink to 1760 Router
    duplex full
    speed 100
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20
    switchport mode trunk

    you will also need to configure a port for trunking between the two switches
    like this

    interface FastEthernet0/24
    description Uplink to Switch
    duplex full
    speed 100
    switchport trunk encapsulation dot1q
    switchport mode trunk

    you will also need to create your vlans in the vlan database, create and "no
    shut" the vlan interfaces on the switch

    on the router, configure the ethernet port like
    interface FastEthernet0/0
    description Lan
    no ip address
    load-interval 30
    speed 100
    full-duplex
    !
    interface FastEthernet0/0.1
    description Vlan_20
    encapsulation dot1Q 20
    ip address 192.168.2.1 255.255.255.0
    !
    interface FastEthernet0/0.2
    description Vlan_10
    encapsulation dot1Q 10
    ip address 192.168.1.1 255.255.255.0


    you can add any ip helper or other ip commands to the subinterfaces.
    finally, setup your routing just like you would if you had two interfaces.


    Peter Rowe wrote:

    > Hi There,
    >
    > I have a client who has 2 2950 Catalyst switches (not used yet) and one
    > Internet router (a 1601 I believe just now)
    >
    > Now, what he wants set up is 2 completely seperate VLANs (not a problem)
    > But they need to access the Internet via the router but never be able to
    > 'speak' to each other.
    >
    > From what I have read I can create a 'router on a stick' whereby i create
    > an ISL link to a fastethernet interface on a router (so I'll have to add a
    > 1710 or better?)
    >
    > Does anyone have any guidelines here or even better a sample config to
    > show a good way of doing this? (I am new to Cisco switching but can do
    > basic router setup.)
    >
    > thanks.


    --
    Chad Whitten
    Network/Systems Administrator
    neXband Communications

    601-944-4801
    Peter Rowe, Oct 28, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    0
    Views:
    555
  2. punisher
    Replies:
    2
    Views:
    2,063
    Charles Deling
    Nov 17, 2005
  3. Croos Bustamunky

    Quick Restore for a Compaq not so quick!

    Croos Bustamunky, May 15, 2004, in forum: Computer Support
    Replies:
    2
    Views:
    5,621
    Ryan 8088
    May 15, 2004
  4. ~misfit~

    Quick question, hopefully quick answer.

    ~misfit~, Dec 28, 2004, in forum: NZ Computing
    Replies:
    114
    Views:
    2,370
    Troglodyte
    Jan 6, 2005
  5. unix
    Replies:
    2
    Views:
    767
    Scott Lowe
    May 26, 2010
Loading...

Share This Page