Quick help needed: Adding IP scope passthrough on cisco 828

Discussion in 'Cisco' started by Lars Bonnesen, Jun 14, 2006.

  1. I have a cisco 828 router which is passing all traffic into our firewall.

    sh running gives me this (among other):

    ip nat inside source list 2 interface BVI1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 z.x.c.v
    ip route a.b.c.d 255.255.255.248 10.10.10.5
    ip http server


    The "problem" is that now we get a new set of IP addresses (because of more
    IP's needed)

    How do I edit the above to pass all trafic from
    ip q.w.e.r subnet 255.255.255.240 to IP 10.10.10.5
    instead of ip route a.b.c.d 255.255.255.248 10.10.10.5
    ?

    Regards, Lars.
     
    Lars Bonnesen, Jun 14, 2006
    #1
    1. Advertising

  2. Lars Bonnesen

    Merv Guest


    > How do I edit the above to pass all trafic from
    > ip q.w.e.r subnet 255.255.255.240 to IP 10.10.10.5
    > instead of ip route a.b.c.d 255.255.255.248 10.10.10.5


    conf t
    no ip route a.b.c.d 255.255.255.248 10.10.10.5
    ip route q.w.e.r 255.255.255.240 10.10.10.5
    exit

    wri mem

    sh ip route static
     
    Merv, Jun 14, 2006
    #2
    1. Advertising

  3. "Merv" <> skrev i en meddelelse
    news:...
    >
    >> How do I edit the above to pass all trafic from
    >> ip q.w.e.r subnet 255.255.255.240 to IP 10.10.10.5
    >> instead of ip route a.b.c.d 255.255.255.248 10.10.10.5

    >
    > conf t


    What does conf t mean? you thing config?

    > no ip route a.b.c.d 255.255.255.248 10.10.10.5
    > ip route q.w.e.r 255.255.255.240 10.10.10.5
    > exit


    that simple?

    > wri mem


    Or copy runnning-config startup-config ?
     
    Lars Bonnesen, Jun 14, 2006
    #3
  4. Lars Bonnesen

    SAto Guest

    Lars Bonnesen skrev:
    > I have a cisco 828 router which is passing all traffic into our firewall.
    >
    > sh running gives me this (among other):
    >
    > ip nat inside source list 2 interface BVI1 overload
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 z.x.c.v
    > ip route a.b.c.d 255.255.255.248 10.10.10.5
    > ip http server
    >
    >
    > The "problem" is that now we get a new set of IP addresses (because of more
    > IP's needed)
    >
    > How do I edit the above to pass all trafic from
    > ip q.w.e.r subnet 255.255.255.240 to IP 10.10.10.5
    > instead of ip route a.b.c.d 255.255.255.248 10.10.10.5


    typing the following in the config mode should do the trick:

    ip route q.w.e.r 255.255.255.240 10.10.10.5
    no ip route a.b.c.d 255.255.255.248 10.10.10.5

    Also please note the NAT access list, you may need to change that as
    well to provide NATing for the new addresses.

    -SAto
     
    SAto, Jun 14, 2006
    #4
  5. Lars Bonnesen

    SAto Guest

    Lars Bonnesen skrev:
    > "Merv" <> skrev i en meddelelse
    > > conf t

    >
    > What does conf t mean? you thing config?


    that is the command used to enter configuration mode
    (actually an abbreviation of "configure terminal").

    > > no ip route a.b.c.d 255.255.255.248 10.10.10.5
    > > ip route q.w.e.r 255.255.255.240 10.10.10.5
    > > exit

    >
    > that simple?


    Yes

    > > wri mem

    >
    > Or copy runnning-config startup-config ?


    Yes

    -SAto
     
    SAto, Jun 14, 2006
    #5
  6. "SAto" <> skrev i en meddelelse
    news:...

    > Also please note the NAT access list, you may need to change that as
    > well to provide NATing for the new addresses.


    The only thing regarding this is:

    ip address 10.10.10.1 255.255.255.0
    ip nat inside

    interface BVI1
    ip address a.b.c.d 255.255.255.252
    ip nat outside

    access-list 2 permit 10.10.10.0 0.0.0.255
    access-list 23 permit 10.10.10.0 0.0.0.255

    Nothing more regaring NAT.

    But I have tried (as a test) to add y.y.y.y 255.255.255.255 10.10.10.5
    (without saveing and restarting), and it does not show up in the sh ip route
    or sh config. Do I need to save and reboot it in order to have it here?

    Regards, Lars.
     
    Lars Bonnesen, Jun 14, 2006
    #6
  7. "Lars Bonnesen" <none@none.æøå> skrev i en meddelelse
    news:44900dec$0$139$...
    >
    > "Merv" <> skrev i en meddelelse
    > news:...
    >>
    >>> How do I edit the above to pass all trafic from
    >>> ip q.w.e.r subnet 255.255.255.240 to IP 10.10.10.5
    >>> instead of ip route a.b.c.d 255.255.255.248 10.10.10.5

    >>
    >> conf t

    >
    > What does conf t mean? you thing config?


    Ok, now I get it - config terminal... (-;

    Regards, Lars.
     
    Lars Bonnesen, Jun 14, 2006
    #7
  8. Lars Bonnesen

    SAto Guest

    Lars Bonnesen skrev:
    > access-list 2 permit 10.10.10.0 0.0.0.255
    >
    > Nothing more regaring NAT.


    As long as the new network you are adding does not need to be NATed you
    should be good. This access list will allow only addresses in the
    10.10.10.1-254 range to be NATed.

    > But I have tried (as a test) to add y.y.y.y 255.255.255.255 10.10.10.5
    > (without saveing and restarting), and it does not show up in the sh ip route
    > or sh config. Do I need to save and reboot it in order to have it here?


    No, there should be no need to either save nor reboot. are you sure the
    command is entered correctly?

    conf t
    ip route y.y.y.y 255.255.255.255 10.10.10.5

    the mask you supply above is a host mask, probably not what you want
    for that network but it should display in the routing table and the "sh
    running" command.

    The "sh config" command only displays configuration that is saved with
    the wr mem or copy run start commands.


    -SAto
     
    SAto, Jun 15, 2006
    #8
  9. It is working as expected and very nicely. Thanks to all of you.,

    Regards, Lars.

    "SAto" <> skrev i en meddelelse
    news:...
    >
    > Lars Bonnesen skrev:
    >> access-list 2 permit 10.10.10.0 0.0.0.255
    >>
    >> Nothing more regaring NAT.

    >
    > As long as the new network you are adding does not need to be NATed you
    > should be good. This access list will allow only addresses in the
    > 10.10.10.1-254 range to be NATed.
    >
    >> But I have tried (as a test) to add y.y.y.y 255.255.255.255 10.10.10.5
    >> (without saveing and restarting), and it does not show up in the sh ip
    >> route
    >> or sh config. Do I need to save and reboot it in order to have it here?

    >
    > No, there should be no need to either save nor reboot. are you sure the
    > command is entered correctly?
    >
    > conf t
    > ip route y.y.y.y 255.255.255.255 10.10.10.5
    >
    > the mask you supply above is a host mask, probably not what you want
    > for that network but it should display in the routing table and the "sh
    > running" command.
    >
    > The "sh config" command only displays configuration that is saved with
    > the wr mem or copy run start commands.
    >
    >
    > -SAto
    >
     
    Lars Bonnesen, Jun 15, 2006
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Lars L. Christensen

    G.SHDSL 828-to-828

    Lars L. Christensen, Dec 16, 2004, in forum: Cisco
    Replies:
    2
    Views:
    1,340
    Igor Mamuziæ
    Dec 17, 2004
  2. Kifla a.k.a. F. Stratocaster

    "passthrough" modem on Cisco 2500

    Kifla a.k.a. F. Stratocaster, Apr 14, 2005, in forum: Cisco
    Replies:
    1
    Views:
    639
    Aaron Leonard
    Apr 14, 2005
  3. Replies:
    4
    Views:
    55,117
    gsingle
    Jul 14, 2006
  4. Replies:
    4
    Views:
    498
    George K
    Nov 20, 2006
  5. Lars Bonnesen

    Cisco 828 passthrough

    Lars Bonnesen, Mar 26, 2007, in forum: Cisco
    Replies:
    0
    Views:
    640
    Lars Bonnesen
    Mar 26, 2007
Loading...

Share This Page