QUESTION: Unable to ping between Router 1 and Router 3

Discussion in 'Cisco' started by Voitec, Sep 12, 2004.

  1. Voitec

    Voitec Guest

    Hi,

    2nd prob for the day; I'm unable to ping between:
    Router 2 s1 <> Router 3 s0

    Can anyone pls correct the following config if necessary? Are all those
    items listed below needed or can I get rid of certain items? I'm trying to
    have as basic a config as necessary for bare connectivity.

    Many thanks,
    Voitec



    ROUTER 1
    *********
    !
    interface Serial1
    ip address 192.169.15.1 255.255.255.0
    no ip directed-broadcast
    clockrate 64000
    !
    router rip
    network 192.169.0.0
    !
    no ip classless
    ip route 172.17.0.0 255.255.0.0 192.169.15.2
    !


    ROUTER 2
    *********
    !
    interface Serial0
    ip address 172.17.0.1 255.255.0.0
    no ip route-cache
    no ip mroute-cache
    clockrate 64000
    !
    interface Serial1
    ip address 192.169.15.2 255.255.255.0
    no ip route-cache
    no ip mroute-cache
    !
    router rip
    network 172.17.0.0
    network 192.169.0.0
    !
    no ip classless
    !


    ROUTER 3
    *********
    !
    interface Serial0
    ip address 172.17.0.2 255.255.0.0
    no ip mroute-cache
    !
    interface Serial1
    ip address 192.168.15.3 255.255.255.0
    clockrate 64000
    !
    router rip
    network 172.17.0.0
    network 192.169.0.0
    !
    no ip classless
    !
    Voitec, Sep 12, 2004
    #1
    1. Advertising

  2. Voitec

    PES Guest

    "Voitec" <> wrote in message
    news:UhV0d.28112$...
    > Hi,
    >
    > 2nd prob for the day; I'm unable to ping between:
    > Router 2 s1 <> Router 3 s0
    >
    > Can anyone pls correct the following config if necessary? Are all those
    > items listed below needed or can I get rid of certain items? I'm trying to
    > have as basic a config as necessary for bare connectivity.
    >
    > Many thanks,
    > Voitec
    >


    Is router 3 s0 physically connected to r1 s1, or r2 s1? Or is r1 s1
    connected to r2 s1? In any case, I would say it is impossible for you to
    connect 3 point to point connections together, the way your configuration
    suggests.

    >
    >
    > ROUTER 1
    > *********
    > !
    > interface Serial1
    > ip address 192.169.15.1 255.255.255.0
    > no ip directed-broadcast
    > clockrate 64000
    > !
    > router rip
    > network 192.169.0.0
    > !
    > no ip classless
    > ip route 172.17.0.0 255.255.0.0 192.169.15.2


    What is this static for? Rip should give you the routing table.

    > !
    >
    >
    > ROUTER 2
    > *********
    > !
    > interface Serial0
    > ip address 172.17.0.1 255.255.0.0
    > no ip route-cache
    > no ip mroute-cache
    > clockrate 64000
    > !
    > interface Serial1
    > ip address 192.169.15.2 255.255.255.0
    > no ip route-cache
    > no ip mroute-cache
    > !
    > router rip
    > network 172.17.0.0
    > network 192.169.0.0
    > !
    > no ip classless
    > !
    >
    >
    > ROUTER 3
    > *********
    > !
    > interface Serial0
    > ip address 172.17.0.2 255.255.0.0
    > no ip mroute-cache
    > !
    > interface Serial1
    > ip address 192.168.15.3 255.255.255.0
    > clockrate 64000
    > !
    > router rip
    > network 172.17.0.0
    > network 192.169.0.0
    > !
    > no ip classless
    > !
    >
    >
    PES, Sep 12, 2004
    #2
    1. Advertising

  3. In article <UhV0d.28112$>,
    "Voitec" <> wrote:

    > Hi,
    >
    > 2nd prob for the day; I'm unable to ping between:
    > Router 2 s1 <> Router 3 s0


    Your subject line says the problem is between Router 1 and Router 3, but
    now you're asking about Router 2 and Router 3. Which is it?

    >
    > Can anyone pls correct the following config if necessary? Are all those
    > items listed below needed or can I get rid of certain items? I'm trying to
    > have as basic a config as necessary for bare connectivity.
    >
    > Many thanks,
    > Voitec
    >
    >
    >
    > ROUTER 1
    > *********
    > !
    > interface Serial1
    > ip address 192.169.15.1 255.255.255.0
    > no ip directed-broadcast
    > clockrate 64000
    > !
    > router rip
    > network 192.169.0.0


    Shouldn't this be "network 192.168.15.0", since your interface has a
    Class C address? Or do you have a 192.169.0.x address on some other
    interface that you're not showing?

    > !
    > no ip classless
    > ip route 172.17.0.0 255.255.0.0 192.169.15.2
    > !
    >
    >
    > ROUTER 2
    > *********
    > !
    > interface Serial0
    > ip address 172.17.0.1 255.255.0.0
    > no ip route-cache
    > no ip mroute-cache
    > clockrate 64000
    > !
    > interface Serial1
    > ip address 192.169.15.2 255.255.255.0
    > no ip route-cache
    > no ip mroute-cache
    > !
    > router rip
    > network 172.17.0.0
    > network 192.169.0.0
    > !
    > no ip classless
    > !
    >
    >
    > ROUTER 3
    > *********
    > !
    > interface Serial0
    > ip address 172.17.0.2 255.255.0.0
    > no ip mroute-cache
    > !
    > interface Serial1
    > ip address 192.168.15.3 255.255.255.0
    > clockrate 64000
    > !
    > router rip
    > network 172.17.0.0
    > network 192.169.0.0
    > !
    > no ip classless
    > !


    --
    Barry Margolin,
    Arlington, MA
    *** PLEASE post questions in newsgroups, not directly to me ***
    Barry Margolin, Sep 12, 2004
    #3
  4. Voitec

    Voitec Guest

    Yes, sorry, just realised the typo.

    I'm unable to ping between Router3 s0 and Router 2 s1, ie. 172.17.0.2 and
    192.169.15.2. This in turn means I cannot ping between 172.17.0.2 and
    192.169.15.1 (which is Router 1 s1).

    Physical connections are as follows:
    Router 3 s0 <> Router 2 s0 (DCE)
    Router 2 s1 <> Router 1 s1 (DCE)

    Apologies for the confusion.


    "Barry Margolin" <> wrote in message
    news:...
    > In article <UhV0d.28112$>,
    > "Voitec" <> wrote:
    >
    > > Hi,
    > >
    > > 2nd prob for the day; I'm unable to ping between:
    > > Router 2 s1 <> Router 3 s0

    >
    > Your subject line says the problem is between Router 1 and Router 3, but
    > now you're asking about Router 2 and Router 3. Which is it?
    >
    > >
    > > Can anyone pls correct the following config if necessary? Are all those
    > > items listed below needed or can I get rid of certain items? I'm trying

    to
    > > have as basic a config as necessary for bare connectivity.
    > >
    > > Many thanks,
    > > Voitec
    > >
    > >
    > >
    > > ROUTER 1
    > > *********
    > > !
    > > interface Serial1
    > > ip address 192.169.15.1 255.255.255.0
    > > no ip directed-broadcast
    > > clockrate 64000
    > > !
    > > router rip
    > > network 192.169.0.0

    >
    > Shouldn't this be "network 192.168.15.0", since your interface has a
    > Class C address? Or do you have a 192.169.0.x address on some other
    > interface that you're not showing?
    >
    > > !
    > > no ip classless
    > > ip route 172.17.0.0 255.255.0.0 192.169.15.2
    > > !
    > >
    > >
    > > ROUTER 2
    > > *********
    > > !
    > > interface Serial0
    > > ip address 172.17.0.1 255.255.0.0
    > > no ip route-cache
    > > no ip mroute-cache
    > > clockrate 64000
    > > !
    > > interface Serial1
    > > ip address 192.169.15.2 255.255.255.0
    > > no ip route-cache
    > > no ip mroute-cache
    > > !
    > > router rip
    > > network 172.17.0.0
    > > network 192.169.0.0
    > > !
    > > no ip classless
    > > !
    > >
    > >
    > > ROUTER 3
    > > *********
    > > !
    > > interface Serial0
    > > ip address 172.17.0.2 255.255.0.0
    > > no ip mroute-cache
    > > !
    > > interface Serial1
    > > ip address 192.168.15.3 255.255.255.0
    > > clockrate 64000
    > > !
    > > router rip
    > > network 172.17.0.0
    > > network 192.169.0.0
    > > !
    > > no ip classless
    > > !

    >
    > --
    > Barry Margolin,
    > Arlington, MA
    > *** PLEASE post questions in newsgroups, not directly to me ***
    Voitec, Sep 12, 2004
    #4
  5. Voitec

    PES Guest

    "Voitec" <> wrote in message
    news:BZX0d.28491$...
    > Yes, sorry, just realised the typo.
    >
    > I'm unable to ping between Router3 s0 and Router 2 s1, ie. 172.17.0.2 and
    > 192.169.15.2. This in turn means I cannot ping between 172.17.0.2 and
    > 192.169.15.1 (which is Router 1 s1).
    >
    > Physical connections are as follows:
    > Router 3 s0 <> Router 2 s0 (DCE)
    > Router 2 s1 <> Router 1 s1 (DCE)
    >
    > Apologies for the confusion.


    After reading Barry's post and this post closer, I realize I previously made
    a mistake. I mistaked 192.169. for 192.168 and thought all three interfaces
    were on the same subnet. I do see an issue with rip. In the network
    statement for rip you have 192.169.0.0. Since 192 is class C, if you had
    typed in 192.169.15.0 (which would be correct), it would show in the config
    file. If you typed 172.17.15.0 in the config, it would show 172.17.0.0. I
    guess what I am trying to say is that rip is configured wrong. You need to
    configure Rip on r2 and r1 with a network of 192.169.15.0. If it still
    doesn't work check to make sure all interfaces are up/up, then post a show
    ip route from each router.

    >
    >
    > "Barry Margolin" <> wrote in message
    > news:...
    >> In article <UhV0d.28112$>,
    >> "Voitec" <> wrote:
    >>
    >> > Hi,
    >> >
    >> > 2nd prob for the day; I'm unable to ping between:
    >> > Router 2 s1 <> Router 3 s0

    >>
    >> Your subject line says the problem is between Router 1 and Router 3, but
    >> now you're asking about Router 2 and Router 3. Which is it?
    >>
    >> >
    >> > Can anyone pls correct the following config if necessary? Are all those
    >> > items listed below needed or can I get rid of certain items? I'm trying

    > to
    >> > have as basic a config as necessary for bare connectivity.
    >> >
    >> > Many thanks,
    >> > Voitec
    >> >
    >> >
    >> >
    >> > ROUTER 1
    >> > *********
    >> > !
    >> > interface Serial1
    >> > ip address 192.169.15.1 255.255.255.0
    >> > no ip directed-broadcast
    >> > clockrate 64000
    >> > !
    >> > router rip
    >> > network 192.169.0.0

    >>
    >> Shouldn't this be "network 192.168.15.0", since your interface has a
    >> Class C address? Or do you have a 192.169.0.x address on some other
    >> interface that you're not showing?
    >>
    >> > !
    >> > no ip classless
    >> > ip route 172.17.0.0 255.255.0.0 192.169.15.2
    >> > !
    >> >
    >> >
    >> > ROUTER 2
    >> > *********
    >> > !
    >> > interface Serial0
    >> > ip address 172.17.0.1 255.255.0.0
    >> > no ip route-cache
    >> > no ip mroute-cache
    >> > clockrate 64000
    >> > !
    >> > interface Serial1
    >> > ip address 192.169.15.2 255.255.255.0
    >> > no ip route-cache
    >> > no ip mroute-cache
    >> > !
    >> > router rip
    >> > network 172.17.0.0
    >> > network 192.169.0.0
    >> > !
    >> > no ip classless
    >> > !
    >> >
    >> >
    >> > ROUTER 3
    >> > *********
    >> > !
    >> > interface Serial0
    >> > ip address 172.17.0.2 255.255.0.0
    >> > no ip mroute-cache
    >> > !
    >> > interface Serial1
    >> > ip address 192.168.15.3 255.255.255.0
    >> > clockrate 64000
    >> > !
    >> > router rip
    >> > network 172.17.0.0
    >> > network 192.169.0.0
    >> > !
    >> > no ip classless
    >> > !

    >>
    >> --
    >> Barry Margolin,
    >> Arlington, MA
    >> *** PLEASE post questions in newsgroups, not directly to me ***

    >
    >
    PES, Sep 12, 2004
    #5
  6. Voitec

    mh Guest

    change the network command under the rip routing process for network 192.168.15.0


    router rip
    no network 192.168.0.0
    network 192.168.15.0
    exit
    mh, Sep 12, 2004
    #6
  7. Voitec

    Voitec Guest

    That was it! Totally missed the 3rd octet in the 192.169.x.x range when
    configuring RIP.
    Thanks very much :)


    "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in message
    news:41445764$...
    >
    > "Voitec" <> wrote in message
    > news:BZX0d.28491$...
    > > Yes, sorry, just realised the typo.
    > >
    > > I'm unable to ping between Router3 s0 and Router 2 s1, ie. 172.17.0.2

    and
    > > 192.169.15.2. This in turn means I cannot ping between 172.17.0.2 and
    > > 192.169.15.1 (which is Router 1 s1).
    > >
    > > Physical connections are as follows:
    > > Router 3 s0 <> Router 2 s0 (DCE)
    > > Router 2 s1 <> Router 1 s1 (DCE)
    > >
    > > Apologies for the confusion.

    >
    > After reading Barry's post and this post closer, I realize I previously

    made
    > a mistake. I mistaked 192.169. for 192.168 and thought all three

    interfaces
    > were on the same subnet. I do see an issue with rip. In the network
    > statement for rip you have 192.169.0.0. Since 192 is class C, if you had
    > typed in 192.169.15.0 (which would be correct), it would show in the

    config
    > file. If you typed 172.17.15.0 in the config, it would show 172.17.0.0.

    I
    > guess what I am trying to say is that rip is configured wrong. You need

    to
    > configure Rip on r2 and r1 with a network of 192.169.15.0. If it still
    > doesn't work check to make sure all interfaces are up/up, then post a show
    > ip route from each router.
    >
    > >
    > >
    > > "Barry Margolin" <> wrote in message
    > > news:...
    > >> In article <UhV0d.28112$>,
    > >> "Voitec" <> wrote:
    > >>
    > >> > Hi,
    > >> >
    > >> > 2nd prob for the day; I'm unable to ping between:
    > >> > Router 2 s1 <> Router 3 s0
    > >>
    > >> Your subject line says the problem is between Router 1 and Router 3,

    but
    > >> now you're asking about Router 2 and Router 3. Which is it?
    > >>
    > >> >
    > >> > Can anyone pls correct the following config if necessary? Are all

    those
    > >> > items listed below needed or can I get rid of certain items? I'm

    trying
    > > to
    > >> > have as basic a config as necessary for bare connectivity.
    > >> >
    > >> > Many thanks,
    > >> > Voitec
    > >> >
    > >> >
    > >> >
    > >> > ROUTER 1
    > >> > *********
    > >> > !
    > >> > interface Serial1
    > >> > ip address 192.169.15.1 255.255.255.0
    > >> > no ip directed-broadcast
    > >> > clockrate 64000
    > >> > !
    > >> > router rip
    > >> > network 192.169.0.0
    > >>
    > >> Shouldn't this be "network 192.168.15.0", since your interface has a
    > >> Class C address? Or do you have a 192.169.0.x address on some other
    > >> interface that you're not showing?
    > >>
    > >> > !
    > >> > no ip classless
    > >> > ip route 172.17.0.0 255.255.0.0 192.169.15.2
    > >> > !
    > >> >
    > >> >
    > >> > ROUTER 2
    > >> > *********
    > >> > !
    > >> > interface Serial0
    > >> > ip address 172.17.0.1 255.255.0.0
    > >> > no ip route-cache
    > >> > no ip mroute-cache
    > >> > clockrate 64000
    > >> > !
    > >> > interface Serial1
    > >> > ip address 192.169.15.2 255.255.255.0
    > >> > no ip route-cache
    > >> > no ip mroute-cache
    > >> > !
    > >> > router rip
    > >> > network 172.17.0.0
    > >> > network 192.169.0.0
    > >> > !
    > >> > no ip classless
    > >> > !
    > >> >
    > >> >
    > >> > ROUTER 3
    > >> > *********
    > >> > !
    > >> > interface Serial0
    > >> > ip address 172.17.0.2 255.255.0.0
    > >> > no ip mroute-cache
    > >> > !
    > >> > interface Serial1
    > >> > ip address 192.168.15.3 255.255.255.0
    > >> > clockrate 64000
    > >> > !
    > >> > router rip
    > >> > network 172.17.0.0
    > >> > network 192.169.0.0
    > >> > !
    > >> > no ip classless
    > >> > !
    > >>
    > >> --
    > >> Barry Margolin,
    > >> Arlington, MA
    > >> *** PLEASE post questions in newsgroups, not directly to me ***

    > >
    > >

    >
    >
    Voitec, Sep 12, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ATM
    Replies:
    2
    Views:
    5,967
    Stephen
    Nov 13, 2008
  2. jorgeantibes

    I do ping others and viceversa but, cannot ping myself

    jorgeantibes, May 15, 2009, in forum: Wireless Networking
    Replies:
    0
    Views:
    528
    jorgeantibes
    May 15, 2009
  3. mark256789
    Replies:
    2
    Views:
    1,334
  4. superkingkong
    Replies:
    2
    Views:
    1,769
    superkingkong
    Apr 17, 2010
  5. verve13
    Replies:
    0
    Views:
    760
    verve13
    Sep 7, 2012
Loading...

Share This Page