Question about QoS over frame-relay

Discussion in 'Cisco' started by ttripp, Feb 28, 2008.

  1. ttripp

    ttripp Guest

    My question is about appling QoS over a frame-relay subinterface. I
    inherited an MPLS network that has mostly T1s on the CE end of things,
    but a few locations have frame-relay connections instead. A typical
    frame-relay setup looks something like this:

    On the physical interface:
    ---------------------------------------------------------------------------
    interface Serial0/1/0
    bandwidth 1536
    no ip address
    max-reserved-bandwidth 100
    encapsulation frame-relay IETF
    load-interval 30
    no fair-queue
    service-module t1 remote-alarm-enable
    frame-relay traffic-shaping
    frame-relay lmi-type ansi
    hold-queue 40 out

    On the subinterface:
    ----------------------------------------------------------------------------
    interface Serial0/1/0.525 point-to-point
    bandwidth 1536
    ip address 10.254.240.2 255.255.255.252
    ip verify unicast reverse-path allow-self-ping
    no ip redirects
    no ip unreachables
    ip virtual-reassembly
    frame-relay interface-dlci 702
    class VOIPovFR


    The frame-relay map class:
    ---------------------------------------------------------------------------
    map-class frame-relay VOIPovFR
    frame-relay cir 1536000
    frame-relay bc 15360
    frame-relay be 0
    frame-relay mincir 1536000
    service-policy output QOSpolicy

    The QoS policy & class maps:
    ------------------------------------------------------------------------------
    class-map match-any REAL-TIME
    match ip dscp ef
    class-map match-any CRITICAL-DATA
    match ip dscp af41
    match protocol h323
    class-map match-any TRANSACTIONAL-DATA
    match access-group 110
    match access-group 111
    (I'm leaving out the access-lists, as they are extensive, and I'm not
    worried about them right this moment.)

    policy-map QOSpoliy
    description Based on telco's recommended settings
    class REAL-TIME
    priority percent 35
    police cir percent 35
    conform-action transmit
    exceed-action set-dscp-transmit 0
    class CRITICAL-DATA
    set dscp af41
    police cir percent 35
    conform-action transmit
    exceed-action set-dscp-transmit 0
    class TRANSACTIONAL-DATA
    set ip dscp af21
    police cir percent 20
    conform-action transmit
    exceed-action set-dscp-transmit 0
    class class-default
    police cir percent 10
    conform-action transmit
    exceed-action transmit


    Everything looks OK to me, but since I've not worked with QoS over
    frame-relay, I'm not 100% sure this is a proper setup. One thing I
    noticed is that I cannot generate a graph of QoS statistics using SDM,
    which I have no problem doing with my CEs that are using T1. Is it
    not possible to use SDM to view those stats, and if not, is there a
    command-line equivilant?

    Thanks.
     
    ttripp, Feb 28, 2008
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. harry

    ip over frame relay

    harry, Nov 27, 2003, in forum: Cisco
    Replies:
    1
    Views:
    810
  2. Chris Moore

    Frame Relay over ISDN (BRI)

    Chris Moore, Jan 8, 2005, in forum: Cisco
    Replies:
    0
    Views:
    992
    Chris Moore
    Jan 8, 2005
  3. Kieron Joy
    Replies:
    1
    Views:
    644
    www.BradReese.Com
    Aug 17, 2005
  4. Replies:
    3
    Views:
    777
  5. burber

    Frame-relay QOS

    burber, Jan 19, 2009, in forum: Cisco
    Replies:
    0
    Views:
    1,000
    burber
    Jan 19, 2009
Loading...

Share This Page