QoS on PPPoE

Discussion in 'Cisco' started by Carsten Grammes, Nov 25, 2004.

  1. Hello world,

    I have the following situation:

    Internet (ADSL) --- ADSL modem --- (PPPoE) --- Cisco Router
    ---Intranet

    Everything's fine so far. Now I want to apply QoS over the PPPoE line
    that means more or less the following rules:

    - low priority: SMTP
    - medium priority: everything else
    - High priority: DNS, ssh, some special protocols

    Can you give me any hint on how to configure this? The Cisco is 3240
    with IOS 12.x.

    Thanks,
    Carsten

    ---
    I want to die peacefully in sleep like my grandfather.
    Not screaming in terror like his passengers!
     
    Carsten Grammes, Nov 25, 2004
    #1
    1. Advertising

  2. Carsten Grammes

    waresd Guest

    Well, I would try using class-maps and policy-maps based on matches
    from access lists that you create to split up the different types of
    traffic. For example:

    ## Match all SMTP traffic
    access-list 100 permit tcp any any eq smtp

    ## Match all DNS, SSH, etc
    access-list 101 permit tcp any any eq 53
    access-list 101 permit tcp any any eq 22

    class-map match-all LOW
    match access-group 100

    class-map match-all HIGH
    match access-group 101

    ## Now create the policy-map that adds priority to the different types
    of traffic.
    policy-map TRAFFIC
    class LOW
    set ip dscp 10

    class HIGH
    priority percent 50
    set ip dscp 38

    class class-default
    fair-queue

    ## Now, apply the policy-map to the outbound interface. Example uses
    Serial0
    interface Serial0
    service-policy output TRAFFIC

    I hope this helps some.
     
    waresd, Nov 25, 2004
    #2
    1. Advertising

  3. Carsten Grammes

    Toby Guest

    Hi

    You will need to classify tour traffic as well as police it (Marking is also
    an option). I am not up on individual features in IOS for particular models
    of router but CCO does state 12.1(T) is adequate for the 3640 to use class
    based policing so here goes.

    Firstly I am assuming you want to apply your policies upstream from the 3640
    to the Inernet, to get better use of the ADSL line as you have little
    control over the traffic once on the Internet or from the Internet unless
    you have an agreement with your ISP and the traffic is destined to/from
    sites within this ISP's AS.

    1) Define how certain traffic types are CLASSIFIED based on the
    classification done by the access list's

    Class-map LOW_PRIORITY
    match access-group 101

    Class-map MED_PRIORITY
    match acces-group 102

    etc. etc.


    2) Use access lists to group each type of traffic into the CLASSES.

    access-list 101 permit ...... use ip/tcp/udp parameters here to catch the ip
    addresses and/or port numbers required
    Dont worry about the explicit deny usually associated with access lists as
    you are just clasifying it.
    access-list 102 permit .......
    etc etc


    3) Define your POLICY

    Policy-map MYPOLICY
    class LOW_PRIORITY
    This is the hard bit as you don't say how you want to police the traffic.
    Various options are available to you. i.e. bandwith minimums, bandwidth
    limits (by discarding), Priority traffic and Congestion management with RED
    (Random early Detect)
    class MED_PRIORITY
    again This is the hard bit as you don't say how you want to police the
    traffic. Various options are available to you. i.e. bandwith minimums,
    bandwidth limits (by discarding), Priority traffic and Congestion management
    with RED (Random early Detect)


    4) APPLY this policy to your out-going Interface.

    Interface ATM0/0
    service-policy output MYPOLICY



    N.B. ther are many many ways to mark, classify and police and the above is
    only an example.

    regards

    Toby



    "Carsten Grammes" <> wrote in message
    news:...
    > Hello world,
    >
    > I have the following situation:
    >
    > Internet (ADSL) --- ADSL modem --- (PPPoE) --- Cisco Router
    > ---Intranet
    >
    > Everything's fine so far. Now I want to apply QoS over the PPPoE line
    > that means more or less the following rules:
    >
    > - low priority: SMTP
    > - medium priority: everything else
    > - High priority: DNS, ssh, some special protocols
    >
    > Can you give me any hint on how to configure this? The Cisco is 3240
    > with IOS 12.x.
    >
    > Thanks,
    > Carsten
    >
    > ---
    > I want to die peacefully in sleep like my grandfather.
    > Not screaming in terror like his passengers!
     
    Toby, Nov 25, 2004
    #3
  4. Carsten Grammes

    Toby Guest

    A quick correction

    The Class-map statement should incude the match-all or match-any statements

    i.e.

    Class-map match-all LOW_PRIORITY
    match access-group 101
    match access-group 102

    The above would have to pass the permit statements of both access groups to
    be included in the class.

    Class-map match-any LOW_PRIORITY
    match access-group 101
    match access-group 102

    The above would need to match a permit statement in either of the access
    lists to be included in the class.

    Regards

    Toby

    "Toby" <> wrote in message
    news:Alppd.830$...
    > Hi
    >
    > You will need to classify tour traffic as well as police it (Marking is
    > also an option). I am not up on individual features in IOS for particular
    > models of router but CCO does state 12.1(T) is adequate for the 3640 to
    > use class based policing so here goes.
    >
    > Firstly I am assuming you want to apply your policies upstream from the
    > 3640 to the Inernet, to get better use of the ADSL line as you have little
    > control over the traffic once on the Internet or from the Internet unless
    > you have an agreement with your ISP and the traffic is destined to/from
    > sites within this ISP's AS.
    >
    > 1) Define how certain traffic types are CLASSIFIED based on the
    > classification done by the access list's
    >
    > Class-map LOW_PRIORITY
    > match access-group 101
    >
    > Class-map MED_PRIORITY
    > match acces-group 102
    >
    > etc. etc.
    >
    >
    > 2) Use access lists to group each type of traffic into the CLASSES.
    >
    > access-list 101 permit ...... use ip/tcp/udp parameters here to catch the
    > ip addresses and/or port numbers required
    > Dont worry about the explicit deny usually associated with access lists as
    > you are just clasifying it.
    > access-list 102 permit .......
    > etc etc
    >
    >
    > 3) Define your POLICY
    >
    > Policy-map MYPOLICY
    > class LOW_PRIORITY
    > This is the hard bit as you don't say how you want to police the traffic.
    > Various options are available to you. i.e. bandwith minimums, bandwidth
    > limits (by discarding), Priority traffic and Congestion management with
    > RED (Random early Detect)
    > class MED_PRIORITY
    > again This is the hard bit as you don't say how you want to police the
    > traffic. Various options are available to you. i.e. bandwith minimums,
    > bandwidth limits (by discarding), Priority traffic and Congestion
    > management with RED (Random early Detect)
    >
    >
    > 4) APPLY this policy to your out-going Interface.
    >
    > Interface ATM0/0
    > service-policy output MYPOLICY
    >
    >
    >
    > N.B. ther are many many ways to mark, classify and police and the above is
    > only an example.
    >
    > regards
    >
    > Toby
    >
    >
    >
    > "Carsten Grammes" <> wrote in message
    > news:...
    >> Hello world,
    >>
    >> I have the following situation:
    >>
    >> Internet (ADSL) --- ADSL modem --- (PPPoE) --- Cisco Router
    >> ---Intranet
    >>
    >> Everything's fine so far. Now I want to apply QoS over the PPPoE line
    >> that means more or less the following rules:
    >>
    >> - low priority: SMTP
    >> - medium priority: everything else
    >> - High priority: DNS, ssh, some special protocols
    >>
    >> Can you give me any hint on how to configure this? The Cisco is 3240
    >> with IOS 12.x.
    >>
    >> Thanks,
    >> Carsten
    >>
    >> ---
    >> I want to die peacefully in sleep like my grandfather.
    >> Not screaming in terror like his passengers!

    >
    >
     
    Toby, Nov 25, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Thilo Wunderlich

    trouble with c1600-sy-l.122-15.T5 and PPPOE

    Thilo Wunderlich, Jul 8, 2003, in forum: Cisco
    Replies:
    0
    Views:
    3,330
    Thilo Wunderlich
    Jul 8, 2003
  2. John Nordien
    Replies:
    0
    Views:
    3,393
    John Nordien
    Nov 22, 2004
  3. Andrew Albert

    QOS for VOIP using 768k of FR / Auto QOS

    Andrew Albert, Feb 6, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,543
  4. dominix
    Replies:
    2
    Views:
    491
    dominix
    Feb 6, 2007
  5. lga775
    Replies:
    1
    Views:
    2,159
    araishee
    Feb 18, 2010
Loading...

Share This Page