qos on cisco 3560 layer 3 switch

Discussion in 'Cisco' started by mr.tetto@gmail.com, Sep 11, 2007.

  1. Guest

    Hello,

    I have 2 switch cisco 3560 L3, they link by ptp wireless with about
    10Mbit of speed, on first switch fa0/1 is setup at 100Mbit/fullduplex
    and same on second switch.
    How I made to reserve 2 of 10Mbit at voip traffic ??

    Thank you so much

    Matte
    , Sep 11, 2007
    #1
    1. Advertising

  2. Guest

    On 11 Sep, 23:53, wrote:
    > Hello,
    >
    > I have 2 switch cisco 3560 L3, they link by ptp wireless with about
    > 10Mbit of speed, on first switch fa0/1 is setup at 100Mbit/fullduplex
    > and same on second switch.
    > How I made to reserve 2 of 10Mbit at voip traffic ??
    >
    > Thank you so much
    >
    > Matte


    You probably can't.

    As I understand it none of the hardware forwarders
    6500, 4500, 3560, 3750 ... can shape the traffic at less than
    the 'natural' rate of the output interface.

    Oh on the other hand maybe you can. Change the
    ports to 10M and use whatever queuing they do.
    This will only work if the wireless rate is > 10Mbps
    real transfer rate. Otherwise back to square one.
    , Sep 12, 2007
    #2
    1. Advertising

  3. Guest

    On 12 Set, 02:47, wrote:
    > On 11 Sep, 23:53, wrote:
    >
    > > Hello,

    >
    > > I have 2 switchcisco3560 L3, they link by ptp wireless with about
    > > 10Mbit of speed, on first switch fa0/1 is setup at 100Mbit/fullduplex
    > > and same on second switch.
    > > How I made to reserve 2 of 10Mbit at voip traffic ??

    >
    > > Thank you so much

    >
    > > Matte

    >
    > You probably can't.
    >
    > As I understand it none of the hardware forwarders
    > 6500, 4500, 3560, 3750 ... can shape the traffic at less than
    > the 'natural' rate of the output interface.
    >
    > Oh on the other hand maybe you can. Change the
    > ports to 10M and use whatever queuing they do.
    > This will only work if the wireless rate is > 10Mbps
    > real transfer rate. Otherwise back to square one.


    Hello, thank you to your reply, today infact I set my port to 10Mbit,
    but now I must know optimezed traffic ?? now how prioritize voip
    traffic ??

    Regards

    Mat
    , Sep 13, 2007
    #3
  4. Guest

    On 13 Sep, 12:02, wrote:
    > On 12 Set, 02:47, wrote:
    >
    >
    >
    >
    >
    > > On 11 Sep, 23:53, wrote:

    >
    > > > Hello,

    >
    > > > I have 2 switchcisco3560 L3, they link by ptp wireless with about
    > > > 10Mbit of speed, on first switch fa0/1 is setup at 100Mbit/fullduplex
    > > > and same on second switch.
    > > > How I made to reserve 2 of 10Mbit at voip traffic ??

    >
    > > > Thank you so much

    >
    > > > Matte

    >
    > > You probably can't.

    >
    > > As I understand it none of the hardware forwarders
    > > 6500, 4500, 3560, 3750 ... can shape the traffic at less than
    > > the 'natural' rate of the output interface.

    >
    > > Oh on the other hand maybe you can. Change the
    > > ports to 10M and use whatever queuing they do.
    > > This will only work if the wireless rate is > 10Mbps
    > > real transfer rate. Otherwise back to square one.

    >
    > Hello, thank you to your reply, today infact I set my port to 10Mbit,
    > but now I must know optimezed traffic ?? now how prioritize voip
    > traffic ??
    >


    You need to read the documents. A key thing
    that is not obvious is that the TOS/DSCP bits
    are by default UNTRUSTED and are cleared
    by the switch.

    I have used this for something or other.
    What follows aer randonish QoS commands.
    Some stuff was working but I cant recall exactly what.

    Good luck.

    mls qos map cos-dscp 0 8 16 26 32 46 48 56
    mls qos srr-queue input bandwidth 50 50
    mls qos srr-queue input cos-map queue 1 threshold 2 1
    mls qos srr-queue input cos-map queue 1 threshold 3 0
    mls qos srr-queue input cos-map queue 2 threshold 1 2
    mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7
    mls qos srr-queue input cos-map queue 2 threshold 3 3 5
    mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14
    15
    mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7
    mls qos srr-queue input dscp-map queue 1 threshold 3 32
    mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20
    21 22 23
    mls qos srr-queue input dscp-map queue 2 threshold 2 26 33 34 35 36
    37 38 39
    mls qos srr-queue input dscp-map queue 2 threshold 2 48 49 50 51 52
    53 54 55
    mls qos srr-queue input dscp-map queue 2 threshold 2 56 57 58 59 60
    61 62 63
    mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 27 28 29
    30 31 40
    mls qos srr-queue input dscp-map queue 2 threshold 3 41 42 43 44 45
    46 47
    mls qos srr-queue output cos-map queue 1 threshold 3 3 5
    mls qos srr-queue output cos-map queue 2 threshold 3 0 1 2 4 6 7
    mls qos srr-queue output dscp-map queue 1 threshold 3 24 26 46
    mls qos srr-queue output dscp-map queue 2 threshold 2 9 10 11 12 13
    14 15
    mls qos srr-queue output dscp-map queue 2 threshold 3 0 1 2 3 4 5 6 7
    mls qos srr-queue output dscp-map queue 2 threshold 3 16 17 18 19 20
    21 22 23
    mls qos srr-queue output dscp-map queue 2 threshold 3 25 27 28 29 30
    31 32 33
    mls qos srr-queue output dscp-map queue 2 threshold 3 34 35 36 37 38
    39 40 41
    mls qos srr-queue output dscp-map queue 2 threshold 3 42 43 44 45 47
    48 49 50
    mls qos srr-queue output dscp-map queue 2 threshold 3 51 52 53 54 55
    56 57 58
    mls qos srr-queue output dscp-map queue 2 threshold 3 59 60 61 62 63
    mls qos queue-set output 1 buffers 20 20 20 40
    mls qos queue-set output 2 buffers 40 40 10 10
    mls qos
    !
    class-map match-any CM-tointernet2
    match input-interface FastEthernet0/2
    class-map match-any CM-tointernet
    match access-group name ACL-tointernet
    class-map match-any CM-voice
    match any
    !
    !
    policy-map PM-tointernet2
    class CM-tointernet
    trust dscp
    policy-map PM-tointernet
    class CM-tointernet
    trust dscp


    interface FastEthernet0/6
    description To Internet
    no ip address
    srr-queue bandwidth shape 25 60 0 0
    srr-queue bandwidth limit 10
    queue-set 2
    priority-queue out
    no mdix auto

    interface FastEthernet0/9
    no ip address
    srr-queue bandwidth share 10 10 60 20
    srr-queue bandwidth shape 10 0 0 0
    mls qos trust device cisco-phone
    no mdix auto
    auto qos voip cisco-phone

    interface FastEthernet0/15
    description IP Phone Port
    no ip address
    duplex full
    srr-queue bandwidth share 10 10 60 20
    srr-queue bandwidth shape 10 0 0 0
    mls qos trust device cisco-phone
    mls qos trust cos
    no mdix auto
    auto qos voip cisco-phone

    ip access-list extended ACL-tointernet
    deny ip 172.16.155.0 0.0.0.255 172.16.155.0 0.0.0.255
    permit ip any any
    , Sep 13, 2007
    #4
  5. stephen Guest

    <> wrote in message
    news:...
    > On 11 Sep, 23:53, wrote:
    > > Hello,
    > >
    > > I have 2 switch cisco 3560 L3, they link by ptp wireless with about
    > > 10Mbit of speed, on first switch fa0/1 is setup at 100Mbit/fullduplex
    > > and same on second switch.
    > > How I made to reserve 2 of 10Mbit at voip traffic ??
    > >
    > > Thank you so much
    > >
    > > Matte

    >
    > You probably can't.
    >
    > As I understand it none of the hardware forwarders
    > 6500, 4500, 3560, 3750 ... can shape the traffic at less than
    > the 'natural' rate of the output interface.


    3560 / 3750 can do some shaping on the interface, and then use SRR limiting
    within that.

    limiting is limited to 90% of line speed at the high end, but i havent used
    any other settings.

    you can enable priority on Q1 on the switch, but if you do that i dont think
    you can limit the outbound high priority traffic on the port.

    the alternative is to use the SRR Q then set Q1 to shaped traffic for the
    portion of link speed you want - setting Q1 to "3" means it gets up to 1/3
    of the bandwidth.

    so port at 100M, limit the speed, and set the 4 Qs as you need them. then
    use DSCP or policies on inbound traffic to put the high priority stuff into
    Q1.

    read the qos chapter of the manual - then when you get to the end read it
    again, as it is fairly confusing - the examples help.

    the config is fairly messy, but most of the mapping settings are global, and
    once you work it out just cut and paste for other switches.

    then finally - test it to make sure it does what you expect.....
    >
    > Oh on the other hand maybe you can. Change the
    > ports to 10M and use whatever queuing they do.
    > This will only work if the wireless rate is > 10Mbps
    > real transfer rate. Otherwise back to square one.

    --
    Regards

    - replace xyz with ntl
    stephen, Sep 14, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. praveen
    Replies:
    1
    Views:
    3,056
    Bjørn Djupvik
    Oct 22, 2003
  2. Joel M. Baldwin

    bridge / layer 2 switch / layer 3 switch

    Joel M. Baldwin, Nov 6, 2003, in forum: Cisco
    Replies:
    2
    Views:
    4,444
    Scooby
    Nov 6, 2003
  3. Warrick FitzGerald

    Layer 4 device on a Layer 3 switch

    Warrick FitzGerald, Feb 24, 2004, in forum: Cisco
    Replies:
    5
    Views:
    1,215
    Craig Johnson
    Feb 24, 2004
  4. Ned
    Replies:
    3
    Views:
    15,874
  5. cantonese boy

    cisco 3560 layer 3 switch question

    cantonese boy, Oct 29, 2007, in forum: Cisco
    Replies:
    1
    Views:
    1,640
    Trendkill
    Oct 29, 2007
Loading...

Share This Page