QoS on ADSL Router cisco 826

Discussion in 'Cisco' started by borghart@gmx.de, Jun 9, 2006.

  1. Guest

    Hi,
    I want to priorise voip traffic on a cisco 826. The current setup is
    attached, but does not do the job - bad voice quality when there is other
    outgoing traffic on the link. Any ideas?


    class-map match-all voice
    match access-group 102

    !-- match rtp ports
    access-list 102 permit udp any any range 11000 12000
    !-- match sip
    access-list 102 permit tcp any eq 5060 any
    access-list 102 permit tcp any any eq 5060


    policy-map VOICE-POLICY
    class voice
    priority 96
    class class-default
    fair-queue

    interface ATM0
    mtu 300
    bandwidth 576
    no ip address
    no ip redirects
    no ip unreachables
    no atm ilmi-keepalive
    dsl operating-mode auto
    dsl enable-training-log
    hold-queue 30 in
    pvc 1/32
    cbr 576
    encapsulation aal5snap
    service-policy output VOICE-POLICY
    pppoe-client dial-pool-number 1
    !
    !

    borghar
     
    , Jun 9, 2006
    #1
    1. Advertising

  2. What about the other side of the link. Does the other side prioritize
    traffic as well.
    As there is no VPN configured in the snippet below I assume you're connected
    to an ISP? Are they prioritizing VoIP traffic as well?
    Do a "show service-policy ..." to see if you're actually doing any QoS.

    Erik

    <> wrote in message
    news:...
    > Hi,
    > I want to priorise voip traffic on a cisco 826. The current setup is
    > attached, but does not do the job - bad voice quality when there is other
    > outgoing traffic on the link. Any ideas?
    >
    >
    > class-map match-all voice
    > match access-group 102
    >
    > !-- match rtp ports
    > access-list 102 permit udp any any range 11000 12000
    > !-- match sip
    > access-list 102 permit tcp any eq 5060 any
    > access-list 102 permit tcp any any eq 5060
    >
    >
    > policy-map VOICE-POLICY
    > class voice
    > priority 96
    > class class-default
    > fair-queue
    >
    > interface ATM0
    > mtu 300
    > bandwidth 576
    > no ip address
    > no ip redirects
    > no ip unreachables
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > dsl enable-training-log
    > hold-queue 30 in
    > pvc 1/32
    > cbr 576
    > encapsulation aal5snap
    > service-policy output VOICE-POLICY
    > pppoe-client dial-pool-number 1
    > !
    > !
    >
    > borghar
     
    Erik Tamminga, Jun 10, 2006
    #2
    1. Advertising

  3. Guest

    On 2006-06-10, Erik Tamminga <> wrote:
    > What about the other side of the link. Does the other side prioritize
    > traffic as well.
    > As there is no VPN configured in the snippet below I assume you're connected
    > to an ISP? Are they prioritizing VoIP traffic as well?
    > Do a "show service-policy ..." to see if you're actually doing any QoS.
    >
    > Erik


    Hi,
    Yes, i am connected to an ISP. I don't know if they prioritize voip
    traffic or not. But for sure voip quality is very good, when there is no
    other traffic on my umlink. When there is other traffic than voip on my
    uplink, voip quality gets bad.
    "show service-policy ..." points out, that outgoing packets are classified
    correctly, but still voip quality is bad, when there is other outgoing
    traffic.
    Regards, Borghar
     
    , Jun 11, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. J. Codac

    Cisco 826 Hang

    J. Codac, May 4, 2004, in forum: Cisco
    Replies:
    3
    Views:
    699
  2. Tim van der Valk
    Replies:
    3
    Views:
    565
  3. Rene Kuhn
    Replies:
    0
    Views:
    911
    Rene Kuhn
    Dec 28, 2005
  4. LincolnShep
    Replies:
    3
    Views:
    2,701
    Jack \(MVP-Networking\).
    Nov 8, 2006
  5. czar

    adsl router to adsl router

    czar, May 1, 2007, in forum: Cisco
    Replies:
    2
    Views:
    451
    Doug McIntyre
    May 1, 2007
Loading...

Share This Page