QOS on 837 for SIP

Discussion in 'Cisco' started by Brad, Mar 23, 2007.

  1. Brad

    Brad Guest

    Hi everyone,

    I have been trying to get some sort of usefull QOS working on my 837
    router, so that VoIP traffic is not affected by other traffic on the
    link. I am connected to a 512/128 ADSL connection.

    I have been following the guide at
    http://www.cisco.com/en/US/products..._guide_chapter09186a0080118cbb.html#wp1097357


    This is what I have so far in my config...

    !
    class-map match-all voice
    match ip precedence 5
    !
    !
    policy-map LLQ
    class voice
    priority 64
    class class-default
    fair-queue
    policy-map shape
    class class-default
    shape average 2250000
    service-policy LLQ
    !
    interface Ethernet0
    ip address 192.168.2.5 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    hold-queue 100 out
    !
    interface Ethernet2
    no ip address
    shutdown
    hold-queue 100 out
    !
    interface ATM0
    mtu 300
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 8/35
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    interface Dialer1
    bandwidth 128
    ip address negotiated
    ip access-group 101 in
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication pap callin
    ppp chap refuse
    ppp pap sent-username XXX
    ppp multilink
    ppp multilink interleave
    ppp multilink fragment-delay 10
    !



    I can apply the policy map LLQ to the dialer interface, and see that 'sh
    policy-map int d1', shows that it is picking up the voice traffic
    correctly, but the voice quality is terrible if anything else is using
    the link at the same time.

    The reference page says that 'shape average 128000' should be applied
    under 'policy-map shape'. It lets me enter it without an error, but it
    doesn't appear there in a 'sh run'

    I can apply 'service-policy output shape' to the dialer interface,
    without an error, but it also won't show up in a 'sh run'

    Can anyone see what I am doing wrong?
     
    Brad, Mar 23, 2007
    #1
    1. Advertising

  2. Hi,

    From what I understand, the Qos you are tying to do in not support in
    virtuel interfaces:
    read the note in the URL you are ref. to: CBTS is supported on the Ethernet
    1 interface.

    Also normally you would specify strict priority as LLQ, but this could
    varify from IOS image.

    Also read the part about the tx transmit ring in the ATM (same URL)
    HTH
    Martin

    "Brad" <> wrote in message
    news:46036984$...
    > Hi everyone,
    >
    > I have been trying to get some sort of usefull QOS working on my 837
    > router, so that VoIP traffic is not affected by other traffic on the link.
    > I am connected to a 512/128 ADSL connection.
    >
    > I have been following the guide at
    > http://www.cisco.com/en/US/products..._guide_chapter09186a0080118cbb.html#wp1097357
    >
    >
    > This is what I have so far in my config...
    >
    > !
    > class-map match-all voice
    > match ip precedence 5
    > !
    > !
    > policy-map LLQ
    > class voice
    > priority 64
    > class class-default
    > fair-queue
    > policy-map shape
    > class class-default
    > shape average 2250000
    > service-policy LLQ
    > !
    > interface Ethernet0
    > ip address 192.168.2.5 255.255.255.0
    > ip nat inside
    > ip virtual-reassembly
    > hold-queue 100 out
    > !
    > interface Ethernet2
    > no ip address
    > shutdown
    > hold-queue 100 out
    > !
    > interface ATM0
    > mtu 300
    > no ip address
    > no atm ilmi-keepalive
    > dsl operating-mode auto
    > pvc 8/35
    > encapsulation aal5mux ppp dialer
    > dialer pool-member 1
    > !
    > interface Dialer1
    > bandwidth 128
    > ip address negotiated
    > ip access-group 101 in
    > ip nat outside
    > ip virtual-reassembly
    > encapsulation ppp
    > dialer pool 1
    > dialer-group 1
    > ppp authentication pap callin
    > ppp chap refuse
    > ppp pap sent-username XXX
    > ppp multilink
    > ppp multilink interleave
    > ppp multilink fragment-delay 10
    > !
    >
    >
    >
    > I can apply the policy map LLQ to the dialer interface, and see that 'sh
    > policy-map int d1', shows that it is picking up the voice traffic
    > correctly, but the voice quality is terrible if anything else is using the
    > link at the same time.
    >
    > The reference page says that 'shape average 128000' should be applied
    > under 'policy-map shape'. It lets me enter it without an error, but it
    > doesn't appear there in a 'sh run'
    >
    > I can apply 'service-policy output shape' to the dialer interface, without
    > an error, but it also won't show up in a 'sh run'
    >
    > Can anyone see what I am doing wrong?
    >
    >
    >
     
    Martin Bilgrav, Mar 25, 2007
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Confused

    Cisco 837-837 VPN

    Confused, Jul 9, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,828
    Confused
    Jul 9, 2003
  2. Suppa Lamah
    Replies:
    8
    Views:
    1,682
  3. Richard Antony Burton
    Replies:
    0
    Views:
    6,337
    Richard Antony Burton
    Jan 5, 2004
  4. Replies:
    4
    Views:
    4,248
  5. Giuen
    Replies:
    0
    Views:
    1,449
    Giuen
    Sep 12, 2008
Loading...

Share This Page