QOS for VOIP using 768k of FR / Auto QOS

Discussion in 'Cisco' started by Andrew Albert, Feb 6, 2005.

  1. I would like to configure auto qos on a cisco 2621 but run into the
    following message when I execute auto qos voip on s0/0.1

    nyc_router(config-subif)#frame-relay interface-dlci 886 IETF
    nyc_router(config-fr-dlci)#auto qos voip
    %Point-to-point sub-interface is not set for CISCO encapsulation !
    AUTOQOS ERROR: Failed to configure "frame-relay ip rtp
    header-compression "
    %Point-to-point sub-interface is not set for CISCO encapsulation !

    I would like to make the changes to allow for auto qos, but doing so
    remotely I worry about losing connectivity from a wrong execution
    method.

    Any suggestions on a course of action would be appreciated.

    Thank you,
    Andy

    !
    !
    interface Serial0/0
    description to PROVIDER
    bandwidth 768
    no ip address
    no ip redirects
    no ip proxy-arp
    encapsulation frame-relay IETF
    no ip mroute-cache
    priority-group 1
    service-module t1 timeslots 12-23
    frame-relay lmi-type ansi
    !
    !
    interface Serial0/0.1 point-to-point
    bandwidth 768
    ip address 207.19.124.254 255.255.255.252
    ip nat outside
    frame-relay interface-dlci 886 IETF
    !
    !
     
    Andrew Albert, Feb 6, 2005
    #1
    1. Advertising

  2. Andrew Albert

    BradReeseCom Guest

    BradReeseCom, Feb 6, 2005
    #2
    1. Advertising

  3. Andrew Albert

    Ben Guest

    Hi Andrew,

    Ideally you would already have some sort of out-of-band access to the
    remote router, such as via a modem on the aux port. Or just a fellow
    tech at the other end to do the config change simultaneously.

    Worst case, you could risk changing the remote end first, which will
    drop your telnet session, then change the local end and hope it comes up.

    cheers,

    Ben

    Andrew Albert wrote:
    > I would like to configure auto qos on a cisco 2621 but run into the
    > following message when I execute auto qos voip on s0/0.1
    >
    > nyc_router(config-subif)#frame-relay interface-dlci 886 IETF
    > nyc_router(config-fr-dlci)#auto qos voip
    > %Point-to-point sub-interface is not set for CISCO encapsulation !
    > AUTOQOS ERROR: Failed to configure "frame-relay ip rtp
    > header-compression "
    > %Point-to-point sub-interface is not set for CISCO encapsulation !
    >
    > I would like to make the changes to allow for auto qos, but doing so
    > remotely I worry about losing connectivity from a wrong execution
    > method.
    >
    > Any suggestions on a course of action would be appreciated.
    >
    > Thank you,
    > Andy
    >
    > !
    > !
    > interface Serial0/0
    > description to PROVIDER
    > bandwidth 768
    > no ip address
    > no ip redirects
    > no ip proxy-arp
    > encapsulation frame-relay IETF
    > no ip mroute-cache
    > priority-group 1
    > service-module t1 timeslots 12-23
    > frame-relay lmi-type ansi
    > !
    > !
    > interface Serial0/0.1 point-to-point
    > bandwidth 768
    > ip address 207.19.124.254 255.255.255.252
    > ip nat outside
    > frame-relay interface-dlci 886 IETF
    > !
    > !
    >
     
    Ben, Feb 7, 2005
    #3
  4. Guess I will have to do things when somebody is onsite.... The key
    question though, is why I was unable to get auto qos to take on the
    interface (is it absolutely required that the remote provider have
    this enabled?)......

    Thanks,

    Andy
     
    Andrew Albert, Feb 7, 2005
    #4
  5. Andrew Albert

    Toby Guest

    "Andrew Albert" <> wrote in message
    news:...
    > Guess I will have to do things when somebody is onsite.... The key
    > question though, is why I was unable to get auto qos to take on the
    > interface (is it absolutely required that the remote provider have
    > this enabled?)......
    >
    > Thanks,
    >
    > Andy


    Cisco type LMI would be required as it can learn the CIR/PIR values set in
    the Frame-Relay cloud on the PVC's, ANSI does not include this information.

    Regards

    Toby
     
    Toby, Feb 7, 2005
    #5
  6. What if you are forced to use IETF from your upstream provider? Any
    suggestions on which way to proceed?


    Regards,


    Andy
     
    Andrew Albert, Feb 8, 2005
    #6
  7. Andrew Albert

    Toby Guest

    "Andrew Albert" <> wrote in message
    news:...
    > What if you are forced to use IETF from your upstream provider? Any
    > suggestions on which way to proceed?
    >
    > Regards,
    >
    > Andy
    >

    Hi Andy

    I am not sure exactly how AutoQos works apart from it detecting type of
    flows using NBAR (protocol recognition) and providng some sort of priority
    algorithm to what it deems possible voice traffic along with MGCP, Skinny,
    and H.323 signaling traffic.

    Without this feature you are going to need to have a box/IOS able to
    adequately classify/mark and police the traffic yourself. I am not a network
    designer though so don't know which IOS varient would be suitable for which
    platforms.

    The method I am used to using is LLQ (Low Latecy Queuing), this is a multi
    queue system with one queue given strict priority over other traffic which
    your voice traffic would go in. As well as having an IOS that supports this
    you will need to plan your bandwidth requirements over your link(s)
    effectively. This method is far too complex to explain in a news group from
    the ground up though, so if you intend using this method I suggest the Cisco
    press book QDOS. In the end though this method will give more control and
    with good planning a much supperior QOS method than any autoqos feature.

    regards

    Toby
     
    Toby, Feb 9, 2005
    #7
  8. Andrew Albert

    Toby Guest

    Correction to below. Cisco book is called DQOS not QDOS. It is a very good
    book but may seem a bit over the top for a single link (if that's all you
    are concerned with). It is very conceptual based to begin with and only
    becomes usefull past half way through in a practical sense.

    Sorry

    Toby


    "Toby" <> wrote in message
    news:mwtOd.3370$...
    >
    > "Andrew Albert" <> wrote in message
    > news:...
    >> What if you are forced to use IETF from your upstream provider? Any
    >> suggestions on which way to proceed?
    >>
    >> Regards,
    >>
    >> Andy
    >>

    > Hi Andy
    >
    > I am not sure exactly how AutoQos works apart from it detecting type of
    > flows using NBAR (protocol recognition) and providng some sort of priority
    > algorithm to what it deems possible voice traffic along with MGCP, Skinny,
    > and H.323 signaling traffic.
    >
    > Without this feature you are going to need to have a box/IOS able to
    > adequately classify/mark and police the traffic yourself. I am not a
    > network designer though so don't know which IOS varient would be suitable
    > for which platforms.
    >
    > The method I am used to using is LLQ (Low Latecy Queuing), this is a multi
    > queue system with one queue given strict priority over other traffic which
    > your voice traffic would go in. As well as having an IOS that supports
    > this you will need to plan your bandwidth requirements over your link(s)
    > effectively. This method is far too complex to explain in a news group
    > from the ground up though, so if you intend using this method I suggest
    > the Cisco press book QDOS. In the end though this method will give more
    > control and with good planning a much supperior QOS method than any
    > autoqos feature.
    >
    > regards
    >
    > Toby
    >
    >
     
    Toby, Feb 9, 2005
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dik Mus

    auto start, and auto replay possible?

    Dik Mus, Oct 27, 2003, in forum: DVD Video
    Replies:
    3
    Views:
    3,735
    Dik Mus
    Oct 28, 2003
  2. VOIP and Auto QoS

    , Sep 10, 2006, in forum: Cisco
    Replies:
    0
    Views:
    529
  3. Replies:
    5
    Views:
    614
    Dave Martindale
    Nov 5, 2005
  4. Replies:
    0
    Views:
    947
  5. Giuen
    Replies:
    0
    Views:
    1,002
    Giuen
    Sep 12, 2008
Loading...

Share This Page