Qos for VoIP over 802.11g over VPN on 871W

Discussion in 'Cisco' started by ensnare, Jan 24, 2009.

  1. ensnare

    ensnare

    Joined:
    Jan 24, 2009
    Messages:
    5
    Hi -- I have a Cisco 7921G which I use to connect to a remote CME router over an IPSec VPN through my 871W.

    7921G --> 871W --> Internet VPN --> 2811 CME

    Unfortunately, I get tremendous jitter from the wireless phone whenever other wireless clients are utilizing network traffic. When the wireless network is only in use by the 7921, jitter hovers around 1-2. But as soon as a file transfer starts utilizing the bandwidth, jitter jumps into the 100-200s and conversations become unbarable.

    I tried configuring QoS, but it seems like that is having no effect. My guess is I'm doing something wrong. I have attached the QoS portion of my run conf ... please let me know if you have any suggestions on optimizing this situation.

    If anyone has a similar configuration with a working run conf, that would be a great starting point.

    Thank you so much in advance.

    dot11 ssid G
    vlan 1
    authentication open
    authentication key-management wpa
    mbssid guest-mode
    wpa-psk ascii 7 1515020B052832302D
    !
    dot11 ssid G-Guest
    vlan 2
    authentication open
    mbssid guest-mode
    !

    class-map match-all SCCP
    match ip dscp cs3
    class-map match-any AutoQoS-VoIP-Remark
    match ip dscp ef
    match ip dscp cs3
    match ip dscp af31
    class-map match-all RTP
    match ip dscp ef
    class-map match-any AutoQoS-VoIP-Control-UnTrust
    match access-group name AutoQoS-VoIP-Control
    class-map match-any AutoQoS-VoIP-RTP-UnTrust
    match protocol rtp audio
    match access-group name AutoQoS-VoIP-RTCP
    !
    !

    policy-map AutoQoS-Policy-UnTrust
    class AutoQoS-VoIP-RTP-UnTrust
    priority percent 70
    set dscp ef
    class AutoQoS-VoIP-Control-UnTrust
    bandwidth percent 5
    set dscp af31
    class AutoQoS-VoIP-Remark
    set dscp default
    class class-default
    fair-queue

    policy-map Voice
    class RTP
    set cos 6
    set precedence 6
    class SCCP
    set cos 3
    set precedence 3
    !

    interface FastEthernet4
    bandwidth 2048
    bandwidth receive 16384
    ip ddns update hostname ajg-colorado.dyndns.org
    ip ddns update HTTP
    ip address dhcp
    ip nat outside
    ip virtual-reassembly
    load-interval 30
    duplex auto
    speed auto
    auto qos voip
    crypto map mymap
    max-reserved-bandwidth 85
    service-policy output AutoQoS-Policy-UnTrust
    !
    interface Dot11Radio0
    no ip address
    beacon period 500
    no dot11 extension aironet
    !
    encryption vlan 1 mode ciphers aes-ccm
    !
    ssid G
    !
    ssid G-Guest
    !
    mbssid
    speed basic-54.0
    station-role root
    world-mode dot11d country US both
    no cdp enable
    max-reserved-bandwidth 85
    service-policy input Voice
    service-policy output Voice
    !
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    service-policy input Voice
    service-policy output Voice
    !
    interface Dot11Radio0.2
    encapsulation dot1Q 2
    bridge-group 2
    bridge-group 2 subscriber-loop-control
    bridge-group 2 spanning-disabled
    bridge-group 2 block-unknown-source
    no bridge-group 2 source-learning
    no bridge-group 2 unicast-flooding
    service-policy input Voice
    service-policy output Voice
    !
    interface Vlan1
    description Internal Network
    no ip address
    ip nat inside
    ip virtual-reassembly
    auto qos voip
    bridge-group 1
    bridge-group 1 spanning-disabled
    !
    interface Vlan2
    description Guest Network
    no ip address
    ip nat inside
    ip virtual-reassembly
    bridge-group 2
    bridge-group 2 spanning-disabled
    !
    interface BVI1
    description Bridge to Internal Network
    ip address 10.1.0.1 255.255.0.0
    ip nat inside
    ip virtual-reassembly
    !
    interface BVI2
    description Bridge from Guest Network to Internet
    ip address 192.168.0.1 255.255.255.0
    ip access-group 130 in
    ip access-group 130 out
    ip nat inside
    ip virtual-reassembly
    service-policy input Guest
    service-policy output Guest
    !

    ip access-list extended AutoQoS-VoIP-Control
    permit tcp any any eq 1720
    permit tcp any any range 11000 11999
    permit udp any any eq 2427
    permit tcp any any eq 2428
    permit tcp any any range 2000 2002
    permit udp any any eq 1719
    permit udp any any eq 5060
    ip access-list extended AutoQoS-VoIP-RTCP
    permit udp any any range 16384 32767
    ip access-list extended RTP
    permit udp any range 16384 32767 any
    permit udp any any range 16384 32767
    ip access-list extended SCCP
    permit tcp any eq 2000 any
    permit tcp any any eq 2000
    !

    bridge 1 route ip
    bridge 2 route ip
     
    ensnare, Jan 24, 2009
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Oli
    Replies:
    3
    Views:
    893
  2. RobertABowie

    802.11b vs 802.11g

    RobertABowie, Jan 1, 2004, in forum: Cisco
    Replies:
    3
    Views:
    1,519
    Walter Roberson
    Jan 1, 2004
  3. Chris Davies
    Replies:
    6
    Views:
    1,515
    Chris Davies
    Jun 15, 2004
  4. jbraly@gmail.com

    Connect to 802.11b but not 802.11g... but used to be able to...?

    jbraly@gmail.com, Mar 8, 2006, in forum: Wireless Networking
    Replies:
    1
    Views:
    521
    Zhong Deng \(MSFT\)
    Mar 13, 2006
  5. =?Utf-8?B?aXR6ZWQ=?=

    802.11g cards can't see 802.11b network?

    =?Utf-8?B?aXR6ZWQ=?=, Aug 19, 2006, in forum: Wireless Networking
    Replies:
    2
    Views:
    871
Loading...

Share This Page