QOS for Video and phone

Discussion in 'Cisco' started by smoove, Jan 12, 2007.

  1. smoove

    smoove Guest

    Does anybody have a config I can look at show a QOS setup for voice and
    video?

    --



    SMOOVE
    91 GSXR 750, 96 Chevy C1500, and 03 350Z
    Hated By Many... Confronted By None!
    Pain is weakness leaving the body!!!
    "it's better to be judged by twelve than carried by six."
    www.myhooptie.com
    smoove, Jan 12, 2007
    #1
    1. Advertising

  2. www.BradReese.Com, Jan 12, 2007
    #2
    1. Advertising

  3. QoS is not a "flip switch", which you turn on and have everything working
    perfect. Setting up QoS is complex of actions, you perform on all equipment
    along the way of interested traffic. For office LAN it will be one set of
    actions, for inter-office communication - another, for WAN and Internet
    traffic it will be third strategy.

    What is your scenario? Are you setting up Voice and Video within the office?
    In this case you will need to configure QoS on access ports, on all
    switches, on affected trunks, etc. If you have a distributed environment,
    offices interconnected by Frame Relay or VPN, then you will need to
    configure not only LAN, but also set up your routers properly. It includes
    traffic study, prioritizing one type of traffic over another, limiting
    certain applications, etc. From one hand you will need to provide quality
    for voice and video, but what if video will kill your mail or SQL traffic?
    If you are configuring Voice and Video over the Internet, you should
    understand, that some (and probably most) ISPs do not conform to your QoS
    requirements. You may try to mark your traffic as a "high priority", but you
    cannot guarantee, that all routers and switches around the world will
    respect this.

    Good luck,

    Mike
    ------
    Hands-Free Headset for a Adapters Cisco IP Phone
    www.ciscoheadsetadapter.com


    "smoove" <> wrote in message
    news:45a7c61e$0$3567$...
    > Does anybody have a config I can look at show a QOS setup for voice and
    > video?
    >
    > --
    >
    >
    >
    > SMOOVE
    > 91 GSXR 750, 96 Chevy C1500, and 03 350Z
    > Hated By Many... Confronted By None!
    > Pain is weakness leaving the body!!!
    > "it's better to be judged by twelve than carried by six."
    > www.myhooptie.com
    >
    headsetadapter.com, Jan 12, 2007
    #3
  4. smoove

    smoove Guest

    We are only running video at 6 of our major cites. IP phones are at all of
    those major cites, but they are currently running as stand alone systems.
    The goal is to connect all the sites phones systems by 3rd quarter. We are
    running 3mb MLFR to the sites from the central office. The maine concerns at
    all offices will be Phones, Citrix, then Video. email is last on the list.


    "headsetadapter.com" <> wrote in message
    news:...
    > QoS is not a "flip switch", which you turn on and have everything working
    > perfect. Setting up QoS is complex of actions, you perform on all
    > equipment along the way of interested traffic. For office LAN it will be
    > one set of actions, for inter-office communication - another, for WAN and
    > Internet traffic it will be third strategy.
    >
    > What is your scenario? Are you setting up Voice and Video within the
    > office? In this case you will need to configure QoS on access ports, on
    > all switches, on affected trunks, etc. If you have a distributed
    > environment, offices interconnected by Frame Relay or VPN, then you will
    > need to configure not only LAN, but also set up your routers properly. It
    > includes traffic study, prioritizing one type of traffic over another,
    > limiting certain applications, etc. From one hand you will need to provide
    > quality for voice and video, but what if video will kill your mail or SQL
    > traffic? If you are configuring Voice and Video over the Internet, you
    > should understand, that some (and probably most) ISPs do not conform to
    > your QoS requirements. You may try to mark your traffic as a "high
    > priority", but you cannot guarantee, that all routers and switches around
    > the world will respect this.
    >
    > Good luck,
    >
    > Mike
    > ------
    > Hands-Free Headset for a Adapters Cisco IP Phone
    > www.ciscoheadsetadapter.com
    >
    >
    > "smoove" <> wrote in message
    > news:45a7c61e$0$3567$...
    >> Does anybody have a config I can look at show a QOS setup for voice and
    >> video?
    >>
    >> --
    >>
    >>
    >>
    >> SMOOVE
    >> 91 GSXR 750, 96 Chevy C1500, and 03 350Z
    >> Hated By Many... Confronted By None!
    >> Pain is weakness leaving the body!!!
    >> "it's better to be judged by twelve than carried by six."
    >> www.myhooptie.com
    >>

    >
    >
    smoove, Jan 15, 2007
    #4
  5. smoove

    garrisb Guest

    smoove wrote:
    > Does anybody have a config I can look at show a QOS setup for voice and
    > video?
    >
    > --
    >
    >
    >
    > SMOOVE
    > 91 GSXR 750, 96 Chevy C1500, and 03 350Z
    > Hated By Many... Confronted By None!
    > Pain is weakness leaving the body!!!
    > "it's better to be judged by twelve than carried by six."
    > www.myhooptie.com


    here's a copy of my lab router..... This has it all and should give you
    some good ideas.....

    !
    class-map match-all realtime
    match dscp ef
    class-map match-all enterprise-ftp-traffic
    match access-group 103
    match protocol ftp
    class-map match-all enterprise-http
    match dscp af21
    class-map match-all match-www
    match access-group 102
    class-map match-all match-ftp
    match access-group 101
    class-map match-any mission-critical
    match dscp af31
    match dscp af32
    match dscp af33
    class-map match-all sqlnet-traffic
    match protocol sqlnet
    class-map match-any scanvenger-traffic
    match protocol kazaa2
    match protocol napster
    class-map match-all match-sw-cs3
    match dscp cs3
    class-map match-all enterprise-ftp
    match dscp af11
    class-map match-all Scavenger
    match dscp cs1
    class-map match-all citrix-traffic
    match protocol citrix
    class-map match-all enterprise-http-traffic
    match protocol http url "*important*"
    class-map match-any real-time-traffic
    match protocol rtp
    match protocol rtcp
    class-map match-all match-sw-af31
    match dscp af31
    class-map match-all match-sw-ef
    match dscp ef
    class-map match-any voice-control-traffic
    match protocol skinny
    match protocol h323
    match protocol mgcp
    match protocol sip
    class-map match-all routing
    match dscp cs6
    !
    !
    policy-map mark-apps1
    description "Lab4_excer_4.1"
    class match-ftp
    set dscp af11
    class match-www
    set dscp af13
    class class-default
    set dscp default
    policy-map mark-nbar
    class sqlnet-traffic
    set dscp af32
    class citrix-traffic
    set dscp af33
    class enterprise-http-traffic
    set dscp af21
    class enterprise-ftp-traffic
    set dscp af11
    class scanvenger-traffic
    set dscp cs1
    class match-sw-cs3
    set dscp af31
    class class-default
    set dscp default
    policy-map mark-nbarv
    class real-time-traffic
    set dscp ef
    class voice-control-traffic
    set dscp af31
    class class-default
    set dscp default
    policy-map llq-policy
    class realtime
    priority 90
    class routing
    bandwidth remaining percent 1
    class mission-critical
    bandwidth remaining percent 60
    random-detect dscp-based
    random-detect dscp 26 51 60 10
    random-detect dscp 28 45 60 10
    random-detect dscp 30 42 60 10
    class enterprise-http
    bandwidth remaining percent 13
    random-detect dscp-based
    random-detect dscp 18 30 40 10
    class enterprise-ftp
    bandwidth remaining percent 10
    random-detect dscp-based
    random-detect dscp 10 26 40 10
    class Scavenger
    bandwidth remaining percent 1
    random-detect dscp-based
    random-detect dscp 8 20 40 10
    class class-default
    bandwidth remaining percent 15
    random-detect dscp-based
    random-detect ecn
    policy-map verify-mark-v
    class match-sw-ef
    class match-sw-af31
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    load-interval 30
    duplex full
    speed 100
    !
    interface FastEthernet0/0.12
    encapsulation dot1Q 12
    ip address 10.1.2.1 255.255.255.0
    ip policy route-map set-ecn
    no snmp trap link-status
    service-policy input mark-nbar
    !
    interface FastEthernet0/0.112
    encapsulation dot1Q 112
    ip address 10.1.112.1 255.255.255.0
    no snmp trap link-status
    service-policy input verify-mark-v
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0/0:1
    bandwidth 384
    ip address 10.2.2.1 255.255.255.0
    encapsulation ppp
    load-interval 30
    service-policy output llq-policy
    !
    interface Serial0/3/0
    no ip address
    shutdown
    fair-queue
    !
    interface Serial0/3/1
    no ip address
    shutdown
    clockrate 2000000
    !
    router ospf 1
    log-adjacency-changes
    network 10.0.0.0 0.255.255.255 area 0
    !
    ip classless
    !
    ip http server
    !
    ip access-list extended best-effort
    permit ip any any precedence routine
    !
    access-list 101 permit tcp any host 10.99.1.15 eq ftp
    access-list 101 permit tcp any host 10.99.1.15 eq ftp-data
    access-list 101 permit tcp host 10.99.1.15 eq ftp any
    access-list 101 permit tcp host 10.99.1.15 eq ftp-data any
    access-list 102 permit tcp any host 10.99.1.15 eq www
    access-list 102 permit tcp host 10.99.1.15 eq www any
    access-list 103 permit ip any host 10.99.1.15
    access-list 103 permit ip host 10.99.1.15 any
    route-map set-ecn permit 10
    match ip address best-effort
    set ip tos min-monetary-cost
    !
    garrisb, Jan 19, 2007
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Andrew Albert

    QOS for VOIP using 768k of FR / Auto QOS

    Andrew Albert, Feb 6, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,489
  2. Hiro
    Replies:
    67
    Views:
    5,029
    Paul Cupis
    Feb 24, 2006
  3. Replies:
    1
    Views:
    672
  4. dominix
    Replies:
    2
    Views:
    473
    dominix
    Feb 6, 2007
  5. Giuen
    Replies:
    0
    Views:
    838
    Giuen
    Sep 12, 2008
Loading...

Share This Page