QOS and bandwidth for ADSL

Discussion in 'Cisco' started by dwilson@scoutcom.net, Apr 27, 2005.

  1. Guest

    Hello. I'm attempting to provide some priority (not exactly QOS) on a
    Cisco 827 for VOIP. The trouble I'm having is portraying correct
    bandwidth so that the router can prioritize packets for an asymetric
    line. It's ADSL 1.5m down, and 256k up.

    Our VOIP partner has provided me with the info that the TOS=12, and I
    put precedence critical on anything tos 12. I'm really only concerned
    with overloading the upstream bandwidth. If our customers are eating
    up 1.5 or a 3.0 mb ckt, they need to look at something besides DSL for
    internet.

    For testing, I have 1 IP phone (Cisco 7960) and 1 laptop. The phone
    uses skinny (some devices use MCGP, but few customers have these) to
    connect to an asterisk box. I ftp a file up to a server, thus
    overloading the upstream.

    Calls are pretty choppy. Any help would be greatly appreciated.
    Sanitized config and version to follow:

    sh conf
    Using 2026 out of 131072 bytes
    !
    version 12.3
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Adsl
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret ###################
    !
    no aaa new-model
    ip subnet-zero
    ip name-server 1.1.1.1
    ip name-server 2.2.2.2
    ip dhcp excluded-address 10.10.10.1
    !
    ip dhcp pool CLIENT
    import all
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    lease 0 2
    !
    username Adsl password ##################
    username CRWS_Ulags privilege 15 password ######################
    !
    !
    class-map match-all voip-rtp
    !
    !
    policy-map qos-policy
    class voip-rtp
    priority 32
    class class-default
    fair-queue
    !
    !
    !
    interface Ethernet0
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    no ip mroute-cache
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no ip mroute-cache
    atm vc-per-vp 64
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 8/35
    cbr 256
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    service-policy output qos-policy
    !
    !
    interface Dialer1
    ip address negotiated
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname
    ppp chap password ###########
    ppp pap sent-username password ###############
    ppp ipcp dns request
    ppp ipcp wins request
    hold-queue 224 in
    !
    ip nat inside source list 102 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    !
    access-list 101 permit ip any any precedence critical tos 12
    access-list 102 permit ip 10.10.10.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    priority-list 1 protocol ip high list 101
    priority-list 1 protocol ip low list 102
    !
    !
    line con 0
    exec-timeout 120 0
    transport preferred all
    transport output all
    stopbits 1
    line vty 0 4
    exec-timeout 120 0
    login local
    length 0
    transport preferred all
    transport input all
    transport output all
    !
    scheduler max-task-time 5000
    end

    Adsl#


    Adsl#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C820 Software (C820-SY6-M), Version 12.3(13), RELEASE SOFTWARE
    (fc2)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2005 by cisco Systems, Inc.
    Compiled Thu 10-Feb-05 11:31 by ssearch
    Image text-base: 0x80013148, data-base: 0x808AF2BC

    ROM: System Bootstrap, Version 12.1(1r)XB1, RELEASE SOFTWARE (fc1)
    ROM: C820 Software (C820-SY6-M), Version 12.3(13), RELEASE SOFTWARE
    (fc2)

    Adsl uptime is 23 hours, 25 minutes
    System returned to ROM by reload
    System image file is "flash:c820-sy6-mz.123-13.bin"

    CISCO C827 (MPC855T) processor (revision 0x901) with 23552K/1024K bytes
    of memor
    y.
    Processor board ID JAD072706PV (2716654291), with hardware revision
    0000
    CPU rev number 5
    Bridging software.
    1 Ethernet/IEEE 802.3 interface(s)
    1 ATM network interface(s)
    128K bytes of non-volatile configuration memory.
    8192K bytes of processor board System flash (Read/Write)
    2048K bytes of processor board Web flash (Read/Write)

    Configuration register is 0x2102
    , Apr 27, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Michael

    2950 QOS wrr-queue bandwidth

    Michael, May 13, 2004, in forum: Cisco
    Replies:
    0
    Views:
    4,806
    Michael
    May 13, 2004
  2. Andrew Albert

    QOS for VOIP using 768k of FR / Auto QOS

    Andrew Albert, Feb 6, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,469
  3. dominix
    Replies:
    2
    Views:
    457
    dominix
    Feb 6, 2007
  4. Giuen
    Replies:
    0
    Views:
    693
    Giuen
    Sep 12, 2008
  5. JF Mezei

    QoS and available Bandwidth

    JF Mezei, Dec 6, 2010, in forum: Cisco
    Replies:
    12
    Views:
    2,873
    JF Mezei
    Dec 15, 2010
Loading...

Share This Page