Q: When on mute, voipfone drops the call after 5 minutes ???

Discussion in 'UK VOIP' started by damn-it, Mar 8, 2007.

  1. damn-it

    damn-it Guest

    Guys,

    I have this weird problem.

    I just got my snom 300, via voipfone, and during a conference call, were
    I was on mute, my phone simply ended the communication after a while
    (about 5 minutes). This already happened few times, and basically make
    voipfone unusable on conference call...

    Had a chat with their support and the answer was as follow:
    "Yes, if there is no audio coming from either end of the call, it will
    be dropped."

    What I see is that even when people are talking on the line, and I am on
    mute, the call is dropped.

    Any clues? (Oh, and this is not a credit issue....)

    Any good alternative provider you can recommend?

    Thanks
    damn-it, Mar 8, 2007
    #1
    1. Advertising

  2. damn-it

    Tim Guest

    damn-it wrote:
    >
    > Any good alternative provider you can recommend?
    >


    It is nothing to do with voipfone.

    And nothing to do with the Snom phone.

    It is a deficiency in the SIP/RTP protocol.

    Mute means one way audio. If the RTP sequence rolls over while you are
    on mute, you lose the call.

    I think. Could be other things too.

    If you could get a pcap/ethereal trace of when the call drops out, I'd
    know for sure.

    Tim
    (been to the pub, so I don't guarantee the above answer)
    Tim, Mar 9, 2007
    #2
    1. Advertising

  3. damn-it

    damn-it Guest

    Tim wrote:
    > damn-it wrote:
    >>
    >> Any good alternative provider you can recommend?
    >>

    >
    > It is nothing to do with voipfone.
    >
    > And nothing to do with the Snom phone.
    >
    > It is a deficiency in the SIP/RTP protocol.
    >
    > Mute means one way audio. If the RTP sequence rolls over while you are
    > on mute, you lose the call.
    >
    > I think. Could be other things too.
    >
    > If you could get a pcap/ethereal trace of when the call drops out, I'd
    > know for sure.
    >
    > Tim
    > (been to the pub, so I don't guarantee the above answer)


    Very interesting point. This is mentioned here as well:
    http://www1.ietf.org/mail-archive/web/sip/current/msg09638.html

    So beer is fine...

    JM
    damn-it, Mar 9, 2007
    #3
  4. In article <>,
    damn-it <> wrote:
    > Guys,
    >
    > I have this weird problem.
    >
    > I just got my snom 300, via voipfone, and during a conference call, were
    > I was on mute, my phone simply ended the communication after a while
    > (about 5 minutes). This already happened few times, and basically make
    > voipfone unusable on conference call...
    >
    > Had a chat with their support and the answer was as follow:
    > "Yes, if there is no audio coming from either end of the call, it will
    > be dropped."
    >
    > What I see is that even when people are talking on the line, and I am on
    > mute, the call is dropped.


    Have a look at the configuration of your phone for something like "Silence
    Suppression". If it is turned on, try turning it off.

    The problem is likely that when on mute, the RTP stream from your phone
    is turned off because you are silent. After 5 min, the remote end thinks
    you're not there any more. With Silence Suppression disabled, the phone
    should continue to send an RTP stream containing silence. Hopefully!

    Cheers
    Tony
    --
    Tony Mountifield
    Work: - http://www.softins.co.uk
    Play: - http://tony.mountifield.org
    Tony Mountifield, Mar 9, 2007
    #4
  5. damn-it

    ian Guest

    In message <>, damn-it
    <> writes

    >What I see is that even when people are talking on the line, and I am
    >on mute, the call is dropped.
    >
    >Any clues? (Oh, and this is not a credit issue....)


    I have an SNOM 300 that I use on voipfone. I set up a call just now,
    with a radio near the phone at one end (to provide continuous
    "conference" audio), and I muted the other end (to inhibit all audio).
    There was no break in the connection for over 20 minutes, after which
    time I manually terminated the call.

    On your SNOM 300, I wonder if you have an inappropriate setting for the
    "Presence Inactivity Timeout" (under Preferences > Privacy Settings)?

    --
    Ian
    ian, Mar 9, 2007
    #5
  6. damn-it

    damn-it Guest

    ian wrote:
    > In message <>, damn-it
    > <> writes
    >
    >> What I see is that even when people are talking on the line, and I am
    >> on mute, the call is dropped.
    >>
    >> Any clues? (Oh, and this is not a credit issue....)

    >
    > I have an SNOM 300 that I use on voipfone. I set up a call just now,
    > with a radio near the phone at one end (to provide continuous
    > "conference" audio), and I muted the other end (to inhibit all audio).
    > There was no break in the connection for over 20 minutes, after which
    > time I manually terminated the call.
    >
    > On your SNOM 300, I wonder if you have an inappropriate setting for the
    > "Presence Inactivity Timeout" (under Preferences > Privacy Settings)?
    >

    Thanks Ian

    Presence Inactivity Timeout (in minutes): 45

    Surely this is not that... Thanks for trying.... MMmmhh.... let me try
    this myself with another dummy conf call....

    will Let you know....

    JM
    damn-it, Mar 9, 2007
    #6
  7. damn-it

    Tim Guest

    ian wrote:
    > On your SNOM 300, I wonder if you have an inappropriate setting for the
    > "Presence Inactivity Timeout" (under Preferences > Privacy Settings)?


    That setting isn't anything to do with audio. It is to do with presence.


    I'm wondering now if the original poster has a SIP ALG in his router
    which is killing the call. That the router can't cope with one way
    RTP(audio).

    Tim
    Tim, Mar 9, 2007
    #7
  8. damn-it

    damn-it Guest

    ian wrote:
    > In message <>, damn-it
    > <> writes
    >
    >> What I see is that even when people are talking on the line, and I am
    >> on mute, the call is dropped.
    >>
    >> Any clues? (Oh, and this is not a credit issue....)

    >
    > I have an SNOM 300 that I use on voipfone. I set up a call just now,
    > with a radio near the phone at one end (to provide continuous
    > "conference" audio), and I muted the other end (to inhibit all audio).
    > There was no break in the connection for over 20 minutes, after which
    > time I manually terminated the call.
    >
    > On your SNOM 300, I wonder if you have an inappropriate setting for the
    > "Presence Inactivity Timeout" (under Preferences > Privacy Settings)?
    >


    Ok, just retried, and was kicked out after 3:14.

    real sad....

    now trying with the Silence Suppression:On.

    will see.

    Thx
    damn-it, Mar 9, 2007
    #8
  9. damn-it

    ian Guest

    In message <45f14345$0$760$>, Tim
    <> writes
    >ian wrote:
    >> On your SNOM 300, I wonder if you have an inappropriate setting for
    >>the "Presence Inactivity Timeout" (under Preferences > Privacy
    >>Settings)?

    >
    >That setting isn't anything to do with audio. It is to do with presence.
    >
    >


    Hmmm. I suspected it might not be relevant (especially as my setting is
    15 minutes, yet the test call I mentioned lasted for over 20 minutes).

    That being the case, what exactly does "presence" mean?

    --
    Ian
    ian, Mar 9, 2007
    #9
  10. damn-it

    damn-it Guest

    Tony Mountifield wrote:
    > In article <>,
    > damn-it <> wrote:
    >> Guys,
    >>
    >> I have this weird problem.
    >>
    >> I just got my snom 300, via voipfone, and during a conference call, were
    >> I was on mute, my phone simply ended the communication after a while
    >> (about 5 minutes). This already happened few times, and basically make
    >> voipfone unusable on conference call...
    >>
    >> Had a chat with their support and the answer was as follow:
    >> "Yes, if there is no audio coming from either end of the call, it will
    >> be dropped."
    >>
    >> What I see is that even when people are talking on the line, and I am on
    >> mute, the call is dropped.

    >
    > Have a look at the configuration of your phone for something like "Silence
    > Suppression". If it is turned on, try turning it off.
    >
    > The problem is likely that when on mute, the RTP stream from your phone
    > is turned off because you are silent. After 5 min, the remote end thinks
    > you're not there any more. With Silence Suppression disabled, the phone
    > should continue to send an RTP stream containing silence. Hopefully!
    >
    > Cheers
    > Tony


    Hi Tony,

    Silence Suppression was Off.... so I set it up to On, and the Mute key
    doesn't work anymore....

    But call seems to hold.... (I guess this is the same as not being on
    mute....)....

    Is there a mean to configure a keep_alive on RTP?

    Thanks
    JM
    damn-it, Mar 9, 2007
    #10
  11. damn-it

    damn-it Guest

    Tim wrote:
    > ian wrote:
    >> On your SNOM 300, I wonder if you have an inappropriate setting for
    >> the "Presence Inactivity Timeout" (under Preferences > Privacy Settings)?

    >
    > That setting isn't anything to do with audio. It is to do with presence.
    >
    >
    > I'm wondering now if the original poster has a SIP ALG in his router
    > which is killing the call. That the router can't cope with one way
    > RTP(audio).
    >
    > Tim
    >

    Good idea Tim

    Router is Draytek 2600. Not sure if there is anything to keep the RTP
    connection alive.... VoIP phone is plugged directly into the router.

    Thanks for the hint. fill fish around....

    JM
    damn-it, Mar 9, 2007
    #11
  12. damn-it

    damn-it Guest

    Tim wrote:
    > ian wrote:
    >> On your SNOM 300, I wonder if you have an inappropriate setting for
    >> the "Presence Inactivity Timeout" (under Preferences > Privacy Settings)?

    >
    > That setting isn't anything to do with audio. It is to do with presence.
    >
    >
    > I'm wondering now if the original poster has a SIP ALG in his router
    > which is killing the call. That the router can't cope with one way
    > RTP(audio).
    >
    > Tim
    >


    Would you say the "Outbound Proxy:" setting would help? I have it blank
    for now....

    Thanks
    damn-it, Mar 9, 2007
    #12
  13. damn-it

    Tim Guest

    damn-it wrote:
    > Router is Draytek 2600. Not sure if there is anything to keep the RTP
    > connection alive.... VoIP phone is plugged directly into the router.


    You need to telnet to your router and disable the SIP ALG.

    once you are in, I think the command is

    sys sip 0

    That's from memory - I've taken out all my draytek routers now, so I
    don't have one I can easily look at.

    If the command isn't there, you need to upgrade your router firmware -
    the old versions have problems with SIP.


    Tim
    Tim, Mar 9, 2007
    #13
  14. damn-it

    Tim Guest

    damn-it wrote:
    >
    > Would you say the "Outbound Proxy:" setting would help? I have it blank
    > for now....
    >


    Not needed for voipfone and a snom. Your phone was shipped to you
    correctly configured.

    Tim
    Tim, Mar 9, 2007
    #14
  15. damn-it

    Paul Hayes Guest

    damn-it wrote:
    > Tim wrote:
    >> ian wrote:
    >>> On your SNOM 300, I wonder if you have an inappropriate setting for
    >>> the "Presence Inactivity Timeout" (under Preferences > Privacy
    >>> Settings)?

    >>
    >> That setting isn't anything to do with audio. It is to do with presence.
    >>
    >>
    >> I'm wondering now if the original poster has a SIP ALG in his router
    >> which is killing the call. That the router can't cope with one way
    >> RTP(audio).
    >>
    >> Tim
    >>

    > Good idea Tim
    >
    > Router is Draytek 2600. Not sure if there is anything to keep the RTP
    > connection alive.... VoIP phone is plugged directly into the router.
    >
    > Thanks for the hint. fill fish around....
    >
    > JM


    aha! We get a lot of problems with the SIP ALG in these routers. You
    need to telnet into it to turn it off:

    telnet (ip address of router)

    enter username & password as you would to login to it's web interface.

    Then issue the command:

    sys sip_alg 0

    Which should disable it.

    Type in:

    sys sip_alg

    and it'll tell you if it's enabled or not.

    If it comes up with an error something along the lines of "command not
    found", you'll probably need to upgrade the firmware on the router,
    should be available on the Draytek website.

    cheers,
    Paul.
    Paul Hayes, Mar 9, 2007
    #15
  16. In article <>,
    damn-it <> wrote:
    > Tony Mountifield wrote:
    > > Have a look at the configuration of your phone for something like "Silence
    > > Suppression". If it is turned on, try turning it off.
    > >
    > > The problem is likely that when on mute, the RTP stream from your phone
    > > is turned off because you are silent. After 5 min, the remote end thinks
    > > you're not there any more. With Silence Suppression disabled, the phone
    > > should continue to send an RTP stream containing silence. Hopefully!

    >
    > Silence Suppression was Off.... so I set it up to On, and the Mute key
    > doesn't work anymore....
    >
    > But call seems to hold.... (I guess this is the same as not being on
    > mute....)....
    >
    > Is there a mean to configure a keep_alive on RTP?


    I'm afraid I'm not familiar with that brand of phone, so could only talk
    in general terms.

    That's weird about the Mute key no longer working.

    A keepalive heartbeat would be a useful thing to have, but I'm not aware
    of one. If you manually unmute and re-mute every few minutes before it
    times out, does it keep the call alive?

    Sorry I can't help further....

    Cheers
    Tony
    --
    Tony Mountifield
    Work: - http://www.softins.co.uk
    Play: - http://tony.mountifield.org
    Tony Mountifield, Mar 9, 2007
    #16
  17. damn-it

    damn-it Guest

    Tim wrote:
    > damn-it wrote:
    >> Router is Draytek 2600. Not sure if there is anything to keep the RTP
    >> connection alive.... VoIP phone is plugged directly into the router.

    >
    > You need to telnet to your router and disable the SIP ALG.
    >
    > once you are in, I think the command is
    >
    > sys sip 0
    >
    > That's from memory - I've taken out all my draytek routers now, so I
    > don't have one I can easily look at.
    >
    > If the command isn't there, you need to upgrade your router firmware -
    > the old versions have problems with SIP.
    >
    >
    > Tim



    Ok,

    Don't want to be funny here, but the Draytek already has another VoIP
    service on it.... (the `don't put all your eggs in the same basket story`)

    I am just trying the same test using voip.co.uk, and the line stays up
    (not cut after 7 min, which is a record). That's bad news for
    voipfone.co.uk.

    Bugger !!!!

    If anyone can share any light on this, very welcome.....

    JM
    damn-it, Mar 9, 2007
    #17
  18. damn-it

    damn-it Guest

    Paul Hayes wrote:
    > damn-it wrote:
    >> Tim wrote:
    >>> ian wrote:
    >>>> On your SNOM 300, I wonder if you have an inappropriate setting for
    >>>> the "Presence Inactivity Timeout" (under Preferences > Privacy
    >>>> Settings)?
    >>>
    >>> That setting isn't anything to do with audio. It is to do with
    >>> presence.
    >>>
    >>>
    >>> I'm wondering now if the original poster has a SIP ALG in his router
    >>> which is killing the call. That the router can't cope with one way
    >>> RTP(audio).
    >>>
    >>> Tim
    >>>

    >> Good idea Tim
    >>
    >> Router is Draytek 2600. Not sure if there is anything to keep the RTP
    >> connection alive.... VoIP phone is plugged directly into the router.
    >>
    >> Thanks for the hint. fill fish around....
    >>
    >> JM

    >
    > aha! We get a lot of problems with the SIP ALG in these routers. You
    > need to telnet into it to turn it off:
    >
    > telnet (ip address of router)
    >
    > enter username & password as you would to login to it's web interface.
    >
    > Then issue the command:
    >
    > sys sip_alg 0
    >
    > Which should disable it.
    >
    > Type in:
    >
    > sys sip_alg
    >
    > and it'll tell you if it's enabled or not.
    >
    > If it comes up with an error something along the lines of "command not
    > found", you'll probably need to upgrade the firmware on the router,
    > should be available on the Draytek website.
    >
    > cheers,
    > Paul.


    All,

    On the draytek promt:
    > sys sip_alg ?

    usage: sys sip_alg [value]
    0 - disable SIP ALG
    1 - enable SIP ALG
    current SIP ALG is disabled


    So after this last test using voip.co.uk, I think I am going to blame
    voipfone rather than draytek or snom....

    Any other suggestion, just lst me know...

    Thanks

    JM
    damn-it, Mar 9, 2007
    #18
  19. damn-it

    Tim Guest

    damn-it wrote:
    >
    > Don't want to be funny here, but the Draytek already has another VoIP
    > service on it.... (the `don't put all your eggs in the same basket story`)


    Just because 1 voip service works, doesn't mean another will. It also
    doesn't mean that 2 voip services will work at the same time.

    Disabling the draytek ALG has helped for fix loads of people's problems.
    It is something I suggest often. It usually helps. I guess at for
    at least 50 people i've dealt with.

    Tim
    Tim, Mar 9, 2007
    #19
  20. damn-it

    damn-it Guest

    Tim wrote:
    > damn-it wrote:
    >>
    >> Don't want to be funny here, but the Draytek already has another VoIP
    >> service on it.... (the `don't put all your eggs in the same basket
    >> story`)

    >
    > Just because 1 voip service works, doesn't mean another will. It also
    > doesn't mean that 2 voip services will work at the same time.
    >
    > Disabling the draytek ALG has helped for fix loads of people's problems.
    > It is something I suggest often. It usually helps. I guess at for
    > at least 50 people i've dealt with.
    >
    > Tim


    I guess I was confused because I thought at fist that disabling SIP ALG
    would prevent the phone plugged in the router to work. Anyway, it seems
    like SIP ALG was already disabled.

    > sys sip_alg ?

    usage: sys sip_alg [value]
    0 - disable SIP ALG
    1 - enable SIP ALG
    current SIP ALG is disabled


    Which sadly bring me back to my original issue :(

    Any other hints?

    For what it is worth, I have tried with voip.co.uk, (opened the account
    this morning) and it seems to work correctly with them....

    Thanks

    JM
    damn-it, Mar 9, 2007
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    4
    Views:
    2,503
    Scooty
    May 3, 2006
  2. =?Utf-8?B?a29vbGVy?=

    Wireless Connection Drops after 5 minutes

    =?Utf-8?B?a29vbGVy?=, Oct 7, 2006, in forum: Wireless Networking
    Replies:
    5
    Views:
    3,605
    =?Utf-8?B?a29vbGVy?=
    Oct 20, 2006
  3. Mr JM
    Replies:
    35
    Views:
    1,591
  4. Mr JM
    Replies:
    17
    Views:
    1,248
    Harry Stottle
    Mar 22, 2008
  5. Screamin'04
    Replies:
    2
    Views:
    902
    Screamin'04
    Dec 18, 2008
Loading...

Share This Page