puzzling routing problem

Discussion in 'Cisco' started by Geert, Apr 7, 2004.

  1. Geert

    Geert Guest

    The following has got me puzzled on a test-router:

    I have 2 'incoming' interfaces:

    one is running RIP
    the other is running EIGRP

    A specific subnet A is advertised both in RIP and in EIGRP (as external).
    Since AD of RIP is 120 and the AD of external EIGRP is 170, the RIP
    route will appear in the routing table.

    So far, so good.

    Now we also have a third 'outgoing' interface.
    This interface is running EIGRP. There is no redistribution between RIP
    and EIGRP.

    and what i have noted is that the subnet A, is not advertised on this
    interface ??????
    The reason for this is that in a "show ip eigrp topology", the subnet
    A has a metric of "Inaccessible" and therefore is not advertised further
    out with EIGRP. The strange thing is that i know for sure that the
    subnet A is NOT advertised with "Inaccessible" on the incoming
    interface. I have verified this: when i shutdown the RIP interface, the
    metric of subnet A changes in the "show ip eigrp topology" to the metric
    received on the EIGRP interface. At this point, the subnet is advertised
    further on the outgoing interface. From the moment, i activate the RIP
    interface, the metric changes to "Inaccessible" (in EIGRP) and the
    subnet stops being advertised on the outgoing interface........

    Why is this ? I must be overlooking something basic here......
    mvg,
    Geert
    Geert, Apr 7, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Rennie
    Replies:
    0
    Views:
    3,340
    John Rennie
    Mar 14, 2006
  2. Steve Meyerson

    Puzzling Hijack (I think) Problem

    Steve Meyerson, Sep 21, 2004, in forum: Computer Support
    Replies:
    7
    Views:
    505
    Jimmy Dean
    Sep 23, 2004
  3. bhat

    A puzzling observation for me!

    bhat, Oct 7, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    422
  4. Demolitio

    puzzling dvd burner problem

    Demolitio, Jul 16, 2005, in forum: Computer Support
    Replies:
    10
    Views:
    913
    Jimmy Dean
    Jul 17, 2005
  5. Mort

    Puzzling Flash Exposure Problem With Canon S100

    Mort, Jan 2, 2012, in forum: Digital Photography
    Replies:
    2
    Views:
    385
    Robert Coe
    Jan 5, 2012
Loading...

Share This Page