PROGRAM.exe not found

Discussion in 'Firefox' started by Martin Leese, May 19, 2005.

  1. Martin Leese

    Martin Leese Guest

    Hi,

    I am running Thunderbid 1.0.2 with Firefox 1.0.4 under
    Windows 95 (and Windows 95 is not supported).

    When I display newsgroup messages in Thunderbird URLs
    are highlighted as links, but when I click on the link
    I get the error message "Windows cannot find PROGRAM.exe".

    What does Thunderbird use PROGRAM.exe to do?

    My current work around is to copy and paste the URL into
    a Firefox window. Is there a better work around?

    --
    Regards,
    Martin Leese
    E-mail: -mail.INVALID
    Web: http://members.tripod.com/martin_leese/
    Martin Leese, May 19, 2005
    #1
    1. Advertising

  2. Martin Leese

    Ralph Fox Guest

    On Thu, 19 May 2005 12:40:19 -0600, in message
     <d6imil$8ho$>, Martin Leese wrote:

    > Hi,
    >
    > I am running Thunderbid 1.0.2 with Firefox 1.0.4 under
    > Windows 95 (and Windows 95 is not supported).
    >
    > When I display newsgroup messages in Thunderbird URLs
    > are highlighted as links, but when I click on the link
    > I get the error message "Windows cannot find PROGRAM.exe".
    >
    > What does Thunderbird use PROGRAM.exe to do?



    1. Most likely there is a messed up entry in the Windows Registry,
    where your default browser should be configured.

    Thunderbird is just relying on the Windows registry
    to find the default browser.


    > My current work around is to copy and paste the URL into
    > a Firefox window. Is there a better work around?



    2. What is your default browser?

    3. Check this out.

    3.1 From Windows Explorer (not IE), go to
    "View -> Folder Options -> File Types"
    3.2 Scroll down in the list box and select the
    entry for "URL:http Hypertext Transfer Protocol".
    3.3 Click the Edit button.
    A new dialog box will pop up.
    3.4 On the new dialog box, select "open" (it should be the
    line in bold).
    3.5 Click the Edit button.
    3.5 In the box labelled "Application to perform action",
    what does it say?

    In particular, does the full directory path to the browser

    3.5.1 Have spaces in it, like examples A and B ?
    3.5.2 Have quote marks around it, like example B ?

    Examples

    A. C:\PROGRAM FILES\Mozilla Firefox\firefox.exe -url "%1"

    B. "C:\PROGRAM FILES\Mozilla Firefox\firefox.exe" -url "%1"

    C. C:\PROGRA~1\MOZILL~1\FIREFOX.EXE -url "%1"

    3.6 Now repeat the same checks for

    URL:https Hypertext Transfer Protocol with Privacy

    URL:ftp File Transfer Protocol


    4. If you can't find these settings in 3, are you comfortable editing
    your Windows registry?



    --
    Cheers,
    Ralph

    A doctor can bury his mistakes, but an architect can only advise his clients to plant vines.
    Ralph Fox, May 21, 2005
    #2
    1. Advertising

  3. Martin Leese

    Martin Leese Guest

    Hi Ralph,

    Many thanks for your help.

    Ralph Fox wrote:

    > On Thu, 19 May 2005 12:40:19 -0600, in message
    > <d6imil$8ho$>, Martin Leese wrote:
    >>
    >>I am running Thunderbid 1.0.2 with Firefox 1.0.4 under
    >>Windows 95 (and Windows 95 is not supported).
    >>
    >>When I display newsgroup messages in Thunderbird URLs
    >>are highlighted as links, but when I click on the link
    >>I get the error message "Windows cannot find PROGRAM.exe".

    >
    > 1. Most likely there is a messed up entry in the Windows Registry,
    > where your default browser should be configured.
    >
    > Thunderbird is just relying on the Windows registry
    > to find the default browser.
    >
    > 2. What is your default browser?


    Firefox. Clicking on a file with the extension ".html"
    brings up the browser fine.

    > 3. Check this out.
    >
    > 3.1 From Windows Explorer (not IE), go to
    > "View -> Folder Options -> File Types"
    > 3.2 Scroll down in the list box and select the
    > entry for "URL:http Hypertext Transfer Protocol".


    There is no such entry. There are entries for
    "URL:MailTo Protocol" and others.

    > 3.3 Click the Edit button.
    > A new dialog box will pop up.
    > 3.4 On the new dialog box, select "open" (it should be the
    > line in bold).
    > 3.5 Click the Edit button.
    > 3.5 In the box labelled "Application to perform action",
    > what does it say?


    It is not there. What should be under the Open action?
    "URL:MailTo Protocol", for example, contains:
    rundll32.exe url.dll,MailToProtocolHandler %l

    > 3.6 Now repeat the same checks for
    > URL:https Hypertext Transfer Protocol with Privac
    > URL:ftp File Transfer Protocol


    Neither of these is present either. I do have:
    URL:MailTo Protocol
    URL:Microsoft Network Protocol
    URL:RLogin Protocol
    URL:Telnet Protocol
    URL:TN3270 Protocol

    > 4. If you can't find these settings in 3, are you comfortable editing
    > your Windows registry?


    Yes, but I can create the missing ones anyway as long
    as somebody tells me what stuff should be under the
    Open action.

    Thanks again for your help.

    --
    Regards,
    Martin Leese
    E-mail: -mail.INVALID
    Web: http://members.tripod.com/martin_leese/
    Martin Leese, May 21, 2005
    #3
  4. Martin Leese

    Rom Guest

    On Fri, 20 May 2005 21:06:26 -0600, Martin Leese rambled:

    > > On Thu, 19 May 2005 12:40:19 -0600, in message
    > > <d6imil$8ho$>, Martin Leese wrote:
    > >>
    > >>I am running Thunderbid 1.0.2 with Firefox 1.0.4 under
    > >>Windows 95 (and Windows 95 is not supported).
    > >>
    > >>When I display newsgroup messages in Thunderbird URLs
    > >>are highlighted as links, but when I click on the link
    > >>I get the error message "Windows cannot find PROGRAM.exe".

    > >
    > > 1. Most likely there is a messed up entry in the Windows Registry,
    > > where your default browser should be configured.
    > >
    > > Thunderbird is just relying on the Windows registry
    > > to find the default browser.
    > >
    > > 2. What is your default browser?

    >
    > Firefox. Clicking on a file with the extension ".html"
    > brings up the browser fine.


    No, the ".html" extension of a file is a file type, and you would have
    the ".html" file type associated with Firefox if clicking a ".html"
    file on your drive opens Firefox.

    It's the "URL:http Hypertext Transfer Protocol", when associated with
    a browser that makes a browser the default, not a ".html" extension.

    Look at these example URLs:
    http://example.com/
    http://example.com/foobar.html
    http://example.com/foobar.exe
    http://example.com/foobar.txt

    The first part is the protocol, in this case is HTTP, the second part
    is the domain name and the location of resources, and the last part
    may show different files with different file types. Clicking on URLs
    like the above examples says to retrieve the file or the web page
    using the HTTP protocol, but your OS needs to know which application
    is to handle them. After that, it's up to the browser how to handle
    files and/or render web pages.

    > > 3. Check this out.
    > >
    > > 3.1 From Windows Explorer (not IE), go to
    > > "View -> Folder Options -> File Types"
    > > 3.2 Scroll down in the list box and select the
    > > entry for "URL:http Hypertext Transfer Protocol".

    >
    > There is no such entry.


    Then Firefox, or any other browser, isn't the default browser (yet).

    > > 3.3 Click the Edit button.
    > > A new dialog box will pop up.
    > > 3.4 On the new dialog box, select "open" (it should be the
    > > line in bold).
    > > 3.5 Click the Edit button.
    > > 3.5 In the box labelled "Application to perform action",
    > > what does it say?

    >
    > It is not there. What should be under the Open action?


    I don't use Win95 and haven't for a long time, but I take it the
    Firefox setting for checking the default browser in "Tools > Options >
    General" doesn't work in Win95?

    Next to the box labelled "Application to perform action" if there
    isn't a "Browse" button in Win95, look at the examples in 3.5.2 of
    Ralph's previous message for what to enter. As even though the URLs
    below are for IE (copy and paste into your browser), the first one has
    some information on the error, and the second one includes Win95 in
    its instructions, which are hard to find these days.
    <http://support.microsoft.com/default.aspx?scid=kb;en-us;191219>
    <http://support.microsoft.com/default.aspx?scid=kb;en-us;177054>

    --
    Rom
    Rom, May 22, 2005
    #4
  5. Martin Leese

    Ralph Fox Guest

    On Fri, 20 May 2005 21:06:26 -0600, in message
     <d6m8jj$mjb$>, Martin Leese wrote:

    > Hi Ralph,
    >
    > Many thanks for your help.
    >
    > Ralph Fox wrote:
    >
    > > On Thu, 19 May 2005 12:40:19 -0600, in message
    > > <d6imil$8ho$>, Martin Leese wrote:
    > >>
    > >>I am running Thunderbid 1.0.2 with Firefox 1.0.4 under
    > >>Windows 95 (and Windows 95 is not supported).
    > >>
    > >>When I display newsgroup messages in Thunderbird URLs
    > >>are highlighted as links, but when I click on the link
    > >>I get the error message "Windows cannot find PROGRAM.exe".

    > >
    > > 1. Most likely there is a messed up entry in the Windows Registry,
    > > where your default browser should be configured.
    > >
    > > Thunderbird is just relying on the Windows registry
    > > to find the default browser.
    > >
    > > 2. What is your default browser?

    >
    > Firefox. Clicking on a file with the extension ".html"
    > brings up the browser fine.


    If you go to Run -> Start and type in a web URL link
    like http://www.mozilla.org/ , which app opens?

    If you click on an internet shortcut pointing to
    http://www.mozilla.org/ , which app opens?

    So far, this has told us that Firefox is associated with local .HTML
    files on your local hard drive. It says nothing about which app is
    associated with web URL links (the more important part of the question).


    > > 3. Check this out.
    > >
    > > 3.1 From Windows Explorer (not IE), go to
    > > "View -> Folder Options -> File Types"
    > > 3.2 Scroll down in the list box and select the
    > > entry for "URL:http Hypertext Transfer Protocol".

    >
    > There is no such entry. There are entries for
    > "URL:MailTo Protocol" and others.



    Then almost certainly your registry is missing a few entries
    which are required.

    I will guess that you will also have problems launching
    web URL links when entering the URL into Run -> Start.


    > > 3.3 Click the Edit button.
    > > A new dialog box will pop up.
    > > 3.4 On the new dialog box, select "open" (it should be the
    > > line in bold).
    > > 3.5 Click the Edit button.
    > > 3.5 In the box labelled "Application to perform action",
    > > what does it say?

    >
    > It is not there. What should be under the Open action?
    > "URL:MailTo Protocol", for example, contains:
    > rundll32.exe url.dll,MailToProtocolHandler %l



    For any URL link association, the registry needs one entry which you
    cannot enter from that dialog. So you can fill in the open action
    as follows (including all quote marks), but that is not enough.

    "C:\Program Files\Mozilla Firefox\firefox.exe" -url "%1"

    However, MS-Windows will not consider it to be a URL link association
    unless the following entry is also in the registry:

    [HKEY_CLASSES_ROOT\http]
    "URL Protocol"=""


    > > 3.6 Now repeat the same checks for
    > > URL:https Hypertext Transfer Protocol with Privac
    > > URL:ftp File Transfer Protocol

    >
    > Neither of these is present either. I do have:
    > URL:MailTo Protocol
    > URL:Microsoft Network Protocol
    > URL:RLogin Protocol
    > URL:Telnet Protocol
    > URL:TN3270 Protocol


    As above.


    > > 4. If you can't find these settings in 3, are you comfortable editing
    > > your Windows registry?

    >
    > Yes, but I can create the missing ones anyway as long
    > as somebody tells me what stuff should be under the
    > Open action.



    As above it needs more than stuff under the Open action.
    It needs another entry to tell MS-Windows that this is a URL protocol.

    This entry is how, for example, MS-Windows knows that the registry
    key [HKEY_CLASSES_ROOT\txtfile] is not for a "txtfile" URL protocol,
    but the registry key [HKEY_CLASSES_ROOT\https] is for an "https" URL
    protocol.


    > Thanks again for your help.



    --
    Cheers,
    Ralph

    "There is only one boss, the customer. And he can fire everybody in
    the company from the chairman on down, simply by spending his money
    somewhere else." -- Sam Walton
    Ralph Fox, May 22, 2005
    #5
  6. Martin Leese

    Martin Leese Guest

    Rom wrote:
    ....
    > I don't use Win95 and haven't for a long time, but I take it the
    > Firefox setting for checking the default browser in "Tools > Options >
    > General" doesn't work in Win95?


    Yes, this worked. Many thanks for your help.

    --
    Regards,
    Martin Leese
    E-mail: -mail.INVALID
    Web: http://members.tripod.com/martin_leese/
    Martin Leese, May 22, 2005
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Steven Pua
    Replies:
    2
    Views:
    1,439
    Harrison
    Jan 10, 2004
  2. Mr. id

    elitelos32.exe virus not found anywhere

    Mr. id, Mar 20, 2005, in forum: Computer Support
    Replies:
    8
    Views:
    441
    Mr. id
    Mar 20, 2005
  3. Joseph Ladovic

    Re:Windows Media Player: wmplayer.exe - Entry Point Not Found

    Joseph Ladovic, Mar 20, 2005, in forum: Computer Information
    Replies:
    0
    Views:
    576
    Joseph Ladovic
    Mar 20, 2005
  4. Don Phillipson

    Found and Not Found

    Don Phillipson, Oct 1, 2009, in forum: Wireless Networking
    Replies:
    1
    Views:
    494
    Jack [MVP-Networking]
    Oct 2, 2009
  5. Nathan Sokalski
    Replies:
    16
    Views:
    3,215
    Vjekoslav
    Feb 22, 2010
Loading...

Share This Page