Program calls home, though I disabled the access

Discussion in 'Computer Security' started by Edw. Peach, Aug 18, 2004.

  1. Edw. Peach

    Edw. Peach Guest

    I have a CD burning program that was bundled with my computer software
    when I bought it, a program called Sonic. It works nicely and I've
    never had a problem with it. I noticed that it checked for updates
    everytime I fired up my computer, so I turned off that service in
    MSCONFIG (WinXP.)

    Whenever I open the program, I notice my 'internet activity' light
    goes on in Zone Alarm. (I have Sonic blocked from internet access with
    my fire wall.) And whenever I burn a CD, I see the activity light go
    on as well.

    I can't see how the program accesses the internet, if I have the
    visible portals I found blocked. It's not a big issue for me, but I
    feel it is an infringement...If I stop a program from accessing the
    internet, ANY program, I expect that it will not be able to call home
    unless I say so.

    What's up with this?
     
    Edw. Peach, Aug 18, 2004
    #1
    1. Advertising

  2. Edw. Peach

    Quaoar Guest

    Edw. Peach wrote:
    > I have a CD burning program that was bundled with my computer software
    > when I bought it, a program called Sonic. It works nicely and I've
    > never had a problem with it. I noticed that it checked for updates
    > everytime I fired up my computer, so I turned off that service in
    > MSCONFIG (WinXP.)
    >
    > Whenever I open the program, I notice my 'internet activity' light
    > goes on in Zone Alarm. (I have Sonic blocked from internet access with
    > my fire wall.) And whenever I burn a CD, I see the activity light go
    > on as well.
    >
    > I can't see how the program accesses the internet, if I have the
    > visible portals I found blocked. It's not a big issue for me, but I
    > feel it is an infringement...If I stop a program from accessing the
    > internet, ANY program, I expect that it will not be able to call home
    > unless I say so.
    >
    > What's up with this?


    msconfig stops the current startup settings only. Many programs will
    reinstitute the auto update, etc, the next time they are run, and
    msconfig must be used once again to disable the option. The only was to
    stop the program from phoning home is to disable the option in the
    program itself from its preferences or options or tools menu.

    Q
     
    Quaoar, Aug 18, 2004
    #2
    1. Advertising

  3. Edw. Peach

    george Guest

    Go to your hosts file and add and open it with notepad.
    make an entry -
    67.67.67.67 www.(whatever the website is).com
    It then will never reach home.

    George
    On Wed, 18 Aug 2004 08:45:45 -0600, "Quaoar" <>
    wrote:

    >Edw. Peach wrote:
    >> I have a CD burning program that was bundled with my computer software
    >> when I bought it, a program called Sonic. It works nicely and I've
    >> never had a problem with it. I noticed that it checked for updates
    >> everytime I fired up my computer, so I turned off that service in
    >> MSCONFIG (WinXP.)
    >>
    >> Whenever I open the program, I notice my 'internet activity' light
    >> goes on in Zone Alarm. (I have Sonic blocked from internet access with
    >> my fire wall.) And whenever I burn a CD, I see the activity light go
    >> on as well.
    >>
    >> I can't see how the program accesses the internet, if I have the
    >> visible portals I found blocked. It's not a big issue for me, but I
    >> feel it is an infringement...If I stop a program from accessing the
    >> internet, ANY program, I expect that it will not be able to call home
    >> unless I say so.
    >>
    >> What's up with this?

    >
    >msconfig stops the current startup settings only. Many programs will
    >reinstitute the auto update, etc, the next time they are run, and
    >msconfig must be used once again to disable the option. The only was to
    >stop the program from phoning home is to disable the option in the
    >program itself from its preferences or options or tools menu.
    >
    >Q
    >
     
    george, Aug 18, 2004
    #3
  4. In article <>, on Wed, 18 Aug 2004 11:22:44 -0400, george
    <> wrote:

    Please don't top post <stuff moved to end/>

    | On Wed, 18 Aug 2004 08:45:45 -0600, "Quaoar" <>
    | wrote:

    <snip />

    | >msconfig stops the current startup settings only. Many programs will
    | >reinstitute the auto update, etc, the next time they are run, and
    | >msconfig must be used once again to disable the option. The only was to
    | >stop the program from phoning home is to disable the option in the
    | >program itself from its preferences or options or tools menu.
    | >
    | >Q
    | >

    | Go to your hosts file and add and open it with notepad.
    | make an entry -
    | 67.67.67.67 www.(whatever the website is).com
    | It then will never reach home.
    |
    | George

    Bad idea. 67.67.67.67 belongs to someone on swbell:

    nslookup 67.67.67.67
    Server: ns1-cro.blueyonder.net
    Address: 62.30.112.39

    Name: adsl-67-67-67-67.dsl.hstntx.swbell.net
    Address: 67.67.67.67

    The correct entry for your host file should be:

    127.0.0.1 www.(whatever the website is).com

    See <http://accs-net.com/hosts/what_is_hosts.html> and
    <http://www.mvps.org/winhelp2002/hosts.htm> for more info.

    <davidp />

    --
    David Postill
     
    David Postill, Aug 18, 2004
    #4
  5. Edw. Peach

    dono Guest

    On Wed, 18 Aug 2004 08:05:34 -0400, Edw. Peach <>
    wrote:

    >I have a CD burning program that was bundled with my computer software
    >when I bought it, a program called Sonic. It works nicely and I've
    >never had a problem with it. I noticed that it checked for updates
    >everytime I fired up my computer, so I turned off that service in
    >MSCONFIG (WinXP.)
    >
    >Whenever I open the program, I notice my 'internet activity' light
    >goes on in Zone Alarm. (I have Sonic blocked from internet access with
    >my fire wall.) And whenever I burn a CD, I see the activity light go
    >on as well.
    >
    >I can't see how the program accesses the internet, if I have the
    >visible portals I found blocked. It's not a big issue for me, but I
    >feel it is an infringement...If I stop a program from accessing the
    >internet, ANY program, I expect that it will not be able to call home
    >unless I say so.
    >
    >What's up with this?

    ########################
    Try a few things. Let it happen, open a DOS box, run
    netstat -an Look at the foreign address column, note the connection
    and the port. It helps not to have any other windows opened. Then do
    a whois on the IP address and see exactly where it's going.
    Also, try to determine the .exe that is calling home. You can do that
    by opening the task manager to see what's running. Search the
    registry and delete the value. Then it will never run.
     
    dono, Aug 19, 2004
    #5
  6. Edw. Peach

    Edw. Peach Guest

    On Wed, 18 Aug 2004 11:22:44 -0400, george <> wrote:

    >Go to your hosts file and add and open it with notepad.
    >make an entry -

    How do I ID the host file? would it be accessible from the program
    folder?
     
    Edw. Peach, Aug 19, 2004
    #6
  7. Edw. Peach

    Edw. Peach Guest

    On Wed, 18 Aug 2004 08:45:45 -0600, "Quaoar" <>
    wrote:


    >msconfig stops the current startup settings only. Many programs will
    >reinstitute the auto update, etc, the next time they are run, and
    >msconfig must be used once again to disable the option. The only was to
    >stop the program from phoning home is to disable the option in the
    >program itself from its preferences or options or tools menu.
    >
    >Q

    I looked through my options with the program itself, and there was
    nothing to disable. I didn't even find an option about 'check for
    updates,' which I think would be a logical place for such a program
    that calls home whenever i use it, to hide.
     
    Edw. Peach, Aug 19, 2004
    #7
  8. Edw. Peach

    Edw. Peach Guest

    Maybe the best option is not to use the program, and to go out and buy
    one. I did not read any agreement on this program as it was already
    loaded on my computer when I bought it. I wouldn't be surprised to
    find some fine print on it stating that the program will contact the
    mother ship.
     
    Edw. Peach, Aug 19, 2004
    #8
  9. Edw. Peach

    Ian Smith Guest

    Assuming you're on a broadband/ADSL/cable, one option is to open a
    "command prompt" box and enter "ipconfig /release" before you start
    the burner software. This effectively disconnects from the internet,
    but you have to enter "ipconfig /renew" to reconnect afterwards. In
    either case you can have the command entered as a batch file (.bat)
    called from a shortcut icon on the desktop. Perhaps I am wrong,
    though.





    .................................................................
    Posted via TITANnews - Uncensored Newsgroups Access
    >>>> at http://www.TitanNews.com <<<<

    -=Every Newsgroup - Anonymous, UNCENSORED, BROADBAND Downloads=-
     
    Ian Smith, Aug 21, 2004
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?UGV0ZXI=?=

    Access to some websites & mail halts/disabled over wireless connec

    =?Utf-8?B?UGV0ZXI=?=, Jul 10, 2005, in forum: Wireless Networking
    Replies:
    0
    Views:
    511
    =?Utf-8?B?UGV0ZXI=?=
    Jul 10, 2005
  2. =?Utf-8?B?bXJ3b25n?=

    SSID called HOME even though I have configured another SSID

    =?Utf-8?B?bXJ3b25n?=, Mar 26, 2006, in forum: Wireless Networking
    Replies:
    0
    Views:
    663
    =?Utf-8?B?bXJ3b25n?=
    Mar 26, 2006
  3. ubifone
    Replies:
    0
    Views:
    4,465
    ubifone
    Jul 29, 2005
  4. Giganews
    Replies:
    27
    Views:
    2,416
    Brian
    Oct 10, 2006
  5. Mr.G  (@¿@)
    Replies:
    5
    Views:
    430
    Mr.G (@¿@)
    Jul 7, 2010
Loading...

Share This Page