Problems with QoS Changes

Discussion in 'Cisco' started by chrisl1977, Apr 16, 2009.

  1. chrisl1977

    chrisl1977

    Joined:
    Apr 16, 2009
    Messages:
    1
    Hello - I'm attempting to setup a QOS rule in my router that allows traffic between certain servers to have at least 25% of the total bandwidth. I want these servers to be able to transfer large amounts of data between them 24x7 without affecting normal traffic (including VoIP), but to be able to use any unused bandwidth without affecting normal traffic. The VoIP qos works perfectly, however my backup rules seem to only allow 25% of the bandwidth to be used at any time between these servers. Here's my config:

    Code:
    !
    ! No configuration change since last restart
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname xxx
    !
    boot-start-marker
    boot system flash c1700-y-mz.123-26.bin
    boot-end-marker
    !
    logging monitor notifications
    enable secret 5 xxx
    enable password xxx
    !
    memory-size iomem 25
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    ip cef
    !
    ! --- access list to identify backup traffic ---
    access-list 105 permit ip host 172.16.3.3 host 172.16.8.39
    access-list 105 permit ip host 172.16.8.39 host 172.16.3.3
    access-list 105 permit ip host 172.16.3.20 host 172.16.8.26
    access-list 105 permit ip host 172.16.8.26 host 172.16.3.20
    !
    !
    class-map match-any Voice-Calls
      description [--- Actual voice traffic ---]
      match ip dscp ef 
      match ip precedence 5 
    class-map match-any Voice-Control
      description [--- Call Controll ---]
      match ip dscp af31 
      match ip precedence 3 
    class-map match-any BETraffic
      description [---Backup Traffic---]
      match access-group 105
    !
    !
    policy-map WAN-Link
     description [-- Apply QoS settings to T1's --]
      class Voice-Calls
       priority 960
      class Voice-Control
       priority percent 10
      class BETraffic
       priority percent 25
      class class-default
       fair-queue
    !
    !
    !
    interface Multilink1
     ip address 192.168.1.14 255.255.255.252
     no cdp enable
     ppp multilink
     ppp multilink group 1
     service-policy output WAN-Link
    !
    interface FastEthernet0
     no ip address
     speed auto
     full-duplex
    !
    interface FastEthernet0.1
     encapsulation dot1Q 1 native
     ip address 172.16.3.1 255.255.255.0
    !
    interface FastEthernet0.2
     encapsulation dot1Q 2
     ip address 172.16.9.1 255.255.255.0
     ip helper-address 172.16.3.3
    !
    interface Serial0
     bandwidth 1536
     no ip address
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip accounting access-violations
     encapsulation ppp
     no fair-queue
     service-module t1 clock source internal
     service-module t1 timeslots 1-24
     service-module t1 remote-alarm-enable
     no cdp enable
     ppp multilink
     ppp multilink group 1
    !
    interface Serial1
     bandwidth 1536
     no ip address
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip accounting access-violations
     encapsulation ppp
     no fair-queue
     service-module t1 clock source internal
     service-module t1 timeslots 1-24
     service-module t1 remote-alarm-enable
     no cdp enable
     ppp multilink
     ppp multilink group 1
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.13
    ip route 172.16.3.0 255.255.255.0 FastEthernet0.1
    ip route 172.16.9.0 255.255.255.0 FastEthernet0.2
    ip route 192.168.1.12 255.255.255.252 Multilink1
    ip http server
    !
    logging history informational
    logging trap notifications
    logging 172.16.0.27
    logging 172.16.0.28
    snmp-server community public RO
    snmp-server enable traps tty
    !
    line con 0
    line aux 0
    line vty 0 4
     password xxx
     login
    !
    end
    
    Ideally, here's what I want to do:
    1. Voice traffic takes precidence over all other traffic. Does this need to be a dedicated data rate or %? I'm not sure, but the current config meets the needs.
    2. All non-VoIP and non-backup traffic should be treated equally and be allowed to use any unused bandwidth.
    3. Backup traffic should be allocated 25% of total bandwidth, but should be allowed to exceed this if available bandwidth exists.

    Here's an alternative which is probably better suited to this task, but beyond my command of IOS:
    1. VoIP and Network Control has highest priority, gets handled first.
    2. Normal traffic gets something between "assured delivery" and "best effort" handling
    3. Backup traffic gets "best effort"...but it should have at least 25% of the line if it's running.

    Any help would be appreciated. Thanks - Chris
    :loo:
    chrisl1977, Apr 16, 2009
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Richard Lefebvre

    Changes to QoS for VoIP is affecting NFS

    Richard Lefebvre, Jan 14, 2005, in forum: Cisco
    Replies:
    0
    Views:
    661
    Richard Lefebvre
    Jan 14, 2005
  2. Andrew Albert

    QOS for VOIP using 768k of FR / Auto QOS

    Andrew Albert, Feb 6, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,473
  3. HG
    Replies:
    5
    Views:
    461
  4. Can2002

    VOIP QOS problems

    Can2002, Jan 29, 2007, in forum: Cisco
    Replies:
    3
    Views:
    631
    Can2002
    Jan 29, 2007
  5. dominix
    Replies:
    2
    Views:
    461
    dominix
    Feb 6, 2007
Loading...

Share This Page