Problems with DSL and DNS

Discussion in 'Cisco' started by thomas, Sep 3, 2006.

  1. thomas

    thomas Guest

    Hi everybody,

    Recently I spent several hours with Cisco engineers helping me to setup my
    DSL connection. I have 871 router and Speedstream 5100 DSL modem.

    Initially we tried to set it up the "regular way" so the modem handles PPPoE
    and all that stuff. Just like my old NetGear router which always worked.
    No matter what, we could not get it to work. The router was not able to
    obtain address from my ISP through DHCP.
    At the same time plugged directly to my PC always worked. I also always
    worked with my old router. But not with Cisco - surprise.

    Finally I called my ISP (Ameritech, previously SBC Chicago) and they told me
    that there was a known problem with Cisco routers and I had a better chance
    switching it to the bridge mode. So we did. After another 4 hours, another
    Cisco engineer managed to set it up, removed all other settings, firewall,
    left the console accessible from the Internet and closed the case.
    I am a Cisco newbie and all I want is the functionality I had with my old
    simple router I could set up in 15 min. I managed to reinstall the firewall
    with the SDM.

    However, my DSL connection still does not work quite well. Whenever it goes
    down the router looses DNS settings and I usually have to restart it.

    Is there any way to fix it? Here are my settings. Is there anything wrong
    with them? Am I missing something?

    Please advise.

    Tomasz


    interface FastEthernet4
    description $ES_WAN$$FW_OUTSIDE$$ETH-WAN$
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    no ip virtual-reassembly
    ip route-cache flow
    duplex auto
    speed auto
    pppoe enable
    pppoe-client dial-pool-number 1
    no cdp enable
    !
    interface Dialer0
    description $FW_OUTSIDE$
    mtu 1492
    ip ddns update sdm_ddns1
    ip address negotiated
    ip access-group 102 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip inspect SDM_MEDIUM out
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip route-cache flow
    dialer pool 1
    no cdp enable
    ppp pap sent-username <my user name>@sbcglobal.net password 7 <encrypted
    password>
    ppp ipcp dns request accept
    !
     
    thomas, Sep 3, 2006
    #1
    1. Advertising

  2. thomas

    Guest

    thomas wrote:
    > Hi everybody,
    >
    > Recently I spent several hours with Cisco engineers helping me to setup my
    > DSL connection. I have 871 router and Speedstream 5100 DSL modem.
    >
    > Initially we tried to set it up the "regular way" so the modem handles PPPoE
    > and all that stuff. Just like my old NetGear router which always worked.
    > No matter what, we could not get it to work. The router was not able to
    > obtain address from my ISP through DHCP.
    > At the same time plugged directly to my PC always worked. I also always
    > worked with my old router. But not with Cisco - surprise.
    >
    > Finally I called my ISP (Ameritech, previously SBC Chicago) and they told me
    > that there was a known problem with Cisco routers and I had a better chance
    > switching it to the bridge mode. So we did. After another 4 hours, another
    > Cisco engineer managed to set it up, removed all other settings, firewall,
    > left the console accessible from the Internet and closed the case.
    > I am a Cisco newbie and all I want is the functionality I had with my old
    > simple router I could set up in 15 min. I managed to reinstall the firewall
    > with the SDM.
    >
    > However, my DSL connection still does not work quite well. Whenever it goes
    > down the router looses DNS settings and I usually have to restart it.
    >
    > Is there any way to fix it? Here are my settings. Is there anything wrong
    > with them? Am I missing something?
    >
    > Please advise.
    >
    > Tomasz
    >
    >
    > interface FastEthernet4
    > description $ES_WAN$$FW_OUTSIDE$$ETH-WAN$
    > no ip address
    > no ip redirects
    > no ip unreachables
    > no ip proxy-arp
    > ip nat outside
    > no ip virtual-reassembly
    > ip route-cache flow
    > duplex auto
    > speed auto
    > pppoe enable
    > pppoe-client dial-pool-number 1
    > no cdp enable
    > !
    > interface Dialer0
    > description $FW_OUTSIDE$
    > mtu 1492
    > ip ddns update sdm_ddns1
    > ip address negotiated
    > ip access-group 102 in
    > no ip redirects
    > no ip unreachables
    > no ip proxy-arp
    > ip inspect SDM_MEDIUM out
    > ip nat outside
    > ip virtual-reassembly
    > encapsulation ppp
    > ip route-cache flow
    > dialer pool 1
    > no cdp enable
    > ppp pap sent-username <my user name>@sbcglobal.net password 7 <encrypted
    > password>
    > ppp ipcp dns request accept
    > !


    Hi,

    I don't know if this will assist however Cisco
    appear to have put a lot of new confguration examples
    on CCO.
    http://www.cisco.com/en/US/tech/tk175/tk819/tech_configuration_examples_list.html

    As to your particular config I am not familiar with using a dialer
    over Ethernet and I am not exactly sure what it means.

    Please post the whole config and I can have a look.
     
    , Sep 4, 2006
    #2
    1. Advertising

  3. thomas

    Guest

    wrote:
    > thomas wrote:
    > > Hi everybody,
    > >
    > > Recently I spent several hours with Cisco engineers helping me to setup my
    > > DSL connection. I have 871 router and Speedstream 5100 DSL modem.
    > >
    > > Initially we tried to set it up the "regular way" so the modem handles PPPoE
    > > and all that stuff. Just like my old NetGear router which always worked.
    > > No matter what, we could not get it to work. The router was not able to
    > > obtain address from my ISP through DHCP.
    > > At the same time plugged directly to my PC always worked. I also always
    > > worked with my old router. But not with Cisco - surprise.
    > >
    > > Finally I called my ISP (Ameritech, previously SBC Chicago) and they told me
    > > that there was a known problem with Cisco routers and I had a better chance
    > > switching it to the bridge mode. So we did. After another 4 hours, another
    > > Cisco engineer managed to set it up, removed all other settings, firewall,
    > > left the console accessible from the Internet and closed the case.
    > > I am a Cisco newbie and all I want is the functionality I had with my old
    > > simple router I could set up in 15 min. I managed to reinstall the firewall
    > > with the SDM.
    > >
    > > However, my DSL connection still does not work quite well. Whenever it goes
    > > down the router looses DNS settings and I usually have to restart it.
    > >
    > > Is there any way to fix it? Here are my settings. Is there anything wrong
    > > with them? Am I missing something?
    > >
    > > Please advise.
    > >
    > > Tomasz
    > >
    > >
    > > interface FastEthernet4
    > > description $ES_WAN$$FW_OUTSIDE$$ETH-WAN$
    > > no ip address
    > > no ip redirects
    > > no ip unreachables
    > > no ip proxy-arp
    > > ip nat outside
    > > no ip virtual-reassembly
    > > ip route-cache flow
    > > duplex auto
    > > speed auto
    > > pppoe enable
    > > pppoe-client dial-pool-number 1
    > > no cdp enable
    > > !
    > > interface Dialer0
    > > description $FW_OUTSIDE$
    > > mtu 1492
    > > ip ddns update sdm_ddns1
    > > ip address negotiated
    > > ip access-group 102 in
    > > no ip redirects
    > > no ip unreachables
    > > no ip proxy-arp
    > > ip inspect SDM_MEDIUM out
    > > ip nat outside
    > > ip virtual-reassembly
    > > encapsulation ppp
    > > ip route-cache flow
    > > dialer pool 1
    > > no cdp enable
    > > ppp pap sent-username <my user name>@sbcglobal.net password 7 <encrypted
    > > password>
    > > ppp ipcp dns request accept
    > > !

    >
    > Hi,
    >
    > I don't know if this will assist however Cisco
    > appear to have put a lot of new confguration examples
    > on CCO.
    > http://www.cisco.com/en/US/tech/tk175/tk819/tech_configuration_examples_list.html
    >
    > As to your particular config I am not familiar with using a dialer
    > over Ethernet and I am not exactly sure what it means.
    >
    > Please post the whole config and I can have a look.


    The link that I have posted will be of limited value since
    all the examples are for DSL interfaces. Sorry.
     
    , Sep 4, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Guest
    Replies:
    3
    Views:
    2,217
    N. Miller
    Sep 5, 2005
  2. Richard Antony Burton
    Replies:
    3
    Views:
    6,643
    Richard Antony Burton
    Dec 18, 2003
  3. Lars Bonnesen
    Replies:
    9
    Views:
    7,254
    chris
    Apr 8, 2006
  4. none
    Replies:
    5
    Views:
    3,183
  5. Jose Padilla

    DNS question - reverse DNS getting cluttered

    Jose Padilla, Jan 21, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    588
    Jose Padilla
    Jan 21, 2004
Loading...

Share This Page