Problems mutual redistributing of ISIS and EIGRP

Discussion in 'Cisco' started by phillip, Dec 6, 2004.

  1. phillip

    phillip Guest

    Router3 <-----> Router1 <-----> Router2
    ISIS redistribution EIGRP
    router

    Router2 CAN ping router3

    Router3 CANNOT ping Router2

    Router1
    interface Serial0
    description connection to router3
    ip address 192.168.1.6 255.255.255.252
    ip router isis
    no keepalive

    interface Serial1
    description connection to router2
    ip address 10.1.1.1 255.255.255.0
    no keepalive

    router eigrp 137
    redistribute isis level-1 metric 100 100 200 1 1500
    network 10.1.1.0 0.0.0.255
    no auto-summary
    no eigrp log-neighbor-changes
    !
    router isis
    redistribute eigrp 137 metric 0 metric-type external level-1
    net 49.0000.0001.0001.00
    is-type level-1



    Router3 <-----> Router1 <-----> Router2
    ISIS redistribution EIGRP
    router


    Router2 CAN ping router3

    Router3 CANNOT ping Router2

    Router3 can see routes from Router2
    Router3#sh ip route
    137.201.0.0/24 is subnetted, 1 subnets
    i L1 137.201.240.0 [115/30] via 192.168.1.6, Serial0
    10.0.0.0/24 is subnetted, 1 subnets
    i L1 10.1.1.0 [115/30] via 192.168.1.6, Serial0
    192.168.1.0/30 is subnetted, 1 subnets
    C 192.168.1.4 is directly connected, Serial0
    i L1 192.168.32.0/24 [115/30] via 192.168.1.6, Serial0
    C 192.168.49.0/24 is directly connected, Serial1
    C 192.168.33.0/24 is directly connected, Ethernet0
    Router3#

    But he cannot ping anything being redistributed to him.

    version 12.2
    !
    hostname Router3
    !
    enable password password
    !

    ip subnet-zero

    interface Ethernet0
    ip address 192.168.33.10 255.255.255.0
    !
    interface Serial0
    ip address 192.168.1.5 255.255.255.252
    ip router isis
    no keepalive
    clockrate 4000000
    !
    interface Serial1
    no ip address
    no keepalive
    !
    router isis
    net 49.0000.0002.0002.00


    Router2 can see Router3's redistributed routes
    Router2#sh ip route
    137.201.0.0/24 is subnetted, 1 subnets
    C 137.201.240.0 is directly connected, Serial0
    10.0.0.0/24 is subnetted, 1 subnets
    C 10.1.1.0 is directly connected, Serial1
    C 192.168.32.0/24 is directly connected, Ethernet0
    D EX 192.168.49.0/24 [170/26137600] via 10.1.1.1, 00:23:53, Serial1
    D EX 192.168.33.0/24 [170/26137600] via 10.1.1.1, 00:23:53, Serial1
    Router2#

    He can also ping Router3

    Router2#ping 192.168.33.10
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.33.10, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 36/41/56 ms
    Router2#

    WHY CAN"T ROUTER3 PING ROUTER2????
    phillip, Dec 6, 2004
    #1
    1. Advertising

  2. Hi Philip,
    When you ping R2 from R3, the source address of that ping is 192.168.1.5.
    So R2 will receive the ping and an ICMP echo-reply will be addressed back to
    the source 192.168.1.5, but as you showed below when you listed the routing
    table of R2, the 192.168.1.0/24 network is not found on R2. So the ping
    reaches R2 but has no return path and the packets are dropped.

    The question is why. You have redistributed ISIS into EIGRP and ISIS
    obviously knows about the 192.168.1.0 network.

    On the redistributing router, EIGRP doesn't accept routes that are also
    connected interfaces. With EIGRP you have to redistribute that connected
    interface separately. I would welcome comments as I'm not sure I completely
    have a handle on why that is true. It's just something I've picked up while
    working with EIGRP in redistribution.

    So R1 router should have the additional line as follows:

    router eigrp 137
    redistribute conneted <----added line
    redistribute isis level-1 metric 100 100 200 1 1500
    network 10.1.1.0 0.0.0.255
    no auto-summary
    no eigrp log-neighbor-changes

    This addition will provide R2 with a return path so that ICMP echo-reply
    packets destined for 192.168.1.5 will be routed back to the source of the
    ping.

    FWIW,
    Robert



    "phillip" <> wrote in message
    news:41b43efe$...
    > Router3 <-----> Router1 <-----> Router2
    > ISIS redistribution EIGRP
    > router
    >
    > Router2 CAN ping router3
    >
    > Router3 CANNOT ping Router2
    >
    > Router1
    > interface Serial0
    > description connection to router3
    > ip address 192.168.1.6 255.255.255.252
    > ip router isis
    > no keepalive
    >
    > interface Serial1
    > description connection to router2
    > ip address 10.1.1.1 255.255.255.0
    > no keepalive
    >
    > router eigrp 137
    > redistribute isis level-1 metric 100 100 200 1 1500
    > network 10.1.1.0 0.0.0.255
    > no auto-summary
    > no eigrp log-neighbor-changes
    > !
    > router isis
    > redistribute eigrp 137 metric 0 metric-type external level-1
    > net 49.0000.0001.0001.00
    > is-type level-1
    >
    >
    >
    > Router3 <-----> Router1 <-----> Router2
    > ISIS redistribution EIGRP
    > router
    >
    >
    > Router2 CAN ping router3
    >
    > Router3 CANNOT ping Router2
    >
    > Router3 can see routes from Router2
    > Router3#sh ip route
    > 137.201.0.0/24 is subnetted, 1 subnets
    > i L1 137.201.240.0 [115/30] via 192.168.1.6, Serial0
    > 10.0.0.0/24 is subnetted, 1 subnets
    > i L1 10.1.1.0 [115/30] via 192.168.1.6, Serial0
    > 192.168.1.0/30 is subnetted, 1 subnets
    > C 192.168.1.4 is directly connected, Serial0
    > i L1 192.168.32.0/24 [115/30] via 192.168.1.6, Serial0
    > C 192.168.49.0/24 is directly connected, Serial1
    > C 192.168.33.0/24 is directly connected, Ethernet0
    > Router3#
    >
    > But he cannot ping anything being redistributed to him.
    >
    > version 12.2
    > !
    > hostname Router3
    > !
    > enable password password
    > !
    >
    > ip subnet-zero
    >
    > interface Ethernet0
    > ip address 192.168.33.10 255.255.255.0
    > !
    > interface Serial0
    > ip address 192.168.1.5 255.255.255.252
    > ip router isis
    > no keepalive
    > clockrate 4000000
    > !
    > interface Serial1
    > no ip address
    > no keepalive
    > !
    > router isis
    > net 49.0000.0002.0002.00
    >
    >
    > Router2 can see Router3's redistributed routes
    > Router2#sh ip route
    > 137.201.0.0/24 is subnetted, 1 subnets
    > C 137.201.240.0 is directly connected, Serial0
    > 10.0.0.0/24 is subnetted, 1 subnets
    > C 10.1.1.0 is directly connected, Serial1
    > C 192.168.32.0/24 is directly connected, Ethernet0
    > D EX 192.168.49.0/24 [170/26137600] via 10.1.1.1, 00:23:53, Serial1
    > D EX 192.168.33.0/24 [170/26137600] via 10.1.1.1, 00:23:53, Serial1
    > Router2#
    >
    > He can also ping Router3
    >
    > Router2#ping 192.168.33.10
    > Type escape sequence to abort.
    > Sending 5, 100-byte ICMP Echos to 192.168.33.10, timeout is 2 seconds:
    > !!!!!
    > Success rate is 100 percent (5/5), round-trip min/avg/max = 36/41/56 ms
    > Router2#
    >
    > WHY CAN"T ROUTER3 PING ROUTER2????
    >
    >
    Bob by the Bay, Dec 6, 2004
    #2
    1. Advertising

  3. phillip

    Ivan Ostreš Guest

    In article <>,
    says...
    > On the redistributing router, EIGRP doesn't accept routes that are also
    > connected interfaces. With EIGRP you have to redistribute that connected
    > interface separately. I would welcome comments as I'm not sure I completely
    > have a handle on why that is true. It's just something I've picked up while
    > working with EIGRP in redistribution.
    >
    >


    This is true, but not just for EIGRP. Whenever you have redistribution
    ISIS/(something else) you never get connected interfaces redistributed
    so you have to do it b using 'redistribute connected' command.

    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
    Ivan Ostreš, Dec 7, 2004
    #3
  4. Interesting. I had only noticed that behaviour with EIGRP though I wouldn't
    be surprised if other routing protocols work similarly.

    However, I don't think the same thing applies to ISIS, there would have had
    connectivity problems in both directions. In this case the problem only had
    to be rectified with EIGRP (no redistribute connected required with ISIS).

    Robert

    "Ivan Ostres" <> wrote in message
    news:...
    > In article <>,
    > says...
    >> On the redistributing router, EIGRP doesn't accept routes that are also
    >> connected interfaces. With EIGRP you have to redistribute that connected
    >> interface separately. I would welcome comments as I'm not sure I
    >> completely
    >> have a handle on why that is true. It's just something I've picked up
    >> while
    >> working with EIGRP in redistribution.
    >>
    >>

    >
    > This is true, but not just for EIGRP. Whenever you have redistribution
    > ISIS/(something else) you never get connected interfaces redistributed
    > so you have to do it b using 'redistribute connected' command.
    >
    > --
    > -Ivan.
    >
    > *** Use Rot13 to see my eMail address ***
    Bob by the Bay, Dec 7, 2004
    #4
  5. phillip

    Ivan Ostreš Guest

    In article <>,
    says...
    > Interesting. I had only noticed that behaviour with EIGRP though I wouldn't
    > be surprised if other routing protocols work similarly.
    >
    > However, I don't think the same thing applies to ISIS, there would have had
    > connectivity problems in both directions. In this case the problem only had
    > to be rectified with EIGRP (no redistribute connected required with ISIS).
    >
    >


    Exactly what I was saing in the first place. If you have ISIS/OSPF
    redistribution, you have to do 'redistribute connected' in OSPF. If you
    have ISIS/EIGRP, you have to do 'redistribute connected' in EIGRP. It is
    ISIS specific that it never "gives" connected route (from interface
    where ISIS is active) to other routing protocol on the router where
    redistribution is performed.


    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
    Ivan Ostreš, Dec 7, 2004
    #5
  6. Ivan,
    Thanks for spelling this out in more detail as I think I interpreted your
    first message incorrectly.

    This is good to know.
    Robert

    "Ivan Ostres" <> wrote in message
    news:...
    > In article <>,
    > says...
    >> Interesting. I had only noticed that behaviour with EIGRP though I
    >> wouldn't
    >> be surprised if other routing protocols work similarly.
    >>
    >> However, I don't think the same thing applies to ISIS, there would have
    >> had
    >> connectivity problems in both directions. In this case the problem only
    >> had
    >> to be rectified with EIGRP (no redistribute connected required with
    >> ISIS).
    >>
    >>

    >
    > Exactly what I was saing in the first place. If you have ISIS/OSPF
    > redistribution, you have to do 'redistribute connected' in OSPF. If you
    > have ISIS/EIGRP, you have to do 'redistribute connected' in EIGRP. It is
    > ISIS specific that it never "gives" connected route (from interface
    > where ISIS is active) to other routing protocol on the router where
    > redistribution is performed.
    >
    >
    > --
    > -Ivan.
    >
    > *** Use Rot13 to see my eMail address ***
    Bob by the Bay, Dec 7, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. phillip
    Replies:
    2
    Views:
    2,957
    mos33
    Sep 19, 2008
  2. Chris

    Washington Mutual Internet Banking Account

    Chris, Feb 22, 2005, in forum: Computer Support
    Replies:
    14
    Views:
    770
    Jerry G.
    Feb 23, 2005
  3. ciscohelp
    Replies:
    0
    Views:
    641
    ciscohelp
    Sep 5, 2006
  4. gagankalra1

    Redistributing static in Eigrp...

    gagankalra1, Jul 1, 2008, in forum: Cisco
    Replies:
    1
    Views:
    614
    donjohnston
    Jul 2, 2008
  5. Brian
    Replies:
    4
    Views:
    3,467
    dkdent
    Sep 3, 2013
Loading...

Share This Page