Problems activating ADSL line on Cisco 827 with Nildram UK

Discussion in 'Cisco' started by Noodles, Jul 11, 2005.

  1. Noodles

    Noodles Guest

    Hello,

    I hope someone can help as this one has been killing me. I have been
    using a 2620 and WIC1-ADSL on my line for many years no problems.
    Connecting a new Cisco 827 and I can't get a thing. It doesn't seem to
    pick up the line.

    I have upgraded to a few of the latest IOS's, tried different line
    cords including a crossover in case I got a bad cord. The line cord
    that works on the 2620/WIC-1 ADSL should be the same for the 827 as far
    as I can see on the Cisco site. Either way I've crossed 2&3 & 4&5 on a
    new cable too still no result.

    I seem to think I am still stuck on layer 1 and would really like to
    know if someone has seen this before. I have attached some outputs
    below to see what is going on.

    Thanks in advance,
    Greg



    Router# show version
    System image file is "flash:c820-y6-mz.123-15.bin"

    CISCO C827 (MPC855T) processor (revision 0x501) with 48128K/1024K bytes
    of memory.
    Processor board ID JAD043608TY (2304846820), with hardware revision
    6711
    CPU rev number 5
    Bridging software.
    1 Ethernet/IEEE 802.3 interface(s)
    1 ATM network interface(s)
    128K bytes of non-volatile configuration memory.
    8192K bytes of processor board System flash (Read/Write)
    2048K bytes of processor board Web flash (Read/Write)

    Configuration register is 0x2102



    Configuration
    =============
    =============



    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    no aaa new-model
    ip subnet-zero
    ip name-server 213.208.106.212
    ip name-server 213.208.106.213
    !
    ip cef
    !
    interface Ethernet0
    ip address 192.168.0.254 255.255.255.0
    ip nat inside
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/38
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    interface Dialer0
    ip address negotiated
    ip accounting output-packets
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer idle-timeout 0
    dialer persistent
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname
    ppp chap password 0 xxxxxxxxxxx
    !
    ip nat inside source list 1 interface Dialer0 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip http server
    !
    dialer-list 1 protocol ip permit
    !
    line con 0
    stopbits 1
    line vty 0 4
    access-class 2 in
    login local
    !
    scheduler max-task-time 5000
    end





    Router#show controllers atm 0
    =============================
    =============================

    PQUICC_SAR (with Alcatel ADSL Module) unit 0 idb at 0x80CEC744, driver
    data stru
    cture at 0x80D243C4
    SCC Registers:
    General [GSMR]=0x1F80:0x00000000, Protocol-specific [PSMR]=0x0
    Events [SCCE]=0x0000, Mask [SCCM]=0x0000, Status [SCCS]=0x0000
    Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E
    Interrupt Registers:
    Config [CICR]=0x00368481, Pending [CIPR]=0x00004000
    Mask [CIMR]=0x40241010, In-srv [CISR]=0x00000000
    Command register [CR]=0x600
    Port A [PADIR]=0xACF8, [PAPAR]=0x0303
    [PAODR]=0x0000, [PADAT]=0x2E6B
    Port B [PBDIR]=0x02B130, [PBPAR]=0x0110C0
    [PBODR]=0x000000, [PBDAT]=0x0225D9
    Port C [PCDIR]=0x0002, [PCPAR]=0x0000
    [PCSO]=0x0031, [PCDAT]=0x0CC2, [PCINT]=0x0000
    Port D [PDDIR]=0x000000, [PDPAR]=0x00FFFF
    [PDDAT]=0x000FFF
    SI [SIMODE]=0x00001000, [SIGMR]=0x00, [SISTR]=0x00
    [SICR]=0x00000025
    BRGC [BRGC2]=0x0001027E, [BRGC3]=0x00000000

    SCC SAR PARAMETER RAM (at 0xFF003F00)
    Rx BD Base [RBASE]=0x80D24760, Fn Code [RFCR]=0x18, Status
    [SRSTATE]=0xD0
    Tx BD Base [TBASE]=0x80D25160, Fn Code [TFCR]=0x10, Status
    [STSTATE]=0x80
    Exception Q [INTBASE]=0x80D29FD8, [INTPTR]=0x80D29FD8, [INT_CNT]=1,
    [INT_ICNT]=1

    Connection Tbl Base [CTBASE]=0xA40
    Max Rx Buff Len [MRBLR]=0
    Rx State [RSTATE]=0x18000000
    Tx State [TSTATE]=0x10000000
    Tx Q base [TQBASE]=0xB00, [TQAPTR]=0xB00, [TQTPTR]=0xB00, [TCNT]=0,
    [T_PTR]=0x0
    Rx Values [SMRBLR]=1536, [RCNT]=0, [R_PTR]=0x0
    Idle cell header uses ATM FORUM format

    AAL2 Parameter RAM (0xFF003FC0):
    RISC_Timer_Enable=0, Scratch1 Base=0x0, Scratch2 Base=0x0
    TXWAIT_BASE=0x0, TXWAIT_PTR=0x0, TXWAIT_WIDTH=0x0, TXWAIT_LAST=0x0
    TPD Base=0x0, RPD Base=0x0, CRC_TABLE_PTR=0x0

    CONNECTION TABLE
    Default connection table [0xFF002A40] for connid=0, real conn id=0
    RCT[0]: rx.status=0x4, rx.imask=0xF, rbd_base=0x0, rbd_ptr=0x0
    TCT[0]: tx.status=0x8, tx.cellhdr=0x0, tbd_base=0x0 tbd_ptr=0x0

    Default connection table [0x80D29C80] for connid=1, real conn id=257
    RCT[1]: rx.status=0x4, rx.imask=0x0, rbd_base=0x30, rbd_ptr=0x30
    TCT[1]: tx.status=0x0, tx.cellhdr=0x0, tbd_base=0x30 tbd_ptr=0x30

    Default connection table [0x80D29CC0] for connid=2, real conn id=258
    RCT[2]: rx.status=0x4, rx.imask=0x0, rbd_base=0x60, rbd_ptr=0x60
    TCT[2]: tx.status=0x0, tx.cellhdr=0x0, tbd_base=0x60 tbd_ptr=0x60


    ADDRESS MATCHING TABLE
    Address Compression Table Used
    Num of first_level_entries=32
    Num of second_level_entries=1024

    Num Interrupt Q overflows = 0, Interrupt Queue:
    ...........
    ...........
    ...........
    ...........
    ...........
    ...........
    ...........
    ...........
    ...........
    ...........
    ...........
    ...........
    ...
    Num valid int Q events = 0
    First Int Q entry = 0x80D29FD8, expt_read_p = 0x80D29FD8

    GENERAL ATM STATISTICS:
    Num invalid cells recv = 0
    Last invalid cell recv = 0x0
    Scheduling of idle cells = 0
    Traffic Shaping disabled = 0

    CONFIGURED VCS ARE:
    ---------- VC(0) ----------
    TX and RX VC for OAM cells and default RX VC vc_type = 0
    TX RING CONFIG:
    conn_id = 0, srvc_type = 2, credit = 1,
    bs = 1, peak_int_delay = 0, no traffic shape = 0,
    TxBD RING STATS:
    Num of packets written to TX ring = 0
    Num TX interrupts received = 0
    Num frames not added to ring = 0, CBR cell TX = 0,
    tx_cell_lastcnt = 0
    Empty CBR cell slot = 0, numCellsToSend = 0
    RxBD RING STATS:
    Now in busy state = 0, Num RX busy int = 0
    Total num RX interrupts received = 0
    Num RX interrupts received for data = 0
    Num RX packets dropped because there is no RX buffer = 0
    Num HEC errors (HEC) = 0, Num aborts (ABT) = 0
    Num length errors (LN) = 0, Num CRC errors (CR) = 0
    Num frames received with CLP bit set (CLP) = 0
    Num frames received with PTI congestion bit set (CNG) = 0
    BDs in RX ring:
    Shadow start BD = 0x80D3AF40, Shadow end BD = 0x80D3B0A8
    nextRxBd: Shadow = 0x80D3AF40, Real = 0x80D24760
    1 Real rbd=0x80D24760 Status=0x9000 Buf=0x2F36480 Len=1528 N
    2 Real rbd=0x80D2476C Status=0x9000 Buf=0x2F35DB0 Len=1528
    3 Real rbd=0x80D24778 Status=0x9000 Buf=0x2F356F0 Len=1528
    4 Real rbd=0x80D24784 Status=0x9000 Buf=0x2F35020 Len=1528
    5 Real rbd=0x80D24790 Status=0x9000 Buf=0x2F34960 Len=1528
    6 Real rbd=0x80D2479C Status=0x9000 Buf=0x2F34290 Len=1528
    7 Real rbd=0x80D247A8 Status=0x9000 Buf=0x2F33BD0 Len=1528
    8 Real rbd=0x80D247B4 Status=0x9000 Buf=0x2F33500 Len=1528
    9 Real rbd=0x80D247C0 Status=0x9000 Buf=0x2F32E40 Len=1528
    10 Real rbd=0x80D247CC Status=0x9000 Buf=0x2F32770 Len=1528
    11 Real rbd=0x80D247D8 Status=0x9000 Buf=0x2F320B0 Len=1528
    12 Real rbd=0x80D247E4 Status=0x9000 Buf=0x2F319E0 Len=1528
    13 Real rbd=0x80D247F0 Status=0x9000 Buf=0x2F31320 Len=1528
    14 Real rbd=0x80D247FC Status=0x9000 Buf=0x2F30C50 Len=1528
    15 Real rbd=0x80D24808 Status=0x9000 Buf=0x2F30590 Len=1528
    16 Real rbd=0x80D24814 Status=0xB000 Buf=0x2F2FEC0 Len=1528
    BDs in TX ring:
    Shadow start BD = 0x80D3AD94, Shadow end BD = 0x80D3AEFC
    nextTxBd: Shadow = 0x80D3AD94, Real = 0x80D25160
    usedTxBd: Shadow = 0x80D3AD94, Real = 0x80D25160
    1 Real tbd=0x80D25160 Status=0x0 Buf=0x2F662B0 Len=52 NU
    2 Real tbd=0x80D2516C Status=0x0 Buf=0x2F66310 Len=52
    3 Real tbd=0x80D25178 Status=0x0 Buf=0x2F66370 Len=52
    4 Real tbd=0x80D25184 Status=0x0 Buf=0x2F663D0 Len=52
    5 Real tbd=0x80D25190 Status=0x0 Buf=0x2F66430 Len=52
    6 Real tbd=0x80D2519C Status=0x0 Buf=0x2F66490 Len=52
    7 Real tbd=0x80D251A8 Status=0x0 Buf=0x2F664F0 Len=52
    8 Real tbd=0x80D251B4 Status=0x0 Buf=0x2F66550 Len=52
    9 Real tbd=0x80D251C0 Status=0x0 Buf=0x2F665B0 Len=52
    10 Real tbd=0x80D251CC Status=0x0 Buf=0x2F66610 Len=52
    11 Real tbd=0x80D251D8 Status=0x0 Buf=0x2F66670 Len=52
    12 Real tbd=0x80D251E4 Status=0x0 Buf=0x2F666D0 Len=52
    13 Real tbd=0x80D251F0 Status=0x0 Buf=0x2F66730 Len=52
    14 Real tbd=0x80D251FC Status=0x0 Buf=0x2F66790 Len=52
    15 Real tbd=0x80D25208 Status=0x0 Buf=0x2F667F0 Len=52
    16 Real tbd=0x80D25214 Status=0x2000 Buf=0x2F66850 Len=52

    ---------- VC(1) ----------
    VPI = 0, VCI = 38,

    Line has not yet been activated. No information available.



    Router# show interface atm 0
    ============================
    ============================

    ATM0 is down, line protocol is down
    Hardware is PQUICC_SAR (with Alcatel ADSL Module)
    MTU 1500 bytes, sub MTU 1500, BW 800 Kbit, DLY 80 usec,
    reliability 0/255, txload 1/255, rxload 1/255
    Encapsulation ATM, loopback not set
    Encapsulation(s): AAL5 AAL2, PVC mode
    10 maximum active VCs, 1024 VCs per VP, 0 current VCCs
    VC Auto Creation Disabled.
    VC idle disconnect time: 300 seconds
    Last input never, output never, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: Per VC Queueing
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 output buffer failures, 0 output buffers swapped out


    Router#DEBUG ATM EVENTS
    =======================
    =======================

    *Mar 1 00:24:10.739: DSL: Could not establish connection
    *Mar 1 00:24:10.739: DSL: Sent command 0x4
    *Mar 1 00:24:10.739: DSL: Send ADSL_OPEN command.
    *Mar 1 00:24:10.739: DSL: Using subfunction 0x2
    *Mar 1 00:24:10.739: DSL: Using subfunction 0x2
    *Mar 1 00:24:10.739: DSL: Sent command 0x3
    *Mar 1 00:24:10.767: DSL: Received response: 0x25
    *Mar 1 00:24:10.771: DSL: Unexpected response 0x25
    *Mar 1 00:24:10.771: DSL: Send ADSL_OPEN command.
    *Mar 1 00:24:10.771: DSL: Using subfunction 0x2
    *Mar 1 00:24:10.771: DSL: Using subfunction 0x2
    *Mar 1 00:24:10.771: DSL: Sent command 0x3
    *Mar 1 00:24:13.271: DSL: 1: Modem state = 0x8
    *Mar 1 00:24:15.775: DSL: 2: Modem state = 0x8
    *Mar 1 00:24:18.275: DSL: 3: Modem state = 0x8
    *Mar 1 00:24:20.775: DSL: 4: Modem state = 0x8
    *Mar 1 00:24:23.279: DSL: 5: Modem state = 0x8
    *Mar 1 00:24:25.779: DSL: 6: Modem state = 0x8
    *Mar 1 00:24:28.279: DSL: 7: Modem state = 0x8
    *Mar 1 00:24:30.779: DSL: 8: Modem state = 0x8
    *Mar 1 00:24:33.279: DSL: 9: Modem state = 0x8
    *Mar 1 00:24:35.779: DSL: 10: Modem state = 0x8
    *Mar 1 00:24:38.279: DSL: 11: Modem state = 0x8
    *Mar 1 00:24:40.779: DSL: 12: Modem state = 0x8
    *Mar 1 00:24:43.279: DSL: 13: Modem state = 0x8
    *Mar 1 00:24:45.779: DSL: 14: Modem state = 0x8
    *Mar 1 00:24:48.279: DSL: 15: Modem state = 0x8
    *Mar 1 00:24:50.779: DSL: 16: Modem state = 0x8
    *Mar 1 00:24:53.279: DSL: 17: Modem state = 0x8
    *Mar 1 00:24:55.779: DSL: 18: Modem state = 0x8
    *Mar 1 00:24:58.279: DSL: 19: Modem state = 0x8
    *Mar 1 00:25:00.779: DSL: 20: Modem state = 0x8
    *Mar 1 00:25:03.279: DSL: Could not establish connection
    *Mar 1 00:25:03.279: DSL: Sent command 0x4
    *Mar 1 00:25:03.279: DSL: Send ADSL_OPEN command.
    *Mar 1 00:25:03.279: DSL: Using subfunction 0x2
    *Mar 1 00:25:03.279: DSL: Using subfunction 0x2
    *Mar 1 00:25:03.279: DSL: Sent command 0x3
    *Mar 1 00:25:03.315: DSL: Received response: 0x25
    *Mar 1 00:25:03.315: DSL: Unexpected response 0x25
    *Mar 1 00:25:03.315: DSL: Send ADSL_OPEN command.
    *Mar 1 00:25:03.315: DSL: Using subfunction 0x2
    *Mar 1 00:25:03.315: DSL: Using subfunction 0x2
    *Mar 1 00:25:03.315: DSL: Sent command 0x3
    *Mar 1 00:25:05.819: DSL: 1: Modem state = 0x8
    *Mar 1 00:25:08.319: DSL: 2: Modem state = 0x8
    *Mar 1 00:25:10.819: DSL: 3: Modem state = 0x8
    *Mar 1 00:25:13.319: DSL: 4: Modem state = 0x8
    *Mar 1 00:25:15.819: DSL: 5: Modem state = 0x8
    Noodles, Jul 11, 2005
    #1
    1. Advertising

  2. Noodles

    Steve Guest

    Steve, Jul 11, 2005
    #2
    1. Advertising

  3. Noodles

    Noodles Guest

    Thanks very much for your help Steve. It is I think the 6th config
    example I've tried that is supposed to work and I still have the same
    result. Its looking more and more like a failed port to me
    Noodles, Jul 11, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Moti
    Replies:
    1
    Views:
    1,159
    jonathan fernandes
    Jul 16, 2003
  2. Anthony

    Cisco 827 Routers and ADSL

    Anthony, Nov 25, 2003, in forum: Cisco
    Replies:
    3
    Views:
    449
    Steve Wyles
    Nov 26, 2003
  3. David M
    Replies:
    9
    Views:
    545
  4. melchiade

    VPN through Cisco 827 / 837 ADSL

    melchiade, May 16, 2006, in forum: Cisco
    Replies:
    0
    Views:
    485
    melchiade
    May 16, 2006
  5. AngeL_VenjadoR
    Replies:
    3
    Views:
    2,075
    www.BradReese.Com
    Jan 29, 2007
Loading...

Share This Page