Problem with .Net Framework!

Discussion in 'MCSD' started by Tanzim Saqib, Dec 6, 2003.

  1. Tanzim Saqib

    Tanzim Saqib Guest

    Hello
    I am novice in VB.NET . I have developed a sample HelloWorld program and a setup application for it. VB.NET warned me that the client machine should install .NET Framework (DOTNETFX.EXE) in order to run the application. I tried it in my Windows ME and found a message "Setup cannot access Windows Installer components. Setup cannot continue." and it terminates. I can not run the setup application. I have found a log file in the Temp folder:

    [12/06/03,23:20:19] Starting Install.exe
    [12/06/03,23:20:19] Parsing switches from commandline: C:\WINDOWS\TEMP\IXP000.TMP\Install.exe
    [12/06/03,23:20:19] SourceDir: C:\WINDOWS\TEMP\IXP000.TMP\
    [12/06/03,23:20:19] Install started
    [12/06/03,23:20:19] Checking system requirements
    [12/06/03,23:20:19] OS: Win Millenium
    [12/06/03,23:20:19] Ver: Second Edition
    [12/06/03,23:20:19] SP:
    [12/06/03,23:20:19] Checking Internet Explorer Version
    [12/06/03,23:20:19] Looking for 5.0.2919.6307
    [12/06/03,23:20:19] Found Internet Explorer Version: 5.50.4134.0100
    [12/06/03,23:20:19] Internet Explorer Version is OK...
    [12/06/03,23:20:19] System meets minimum requirements
    [12/06/03,23:20:19] Checking Windows Installer version...
    [12/06/03,23:20:19] Trying to load msi.dll
    [12/06/03,23:20:19] Loading: C:\WINDOWS\INSTALLER\INSTMSI0\msi.dll
    [12/06/03,23:20:19] Cannot find Windows Installer.
    [12/06/03,23:20:19] Finished Checking Windows Installer version.
    [12/06/03,23:20:19] Preparing Dialog
    [12/06/03,23:20:19] Message: Microsoft .NET Framework Setup needs to update the Microsoft Windows Installer components before Setup can continue. Proceed with installation?
    [12/06/03,23:20:19] Installing Windows Installer
    [12/06/03,23:20:19] Running InstMsi.exe /c:"msiinst /delayrebootq"
    [12/06/03,23:20:24] Windows Installer Installation returned 0
    [12/06/03,23:20:24]

    [InstMsi.exe]

    ReturnCode=0
    [12/06/03,23:20:24] Searching for MSI: C:\WINDOWS\TEMP\IXP000.TMP\netfx.msi
    [12/06/03,23:20:24] Reading Properties from MSI database: C:\WINDOWS\TEMP\IXP000.TMP\netfx.msi
    [12/06/03,23:20:24] Reading URTVersion
    [12/06/03,23:20:24] Trying to load msi.dll
    [12/06/03,23:20:24] Loading: C:\WINDOWS\INSTALLER\INSTMSI0\msi.dll
    [12/06/03,23:20:24] Preparing Dialog
    [12/06/03,23:20:24] Message: Setup cannot access Windows Installer components. Setup cannot continue.
    [12/06/03,23:20:25] Install.exe returning 4099
    [12/06/03,23:20:25]

    [Install.exe]

    ReturnCode=4099



    Is this possible to run .NET applications on Windows 9x? Any help will be appreciated. Thank you!

    Tanzim Saqib

    Problemsetter, ACM Valladolid Online Judge, Spain.
    Website: http://tanzim.tk


    This posting is provided "AS IS" with no warranties.
    Tanzim Saqib, Dec 6, 2003
    #1
    1. Advertising

  2. Tanzim Saqib

    Uraza Guest

    Isn't it that the receiving machine where you intend to install must have the right msi package installed?

    If it is for Windows 95, 98 or ME http://www.microsoft.com/downloads/...FamilyID=CEBBACD8-C094-4255-B702-DE3BB768148F may be valuable.

    Regards...
    "Tanzim Saqib" <> wrote in message news:...
    Hello
    I am novice in VB.NET . I have developed a sample HelloWorld program and a setup application for it. VB.NET warned me that the client machine should install .NET Framework (DOTNETFX.EXE) in order to run the application. I tried it in my Windows ME and found a message "Setup cannot access Windows Installer components. Setup cannot continue." and it terminates. I can not run the setup application. I have found a log file in the Temp folder:

    [12/06/03,23:20:19] Starting Install.exe
    [12/06/03,23:20:19] Parsing switches from commandline: C:\WINDOWS\TEMP\IXP000.TMP\Install.exe
    [12/06/03,23:20:19] SourceDir: C:\WINDOWS\TEMP\IXP000.TMP\
    [12/06/03,23:20:19] Install started
    [12/06/03,23:20:19] Checking system requirements
    [12/06/03,23:20:19] OS: Win Millenium
    [12/06/03,23:20:19] Ver: Second Edition
    [12/06/03,23:20:19] SP:
    [12/06/03,23:20:19] Checking Internet Explorer Version
    [12/06/03,23:20:19] Looking for 5.0.2919.6307
    [12/06/03,23:20:19] Found Internet Explorer Version: 5.50.4134.0100
    [12/06/03,23:20:19] Internet Explorer Version is OK...
    [12/06/03,23:20:19] System meets minimum requirements
    [12/06/03,23:20:19] Checking Windows Installer version...
    [12/06/03,23:20:19] Trying to load msi.dll
    [12/06/03,23:20:19] Loading: C:\WINDOWS\INSTALLER\INSTMSI0\msi.dll
    [12/06/03,23:20:19] Cannot find Windows Installer.
    [12/06/03,23:20:19] Finished Checking Windows Installer version.
    [12/06/03,23:20:19] Preparing Dialog
    [12/06/03,23:20:19] Message: Microsoft .NET Framework Setup needs to update the Microsoft Windows Installer components before Setup can continue. Proceed with installation?
    [12/06/03,23:20:19] Installing Windows Installer
    [12/06/03,23:20:19] Running InstMsi.exe /c:"msiinst /delayrebootq"
    [12/06/03,23:20:24] Windows Installer Installation returned 0
    [12/06/03,23:20:24]

    [InstMsi.exe]

    ReturnCode=0
    [12/06/03,23:20:24] Searching for MSI: C:\WINDOWS\TEMP\IXP000.TMP\netfx.msi
    [12/06/03,23:20:24] Reading Properties from MSI database: C:\WINDOWS\TEMP\IXP000.TMP\netfx.msi
    [12/06/03,23:20:24] Reading URTVersion
    [12/06/03,23:20:24] Trying to load msi.dll
    [12/06/03,23:20:24] Loading: C:\WINDOWS\INSTALLER\INSTMSI0\msi.dll
    [12/06/03,23:20:24] Preparing Dialog
    [12/06/03,23:20:24] Message: Setup cannot access Windows Installer components. Setup cannot continue.
    [12/06/03,23:20:25] Install.exe returning 4099
    [12/06/03,23:20:25]

    [Install.exe]

    ReturnCode=4099



    Is this possible to run .NET applications on Windows 9x? Any help will be appreciated. Thank you!

    Tanzim Saqib

    Problemsetter, ACM Valladolid Online Judge, Spain.
    Website: http://tanzim.tk


    This posting is provided "AS IS" with no warranties.
    Uraza, Dec 7, 2003
    #2
    1. Advertising

  3. Tanzim Saqib

    Tanzim Saqib Guest

    Thanks for replying. I am pretty sure that Windows Installer is installed. How can I know the version?

    Tanzim Saqib

    Problemsetter, ACM Valladolid Online Judge, Spain.
    Website: http://tanzim.tk


    This posting is provided "AS IS" with no warranties.
    Tanzim Saqib, Dec 8, 2003
    #3
  4. Tanzim Saqib

    Tanzim Saqib Guest

    I've installed that file couple minutes ago and found the message "This service already exists."
    Tanzim Saqib

    Problemsetter, ACM Valladolid Online Judge, Spain.
    Website: http://tanzim.tk


    This posting is provided "AS IS" with no warranties.
    Tanzim Saqib, Dec 8, 2003
    #4
  5. Tanzim Saqib

    Uraza Guest

    And you found this on the machine you are trying to install the .msi? Perhaps you need to remove and re-install the latest version. Just a guess.
    "Tanzim Saqib" <> wrote in message news:ecQbS%...
    I've installed that file couple minutes ago and found the message "This service already exists."
    Tanzim Saqib

    Problemsetter, ACM Valladolid Online Judge, Spain.
    Website: http://tanzim.tk


    This posting is provided "AS IS" with no warranties.
    Uraza, Dec 8, 2003
    #5
  6. Tanzim Saqib

    Tanzim Saqib Guest

    Yes, I am trying to install on my client machine which runs on Windows ME. How can I remove MSI?? Thanks again!
    Tanzim Saqib

    Problemsetter, ACM Valladolid Online Judge, Spain.
    Website: http://tanzim.tk


    This posting is provided "AS IS" with no warranties.
    Tanzim Saqib, Dec 8, 2003
    #6
  7. Tanzim Saqib

    Uraza Guest

    I never tried uninstalling it myself. So I am referring you to this link (Google is my friend.) in the hopes that it may help you. http://appdeploy.com/faq/windowsinstaller.shtml

    "Tanzim Saqib" <> wrote in message news:%...
    Yes, I am trying to install on my client machine which runs on Windows ME. How can I remove MSI?? Thanks again!
    Tanzim Saqib

    Problemsetter, ACM Valladolid Online Judge, Spain.
    Website: http://tanzim.tk


    This posting is provided "AS IS" with no warranties.
    Uraza, Dec 8, 2003
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Yung
    Replies:
    6
    Views:
    1,487
    John Yung
    Dec 30, 2005
  2. =?Utf-8?B?SEVMTE9IRUxMTw==?=

    .NET Framework problem - no access to internet

    =?Utf-8?B?SEVMTE9IRUxMTw==?=, Aug 27, 2007, in forum: Wireless Networking
    Replies:
    0
    Views:
    421
    =?Utf-8?B?SEVMTE9IRUxMTw==?=
    Aug 27, 2007
  3. Tanzim Saqib

    Problem with .Net Framework!

    Tanzim Saqib, Dec 6, 2003, in forum: MCAD
    Replies:
    6
    Views:
    538
    Mas Jabier
    Dec 17, 2003
  4. Dutchman

    update problem Net framework

    Dutchman, May 25, 2009, in forum: Computer Support
    Replies:
    2
    Views:
    485
    chuckcar
    May 25, 2009
  5. Ozark

    Installing Paint.net / .NET Framework 3.5

    Ozark, Dec 6, 2009, in forum: Computer Support
    Replies:
    2
    Views:
    1,344
    Ozark
    Dec 9, 2009
Loading...

Share This Page