Problem with LFI fragment reassembly

Discussion in 'Cisco' started by Dieter Jansen, May 20, 2005.

  1. Hi Folks,

    I have been working with a couple of clients who have ADSL WANs
    (over a private IP provider, not the public Internet) who are
    experimenting with QoS and LFI.

    The first client runs c837-k9o3sy6-mz.123-2.T.bin on a bunch of
    837s, whilst the second runs c1700-k9o3sy7-mz.122-4.T7.bin on
    1751s with ADSL WICs.

    I was able to add QoS and LFI to the 837s without much drama but
    I've had problems with the 1751s. When I add LFI to the 1751s
    the central site cannot ping PCs on the remote LAN with packets
    larger than 600 bytes. Interestingly it can ping the remote
    router itself with large packets. Switching ppp multilink off
    restores correct operation.

    The 1751 does seem to get into multilink LFI mode as there is
    the usual pause when I enable multilink and then a "sh int di1"
    starts to show the virtual-access interfaces and "interleaves"
    appear in the stats display.

    I assume that 600 bytes corresponds to 10 msec of the 512 Kbps
    bandwidth as I'm using "ppp multilink fragment delay 10".

    The routers are not entirely identical as they have had quite
    different histories, so I'm assuming that the problem 1751 has
    a setting that is preventing fragment reassembly to the LAN
    interface???

    The clients are't keen on me posting full configs, but the
    following may be enough to allow somone to spot the obvious
    error ;-)

    The (working) 837 router looks like:

    version 12.3
    ...
    ip cef
    ...
    policy-map QoS-XXX
    ...
    policy-map DiffServ-Marking-XXX
    ...
    interface Ethernet0
    ip address x.x.x.x 255.255.255.0
    service-policy input DiffServ-Marking-XXX
    ip route-cache flow
    no ip mroute-cache
    hold-queue 100 out
    ...
    interface ATM0
    no ip address
    no ip mroute-cache
    no atm ilmi-keepalive
    pvc 8/35
    encapsulation aal5snap
    protocol ip inarp
    protocol ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    dsl power-cutback 0
    bridge-group 1
    hold-queue 224 in
    !
    interface ATM0.1 point-to-point
    no ip mroute-cache
    ...
    interface Dialer1
    bandwidth 512
    ip address negotiated
    service-policy output QoS-XXX
    encapsulation ppp
    ip tcp header-compression
    no ip mroute-cache
    dialer pool 1
    dialer idle-timeout 0
    dialer persistent delay initial 30
    dialer persistent delay 30
    dialer persistent max-attempts 3
    dialer-group 1
    keepalive 10 3
    ppp authentication chap callin
    ppp chap hostname x
    ppp chap password 7 xxxxxxxxxxxxxxxxx
    ppp multilink
    ppp multilink fragment delay 10
    ppp multilink interleave
    hold-queue 224 in

    The (broken) 1751 router looks like:

    version 12.2
    ...
    ip cef
    ...
    policy-map QoS-XXX
    ...
    policy-map DiffServ-Marking-XXX
    ...
    interface ATM0/0
    no ip address
    no ip mroute-cache
    atm vc-per-vp 256
    no atm ilmi-keepalive
    pvc 8/35
    encapsulation aal5snap
    protocol ip inarp
    protocol ppp dialer
    dialer pool-member 1
    !
    dsl operating-mode auto
    no fair-queue
    bridge-group 1
    hold-queue 224 in
    !
    interface ATM0/0.1 point-to-point
    no ip mroute-cache
    ...
    interface FastEthernet0/0
    ip address x.x.x.x 255.255.255.0
    service-policy input DiffServ-Marking-XXX
    no ip mroute-cache
    speed auto
    hold-queue 100 out
    ...
    interface Dialer1
    bandwidth 512
    ip address negotiated
    service-policy output QoS-XXX
    encapsulation ppp
    ip tcp header-compression
    no ip mroute-cache
    dialer pool 1
    dialer idle-timeout 0
    dialer persistent delay initial 30
    dialer persistent delay 30
    dialer persistent max-attempts 3
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname x
    ppp chap password 7 xxxxxxxxxxxxxxxxxxxxxxx
    ppp multilink
    ppp multilink fragment delay 10
    ppp multilink interleave

    Can anyone spot what's wrong? I suppose it could be the
    router model, the IOS version, or perhaps the ISP's core
    router config that are at fault, but I think I'm doing
    something that prevents reassembly.

    Any thoughts greatly appreciated.

    Cheers, Dieter.
    Dieter Jansen, May 20, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Karnov
    Replies:
    1
    Views:
    8,287
    CCIE8122
    May 24, 2004
  2. Dieter Jansen
    Replies:
    0
    Views:
    510
    Dieter Jansen
    Jun 5, 2005
  3. Dieter Jansen

    Possible problems with LFI on a c837

    Dieter Jansen, Sep 1, 2005, in forum: Cisco
    Replies:
    0
    Views:
    403
    Dieter Jansen
    Sep 1, 2005
  4. Mudropolk

    PPP LFI over L2TPv3

    Mudropolk, Nov 2, 2006, in forum: Cisco
    Replies:
    0
    Views:
    940
    Mudropolk
    Nov 2, 2006
  5. mca3200

    Coolpix 3200 lens reassembly

    mca3200, Jun 20, 2006, in forum: Digital Photography
    Replies:
    4
    Views:
    464
    mca3200 via PhotoKB.com
    Jun 21, 2006
Loading...

Share This Page