Problem with Ip address of a Tunnel interface

Discussion in 'Cisco' started by Davide, Apr 1, 2004.

  1. Davide

    Davide Guest

    I have a strange problem with Cisco 827 routers.
    I configured a Tunnel between two of them on a DSL Internet
    connection.
    Everything works fine except when a router is shut down and then
    turned on again.
    It loose the IP address configuration of the tunnel interface because
    the router adds a trailing 0 after the subnet mask of the address!
    When i configure the interface i type:

    ip address 10.10.1.1 255.255.255.252

    the router answer with:

    Router(conf-if)#

    and everything seems ok.
    But if i type sh run or sh conf after wr mem i get

    interface Tunnel0
    description Tunnel towards Show Room
    ip address 10.10.1.1 255.255.255.252 0
    tunnel source ATM0.1
    tunnel destination x.x.x.x
    tunnel mode ipip

    When the router reloads it's configuration it says:

    ip address 10.10.1.1 255.255.255.252 0
    ^
    % Invalid input detected at '^' marker.

    and the Tunnel conf become:

    interface Tunnel0
    description Tunnel towards Show Room
    no ip address
    no keepalive
    tunnel source ATM0.1
    tunnel destination x.x.x.x
    tunnel mode ipip

    To fix this i have to connect to the router and manually reconfigure
    the Tunnel.
    Thanks in advance for any help!

    Davide.
     
    Davide, Apr 1, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Ireland
    Replies:
    1
    Views:
    1,092
    Claude LeFort
    Nov 11, 2003
  2. Davide
    Replies:
    0
    Views:
    381
    Davide
    Apr 1, 2004
  3. a.nonny mouse
    Replies:
    2
    Views:
    1,130
  4. Replies:
    6
    Views:
    29,598
  5. Prasanna
    Replies:
    3
    Views:
    6,910
    slyubski
    Jan 31, 2009
Loading...

Share This Page