Problem with .asx/WMP in Firefox 1.0.7

Discussion in 'Firefox' started by Christopher Bogart, Feb 18, 2006.

  1. Some time ago in IE, I deleted items in "View Objects" under Internet
    Options.

    Since that time, I've been unable to view video files on several
    websites in IE & Firefox using MP 9/10. I've tested different sites. For
    example, Foxnews.com works with both. Neither work for CNN & Amazon.

    Right clicking, then error details shows:

    Windows Media Player cannot play the file because the specified protocol
    is not supported. If you typed a URL in the Open URL dialog box, try
    using a different transport protocol (for example, "http:" or "rtsp:").

    Another error:

    Windows Media Player cannot play any items in the playlist. For
    additional information, right-click an item that cannot be played, and
    then click Error Details.

    Here's my info:

    XP Professional (SP1a)
    Firefox 1.0.7 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
    rv:1.7.12) Gecko/20050915 Firefox/1.0.7)
    Extensions: Chromedit 0.1.1.1
    Media Player 10

    The Active X & Media player plug-in do test successfully from
    http://members.aol.com/jrzycrim01/mozilla/wmp/wmpaxtest.html. The
    Windows Media Player 9.0 registry patch is installed.

    I also tried installing FF 1.5.0.1, but couldn't even get it to launch
    stating that I already had a browser open and I had to close it to
    continue. So I'm back to 1.0.7

    I've been told I may need to re-register the non-working protocol.

    Regedit already has .asx there. So the re-register of .asx should look like?

    REGEDIT4

    [HKEY_CLASSES_ROOT\.asx]
    @="URL:.asx"
    "URL Protocol"=""

    [HKEY_CLASSES_ROOT\.asx\shell]

    [HKEY_CLASSES_ROOT\.asx\shell\open]

    [HKEY_CLASSES_ROOT\.asx\shell\open\command]
    @="\"C:\\Program Files\\Windows Media Player\\wmplayer.exe\" \"%1\""

    FYI: I was able on one site to copy the .asx url, copy it to the browser
    and play it with mplayer2.exe, not wmplayer.

    Appreciate any help.

    Thanks.
    *** Free account sponsored by SecureIX.com ***
    *** Encrypt your Internet usage with a free VPN account from http://www.SecureIX.com ***
     
    Christopher Bogart, Feb 18, 2006
    #1
    1. Advertising

  2. Christopher Bogart wrote:
    > Some time ago in IE, I deleted items in "View Objects" under Internet
    > Options.
    >
    > Since that time, I've been unable to view video files on several
    > websites in IE & Firefox using MP 9/10. I've tested different sites.
    > For example, Foxnews.com works with both. Neither work for CNN & Amazon.
    >
    > Right clicking, then error details shows:
    >
    > Windows Media Player cannot play the file because the specified
    > protocol is not supported. If you typed a URL in the Open URL dialog
    > box, try using a different transport protocol (for example, "http:" or
    > "rtsp:").
    >
    > Another error:
    >
    > Windows Media Player cannot play any items in the playlist. For
    > additional information, right-click an item that cannot be played, and
    > then click Error Details.
    >
    > Here's my info:
    >
    > XP Professional (SP1a)
    > Firefox 1.0.7 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
    > rv:1.7.12) Gecko/20050915 Firefox/1.0.7)
    > Extensions: Chromedit 0.1.1.1
    > Media Player 10
    >
    > The Active X & Media player plug-in do test successfully from
    > http://members.aol.com/jrzycrim01/mozilla/wmp/wmpaxtest.html. The
    > Windows Media Player 9.0 registry patch is installed.
    >
    > I also tried installing FF 1.5.0.1, but couldn't even get it to launch
    > stating that I already had a browser open and I had to close it to
    > continue. So I'm back to 1.0.7
    >
    > I've been told I may need to re-register the non-working protocol.
    >
    > Regedit already has .asx there. So the re-register of .asx should look
    > like?
    >
    > REGEDIT4
    >
    > [HKEY_CLASSES_ROOT\.asx]
    > @="URL:.asx"
    > "URL Protocol"=""
    >
    > [HKEY_CLASSES_ROOT\.asx\shell]
    >
    > [HKEY_CLASSES_ROOT\.asx\shell\open]
    >
    > [HKEY_CLASSES_ROOT\.asx\shell\open\command]
    > @="\"C:\\Program Files\\Windows Media Player\\wmplayer.exe\" \"%1\""
    >
    > FYI: I was able on one site to copy the .asx url, copy it to the
    > browser and play it with mplayer2.exe, not wmplayer.
    >
    > Appreciate any help.
    >
    > Thanks.
    > *** Free account sponsored by SecureIX.com ***
    > *** Encrypt your Internet usage with a free VPN account from
    > http://www.SecureIX.com ***

    Um, undo the changes you made in internet options
     
    Moz Champion (Dan), Feb 19, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Russ Tobin
    Replies:
    0
    Views:
    1,085
    Russ Tobin
    May 3, 2005
  2. John

    asx files?

    John, May 19, 2006, in forum: Computer Information
    Replies:
    1
    Views:
    420
    Plato
    May 20, 2006
  3. blnstr
    Replies:
    1
    Views:
    547
    thanatoid
    Dec 8, 2006
  4. Replies:
    2
    Views:
    1,556
  5. who'sthat

    WMP and .asx file problem

    who'sthat, Oct 4, 2007, in forum: Computer Support
    Replies:
    0
    Views:
    499
    who'sthat
    Oct 4, 2007
Loading...

Share This Page