Problem in using linkbutton in asp.net2.0

Discussion in 'General Computer Support' started by IvanTsoi, Jul 27, 2011.

  1. IvanTsoi

    IvanTsoi

    Joined:
    Jul 27, 2011
    Messages:
    1
    I install a plug in (DualSelectListBox.dll) in lib that can product a DualSelectListBox in a web page.

    the following is the Header
    <%@ Register TagPrefix="cc1" Namespace="Skynet" Assembly="DualSelectListBox" %>
    .........


    I replaced the DualSelectListBox inside a panel

    <Panel1>
    ......
    <cc1:DualSelectListBox id="DualSelectListBox1" runat="server" Width="750px" >....</cc1:DualSelectListBox>
    ......
    </Panel1>

    Then use a LINKBUTTON to call an event
    <asp:LinkButton id="Linkbutton4" onclick="OKClick" runat="server" />

    But I find it cannot fire when I push the linkButton unless I replace the linkbutton as button or put the DualSelectListBox outside the panel.

    It was OK in ASP.net1.0. But when Upgrade to 2.0, it is out of order.
    IvanTsoi, Jul 27, 2011
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. gautam2u@gmail.com
    Replies:
    2
    Views:
    1,575
    ProgTalk
    Feb 7, 2008
  2. tapasmahata

    Dynamic LinkButton not working in ASP.NET

    tapasmahata, Mar 14, 2008, in forum: Software
    Replies:
    0
    Views:
    1,461
    tapasmahata
    Mar 14, 2008
  3. iquad
    Replies:
    0
    Views:
    719
    iquad
    Aug 14, 2008
  4. statichash
    Replies:
    0
    Views:
    832
    statichash
    May 21, 2009
  5. statichash

    Make a testsite exact copy of an ASP.NET2.0 site

    statichash, May 21, 2009, in forum: General Computer Support
    Replies:
    2
    Views:
    1,258
    offshoredevelopment
    Jul 8, 2009
Loading...

Share This Page