Problem. Im using me windows right now

Discussion in 'NZ Computing' started by Roger_Nickel, Mar 3, 2004.

  1. Roger_Nickel

    Roger_Nickel Guest

    nick wrote:
    > Anyone know why I would lose my login on madrake. I was stepped through the
    > initial set up with help on the phone a week ago. But now the system at
    > boot up just now had to fix itself i guess. Anyway, I was warned that data
    > might be lost. As I say, its lost the login details after the repair and
    > now I cant get to the thing. It's bringing up a local host screen and I
    > think I need to recreate the user. Im not sure how thats done. Anyone help
    > me here please.
    >
    > thanks
    >
    >

    can you get a login prompt?. If you can still log in as root you will be
    able to run the deluser command from the console. Use the Midnight
    Commander (mc at the command prompt) to find it, it is at
    /usr/sbin/deluser on Debian. Then you can use the adduser command to
    recreate the account. If you are using an X-window log in it could be
    crashing during the X-window boot which will give you the console but
    with the keyboard locked out. This is harder.
    If you are booting with LILO,you can try "single" at the LILO prompt
    to start a single user console but it won't work if the command line is
    locked in the LILO configuration file. If necessary, use a Linux boot
    disk to get a command line, tomsrbt is recommended and a web search will
    find it.
    Mount the disk partition containing your /etc directory ('man mount'
    for help on the mount command}. If using a boot disk, you need a mount
    point for the filesystem. Usually this is /mnt. The command 'fdisk
    /dev/hda' will allow you to read the partition table and find out how
    the disk is partitioned. A second drive would be /dev/hdb etc. In the
    simple case '/bin/mount /dev/hda1 /mnt' will get you going assuming that
    all of Linux is on the first partition of the first hard disk drive.in
    this case the path to the /etc directory will be /mnt/etc and the boot
    disk /etc directory will be /etc (!).
    Once you have the filesystem containing the /etc directory mounted,
    you can edit the /etc/inittab file which controls the boot process. You
    need to change the default runlevel to give you a console login rather
    than a graphic shell login. look for a line like
    id:4:initdefault:
    On Debian this line causes a boot into run level four, or console mode.
    Check the comments in your file to see what change you need to make to
    get a console mode boot. Edit and save the file. If using the tomsrbt
    disk, use the pico editor. Reboot. You are hopefully now in console mode
    and looking at a login prompt. Login as root and do the deluser/adduser
    thing. Once console mode is working, try the command 'telinit x' (where
    x is the original default runlevel) to start X-windows.
     
    Roger_Nickel, Mar 3, 2004
    #1
    1. Advertising

  2. Roger_Nickel

    dmbkiwi Guest

    On Wed, 03 Mar 2004 19:00:26 -0800, nick wrote:

    > Anyone know why I would lose my login on madrake. I was stepped through the
    > initial set up with help on the phone a week ago. But now the system at
    > boot up just now had to fix itself i guess. Anyway, I was warned that data
    > might be lost. As I say, its lost the login details after the repair and
    > now I cant get to the thing. It's bringing up a local host screen and I
    > think I need to recreate the user. Im not sure how thats done. Anyone help
    > me here please.
    >
    > thanks


    Have you got a graphical login? ie, is the screen black with a command
    prompt? If so, then login using your username and password.

    Then type:

    startx

    Tell us what you get.

    Matt
     
    dmbkiwi, Mar 3, 2004
    #2
    1. Advertising

  3. Roger_Nickel

    nick Guest

    On Wed, 03 Mar 2004 20:46:48 +1300, Roger_Nickel wrote:

    > nick wrote:
    >> Anyone know why I would lose my login on madrake. I was stepped through
    >> the initial set up with help on the phone a week ago. But now the
    >> system at boot up just now had to fix itself i guess. Anyway, I was
    >> warned that data might be lost. As I say, its lost the login details
    >> after the repair and now I cant get to the thing. It's bringing up a
    >> local host screen and I think I need to recreate the user. Im not sure
    >> how thats done. Anyone help me here please.
    >>
    >> thanks
    >>
    >>

    > can you get a login prompt?. If you can still log in as root you will be
    > able to run the deluser command from the console. Use the Midnight
    > Commander (mc at the command prompt) to find it, it is at
    > /usr/sbin/deluser on Debian. Then you can use the adduser command to
    > recreate the account. If you are using an X-window log in it could be
    > crashing during the X-window boot which will give you the console but with
    > the keyboard locked out. This is harder.
    > If you are booting with LILO,you can try "single" at the LILO prompt
    > to start a single user console but it won't work if the command line is
    > locked in the LILO configuration file. If necessary, use a Linux boot disk
    > to get a command line, tomsrbt is recommended and a web search will find
    > it.
    > Mount the disk partition containing your /etc directory ('man mount'
    > for help on the mount command}. If using a boot disk, you need a mount
    > point for the filesystem. Usually this is /mnt. The command 'fdisk
    > /dev/hda' will allow you to read the partition table and find out how the
    > disk is partitioned. A second drive would be /dev/hdb etc. In the simple
    > case '/bin/mount /dev/hda1 /mnt' will get you going assuming that all of
    > Linux is on the first partition of the first hard disk drive.in this case
    > the path to the /etc directory will be /mnt/etc and the boot disk /etc
    > directory will be /etc (!).
    > Once you have the filesystem containing the /etc directory mounted,
    > you can edit the /etc/inittab file which controls the boot process. You
    > need to change the default runlevel to give you a console login rather
    > than a graphic shell login. look for a line like
    > id:4:initdefault:
    > On Debian this line causes a boot into run level four, or console mode.
    > Check the comments in your file to see what change you need to make to get
    > a console mode boot. Edit and save the file. If using the tomsrbt disk,
    > use the pico editor. Reboot. You are hopefully now in console mode and
    > looking at a login prompt. Login as root and do the deluser/adduser thing.
    > Once console mode is working, try the command 'telinit x' (where x is the
    > original default runlevel) to start X-windows.


    right. managed to get in. On boot up, i get to a screen with options.
    titled local host. A grey box with icon folder buttons on the left hand
    side. I click on the user thats set up for me after scrolling down to it.
    I have the option in a drop down box to get to, something simalar to a dos
    prompt where I I found that by typing my user name at the promt I can get
    into my user.

    found that by typing ked at the user local host promt I get into the kde
    interface. I have tried by going into configure your computer and clicked
    on defaults to user but on reboot I have to get to the dos promt thing
    again and type in kde.

    Question, how do I get kde to fire up to the user interface where I jsut
    type in my user name and pw ?. withpout having to go through to the promt
    and tell it to go to kde.
     
    nick, Mar 3, 2004
    #3
  4. Roger_Nickel

    nick Guest

    On Wed, 03 Mar 2004 20:46:48 +1300, Roger_Nickel wrote:

    > nick wrote:
    >> Anyone know why I would lose my login on madrake. I was stepped through
    >> the initial set up with help on the phone a week ago. But now the
    >> system at boot up just now had to fix itself i guess. Anyway, I was
    >> warned that data might be lost. As I say, its lost the login details
    >> after the repair and now I cant get to the thing. It's bringing up a
    >> local host screen and I think I need to recreate the user. Im not sure
    >> how thats done. Anyone help me here please.
    >>
    >> thanks
    >>
    >>

    > can you get a login prompt?. If you can still log in as root you will be
    > able to run the deluser command from the console. Use the Midnight
    > Commander (mc at the command prompt) to find it, it is at
    > /usr/sbin/deluser on Debian. Then you can use the adduser command to
    > recreate the account. If you are using an X-window log in it could be
    > crashing during the X-window boot which will give you the console but with
    > the keyboard locked out. This is harder.
    > If you are booting with LILO,you can try "single" at the LILO prompt
    > to start a single user console but it won't work if the command line is
    > locked in the LILO configuration file. If necessary, use a Linux boot disk
    > to get a command line, tomsrbt is recommended and a web search will find
    > it.
    > Mount the disk partition containing your /etc directory ('man mount'
    > for help on the mount command}. If using a boot disk, you need a mount
    > point for the filesystem. Usually this is /mnt. The command 'fdisk
    > /dev/hda' will allow you to read the partition table and find out how the
    > disk is partitioned. A second drive would be /dev/hdb etc. In the simple
    > case '/bin/mount /dev/hda1 /mnt' will get you going assuming that all of
    > Linux is on the first partition of the first hard disk drive.in this case
    > the path to the /etc directory will be /mnt/etc and the boot disk /etc
    > directory will be /etc (!).
    > Once you have the filesystem containing the /etc directory mounted,
    > you can edit the /etc/inittab file which controls the boot process. You
    > need to change the default runlevel to give you a console login rather
    > than a graphic shell login. look for a line like
    > id:4:initdefault:
    > On Debian this line causes a boot into run level four, or console mode.
    > Check the comments in your file to see what change you need to make to get
    > a console mode boot. Edit and save the file. If using the tomsrbt disk,
    > use the pico editor. Reboot. You are hopefully now in console mode and
    > looking at a login prompt. Login as root and do the deluser/adduser thing.
    > Once console mode is working, try the command 'telinit x' (where x is the
    > original default runlevel) to start X-windows.


    Oh yeah. Im using a lilo screen.
     
    nick, Mar 3, 2004
    #4
  5. Roger_Nickel

    Lebowski Guest

    "nick" <> wrote in message
    news:p...
    > On Wed, 03 Mar 2004 20:46:48 +1300, Roger_Nickel wrote:
    >
    > > nick wrote:
    > >> Anyone know why I would lose my login on madrake. I was stepped

    through
    > >> the initial set up with help on the phone a week ago. But now the
    > >> system at boot up just now had to fix itself i guess. Anyway, I was
    > >> warned that data might be lost. As I say, its lost the login details
    > >> after the repair and now I cant get to the thing. It's bringing up a
    > >> local host screen and I think I need to recreate the user. Im not sure
    > >> how thats done. Anyone help me here please.
    > >>
    > >> thanks
    > >>
    > >>

    > > can you get a login prompt?. If you can still log in as root you will be
    > > able to run the deluser command from the console. Use the Midnight
    > > Commander (mc at the command prompt) to find it, it is at
    > > /usr/sbin/deluser on Debian. Then you can use the adduser command to
    > > recreate the account. If you are using an X-window log in it could be
    > > crashing during the X-window boot which will give you the console but

    with
    > > the keyboard locked out. This is harder.
    > > If you are booting with LILO,you can try "single" at the LILO prompt
    > > to start a single user console but it won't work if the command line is
    > > locked in the LILO configuration file. If necessary, use a Linux boot

    disk
    > > to get a command line, tomsrbt is recommended and a web search will find
    > > it.
    > > Mount the disk partition containing your /etc directory ('man mount'
    > > for help on the mount command}. If using a boot disk, you need a mount
    > > point for the filesystem. Usually this is /mnt. The command 'fdisk
    > > /dev/hda' will allow you to read the partition table and find out how

    the
    > > disk is partitioned. A second drive would be /dev/hdb etc. In the simple
    > > case '/bin/mount /dev/hda1 /mnt' will get you going assuming that all of
    > > Linux is on the first partition of the first hard disk drive.in this

    case
    > > the path to the /etc directory will be /mnt/etc and the boot disk /etc
    > > directory will be /etc (!).
    > > Once you have the filesystem containing the /etc directory mounted,
    > > you can edit the /etc/inittab file which controls the boot process. You
    > > need to change the default runlevel to give you a console login rather
    > > than a graphic shell login. look for a line like
    > > id:4:initdefault:
    > > On Debian this line causes a boot into run level four, or console mode.
    > > Check the comments in your file to see what change you need to make to

    get
    > > a console mode boot. Edit and save the file. If using the tomsrbt disk,
    > > use the pico editor. Reboot. You are hopefully now in console mode and
    > > looking at a login prompt. Login as root and do the deluser/adduser

    thing.
    > > Once console mode is working, try the command 'telinit x' (where x is

    the
    > > original default runlevel) to start X-windows.

    >
    > right. managed to get in. On boot up, i get to a screen with options.
    > titled local host. A grey box with icon folder buttons on the left hand
    > side. I click on the user thats set up for me after scrolling down to it.
    > I have the option in a drop down box to get to, something simalar to a dos
    > prompt where I I found that by typing my user name at the promt I can get
    > into my user.
    >
    > found that by typing ked at the user local host promt I get into the kde
    > interface. I have tried by going into configure your computer and clicked
    > on defaults to user but on reboot I have to get to the dos promt thing
    > again and type in kde.
    >
    > Question, how do I get kde to fire up to the user interface where I jsut
    > type in my user name and pw ?. withpout having to go through to the promt
    > and tell it to go to kde.
    >


    If this is Linux, **** that ;)))
     
    Lebowski, Mar 3, 2004
    #5
  6. Roger_Nickel

    nick Guest

    On Wed, 03 Mar 2004 20:54:00 +1300, dmbkiwi wrote:

    > On Wed, 03 Mar 2004 19:00:26 -0800, nick wrote:
    >
    >> Anyone know why I would lose my login on madrake. I was stepped through
    >> the initial set up with help on the phone a week ago. But now the
    >> system at boot up just now had to fix itself i guess. Anyway, I was
    >> warned that data might be lost. As I say, its lost the login details
    >> after the repair and now I cant get to the thing. It's bringing up a
    >> local host screen and I think I need to recreate the user. Im not sure
    >> how thats done. Anyone help me here please.
    >>
    >> thanks

    >
    > Have you got a graphical login? ie, is the screen black with a command
    > prompt? If so, then login using your username and password.
    >
    > Then type:
    >
    > startx
    >
    > Tell us what you get.
    >
    > Matt


    startx takes me straight to my user desktop. Now, question ios, how do i
    get it to defualt to the user desktop on boot rather than going through
    the business of typing that in. After finding my was to the promt
     
    nick, Mar 3, 2004
    #6
  7. Roger_Nickel

    Roger_Nickel Guest

    nick wrote:
    right. managed to get in. On boot up, i get to a screen with options.
    > titled local host. A grey box with icon folder buttons on the left hand
    > side. I click on the user thats set up for me after scrolling down to it.
    > I have the option in a drop down box to get to, something simalar to a dos
    > prompt where I I found that by typing my user name at the promt I can get
    > into my user.
    >
    > found that by typing ked at the user local host promt I get into the kde
    > interface. I have tried by going into configure your computer and clicked
    > on defaults to user but on reboot I have to get to the dos promt thing
    > again and type in kde.
    >
    > Question, how do I get kde to fire up to the user interface where I jsut
    > type in my user name and pw ?. withpout having to go through to the promt
    > and tell it to go to kde.
    >

    Sounds as if you have reached the X-window login manager. Assuming that
    it is the KDE login manager, you can configure it from the KDE desktop.
    Do 'KDE Control Centre/System/Login Manager' and fill in the entry for
    your user name with the options you want
     
    Roger_Nickel, Mar 3, 2004
    #7
  8. Roger_Nickel

    nick Guest

    On Wed, 03 Mar 2004 21:14:30 +1300, nick wrote:

    > On Wed, 03 Mar 2004 20:46:48 +1300, Roger_Nickel wrote:
    >
    >> nick wrote:
    >>> Anyone know why I would lose my login on madrake. I was stepped
    >>> through the initial set up with help on the phone a week ago. But now
    >>> the system at boot up just now had to fix itself i guess. Anyway, I
    >>> was warned that data might be lost. As I say, its lost the login
    >>> details after the repair and now I cant get to the thing. It's
    >>> bringing up a local host screen and I think I need to recreate the
    >>> user. Im not sure how thats done. Anyone help me here please.
    >>>
    >>> thanks
    >>>
    >>>

    >> can you get a login prompt?. If you can still log in as root you will be
    >> able to run the deluser command from the console. Use the Midnight
    >> Commander (mc at the command prompt) to find it, it is at
    >> /usr/sbin/deluser on Debian. Then you can use the adduser command to
    >> recreate the account. If you are using an X-window log in it could be
    >> crashing during the X-window boot which will give you the console but
    >> with the keyboard locked out. This is harder.
    >> If you are booting with LILO,you can try "single" at the LILO prompt
    >> to start a single user console but it won't work if the command line is
    >> locked in the LILO configuration file. If necessary, use a Linux boot
    >> disk to get a command line, tomsrbt is recommended and a web search will
    >> find it.
    >> Mount the disk partition containing your /etc directory ('man mount'
    >> for help on the mount command}. If using a boot disk, you need a mount
    >> point for the filesystem. Usually this is /mnt. The command 'fdisk
    >> /dev/hda' will allow you to read the partition table and find out how
    >> the disk is partitioned. A second drive would be /dev/hdb etc. In the
    >> simple case '/bin/mount /dev/hda1 /mnt' will get you going assuming that
    >> all of Linux is on the first partition of the first hard disk drive.in
    >> this case the path to the /etc directory will be /mnt/etc and the boot
    >> disk /etc directory will be /etc (!).
    >> Once you have the filesystem containing the /etc directory mounted,
    >> you can edit the /etc/inittab file which controls the boot process. You
    >> need to change the default runlevel to give you a console login rather
    >> than a graphic shell login. look for a line like
    >> id:4:initdefault:
    >> On Debian this line causes a boot into run level four, or console mode.
    >> Check the comments in your file to see what change you need to make to
    >> get a console mode boot. Edit and save the file. If using the tomsrbt
    >> disk, use the pico editor. Reboot. You are hopefully now in console mode
    >> and looking at a login prompt. Login as root and do the deluser/adduser
    >> thing. Once console mode is working, try the command 'telinit x' (where
    >> x is the original default runlevel) to start X-windows.

    >
    > Oh yeah. Im using a lilo screen.


    its not finding the gui it would appear. been into drakeboot but even
    with auto login specified and gui ticked, it wont auto login.
     
    nick, Mar 3, 2004
    #8
  9. Roger_Nickel

    harry Guest

    Lebowski wrote:

    > If this is Linux, **** that ;)))


    Its one users installation of mandrake.
    Happy trolling !
     
    harry, Mar 3, 2004
    #9
  10. Roger_Nickel

    nick Guest

    Anyone know why I would lose my login on madrake. I was stepped through the
    initial set up with help on the phone a week ago. But now the system at
    boot up just now had to fix itself i guess. Anyway, I was warned that data
    might be lost. As I say, its lost the login details after the repair and
    now I cant get to the thing. It's bringing up a local host screen and I
    think I need to recreate the user. Im not sure how thats done. Anyone help
    me here please.

    thanks
     
    nick, Mar 4, 2004
    #10
  11. Roger_Nickel

    Gordon Guest

    On Wed, 03 Mar 2004 21:38:17 +1300, nick wrote:

    > startx takes me straight to my user desktop. Now, question ios, how do i
    > get it to defualt to the user desktop on boot rather than going through
    > the business of typing that in. After finding my was to the promt


    mcc

    In the boot section.
     
    Gordon, Mar 4, 2004
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. HackaX0rus

    what are you listening to right now...

    HackaX0rus, Jul 4, 2005, in forum: The Lounge
    Replies:
    4
    Views:
    2,561
    Silverstrand
    Jul 4, 2005
  2. Replies:
    4
    Views:
    2,601
    Chrissy Cruiser
    Aug 29, 2005
  3. siliconpi
    Replies:
    2
    Views:
    810
    Don B
    Nov 29, 2004
  4. Bigfoot It Is
    Replies:
    0
    Views:
    531
    Bigfoot It Is
    Oct 30, 2006
  5. =?ISO-8859-1?Q?R=F4g=EAr?=

    If this isn't the right group, please direct me to the right one

    =?ISO-8859-1?Q?R=F4g=EAr?=, Jul 23, 2007, in forum: Computer Support
    Replies:
    2
    Views:
    434
    Jeff Wisnia
    Jul 23, 2007
Loading...

Share This Page