Printing problem "Thunking Spooler"

Discussion in 'Windows 64bit' started by Miklaing, Feb 7, 2008.

  1. Miklaing

    Miklaing Guest

    Not sure if this is a V64 issue, a windows printing issue, or a Canon issue,
    so I'm hitting all three to check for solutions:

    Looking for some sort of solution to this problem. First, I'm running Vista
    64 ultimate. Windows generates the error whenever I try to start a CD label
    printing program for my Canon MP830. The whole message is "Thunking Spooler
    APIS from 32 to 64 Process has stopped working." Windows then does the
    solution check to no avail. I have attempted to uninstall/reinstall printer
    drivers and the software, but that has not resolved the issue. All updates
    are current. Anybody else run into this problem and able to resolve it?
    Miklaing, Feb 7, 2008
    #1
    1. Advertising

  2. I am not familiar with the printer nor the software, but experience tells me
    that even if a device arrives with a 64bit driver, companion software does
    not allways follow with the same standard - this may not be a problem, but
    it could be if it is accessing the hardware. I would contact Canon Support
    and have them verify that the Labeler should work on your specific system.

    This does not sound as any OS error or message, but when you talk to Canon
    make sure you have had a look in your 'Event Viewer', which you can access
    from the 'Administrative Tools' section of 'Control Panel'. If you see any
    errors or warnings that seem related to your problem ( a time stamp may help
    you identify specific errors) then be sure to tell Canon about those.


    Tony. . .


    "Miklaing" <> wrote in message
    news:...
    > Not sure if this is a V64 issue, a windows printing issue, or a Canon
    > issue,
    > so I'm hitting all three to check for solutions:
    >
    > Looking for some sort of solution to this problem. First, I'm running
    > Vista
    > 64 ultimate. Windows generates the error whenever I try to start a CD
    > label
    > printing program for my Canon MP830. The whole message is "Thunking
    > Spooler
    > APIS from 32 to 64 Process has stopped working." Windows then does the
    > solution check to no avail. I have attempted to uninstall/reinstall
    > printer
    > drivers and the software, but that has not resolved the issue. All updates
    > are current. Anybody else run into this problem and able to resolve it?
    >
    Tony Sperling, Feb 7, 2008
    #2
    1. Advertising

  3. Tony is correct. Some manufacturers are not supporting full functionality
    under Vista, especially for older devices.

    "Miklaing" <> wrote in message
    news:...
    > Not sure if this is a V64 issue, a windows printing issue, or a Canon
    > issue,
    > so I'm hitting all three to check for solutions:
    >
    > Looking for some sort of solution to this problem. First, I'm running
    > Vista
    > 64 ultimate. Windows generates the error whenever I try to start a CD
    > label
    > printing program for my Canon MP830. The whole message is "Thunking
    > Spooler
    > APIS from 32 to 64 Process has stopped working." Windows then does the
    > solution check to no avail. I have attempted to uninstall/reinstall
    > printer
    > drivers and the software, but that has not resolved the issue. All updates
    > are current. Anybody else run into this problem and able to resolve it?
    >
    Colin Barnhorst, Feb 7, 2008
    #3
  4. Miklaing

    Miklaing Guest

    When checking the event viewer it all seems to point to this error:

    Faulting application splwow64.exe, version 6.0.6000.16386, time stamp
    0x4549c865, faulting module KPDui64.dll, version 5.3.0.42, time stamp
    0x4666b217, exception code 0xc000000d, fault offset 0x000000000000e805,
    process id 0x24c4, application start time 0x01c869c3163bef58.

    Does this shed any additional light on the issue? The program allows
    printing directly to CD, and it used to be fine.

    "Tony Sperling" wrote:

    > I am not familiar with the printer nor the software, but experience tells me
    > that even if a device arrives with a 64bit driver, companion software does
    > not allways follow with the same standard - this may not be a problem, but
    > it could be if it is accessing the hardware. I would contact Canon Support
    > and have them verify that the Labeler should work on your specific system.
    >
    > This does not sound as any OS error or message, but when you talk to Canon
    > make sure you have had a look in your 'Event Viewer', which you can access
    > from the 'Administrative Tools' section of 'Control Panel'. If you see any
    > errors or warnings that seem related to your problem ( a time stamp may help
    > you identify specific errors) then be sure to tell Canon about those.
    >
    >
    > Tony. . .
    >
    >
    > "Miklaing" <> wrote in message
    > news:...
    > > Not sure if this is a V64 issue, a windows printing issue, or a Canon
    > > issue,
    > > so I'm hitting all three to check for solutions:
    > >
    > > Looking for some sort of solution to this problem. First, I'm running
    > > Vista
    > > 64 ultimate. Windows generates the error whenever I try to start a CD
    > > label
    > > printing program for my Canon MP830. The whole message is "Thunking
    > > Spooler
    > > APIS from 32 to 64 Process has stopped working." Windows then does the
    > > solution check to no avail. I have attempted to uninstall/reinstall
    > > printer
    > > drivers and the software, but that has not resolved the issue. All updates
    > > are current. Anybody else run into this problem and able to resolve it?
    > >

    >
    >
    >
    Miklaing, Feb 7, 2008
    #4
  5. KPDui64.dll is not a binary that is shipped in the OS. It's causing the
    splwow64.exe application to terminate.

    Does the Canon MP830 driver need this file?

    I normally associate KPD with Kyocera devices



    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/search/?adv=1

    This posting is provided "AS IS" with no warranties, and confers no rights.

    "Miklaing" <> wrote in message
    news:...
    > When checking the event viewer it all seems to point to this error:
    >
    > Faulting application splwow64.exe, version 6.0.6000.16386, time stamp
    > 0x4549c865, faulting module KPDui64.dll, version 5.3.0.42, time stamp
    > 0x4666b217, exception code 0xc000000d, fault offset 0x000000000000e805,
    > process id 0x24c4, application start time 0x01c869c3163bef58.
    >
    > Does this shed any additional light on the issue? The program allows
    > printing directly to CD, and it used to be fine.
    >
    > "Tony Sperling" wrote:
    >
    >> I am not familiar with the printer nor the software, but experience tells
    >> me
    >> that even if a device arrives with a 64bit driver, companion software
    >> does
    >> not allways follow with the same standard - this may not be a problem,
    >> but
    >> it could be if it is accessing the hardware. I would contact Canon
    >> Support
    >> and have them verify that the Labeler should work on your specific
    >> system.
    >>
    >> This does not sound as any OS error or message, but when you talk to
    >> Canon
    >> make sure you have had a look in your 'Event Viewer', which you can
    >> access
    >> from the 'Administrative Tools' section of 'Control Panel'. If you see
    >> any
    >> errors or warnings that seem related to your problem ( a time stamp may
    >> help
    >> you identify specific errors) then be sure to tell Canon about those.
    >>
    >>
    >> Tony. . .
    >>
    >>
    >> "Miklaing" <> wrote in message
    >> news:...
    >> > Not sure if this is a V64 issue, a windows printing issue, or a Canon
    >> > issue,
    >> > so I'm hitting all three to check for solutions:
    >> >
    >> > Looking for some sort of solution to this problem. First, I'm running
    >> > Vista
    >> > 64 ultimate. Windows generates the error whenever I try to start a CD
    >> > label
    >> > printing program for my Canon MP830. The whole message is "Thunking
    >> > Spooler
    >> > APIS from 32 to 64 Process has stopped working." Windows then does the
    >> > solution check to no avail. I have attempted to uninstall/reinstall
    >> > printer
    >> > drivers and the software, but that has not resolved the issue. All
    >> > updates
    >> > are current. Anybody else run into this problem and able to resolve it?
    >> >

    >>
    >>
    >>
    Alan Morris [MSFT], Feb 7, 2008
    #5
  6. If it used to work on this same system, then you should think hard if (or
    what?) you may have changed lately. You could try a system restore to a date
    when you believe it worked, or you could try and uninstall this software -
    remove the driver if this part of the software is part of the driver. You
    may even uninstall the printer and all driver/software that belongs to it -
    unplug the device and reboot and re-install everything again from scratch.
    Obviously, this is an ordeal and before doing that, I'd suggest that you
    take some time and consider what you have been doing that may have triggered
    this - you don't want it to catch you unawares again.

    The error message doesn't tell me anything much, but make a copy of it and
    store it somewhere safe - you may need to ship it off to Canon some day.
    There are some clear indications, but you would need to be familiar with the
    internals of that device and the parts of the OS that it accesses to
    actually start making guesses.

    If you are having more or less specific suspicions towards things that might
    have triggered the failure, try and disable any of those before
    re-installing, but don't forget to re-boot!


    Tony. . .


    "Miklaing" <> wrote in message
    news:...
    > When checking the event viewer it all seems to point to this error:
    >
    > Faulting application splwow64.exe, version 6.0.6000.16386, time stamp
    > 0x4549c865, faulting module KPDui64.dll, version 5.3.0.42, time stamp
    > 0x4666b217, exception code 0xc000000d, fault offset 0x000000000000e805,
    > process id 0x24c4, application start time 0x01c869c3163bef58.
    >
    > Does this shed any additional light on the issue? The program allows
    > printing directly to CD, and it used to be fine.
    >
    > "Tony Sperling" wrote:
    >
    >> I am not familiar with the printer nor the software, but experience tells
    >> me
    >> that even if a device arrives with a 64bit driver, companion software
    >> does
    >> not allways follow with the same standard - this may not be a problem,
    >> but
    >> it could be if it is accessing the hardware. I would contact Canon
    >> Support
    >> and have them verify that the Labeler should work on your specific
    >> system.
    >>
    >> This does not sound as any OS error or message, but when you talk to
    >> Canon
    >> make sure you have had a look in your 'Event Viewer', which you can
    >> access
    >> from the 'Administrative Tools' section of 'Control Panel'. If you see
    >> any
    >> errors or warnings that seem related to your problem ( a time stamp may
    >> help
    >> you identify specific errors) then be sure to tell Canon about those.
    >>
    >>
    >> Tony. . .
    >>
    >>
    >> "Miklaing" <> wrote in message
    >> news:...
    >> > Not sure if this is a V64 issue, a windows printing issue, or a Canon
    >> > issue,
    >> > so I'm hitting all three to check for solutions:
    >> >
    >> > Looking for some sort of solution to this problem. First, I'm running
    >> > Vista
    >> > 64 ultimate. Windows generates the error whenever I try to start a CD
    >> > label
    >> > printing program for my Canon MP830. The whole message is "Thunking
    >> > Spooler
    >> > APIS from 32 to 64 Process has stopped working." Windows then does the
    >> > solution check to no avail. I have attempted to uninstall/reinstall
    >> > printer
    >> > drivers and the software, but that has not resolved the issue. All
    >> > updates
    >> > are current. Anybody else run into this problem and able to resolve it?
    >> >

    >>
    >>
    >>
    Tony Sperling, Feb 7, 2008
    #6
  7. Miklaing

    Theo Guest

    According to the Canon web site there are no 64-bit drivers
    for this, so where did you came up with a driver?

    OS Compatibility:
    Windows XP/2000/Me/98 and Mac OS X version 10.2.4 to 10.4.x

    If you don't have Vista x64 specific drivers you can't
    expect this to work.



    Miklaing wrote:
    > Not sure if this is a V64 issue, a windows printing issue, or a Canon issue,
    > so I'm hitting all three to check for solutions:
    >
    > Looking for some sort of solution to this problem. First, I'm running Vista
    > 64 ultimate. Windows generates the error whenever I try to start a CD label
    > printing program for my Canon MP830. The whole message is "Thunking Spooler
    > APIS from 32 to 64 Process has stopped working." Windows then does the
    > solution check to no avail. I have attempted to uninstall/reinstall printer
    > drivers and the software, but that has not resolved the issue. All updates
    > are current. Anybody else run into this problem and able to resolve it?
    >
    Theo, Feb 7, 2008
    #7
  8. Miklaing

    Theo Guest

    I must retract my statement below. For some reason the tab
    for selecting drivers was not showing before. When I went
    back and flipped through a few pages and I ended up at the
    driver page the button for selecting the OS popped up.

    There are Vista x64 drivers, but there is no KPDui64.dll in
    the driver file. The file must have a different origin.


    Theo wrote:
    > According to the Canon web site there are no 64-bit drivers for this, so
    > where did you came up with a driver?
    >
    > OS Compatibility:
    > Windows XP/2000/Me/98 and Mac OS X version 10.2.4 to 10.4.x
    >
    > If you don't have Vista x64 specific drivers you can't expect this to work.
    >
    >
    >
    > Miklaing wrote:
    >> Not sure if this is a V64 issue, a windows printing issue, or a Canon
    >> issue, so I'm hitting all three to check for solutions:
    >>
    >> Looking for some sort of solution to this problem. First, I'm running
    >> Vista 64 ultimate. Windows generates the error whenever I try to start
    >> a CD label printing program for my Canon MP830. The whole message is
    >> "Thunking Spooler APIS from 32 to 64 Process has stopped working."
    >> Windows then does the solution check to no avail. I have attempted to
    >> uninstall/reinstall printer drivers and the software, but that has not
    >> resolved the issue. All updates are current. Anybody else run into
    >> this problem and able to resolve it?
    >>
    Theo, Feb 7, 2008
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. elie
    Replies:
    0
    Views:
    950
  2. elie
    Replies:
    0
    Views:
    875
  3. elie
    Replies:
    0
    Views:
    928
  4. elie
    Replies:
    0
    Views:
    944
  5. elie
    Replies:
    2
    Views:
    774
    shelleyleena
    Nov 27, 2010
Loading...

Share This Page