printing problem magenta cast canon i9900

Discussion in 'Digital Photography' started by manunderstress@gmail.com, Oct 16, 2005.

  1. Guest

    I have a canon i9900 and am trying to print sRGB .jpgs onto red river
    satin paper via photoshop 7. Problem is I get a magenta cast when
    trying to use ICC profiles.

    Work flow is like this:

    1. open .jpg in photoshop, specify sRGB working space as embedded in
    jpg (I use adobe now but these were older pictures)
    2. print with preview
    color management:
    source space = document
    print space: rr upsatin i9900 (supplied ICC from Red River), choose
    relative colorimetric, black point compensation
    3. click "Print"
    4. Printer box comes up- click "properties", on main tab color
    adjustment set to "manual" and print type set to "none"

    Then print and the magenta cast can be seen in the preview, before even
    printing out. Monitor is calibrated. Mostly the reds and oranges have
    too much magenta. Curiously enough I don't have the problem if print
    space is set to "printer color management" but that defeats the purpose
    of using an ICC profile ..what gives?
     
    , Oct 16, 2005
    #1
    1. Advertising

  2. C Wright Guest

    On 10/15/05 8:10 PM, in article
    ,
    "" <> wrote:

    > I have a canon i9900 and am trying to print sRGB .jpgs onto red river
    > satin paper via photoshop 7. Problem is I get a magenta cast when
    > trying to use ICC profiles.
    >
    > Work flow is like this:
    >
    > 1. open .jpg in photoshop, specify sRGB working space as embedded in
    > jpg (I use adobe now but these were older pictures)
    > 2. print with preview
    > color management:
    > source space = document
    > print space: rr upsatin i9900 (supplied ICC from Red River), choose
    > relative colorimetric, black point compensation
    > 3. click "Print"
    > 4. Printer box comes up- click "properties", on main tab color
    > adjustment set to "manual" and print type set to "none"
    >
    > Then print and the magenta cast can be seen in the preview, before even
    > printing out. Monitor is calibrated. Mostly the reds and oranges have
    > too much magenta. Curiously enough I don't have the problem if print
    > space is set to "printer color management" but that defeats the purpose
    > of using an ICC profile ..what gives?
    >

    Unless you did not mention everything that you do in your work flow
    description I see a few possible omissions:
    In the print with preview dialog are you first selecting 'page setup' and
    making sure that your i9900 is the selected printer.
    Then the same thing after clicking on the 'print' button.
    Also, I don't see where you have selected the paper in the printer driver -
    after selecting your rr paper in PS Red River probably tells you to select
    something like glossy photo paper in the printer driver.
    In the printer driver selections you will also need to select 'no color
    management.'
     
    C Wright, Oct 16, 2005
    #2
    1. Advertising

  3. Guest

    Yeah, the i9900 is selected and everywhere it gives me the chance I
    have "Glossy Photo Paper" selected and ICM unchecked, Color Adjustment
    = Manual and Print Type = None. I do not see however where I can
    explicitly select 'no color management.' I thought that having ICM
    uncheck and print type None was effectively doint that.
     
    , Oct 16, 2005
    #3
  4. Roy Guest

    <> wrote in message
    news:...
    >I have a canon i9900 and am trying to print sRGB .jpgs onto red river
    > satin paper via photoshop 7. Problem is I get a magenta cast when
    > trying to use ICC profiles.
    >
    > Work flow is like this:
    >
    > 1. open .jpg in photoshop, specify sRGB working space as embedded in
    > jpg (I use adobe now but these were older pictures)
    > 2. print with preview
    > color management:
    > source space = document
    > print space: rr upsatin i9900 (supplied ICC from Red River), choose
    > relative colorimetric, black point compensation
    > 3. click "Print"
    > 4. Printer box comes up- click "properties", on main tab color
    > adjustment set to "manual" and print type set to "none"
    >
    > Then print and the magenta cast can be seen in the preview, before even
    > printing out. Monitor is calibrated. Mostly the reds and oranges have
    > too much magenta. Curiously enough I don't have the problem if print
    > space is set to "printer color management" but that defeats the purpose
    > of using an ICC profile ..what gives?



    Hi there.

    I don't use a Canon printer, so I do not know how to set the printer
    dialogues to ensure it is not Colour Managing.

    A Magenta cast usually indicates double Colour Management. Once in PS and
    again in the Printer.

    When you stopped PS from C. Managing by selecting "Printer Management" in
    the Print Space, you were then letting only the Printer do the Corrections
    and were getting Correct Prints.

    This confirms that CM was being applied twice, and when you changed the
    workflow it was only being done once, and it was only being done in the
    Printer.

    I presume that somehow the Printer is now using the correct ICC Profile, or
    that one of its own built in Profiles is a very close match to the Red River
    one.

    There are obvious dangers in this system, since you do not seem to be able
    to control which Profile the Printer selects, and some change to some other
    Printer setting might well cause the use of another and incorrect profile.

    I have seen instructions in a previous Thread, about how to stop a Canon
    Printer applying C. M., but it was much more complicated than with an Epson.
    With a little luck or some perseverance on your part you may find out how to
    do that, and then be able to return to letting PS do the CM, without any
    interferance from the Printer..

    Until then just continue letting the Printer do it, and hope it keeps
    picking the correct Profile.

    Roy G
     
    Roy, Oct 16, 2005
    #4
  5. C Wright Guest

    On 10/15/05 11:41 PM, in article
    ,
    "" <> wrote:

    > Yeah, the i9900 is selected and everywhere it gives me the chance I
    > have "Glossy Photo Paper" selected and ICM unchecked, Color Adjustment
    > = Manual and Print Type = None. I do not see however where I can
    > explicitly select 'no color management.' I thought that having ICM
    > uncheck and print type None was effectively doint that.
    >

    I have an i9900 printer but am currently using it on a Mac (you are probably
    using yours on a Windows machine). I can't imagine, however, that the
    printer driver options would be that different. When printing to the i9900
    clicking the print button in PS brings up the printer driver dialog box. In
    that window there are numerous selectable options including Quality and
    Media, Color Options, etc, etc. In the Color Options choice there should be
    an additional option to select 'Color Correction - None.' If you don't find
    that option I guess a Windows user will have to help out!
    Chuck
     
    C Wright, Oct 16, 2005
    #5
  6. kctan Guest

    You are using double color management. Off the printer color management when
    you use 3rd party paper ICC profile or any custom profile.

    "Roy" <> wrote in message
    news:wGt4f.1878$...
    > <> wrote in message
    > news:...
    >>I have a canon i9900 and am trying to print sRGB .jpgs onto red river
    >> satin paper via photoshop 7. Problem is I get a magenta cast when
    >> trying to use ICC profiles.
    >>
    >> Work flow is like this:
    >>
    >> 1. open .jpg in photoshop, specify sRGB working space as embedded in
    >> jpg (I use adobe now but these were older pictures)
    >> 2. print with preview
    >> color management:
    >> source space = document
    >> print space: rr upsatin i9900 (supplied ICC from Red River), choose
    >> relative colorimetric, black point compensation
    >> 3. click "Print"
    >> 4. Printer box comes up- click "properties", on main tab color
    >> adjustment set to "manual" and print type set to "none"
    >>
    >> Then print and the magenta cast can be seen in the preview, before even
    >> printing out. Monitor is calibrated. Mostly the reds and oranges have
    >> too much magenta. Curiously enough I don't have the problem if print
    >> space is set to "printer color management" but that defeats the purpose
    >> of using an ICC profile ..what gives?

    >
    >
    > Hi there.
    >
    > I don't use a Canon printer, so I do not know how to set the printer
    > dialogues to ensure it is not Colour Managing.
    >
    > A Magenta cast usually indicates double Colour Management. Once in PS and
    > again in the Printer.
    >
    > When you stopped PS from C. Managing by selecting "Printer Management" in
    > the Print Space, you were then letting only the Printer do the Corrections
    > and were getting Correct Prints.
    >
    > This confirms that CM was being applied twice, and when you changed the
    > workflow it was only being done once, and it was only being done in the
    > Printer.
    >
    > I presume that somehow the Printer is now using the correct ICC Profile,
    > or that one of its own built in Profiles is a very close match to the Red
    > River one.
    >
    > There are obvious dangers in this system, since you do not seem to be able
    > to control which Profile the Printer selects, and some change to some
    > other Printer setting might well cause the use of another and incorrect
    > profile.
    >
    > I have seen instructions in a previous Thread, about how to stop a Canon
    > Printer applying C. M., but it was much more complicated than with an
    > Epson. With a little luck or some perseverance on your part you may find
    > out how to do that, and then be able to return to letting PS do the CM,
    > without any interferance from the Printer..
    >
    > Until then just continue letting the Printer do it, and hope it keeps
    > picking the correct Profile.
    >
    > Roy G
    >
    >
    >
     
    kctan, Oct 16, 2005
    #6
  7. Guest

    It is off. That's the problem...color
    adjustment set to "manual" and print type set to "none" in printer
    driver.
     
    , Oct 17, 2005
    #7
  8. Roy Guest

    <> wrote in message
    news:...
    > It is off. That's the problem...color
    > adjustment set to "manual" and print type set to "none" in printer
    > driver.
    >


    Hi there again.

    I am certain that your technique of setting to "Manual" and then print type
    "None", is not turning off CM. From the little I can remember, it was much
    more complicated than that.

    When you did this, and allowed PS to CM you got Prints which had all the
    classic symptoms of Double CM.

    When you prevented PS doing any CM by specifying "Printer management" in the
    Print Space box, the symptoms went away.

    So it is obvious that your Printer was still applying CM. Perhaps not using
    the correct profile, but getting fairly close.

    If you ask on this group, someone will be able to give you the exact routine
    to turn off CM in a Canon. Once you get that info, you can revert to
    allowing PS to do the CM using your Red River Profile.

    Roy G
     
    Roy, Oct 17, 2005
    #8
  9. Markeau Guest

    <> wrote in message
    news:...
    >I have a canon i9900 and am trying to print sRGB .jpgs onto red river
    > satin paper via photoshop 7. Problem is I get a magenta cast when
    > trying to use ICC profiles.


    I have been following this thread+responses. It does sound like you
    are doing everything correctly. Have you successfully printed on any
    media other than the red river satin? Note that at least one poster
    had similar persistent color cast problems on an i9900 but a
    replacement was OK.

    This pdf pretty much sums up how to set CM with a Canon printer:
    http://www.qualiteitems.com/canon.pdf

    And just a sanity check: for sure in the printer driver all Effects
    are disabled?

    If I had this problem, I would probably try reinstalling the printer
    driver, rebooting between uninstall/reinstall.
     
    Markeau, Oct 18, 2005
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. nobody nowhere

    Epson printer 1280/1290, is there a red/magenta cast?

    nobody nowhere, Jul 30, 2003, in forum: Digital Photography
    Replies:
    2
    Views:
    571
    nobody nowhere
    Jul 30, 2003
  2. Ed

    Epson 2000P - yellow printing cast on borders

    Ed, Sep 24, 2003, in forum: Digital Photography
    Replies:
    0
    Views:
    347
  3. Stacey

    Fix for magneta cast with i9900

    Stacey, Feb 12, 2005, in forum: Digital Photography
    Replies:
    14
    Views:
    510
    Brian C. Baird
    Feb 14, 2005
  4. RichA
    Replies:
    19
    Views:
    605
    John Turco
    Aug 14, 2007
  5. Wally

    Strong magenta cast in Lightroom

    Wally, Jan 20, 2011, in forum: Digital Photography
    Replies:
    12
    Views:
    1,433
    otter
    Feb 24, 2011
Loading...

Share This Page