Prevent Firefox from reloading a page ?

Discussion in 'Firefox' started by Ron Duval, Jan 11, 2005.

  1. Ron Duval

    Ron Duval Guest

    I surf offline with Firefox 1.0.

    On the site www.boursier.com (french language), I click say on 2 or 3 lines
    in the middle of the screen to see the stock exchange news. Then I
    disconnect.
    After approximately 5 mn, the pages try to reload themselves automatically,
    which leads to the xul error page saying it is impossible to establish the
    connection.

    Is there anyway to block this behaviour? I tried to block javascripts,
    tweaked about:config with cache frequency checking, or all the timeout
    parameters. Nothing did it.

    It happened with Opera, too, but Opera just showed a dialog box and did not
    empty the pages. With Firefox, I have to reconnect and reload every 5 mn,
    which is very inconvenient.
    Ron Duval, Jan 11, 2005
    #1
    1. Advertising

  2. Ron Duval

    MLC Guest

    _Ron Duval_, martedì 11/gen/2005:

    > I surf offline with Firefox 1.0.
    >
    > On the site www.boursier.com (french language), I click say on 2 or 3 lines
    > in the middle of the screen to see the stock exchange news. Then I
    > disconnect.
    > After approximately 5 mn, the pages try to reload themselves automatically,
    > which leads to the xul error page saying it is impossible to establish the
    > connection.
    >
    > Is there anyway to block this behaviour? I tried to block javascripts,
    > tweaked about:config with cache frequency checking, or all the timeout
    > parameters. Nothing did it.
    >
    > It happened with Opera, too, but Opera just showed a dialog box and did not
    > empty the pages. With Firefox, I have to reconnect and reload every 5 mn,
    > which is very inconvenient.


    Did you try to set Firefox offline?
    File - Work Offline
    I think this should prevent FF from trying to refresh the page.

    Then, if you get bored to have to use the menu everytime, there is an
    extension to show a button on the status bar to connect/disconnect:
    "Work Offline"
    http://multi.nadenade.com/leafy/Mozilla/Offline/
    --
    Maria Luisa C - 11/01/2005 18.04.52
    MLC, Jan 11, 2005
    #2
    1. Advertising

  3. Ron Duval

    Ron Duval Guest

    MLC <> wrote in news:9iudjem8trh6$:

    > http://multi.nadenade.com/leafy/Mozilla/Offline/


    It seems to work, but ... not really!

    If you switch to offline, FF stops refreshing pages, which is OK. However,
    if you need to view a new page (clicking a link for instance from outlook
    express), you need to connect even for a short time, and then the frozen
    pages try to refresh again. However, they never get displayed again and FF
    keeps running. All you get are the error pages with "Connection Failure
    Error". And you can't get the pages back from the cache.

    I can't find the solution. Is there any timeout parameter that I could
    increase anywhere ? Is there a way to get the pages back from the cache ?
    Or is there a way to definitely block this reloading mechanisn as soon as a
    page is displayed ?
    Ron Duval, Jan 11, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. RodneyK

    Firefox keeps reloading web pages.

    RodneyK, Mar 9, 2006, in forum: Firefox
    Replies:
    9
    Views:
    19,906
    SkyKing
    Nov 12, 2007
  2. Aspersion
    Replies:
    8
    Views:
    850
    Bob Barrows
    Aug 11, 2003
  3. cuppa-t

    Page Reloading/Refreshing bug???

    cuppa-t, Jan 28, 2008, in forum: Computer Support
    Replies:
    10
    Views:
    812
    chuckcar
    Feb 2, 2008
  4. John Doe
    Replies:
    1
    Views:
    964
    Peter Potamus the Purple Hippo
    Jul 1, 2009
  5. Replies:
    2
    Views:
    699
Loading...

Share This Page