pppoe on 802.1q with cos

Discussion in 'Cisco' started by jbaudet@gmail.com, Mar 11, 2013.

  1. Guest

    Hi,

    I search a configuration for a CPE (cisco 800 or 1700 or 1800).

    I have tu use an Ethernet port (not the ATM interface, I have a modem).
    I have to tag all my packet with a vlan ID (ID 2900 so ISL not working) in 802.1q
    I have to tag all my packet witch CoS (at 2 or 4).

    The configuration work if I have the pppoe-client on my interface directly but it's not tagged in 802.1q and my provider need it.

    Do you have some other configuration for that ?

    The relevant configuration :

    !
    interface FastEthernet0/0
    no ip address
    speed 100
    full-duplex
    pppoe-client dial-pool-number 1
    !
    !
    interface Dialer0
    description PPPoE to ISP
    mtu 1492
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat outside
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    dialer idle-timeout 270
    dialer-group 1
    keepalive 5 2
    ppp authentication pap chap callin
    ppp chap hostname loing@realm
    ppp chap password xxxxx
    ppp ipcp address accept
    !
    ip route 0.0.0.0 0.0.0.0 Dialer0


    What I need is somthing like :

    interface FastEthernet0/0.2900
    no ip address
    encapsulation dot1Q 2900
    pppoe-client dial-pool-number 1
    !

    but pppoe-client is not supported on subinterface.

    Thanks,
    , Mar 11, 2013
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Oli
    Replies:
    3
    Views:
    838
  2. Tony Warburton

    difference between 802.3b and 802.11b

    Tony Warburton, Nov 25, 2004, in forum: Wireless Networking
    Replies:
    2
    Views:
    3,530
    =?Utf-8?B?UGF2ZWwgQS4=?=
    Nov 25, 2004
  3. John Nordien
    Replies:
    0
    Views:
    3,335
    John Nordien
    Nov 22, 2004
  4. Wizard

    Tagging TOS to 802.1P COS

    Wizard, Mar 18, 2008, in forum: Cisco
    Replies:
    0
    Views:
    645
    Wizard
    Mar 18, 2008
  5. lga775
    Replies:
    1
    Views:
    2,132
    araishee
    Feb 18, 2010
Loading...

Share This Page