port rate limit on 3750

Discussion in 'Cisco' started by Morph, Nov 19, 2007.

  1. Morph

    Morph Guest

    Can a cisco 3750 (regular or Metro) switch be used to specify the speed
    for each sepparate port.
    If yes where can I find more information regarding the configuration.

    The idea is to limit the internet access speed for several customers
    each connected to a different port on the 3750.

    Is there any cheaper switch then the 3750 that can do that?

    Regards.
    Morph, Nov 19, 2007
    #1
    1. Advertising

  2. Morph

    Trendkill Guest

    On Nov 19, 3:42 pm, Morph <> wrote:
    > Can a cisco 3750 (regular or Metro) switch be used to specify the speed
    > for each sepparate port.
    > If yes where can I find more information regarding the configuration.
    >
    > The idea is to limit the internet access speed for several customers
    > each connected to a different port on the 3750.
    >
    > Is there any cheaper switch then the 3750 that can do that?
    >
    > Regards.


    Someone feel free to correct me where I am wrong, but switches like
    this do not limit ports at an individual basis. You can put on an
    ACL, or use QoS to place the traffic from that port in a particular
    bucket, and then use your core, WAN or internet routers to limit the
    traffic based on the ACL or marking (or a CAR statement), but I am not
    aware of a configuration command that will allow you to do that on a
    port with one command. I have not tinkered with 3570s, so perhaps
    someone else can clarify.
    Trendkill, Nov 20, 2007
    #2
    1. Advertising

  3. Morph

    Trendkill Guest

    On Nov 20, 6:55 am, Trendkill <> wrote:
    > On Nov 19, 3:42 pm, Morph <> wrote:
    >
    > > Can a cisco 3750 (regular or Metro) switch be used to specify the speed
    > > for each sepparate port.
    > > If yes where can I find more information regarding the configuration.

    >
    > > The idea is to limit the internet access speed for several customers
    > > each connected to a different port on the 3750.

    >
    > > Is there any cheaper switch then the 3750 that can do that?

    >
    > > Regards.

    >
    > Someone feel free to correct me where I am wrong, but switches like
    > this do not limit ports at an individual basis. You can put on an
    > ACL, or use QoS to place the traffic from that port in a particular
    > bucket, and then use your core, WAN or internet routers to limit the
    > traffic based on the ACL or marking (or a CAR statement), but I am not
    > aware of a configuration command that will allow you to do that on a
    > port with one command. I have not tinkered with 3570s, so perhaps
    > someone else can clarify.


    Here is a great thread from another board, that has links and a good
    discussion:

    http://www.gossamer-threads.com/lists/cisco/nsp/75464
    Trendkill, Nov 20, 2007
    #3
  4. Morph

    Jeremy270 Guest

    On Nov 20, 6:56 am, Trendkill <> wrote:
    > On Nov 20, 6:55 am, Trendkill <> wrote:
    >
    >
    >
    >
    >
    > > On Nov 19, 3:42 pm, Morph <> wrote:

    >
    > > > Can a cisco 3750 (regular or Metro) switch be used to specify the speed
    > > > for each sepparate port.
    > > > If yes where can I find more information regarding the configuration.

    >
    > > > The idea is to limit the internet access speed for several customers
    > > > each connected to a different port on the 3750.

    >
    > > > Is there any cheaper switch then the 3750 that can do that?

    >
    > > > Regards.

    >
    > > Someone feel free to correct me where I am wrong, but switches like
    > > this do not limit ports at an individual basis. You can put on an
    > > ACL, or use QoS to place the traffic from that port in a particular
    > > bucket, and then use your core, WAN or internet routers to limit the
    > > traffic based on the ACL or marking (or a CAR statement), but I am not
    > > aware of a configuration command that will allow you to do that on a
    > > port with one command. I have not tinkered with 3570s, so perhaps
    > > someone else can clarify.

    >
    > Here is a great thread from another board, that has links and a good
    > discussion:
    >
    > http://www.gossamer-threads.com/lists/cisco/nsp/75464- Hide quoted text -
    >
    > - Show quoted text -



    --------------------------------------------------------------------------------------
    This is on a 3550 Switch that we use to rate-limit multiple
    customers. Now you can turn on MLS QOS and configure individual
    customers as well. Either way you will need to test the throughput to
    make sure you have the right burst setting.


    class-map match-all internet-to-CustA
    match access-group name internet-to-CustA

    class-map match-all CustA-to-internet
    match access-group name CustA-to-internet

    class-map match-all internet-to-CustB
    match access-group name internet-to-CustB

    class-map match-all CustB-to-internet
    match access-group name CustB-to-internet
    !
    !
    policy-map CPEs-to-internet
    class CustB-to-internet
    police 6144000 1152000 exceed-action drop
    class CustA-to-internet
    police 3072000 576000 exceed-action drop

    policy-map internet-to-CPEs
    class internet-to-CustB
    police 6144000 1152000 exceed-action drop
    class internet-to-CustA
    police 3072000 576000 exceed-action drop




    interface GigabitEthernet0/1
    description Core Network
    switchport trunk encapsulation dot1q
    switchport mode trunk
    no ip address
    service-policy input CPEs-to-internet


    interface GigabitEthernet0/2
    description TO-> CustB Network
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 711-720
    switchport mode trunk
    no ip address
    service-policy input internet-to-CPEs
    no cdp enable


    ip access-list extended CustA-to-internet
    remark Match Traffic destined for CustA
    permit ip any 207.x.x.x 0.0.0.31
    ip access-list extended CustB-to-internet
    remark Match Traffic destined for CustB
    permit ip any 207.x.x.0 0.0.0.255
    ip access-list extended internet-to-CustA
    remark Match traffic sourcing from interCPEs
    permit ip 207.x.x.x 0.0.0.31 any
    ip access-list extended internet-to-CustB
    remark Match traffic sourcing from interCPEs
    permit ip 207.x.x.0 0.0.0.255 any


    -Jeremy
    ---------------------------------------------------------------------------------------------
    Jeremy270, Nov 20, 2007
    #4
  5. Morph

    Trendkill Guest

    On Nov 20, 10:54 am, Jeremy270 <> wrote:
    > On Nov 20, 6:56 am, Trendkill <> wrote:
    >
    >
    >
    > > On Nov 20, 6:55 am, Trendkill <> wrote:

    >
    > > > On Nov 19, 3:42 pm, Morph <> wrote:

    >
    > > > > Can a cisco 3750 (regular or Metro) switch be used to specify the speed
    > > > > for each sepparate port.
    > > > > If yes where can I find more information regarding the configuration.

    >
    > > > > The idea is to limit the internet access speed for several customers
    > > > > each connected to a different port on the 3750.

    >
    > > > > Is there any cheaper switch then the 3750 that can do that?

    >
    > > > > Regards.

    >
    > > > Someone feel free to correct me where I am wrong, but switches like
    > > > this do not limit ports at an individual basis. You can put on an
    > > > ACL, or use QoS to place the traffic from that port in a particular
    > > > bucket, and then use your core, WAN or internet routers to limit the
    > > > traffic based on the ACL or marking (or a CAR statement), but I am not
    > > > aware of a configuration command that will allow you to do that on a
    > > > port with one command. I have not tinkered with 3570s, so perhaps
    > > > someone else can clarify.

    >
    > > Here is a great thread from another board, that has links and a good
    > > discussion:

    >
    > >http://www.gossamer-threads.com/lists/cisco/nsp/75464-Hide quoted text -

    >
    > > - Show quoted text -

    >
    > --------------------------------------------------------------------------------------
    > This is on a 3550 Switch that we use to rate-limit multiple
    > customers. Now you can turn on MLS QOS and configure individual
    > customers as well. Either way you will need to test the throughput to
    > make sure you have the right burst setting.
    >
    > class-map match-all internet-to-CustA
    > match access-group name internet-to-CustA
    >
    > class-map match-all CustA-to-internet
    > match access-group name CustA-to-internet
    >
    > class-map match-all internet-to-CustB
    > match access-group name internet-to-CustB
    >
    > class-map match-all CustB-to-internet
    > match access-group name CustB-to-internet
    > !
    > !
    > policy-map CPEs-to-internet
    > class CustB-to-internet
    > police 6144000 1152000 exceed-action drop
    > class CustA-to-internet
    > police 3072000 576000 exceed-action drop
    >
    > policy-map internet-to-CPEs
    > class internet-to-CustB
    > police 6144000 1152000 exceed-action drop
    > class internet-to-CustA
    > police 3072000 576000 exceed-action drop
    >
    > interface GigabitEthernet0/1
    > description Core Network
    > switchport trunk encapsulation dot1q
    > switchport mode trunk
    > no ip address
    > service-policy input CPEs-to-internet
    >
    > interface GigabitEthernet0/2
    > description TO-> CustB Network
    > switchport trunk encapsulation dot1q
    > switchport trunk allowed vlan 711-720
    > switchport mode trunk
    > no ip address
    > service-policy input internet-to-CPEs
    > no cdp enable
    >
    > ip access-list extended CustA-to-internet
    > remark Match Traffic destined for CustA
    > permit ip any 207.x.x.x 0.0.0.31
    > ip access-list extended CustB-to-internet
    > remark Match Traffic destined for CustB
    > permit ip any 207.x.x.0 0.0.0.255
    > ip access-list extended internet-to-CustA
    > remark Match traffic sourcing from interCPEs
    > permit ip 207.x.x.x 0.0.0.31 any
    > ip access-list extended internet-to-CustB
    > remark Match traffic sourcing from interCPEs
    > permit ip 207.x.x.0 0.0.0.255 any
    >
    > -Jeremy
    > ---------------------------------------------------------------------------------------------


    Yes, since the 3750 is a layer 3 switch, you can do the marking and
    limiting on the same device. Thanks for the example Jeremy.
    Trendkill, Nov 20, 2007
    #5
  6. Morph

    stephen Guest

    "Trendkill" <> wrote in message
    news:...
    > On Nov 20, 6:55 am, Trendkill <> wrote:
    > > On Nov 19, 3:42 pm, Morph <> wrote:
    > >
    > > > Can a cisco 3750 (regular or Metro) switch be used to specify the

    speed
    > > > for each sepparate port.
    > > > If yes where can I find more information regarding the configuration.

    > >
    > > > The idea is to limit the internet access speed for several customers
    > > > each connected to a different port on the 3750.

    > >
    > > > Is there any cheaper switch then the 3750 that can do that?

    > >
    > > > Regards.

    > >
    > > Someone feel free to correct me where I am wrong, but switches like
    > > this do not limit ports at an individual basis. You can put on an
    > > ACL, or use QoS to place the traffic from that port in a particular
    > > bucket, and then use your core, WAN or internet routers to limit the
    > > traffic based on the ACL or marking (or a CAR statement), but I am not
    > > aware of a configuration command that will allow you to do that on a
    > > port with one command. I have not tinkered with 3570s, so perhaps
    > > someone else can clarify.

    >
    > Here is a great thread from another board, that has links and a good
    > discussion:
    >
    > http://www.gossamer-threads.com/lists/cisco/nsp/75464


    you need to check about whether this is traffic into the switch from the
    customer port, or going out to them (for consumers you usually worry over
    traffic to them, but a hosting centre probably cares about traffic from
    servers into the switch).

    3560 / 3750 only police on inbound traffic.

    there is an interface command to limit bandwidth on outbound interface to a
    % of link speed that may do what you want.
    srr-queue bandwidth limit <number> - this is a number between 10 and 90%.

    AFAIR this only affects outbound, but may do inbound as well.

    if you need QoS it still works when you use the limit command - which is
    much better than other switches i have tried to do similar things on.
    Note the switch uses a complicated qos model and the various mls qos are
    different to most other cisco boxes.
    i found i couldnt use the priority Q if i wanted to limit total real time
    traffic on an interface....

    --
    Regards

    - replace xyz with ntl
    stephen, Nov 21, 2007
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Alireza Dabagh [MS]

    3750 G 24TS vs. 3750 G 12S

    Alireza Dabagh [MS], Sep 28, 2004, in forum: Cisco
    Replies:
    4
    Views:
    2,477
    Alireza Dabagh [MS]
    Sep 29, 2004
  2. Nazgulero

    CAR/Rate Limit support on 3550/3750

    Nazgulero, May 2, 2005, in forum: Cisco
    Replies:
    1
    Views:
    3,118
    Mr Ping
    May 2, 2005
  3. Kanagaraj Krishna

    Re: Cisco 3750 egress rate-limit

    Kanagaraj Krishna, Sep 27, 2005, in forum: Cisco
    Replies:
    2
    Views:
    11,106
    schavez
    Feb 14, 2008
  4. Paolo
    Replies:
    0
    Views:
    629
    Paolo
    May 6, 2008
  5. 3560 Limit rate port

    , Apr 22, 2010, in forum: Cisco
    Replies:
    5
    Views:
    3,764
    bod43
    Apr 27, 2010
Loading...

Share This Page