Port forwarding on Cisco 1800 series - Help

Discussion in 'Cisco' started by Tom, Aug 8, 2010.

  1. Tom

    Tom Guest

    Can someone help explain how I can forward ports, such as 80, from a
    public DHCP address, to an Internal LAN address?

    Because my public IP changes often I'm not sure how I can NAT that to
    an internal LAN ip such as 192.168.1.103 port 80.

    Currently my router is setup like so to NAT outside:

    ip nat inside source list 1 interface FastEthernet1 overload

    But not sure how I can take the DHCP assigned IP/port to an internal
    IP.

    Thanks?
     
    Tom, Aug 8, 2010
    #1
    1. Advertising

  2. Tom

    Morph Guest

    In the message
    <> Tom
    wrote:

    | Can someone help explain how I can forward ports, such as 80, from a
    | public DHCP address, to an Internal LAN address?
    |
    | Because my public IP changes often I'm not sure how I can NAT that to
    | an internal LAN ip such as 192.168.1.103 port 80.
    |
    | Currently my router is setup like so to NAT outside:
    |
    | ip nat inside source list 1 interface FastEthernet1 overload
    |
    | But not sure how I can take the DHCP assigned IP/port to an internal
    | IP.

    ip nat inside source static tcp 192.168.1.103 80 interface FastEthernet1
    80 extendable
     
    Morph, Aug 8, 2010
    #2
    1. Advertising

  3. Tom

    Tom Guest

    On Aug 8, 3:08 am, Morph <> wrote:
    > In the message
    > <> Tom
    > wrote:
    >
    > | Can someone help explain how I can forward ports, such as 80, from a
    > | public DHCP address, to an Internal LAN address?
    > |
    > | Because my public IP changes often I'm not sure how I can NAT that to
    > | an internal LAN ip such as 192.168.1.103 port 80.
    > |
    > | Currently my router is setup like so to NAT outside:
    > |
    > | ip nat inside source list 1 interface FastEthernet1 overload
    > |
    > | But not sure how I can take the DHCP assigned IP/port to an internal
    > | IP.
    >
    > ip nat inside source static tcp 192.168.1.103 80 interface FastEthernet1
    > 80 extendable


    Thanks for quick reply, but...seems extendable is seen as invalid
    input. Maybe IOS?

    Thor(config)#ip nat inside source static tcp 192.168.1.103 80 int f1
    80 ?
    <cr>

    Thor(config)#$de source static tcp 192.168.1.103 80 int f1 80
    ext ?
    % Unrecognized command
    ip nat inside source static tcp 192.168.1.103 80 int f1 80 extendable

    ^
    12.3(8r)YH12 release fc1
     
    Tom, Aug 8, 2010
    #3
  4. Tom

    Tom Guest

    On Aug 8, 8:21 am, Tom <> wrote:
    > On Aug 8, 3:08 am, Morph <> wrote:
    >
    >
    >
    > > In the message
    > > <> Tom
    > > wrote:

    >
    > > | Can someone help explain how I can forward ports, such as 80, from a
    > > | public DHCP address, to an Internal LAN address?
    > > |
    > > | Because my public IP changes often I'm not sure how I can NAT that to
    > > | an internal LAN ip such as 192.168.1.103 port 80.
    > > |
    > > | Currently my router is setup like so to NAT outside:
    > > |
    > > | ip nat inside source list 1 interface FastEthernet1 overload
    > > |
    > > | But not sure how I can take the DHCP assigned IP/port to an internal
    > > | IP.

    >
    > > ip nat inside source static tcp 192.168.1.103 80 interface FastEthernet1
    > > 80 extendable

    >
    > Thanks for quick reply, but...seems extendable is seen as invalid
    > input.  Maybe IOS?
    >
    > Thor(config)#ip nat inside source static tcp 192.168.1.103 80 int f1
    > 80 ?
    >   <cr>
    >
    > Thor(config)#$de source static tcp 192.168.1.103 80 int f1 80
    > ext ?
    > % Unrecognized command
    > ip nat inside source static tcp 192.168.1.103 80 int f1 80 extendable
    >
    > ^
    > 12.3(8r)YH12 release fc1


    Not sure what's up, but under initial config I was able to enter the
    line with extendable, however after finalizing my config that last arg
    was no longer available, so appear that something in my config is
    changing so that I can not use this line?

    Would it be due to using DHCP or maybe my config to NAT outside for my
    LAN?

    It's odd that it was available at first then as I was ready to enter
    the line after initial config that it was no longer available.
     
    Tom, Aug 8, 2010
    #4
  5. Tom

    Tom Guest

    On Aug 8, 11:36 am, Tom <> wrote:
    > On Aug 8, 8:21 am, Tom <> wrote:
    >
    >
    >
    > > On Aug 8, 3:08 am, Morph <> wrote:

    >
    > > > In the message
    > > > <> Tom
    > > > wrote:

    >
    > > > | Can someone help explain how I can forward ports, such as 80, from a
    > > > | public DHCP address, to an Internal LAN address?
    > > > |
    > > > | Because my public IP changes often I'm not sure how I can NAT that to
    > > > | an internal LAN ip such as 192.168.1.103 port 80.
    > > > |
    > > > | Currently my router is setup like so to NAT outside:
    > > > |
    > > > | ip nat inside source list 1 interface FastEthernet1 overload
    > > > |
    > > > | But not sure how I can take the DHCP assigned IP/port to an internal
    > > > | IP.

    >
    > > > ip nat inside source static tcp 192.168.1.103 80 interface FastEthernet1
    > > > 80 extendable

    >
    > > Thanks for quick reply, but...seems extendable is seen as invalid
    > > input.  Maybe IOS?

    >
    > > Thor(config)#ip nat inside source static tcp 192.168.1.103 80 int f1
    > > 80 ?
    > >   <cr>

    >
    > > Thor(config)#$de source static tcp 192.168.1.103 80 int f1 80
    > > ext ?
    > > % Unrecognized command
    > > ip nat inside source static tcp 192.168.1.103 80 int f1 80 extendable

    >
    > > ^
    > > 12.3(8r)YH12 release fc1

    >
    > Not sure what's up, but under initial config I was able to enter the
    > line with extendable, however after finalizing my config that last arg
    > was no longer available, so appear that something in my config is
    > changing so that I can not use this line?
    >
    > Would it be due to using DHCP or maybe my config to NAT outside for my
    > LAN?
    >
    > It's odd that it was available at first then as I was ready to enter
    > the line after initial config that it was no longer available.


    I'm beginning to think this syntax is not correct:

    ip nat inside source static tcp 192.168.1.103 80 interface
    FastEthernet1
    80 extendable

    Any other suggestions ?

    Thanks.
     
    Tom, Aug 8, 2010
    #5
  6. Tom

    Rob Guest

    Tom <> wrote:
    > I'm beginning to think this syntax is not correct:
    >
    > ip nat inside source static tcp 192.168.1.103 80 interface
    > FastEthernet1
    > 80 extendable
    >
    > Any other suggestions ?


    I think it should be "overload" instead of "extendable".
     
    Rob, Aug 8, 2010
    #6
  7. Tom

    Tom Guest

    On Aug 8, 1:31 pm, Rob <> wrote:
    > Tom <> wrote:
    > > I'm beginning to think this syntax is not correct:

    >
    > > ip nat inside source static tcp 192.168.1.103 80 interface
    > > FastEthernet1
    > > 80 extendable

    >
    > > Any other suggestions ?

    >
    > I think it should be "overload" instead of "extendable".


    Nope...will not take any args after the port number. The help "?"
    shows <cr> as the last option in this case.

    Is very odd, because seems should be such a simple thing to do.
     
    Tom, Aug 8, 2010
    #7
  8. Tom

    Rob Guest

    Tom <> wrote:
    > On Aug 8, 1:31 pm, Rob <> wrote:
    >> Tom <> wrote:
    >> > I'm beginning to think this syntax is not correct:

    >>
    >> > ip nat inside source static tcp 192.168.1.103 80 interface
    >> > FastEthernet1
    >> > 80 extendable

    >>
    >> > Any other suggestions ?

    >>
    >> I think it should be "overload" instead of "extendable".

    >
    > Nope...will not take any args after the port number. The help "?"
    > shows <cr> as the last option in this case.
    >
    > Is very odd, because seems should be such a simple thing to do.


    And it does not work?
     
    Rob, Aug 8, 2010
    #8
  9. Tom

    Tom Guest

    On Aug 8, 3:14 pm, Rob <> wrote:
    > Tom <> wrote:
    > > On Aug 8, 1:31 pm, Rob <> wrote:
    > >> Tom <> wrote:
    > >> > I'm beginning to think this syntax is not correct:

    >
    > >> > ip nat inside source static tcp 192.168.1.103 80 interface
    > >> > FastEthernet1
    > >> > 80 extendable

    >
    > >> > Any other suggestions ?

    >
    > >> I think it should be "overload" instead of "extendable".

    >
    > > Nope...will not take any args after the port number.  The help "?"
    > > shows <cr> as the last option in this case.

    >
    > > Is very odd, because seems should be such a simple thing to do.

    >
    > And it does not work?


    Nope...does not work. So will take the command without the last arg,
    but just does not work.
    I can enter the command with the extendable arg if I use the external
    IP address vs the interface, however that won't work because my
    external (public) IP is assigned via DHCP.

    Seems so close, but so far:(
     
    Tom, Aug 8, 2010
    #9
  10. Tom

    Tom Guest

    On Aug 8, 3:14 pm, Rob <> wrote:
    > Tom <> wrote:
    > > On Aug 8, 1:31 pm, Rob <> wrote:
    > >> Tom <> wrote:
    > >> > I'm beginning to think this syntax is not correct:

    >
    > >> > ip nat inside source static tcp 192.168.1.103 80 interface
    > >> > FastEthernet1
    > >> > 80 extendable

    >
    > >> > Any other suggestions ?

    >
    > >> I think it should be "overload" instead of "extendable".

    >
    > > Nope...will not take any args after the port number.  The help "?"
    > > shows <cr> as the last option in this case.

    >
    > > Is very odd, because seems should be such a simple thing to do.

    >
    > And it does not work?


    This works:

    ip nat inside source static tcp 192.168.1.103 22 68.204.221.132 22
    extendable

    But obviously that won't do because the IP will change. Using DDNS to
    always get to my internal IP.
     
    Tom, Aug 8, 2010
    #10
  11. Tom

    Tom Guest

    On Aug 8, 3:59 pm, Tom <> wrote:
    > On Aug 8, 3:14 pm, Rob <> wrote:
    >
    >
    >
    > > Tom <> wrote:
    > > > On Aug 8, 1:31 pm, Rob <> wrote:
    > > >> Tom <> wrote:
    > > >> > I'm beginning to think this syntax is not correct:

    >
    > > >> > ip nat inside source static tcp 192.168.1.103 80 interface
    > > >> > FastEthernet1
    > > >> > 80 extendable

    >
    > > >> > Any other suggestions ?

    >
    > > >> I think it should be "overload" instead of "extendable".

    >
    > > > Nope...will not take any args after the port number.  The help "?"
    > > > shows <cr> as the last option in this case.

    >
    > > > Is very odd, because seems should be such a simple thing to do.

    >
    > > And it does not work?

    >
    > This works:
    >
    > ip nat inside source static tcp 192.168.1.103 22 68.204.221.132 22
    > extendable
    >
    > But obviously that won't do because the IP will change.  Using DDNS to
    > always get to my internal IP.


    Ouch! I didn't notice that my DDNS was not working...

    Turns out this does work:

    ip nat inside source static tcp 192.168.1.103 22 interface Ethernet0
    22

    My DDNS name was not being updated for some reason and IP had changed.

    Thanks for all the feedback!

    ....walks away red faced....
     
    Tom, Aug 8, 2010
    #11
  12. Tom

    Morph Guest

    In the message
    <> Tom
    wrote:

    | > ip nat inside source static tcp 192.168.1.103 80 interface FastEthernet1
    | > 80 extendable
    |
    | Thanks for quick reply, but...seems extendable is seen as invalid
    | input. Maybe IOS?

    Try without the extendable command. It should work.
     
    Morph, Aug 8, 2010
    #12
  13. Tom

    Tom Guest

    On Aug 8, 4:20 pm, Morph <> wrote:
    > In the message
    > <> Tom
    > wrote:
    >
    > | > ip nat inside source static tcp 192.168.1.103 80 interface FastEthernet1
    > | > 80 extendable
    > |
    > | Thanks for quick reply, but...seems extendable is seen as invalid
    > | input.  Maybe IOS?
    >
    > Try without the extendable command. It should work.


    Thanks...you are correct...worked without extendable:)
     
    Tom, Aug 8, 2010
    #13
  14. Tom

    bod43 Guest

    On 8 Aug, 21:37, Tom <> wrote:
    > On Aug 8, 4:20 pm, Morph <> wrote:
    >
    > > In the message
    > > <> Tom
    > > wrote:

    >
    > > | > ip nat inside source static tcp 192.168.1.103 80 interface FastEthernet1
    > > | > 80 extendable
    > > |
    > > | Thanks for quick reply, but...seems extendable is seen as invalid
    > > | input.  Maybe IOS?

    >
    > > Try without the extendable command. It should work.

    >
    > Thanks...you are correct...worked without extendable:)


    I never use "extendable" I read the documentation, failed
    to understand it at all and have never looked back:)

    It is in a lot of Cisco examples and lots of people do seem
    to put it in their NAT statements but I kind of like to
    know what is going on.
     
    bod43, Aug 9, 2010
    #14
  15. Tom

    Tom Guest

    On Aug 8, 7:43 pm, bod43 <> wrote:
    > On 8 Aug, 21:37, Tom <> wrote:
    >
    > > On Aug 8, 4:20 pm, Morph <> wrote:

    >
    > > > In the message
    > > > <> Tom
    > > > wrote:

    >
    > > > | > ip nat inside source static tcp192.168.1.103 80interface FastEthernet1
    > > > | > 80 extendable
    > > > |
    > > > | Thanks for quick reply, but...seems extendable is seen as invalid
    > > > | input.  Maybe IOS?

    >
    > > > Try without the extendable command. It should work.

    >
    > > Thanks...you are correct...worked without extendable:)

    >
    > I never use "extendable" I read the documentation, failed
    > to understand it at all and have never looked back:)
    >
    > It is in a lot of Cisco examples and lots of people do seem
    > to put it in their NAT statements but I kind of like to
    > know what is going on.


    I'll probably never use it either. I too tried to make sense of it,
    but just couldn't see why it is necessary. Seems fine without it:)
     
    Tom, Aug 9, 2010
    #15
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jon Jonsson

    Cisco 800 series port forwarding

    Jon Jonsson, Nov 12, 2003, in forum: Cisco
    Replies:
    4
    Views:
    14,230
    JShepherd
    Nov 14, 2003
  2. CompGuy
    Replies:
    11
    Views:
    130,111
    jhonny
    Sep 28, 2011
  3. Thomas Reinberger
    Replies:
    1
    Views:
    4,385
  4. alanwilson
    Replies:
    0
    Views:
    966
    alanwilson
    Oct 30, 2007
  5. Jason
    Replies:
    1
    Views:
    3,050
    Greeley
    Feb 19, 2008
Loading...

Share This Page