Port 21 (FTP) Open. How to close.

Discussion in 'Windows 64bit' started by Maj.BPudgeman, Jan 25, 2008.

  1. While testing my security at GRC.com (ShieldsUp) I find that port 21 shows
    open. I'd like to close it but can't figure out how. I have the firewall on
    and have tried both settings on the block all access option. I also have a
    Linksys router with firewall turned on.

    I also tried changing the registry entry for ....DisableStatefulFTP with no
    luck.

    Any thoughts would be appreciated.

    BTW My Vista is 64bit, Ultimate.

    Thanks
     
    Maj.BPudgeman, Jan 25, 2008
    #1
    1. Advertising

  2. Maj.BPudgeman

    Jason Gurtz Guest

    Maj.BPudgeman wrote:
    > While testing my security at GRC.com (ShieldsUp) I find that port 21 shows
    > open. I'd like to close it but can't figure out how. I have the firewall on
    > and have tried both settings on the block all access option. I also have a
    > Linksys router with firewall turned on.


    I believe that GRC service checks external ports which are open. This
    means check the settings on your router (maybe a static port mapping/DMZ
    setting?).

    "netstat -ano" at the cmd prompt will tell you the local ports that are
    open; look for ports in the "Listening" state. -o option give PID of
    prog that has the port open. You can add the PID column in task manager
    to see.

    ~JasonG

    --
     
    Jason Gurtz, Jan 25, 2008
    #2
    1. Advertising

  3. Maj.BPudgeman

    Jud Hendrix Guest

    On Fri, 25 Jan 2008 10:05:06 -0800, Maj.BPudgeman
    <> wrote:

    >While testing my security at GRC.com (ShieldsUp) I find that port 21 shows
    >open. I'd like to close it but can't figure out how.


    It's the FTP-port. Not sure if it is such a good idea to close it.

    jud
     
    Jud Hendrix, Jan 25, 2008
    #3
  4. Thanks. You put me on the right path to a solution. My new router has a
    storage link and apparently it uses port 21 for attached storage devices. I
    was able to block it and go back to stealth mode.

    Perhaps I'll have a problem if I do attach a drive, but I'll cross that
    bridge when it hatches.

    Anyone interested the setting is in the router management Storage/FTP
    Server/FTP Server = disable.

    Thanks agin.

    "Jason Gurtz" wrote:

    > Maj.BPudgeman wrote:
    > > While testing my security at GRC.com (ShieldsUp) I find that port 21 shows
    > > open. I'd like to close it but can't figure out how. I have the firewall on
    > > and have tried both settings on the block all access option. I also have a
    > > Linksys router with firewall turned on.

    >
    > I believe that GRC service checks external ports which are open. This
    > means check the settings on your router (maybe a static port mapping/DMZ
    > setting?).
    >
    > "netstat -ano" at the cmd prompt will tell you the local ports that are
    > open; look for ports in the "Listening" state. -o option give PID of
    > prog that has the port open. You can add the PID column in task manager
    > to see.
    >
    > ~JasonG
    >
    > --
    >
     
    Maj.BPudgeman, Jan 25, 2008
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    4
    Views:
    6,600
    Walter Roberson
    Mar 2, 2005
  2. syn_NOSPAM_uw

    FTP port open on Cisco 1841

    syn_NOSPAM_uw, Apr 11, 2006, in forum: Cisco
    Replies:
    3
    Views:
    4,898
  3. Neil Armstrong
    Replies:
    3
    Views:
    18,063
    Bill Sanderson
    Sep 18, 2003
  4. Frosty

    ftp://ftp.isc.org

    Frosty, Nov 22, 2006, in forum: Computer Support
    Replies:
    2
    Views:
    1,078
  5. Mike Easter

    Why can't I access ftp://ftp.isc.org/ ?

    Mike Easter, Mar 14, 2007, in forum: Computer Support
    Replies:
    10
    Views:
    871
    Vanguard
    Mar 15, 2007
Loading...

Share This Page