POPORT

Discussion in 'MCSE' started by kpg, Dec 2, 2004.

  1. kpg

    kpg Guest

    Since it's a slow day I'll empty out my box
    of annoying little questions:

    When I try to connect to my IIS 5 FTP site over my LAN I get

    200 ...
    500 'POPORT 192,168,1,1,19,138' Command not understood
    500 ...

    I sure the command should be 'PORT 192,...'

    This happens on several XP boxes (SP1 and SP2) when
    using IE6 and also intermittently when using WS FTP Pro.

    What is the deal????

    --
    kpg A+ MCP MCNGP 0x22
    It is impossible to defeat an ignorant man in argument. ~William G. McAdoo
     
    kpg, Dec 2, 2004
    #1
    1. Advertising

  2. kpg

    kpg Guest

    For those interested in my little problem:

    WINSOCK.DLL: WinSock 2.0
    WS_FTP Pro 6.01 99.01.29, Copyright © 1992-1999 Ipswitch, Inc.
    - -
    220 svr-003 Microsoft FTP Service (Version 5.0).
    USER anonymous
    331 Anonymous access allowed, send identity (e-mail name) as password.
    PASS (hidden)
    230-Welcome to My FTP
    230 Anonymous user logged in.
    PWD
    257 "/" is current directory.
    SYST
    215 Windows_NT version 5.0
    Host type (S): Microsoft NT
    PORT 192,168,1,139,4,242
    500 'POPORT 192,168,1,1,19,140': command not understood
    ! Failed "port":
    ! Retrieve of folder listing failed (0)
     
    kpg, Dec 2, 2004
    #2
    1. Advertising

  3. Mate, that can sometimes mean the command is too long, you're not trying to
    change to a very deep directory structure are you?

    Wayne McGlinn
    Brisbane, Oz

    "kpg" <> wrote in message
    news:...
    > For those interested in my little problem:
    >

    <snip>
    > 500 'POPORT 192,168,1,1,19,140': command not understood
    > ! Failed "port":
    > ! Retrieve of folder listing failed (0)
    >
     
    Wayne McGlinn, Dec 2, 2004
    #3
  4. kpg

    kpg Guest

    "Wayne McGlinn" <> wrote in message
    news:...
    > Mate, that can sometimes mean the command is too long, you're not trying
    > to
    > change to a very deep directory structure are you?
    >
    > Wayne McGlinn
    > Brisbane, Oz
    >


    No. Someone told me it may be a problem with the NAT router
    not translating the command correctly. I'm leaning toward that
    explanation. I did a firmware upgrade on that router about a year
    ago and it killed all FTP access, so I rolled it back.

    Lynksys BEFSR41
    firmware version: 1.42.3, Jan 28 2002

    kpg
     
    kpg, Dec 2, 2004
    #4
  5. Ok, have you tried passive ftp as opposed to active?
    I've also had issues in the past with Checkpoint firewalls not understanding
    the end-of-line character.
    From RFC959 (page 45)

    "The commands begin with a command code followed by an argument
    field. The command codes are four or fewer alphabetic characters.
    Upper and lower case alphabetic characters are to be treated
    identically. Thus, any of the following may represent the
    retrieve command:

    RETR Retr retr ReTr rETr

    This also applies to any symbols representing parameter values,
    such as A or a for ASCII TYPE. The command codes and the argument
    fields are separated by one or more spaces.

    The argument field consists of a variable length character string
    ending with the character sequence <CRLF> (Carriage Return, Line
    Feed) for NVT-ASCII representation; for other negotiated languages
    a different end of line character might be used. It should be
    noted that the server is to take no action until the end of line
    code is received."

    Wayne


    "kpg" <> wrote in message
    news:...
    > "Wayne McGlinn" <> wrote in message
    > news:...
    > > Mate, that can sometimes mean the command is too long, you're not trying
    > > to
    > > change to a very deep directory structure are you?
    > >
    > > Wayne McGlinn
    > > Brisbane, Oz
    > >

    >
    > No. Someone told me it may be a problem with the NAT router
    > not translating the command correctly. I'm leaning toward that
    > explanation. I did a firmware upgrade on that router about a year
    > ago and it killed all FTP access, so I rolled it back.
    >
    > Lynksys BEFSR41
    > firmware version: 1.42.3, Jan 28 2002
    >
    > kpg
    >
     
    Wayne McGlinn, Dec 3, 2004
    #5
  6. kpg

    kpg Guest

    > Ok, have you tried passive ftp as opposed to active?

    Yeah. Can't use Passive FTP because XP SP2 blocks it (?)

    That is, When the "use passive FTP" check box is checked in
    IE Tools/advanced then our API driven update software for our
    product does not connect after we upgraded to SP2. Unchecking
    the box (active FTP using the PORT command) solved the problem.

    This morning I reset to modem reconfigured some server IP
    address, installed some security updates and rebooted both
    servers and now it works.

    So all is well for now.

    Thanks.

    kp "i hate black boxing it" g
     
    kpg, Dec 3, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.

Share This Page