Poor performance with a 3640

Discussion in 'Cisco' started by insyte@gmail.com, Dec 1, 2006.

  1. Guest

    I have a 3640 with 3 FastEthernet interfaces and 128M of memory.

    Our primary ISP provides us with a 25Mb ethernet feed. If I bypass the
    router and plug a laptop directly into their switch, I can easily
    saturate the 25Mb link while downloading large test files from one of
    their servers. If I move my laptop to one of the interfaces on the
    router, I max out at around 200 kbps. In a lab environment (PC1 <->
    Fa0/0 <-> Fa1/0 <-> PC2) I can sometimes push that up to a full 1Mbps.

    I know the 3640 was designed to be able to handle a full DS3, so our
    25Mb + 8Mb links should be no problem. BGP isn't loading it down, as
    we get a default route from one ISP and a few ( 7, last time I checked
    ) local routes from the second.

    Basically this is a vanilla config of IOS 12.2(31). I enabled CEF,
    which seems to have improved things slightly.

    If I'm reading this correctly, we're not running low on memory:

    Border#sh mem sum
    Head Total(b) Used(b) Free(b) Lowest(b)
    Largest(b)
    Processor 61FC14C0 96725824 5888480 90837344 89298640
    89243144
    I/O 7C00000 4194312 2321752 1872560 1872560
    1872508

    What else should I be looking at? I can't believe this router is
    actually choking on our (relatively) minimal amount of throughput...

    Thanks!

    -Ben
     
    , Dec 1, 2006
    #1
    1. Advertising

  2. "" <> writes:
    >I have a 3640 with 3 FastEthernet interfaces and 128M of memory.


    >Our primary ISP provides us with a 25Mb ethernet feed. If I bypass the
    >router and plug a laptop directly into their switch, I can easily
    >saturate the 25Mb link while downloading large test files from one of
    >their servers. If I move my laptop to one of the interfaces on the
    >router, I max out at around 200 kbps. In a lab environment (PC1 <->
    >Fa0/0 <-> Fa1/0 <-> PC2) I can sometimes push that up to a full 1Mbps.



    Check your duplex settings on your FastE links. Match what the ISP is doing.

    Duplex mismatch can give pittiful throughput like this.

    Yes, the 3640 should easily be able to handle 20Mbps. I haven't pushed
    them much beyond that, but had no problems at that level.
     
    Doug McIntyre, Dec 1, 2006
    #2
    1. Advertising

  3. Guest


    > Check your duplex settings on your FastE links. Match what the ISP is doing.


    I have both interfaces set to 100-full. I'm pretty sure it's not a
    duplex issue, as I see the same problem when connecting directly to a
    pair of PCs. I will double-check with the ISPs, though.

    -Ben
     
    , Dec 1, 2006
    #3
  4. Guest

    wrote:
    > > Check your duplex settings on your FastE links. Match what the ISP is doing.

    >
    > I have both interfaces set to 100-full. I'm pretty sure it's not a
    > duplex issue, as I see the same problem when connecting directly to a
    > pair of PCs. I will double-check with the ISPs, though.


    Ideally reload router to clear out all counters and stats.

    Create the problem,

    During traffic forwarding gather:-

    sh proc cpu

    Afterwards gather

    sh int
    sh int switching
    sh int stats
    sh buff

    >From your description it is still most likely a duplex mismatch,

    this is not meant to be other than helpful, your description
    does not suggest that you understand what to do with
    duplex settings, There are many good posts on this
    group about it and I wont repeat here.

    In fact rather than the above you could just try
    all 4 possible combinations of full/auto on both interfaces.

    Dont bother with half or speed settings.
     
    , Dec 1, 2006
    #4
  5. wrote:

    >
    >> Check your duplex settings on your FastE links. Match what the ISP is
    >> doing.

    >
    > I have both interfaces set to 100-full. I'm pretty sure it's not a
    > duplex issue, as I see the same problem when connecting directly to a
    > pair of PCs. I will double-check with the ISPs, though.


    If you set one side to full duplex, you MUST set the other side (your PC or
    the switch of your ISP) too! If the other side does auto negotiation, it
    gets no answer to the negotiation request and must set to half duplex...

    greetings
    Mathias
     
    Mathias Mistrik, Dec 1, 2006
    #5
  6. Guest


    > From your description it is still most likely a duplex mismatch,


    And, of course, you (and Doug) were right. I actually do understand
    the implications of duplex mismatches, learned the hard way. But for
    some reason it's an ongoing blind spot for me... I frequently don't
    think to consider duplex until after beating my head against the wall
    for a few hours/days.

    In this case the first internal switch was set to 'auto' and was
    showing a ton of collisions. I moved it to 'full' and everything was
    goodness and light.

    This also explains the weird performance I saw with my lab tests, as
    the PCs were set to auto.

    Thanks...

    -Ben
     
    , Dec 1, 2006
    #6
  7. Peter Guest

    Hi Ben,

    > In this case the first internal switch was set to 'auto' and was
    > showing a ton of collisions. I moved it to 'full' and everything was
    > goodness and light.


    One golden rule that helps is -
    If one end of an Ethernet link is set to AUTO then the other end
    should also be AUTO.

    AUTO <> AUTO usually works fine, but it may require a BREAK/RECONNECT
    of the physical cable to ensure neotiation takes place correctly.

    AUTO <> MANUAL will ALWAYS fail, unless the MANUAL side is set to
    10/Half (the "default" fall-back for AUTO).

    Cheers..............pk.

    --
    Peter from Auckland.
     
    Peter, Dec 1, 2006
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jerry Bacon

    Poor outgoing performance

    Jerry Bacon, Feb 22, 2004, in forum: Cisco
    Replies:
    3
    Views:
    502
    Craig Johnson
    Feb 24, 2004
  2. hari
    Replies:
    2
    Views:
    660
    Dan Daniels
    Mar 28, 2005
  3. =?Utf-8?B?dW51c3VhbHBzeWNobw==?=

    Poor reception, poor connection, and dropped signal

    =?Utf-8?B?dW51c3VhbHBzeWNobw==?=, Jun 7, 2006, in forum: Wireless Networking
    Replies:
    2
    Views:
    3,849
    Doug Sherman [MVP]
    Jun 7, 2006
  4. Kevin M

    Poor Performance

    Kevin M, May 29, 2004, in forum: Computer Information
    Replies:
    16
    Views:
    788
    derek / nul
    May 30, 2004
  5. Rich

    Poor, poor P&S owner learns too late...

    Rich, May 13, 2009, in forum: Digital Photography
    Replies:
    66
    Views:
    1,883
    Bob Larter
    Jun 11, 2009
Loading...

Share This Page