Poor outgoing performance

Discussion in 'Cisco' started by Jerry Bacon, Feb 22, 2004.

  1. Jerry Bacon

    Jerry Bacon Guest

    I have a 3620 with two T1 point-to-point connections to Qwest with
    per-packet load sharing. My inbound performance is as expected (about
    3Mbits/sec), but the best I can get outbound is about 1Mbit/sec. Any
    suggestions? Here's the line config:

    interface Serial0/0
    bandwidth 1536
    ip address a.b.c.6 255.255.255.252
    ip access-group 101 in
    ip verify unicast reverse-path
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip load-sharing per-packet
    rate-limit input access-group 191 64000 6400 12800 conform-action transmit
    exceed-action drop
    no ip mroute-cache
    no cdp enable
    end

    (Yes - CEF is enabled. The rate limit is to prevent ICMP floods.)

    --
    Jerry B.

    "The optimist proclaims that we live in the best of all possible worlds, and
    the pessimist fears this is true." - James Cabell
    Jerry Bacon, Feb 22, 2004
    #1
    1. Advertising

  2. On Sun, 22 Feb 2004 07:44:21 -0800, "Jerry Bacon"
    <> wrote:

    >I have a 3620 with two T1 point-to-point connections to Qwest with
    >per-packet load sharing. My inbound performance is as expected (about
    >3Mbits/sec), but the best I can get outbound is about 1Mbit/sec. Any
    >suggestions? Here's the line config:


    What is the CPU usage when outbound bandwidth is being tested? I very
    much doubt the router is the issue here but it's worth checking.

    How are you testing outbound throughput, and how are you testing
    inbound?

    -Terry

    >interface Serial0/0
    > bandwidth 1536
    > ip address a.b.c.6 255.255.255.252
    > ip access-group 101 in
    > ip verify unicast reverse-path
    > no ip redirects
    > no ip unreachables
    > no ip proxy-arp
    > ip load-sharing per-packet
    > rate-limit input access-group 191 64000 6400 12800 conform-action transmit
    >exceed-action drop
    > no ip mroute-cache
    > no cdp enable
    >end
    >
    >(Yes - CEF is enabled. The rate limit is to prevent ICMP floods.)
    Terry Baranski, Feb 22, 2004
    #2
    1. Advertising

  3. Jerry Bacon

    Jerry Bacon Guest

    The router CPU utilization is 25-30% when the inbound traffic is 2.5-3M.
    I've done the tests at very low traffic times, so I'm quite certain that is
    not the problem.

    I've used various test tools, ftp and iperf in particular.

    --
    Jerry B.

    "The optimist proclaims that we live in the best of all possible worlds, and
    the pessimist fears this is true." - James Cabell

    "Terry Baranski" <0VE.com> wrote in message
    news:...
    >
    > What is the CPU usage when outbound bandwidth is being tested? I very
    > much doubt the router is the issue here but it's worth checking.
    >
    > How are you testing outbound throughput, and how are you testing
    > inbound?
    Jerry Bacon, Feb 23, 2004
    #3
  4. Try disabling weighted fair queueing with no fair-queue. Since you are load
    sharing per-packet, the router is probably having a hard time queueing the
    traffic going to different interfaces. This is why inbound performance is
    better; I doubt Qwest is doing any queueing. Note that you might not ever
    get to 3MB a second with a single FTP session, because the packets may
    arrive out of order. Give that a shot and retry your tests.

    Craig Johnson, CCIE #6965
    "Jerry Bacon" <> wrote in message
    news:4038ce4c@platinum....
    > I have a 3620 with two T1 point-to-point connections to Qwest with
    > per-packet load sharing. My inbound performance is as expected (about
    > 3Mbits/sec), but the best I can get outbound is about 1Mbit/sec. Any
    > suggestions? Here's the line config:
    >
    > interface Serial0/0
    > bandwidth 1536
    > ip address a.b.c.6 255.255.255.252
    > ip access-group 101 in
    > ip verify unicast reverse-path
    > no ip redirects
    > no ip unreachables
    > no ip proxy-arp
    > ip load-sharing per-packet
    > rate-limit input access-group 191 64000 6400 12800 conform-action

    transmit
    > exceed-action drop
    > no ip mroute-cache
    > no cdp enable
    > end
    >
    > (Yes - CEF is enabled. The rate limit is to prevent ICMP floods.)
    >
    > --
    > Jerry B.
    >
    > "The optimist proclaims that we live in the best of all possible worlds,

    and
    > the pessimist fears this is true." - James Cabell
    >
    >
    >
    Craig Johnson, Feb 24, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. hari
    Replies:
    2
    Views:
    653
    Dan Daniels
    Mar 28, 2005
  2. =?Utf-8?B?dW51c3VhbHBzeWNobw==?=

    Poor reception, poor connection, and dropped signal

    =?Utf-8?B?dW51c3VhbHBzeWNobw==?=, Jun 7, 2006, in forum: Wireless Networking
    Replies:
    2
    Views:
    3,821
    Doug Sherman [MVP]
    Jun 7, 2006
  3. Kevin M

    Poor Performance

    Kevin M, May 29, 2004, in forum: Computer Information
    Replies:
    16
    Views:
    780
    derek / nul
    May 30, 2004
  4. John Rennie

    Poor FTP performance with 837

    John Rennie, Oct 1, 2006, in forum: Cisco
    Replies:
    3
    Views:
    662
  5. Rich

    Poor, poor P&S owner learns too late...

    Rich, May 13, 2009, in forum: Digital Photography
    Replies:
    66
    Views:
    1,865
    Bob Larter
    Jun 11, 2009
Loading...

Share This Page