Point-to-point T1 with 2620XM and crossover cable

Discussion in 'Cisco' started by Chris, Apr 25, 2006.

  1. Chris

    Chris Guest

    I'm new to T1s, as I'm from a country where they don't exist. I'm
    trying to get a test network up between two 2620XMs with single-port T1
    CSU/DSU WICs, installed in slot0 of each router. Both 2620s are running
    IOS 12.2(34). Unfortunately, "sh int" reports that ser0/0 on each
    router is down, thus obviously I'm not getting a connection. I'm using
    a T1 crossover cable (wire 1>5, 2>4 I believe) and, when it's
    connected, the "AL" and "CD" lights on the WICs on each router are lit.

    Here are the configs:

    router1:
    !
    version 12.2
    !
    hostname test1
    !
    ip subnet-zero
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0
    ip address 192.168.0.1 255.255.0.0
    service-module t1 timeslots 1-24
    !
    ip classless
    no ip http server
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    end

    router2:
    !
    version 12.2
    !
    ip subnet-zero
    ip cef
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    speed auto
    half-duplex
    !
    interface Serial0/0
    ip address 192.168.1.1 255.255.0.0
    no fair-queue
    service-module t1 timeslots 1-24
    !
    ip classless
    ip http server
    !
    dialer-list 1 protocol ip permit
    !
    line con 0
    line aux 0
    line vty 0 4
    password ***
    login
    !
    end

    Here is the interface detail:

    router1:
    Serial0/0 is down, line protocol is down
    Hardware is PQUICC with Fractional T1 CSU/DSU
    Internet address is 192.168.0.1/16
    MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation HDLC, loopback not set
    Keepalive set (10 sec)
    Last input 00:24:04, output 00:24:06, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: weighted fair
    Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations 0/1/256 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 1152 kilobits/sec
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    4 packets input, 846 bytes, 0 no buffer
    Received 4 broadcasts, 0 runts, 1 giants, 0 throttles
    1 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    1 packets output, 24 bytes, 0 underruns
    0 output errors, 0 collisions, 48 interface resets
    0 output buffer failures, 0 output buffers swapped out
    2 carrier transitions
    DCD=down DSR=up DTR=up RTS=up CTS=down

    router2:
    Serial0/0 is down, line protocol is down
    Hardware is PQUICC with Fractional T1 CSU/DSU
    Internet address is 192.168.1.1/16
    MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec,
    reliability 252/255, txload 1/255, rxload 1/255
    Encapsulation HDLC, loopback not set
    Keepalive set (10 sec)
    Last input 00:24:36, output 00:24:33, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    1 packets input, 24 bytes, 0 no buffer
    Received 1 broadcasts, 0 runts, 0 giants, 0 throttles
    1628 input errors, 769 CRC, 825 frame, 0 overrun, 0 ignored, 33
    abort
    4 packets output, 846 bytes, 0 underruns
    0 output errors, 0 collisions, 53 interface resets
    0 output buffer failures, 0 output buffers swapped out
    2 carrier transitions
    DCD=down DSR=up DTR=up RTS=up CTS=down

    Any help would be greatly appreciated!

    TIA and HAND,


    Chris
    Chris, Apr 25, 2006
    #1
    1. Advertising

  2. Chris

    Merv Guest


    > I'm using > a T1 crossover cable (wire 1>5, 2>4 I believe) and, when it's
    > connected, the "AL" and "CD" lights on the WICs on each router are lit.


    T1 is a synchronous tramsmission facility and so the "circuit" has to
    be timed.
    On a real T1 the circuit would be timed by the carrier and the router's
    built in DSU would synch to networkk time. in a back to bak scenario
    you need to provide this timing.
    This is done by having one of the router clock your "ciurcuit"

    Use the "show controller t1" command to find out the controller
    designation on your router

    controller t1 <controller>
    clock source internal
    Merv, Apr 25, 2006
    #2
    1. Advertising

  3. Chris

    Chris Guest

    Merv wrote:
    > > I'm using > a T1 crossover cable (wire 1>5, 2>4 I believe) and, when it's
    > > connected, the "AL" and "CD" lights on the WICs on each router are lit.

    >
    > T1 is a synchronous tramsmission facility and so the "circuit" has to
    > be timed.
    > On a real T1 the circuit would be timed by the carrier and the router's
    > built in DSU would synch to networkk time. in a back to bak scenario
    > you need to provide this timing.
    > This is done by having one of the router clock your "ciurcuit"
    >
    > Use the "show controller t1" command to find out the controller
    > designation on your router
    >
    > controller t1 <controller>
    > clock source internal


    I knew that there had to be one clock source, and I entered that in the
    ser0/0 interface with the command "clock rate 56000". Strangely,
    though, it doesn't seem to show up in the output from "show running" or
    "show int ser0/0". I'm not sure why that is?

    I'm at home now so I can't run the command you mentioned just yet, but
    I'll run it tomorrow morning & post the results.

    TIA!
    Chris, Apr 25, 2006
    #3
  4. Chris

    Merv Guest

    The clock rate command is used when there is a V.35 interface but not
    when you have a bulit-in DSU
    Merv, Apr 25, 2006
    #4
  5. Chris

    Chris Guest

    Merv wrote:
    > The clock rate command is used when there is a V.35 interface but not
    > when you have a bulit-in DSU


    V.35 as in if I was really using a serial cable, right? But when I'm
    using a T1 crossover cable the router uses it's internal DSU?
    Chris, Apr 26, 2006
    #5
  6. Chris

    clubfoot Guest

    Also, a T1 crossover is 1->4 and 2->5.

    "Chris" <> wrote in message
    news:...
    > Merv wrote:
    >> The clock rate command is used when there is a V.35 interface but not
    >> when you have a bulit-in DSU

    >
    > V.35 as in if I was really using a serial cable, right? But when I'm
    > using a T1 crossover cable the router uses it's internal DSU?
    >
    clubfoot, Apr 26, 2006
    #6
  7. Chris

    Chris Guest

    Merv wrote:
    > > I'm using > a T1 crossover cable (wire 1>5, 2>4 I believe) and, when it's
    > > connected, the "AL" and "CD" lights on the WICs on each router are lit.

    >
    > T1 is a synchronous tramsmission facility and so the "circuit" has to
    > be timed.
    > On a real T1 the circuit would be timed by the carrier and the router's
    > built in DSU would synch to networkk time. in a back to bak scenario
    > you need to provide this timing.
    > This is done by having one of the router clock your "ciurcuit"
    >
    > Use the "show controller t1" command to find out the controller
    > designation on your router
    >
    > controller t1 <controller>
    > clock source internal


    "show controller t1" shows nothing on both routers, i.e. I run the
    command and it doesn't give me any output; and then returns to the
    enable prompt.

    Do I need the "service-module t1 clock source internal" command on one
    router, or both? I'm still having the same problems, AL and CD lights
    are illuminated on the WICs but Serial0/0 is still down on both routers.
    Chris, Apr 26, 2006
    #7
  8. Chris

    Merv Guest

    Internal clocking is just done on one router; other routerwill derive
    clock
    Merv, Apr 26, 2006
    #8
  9. Chris

    Chris Guest

    Merv wrote:
    > Internal clocking is just done on one router; other routerwill derive
    > clock


    I think I have it up and running now, thanks! I can ping Serial0/0 on
    each router from the other router, without Ethernet connections plugged
    in.

    Interestingly, "show controller T1" still does not give me any output...
    Chris, Apr 26, 2006
    #9
  10. "show controller t1" works with other integrated CSU/DSUs, like the
    VWICs. Use "show service-module s0/0" for yours.

    Also keep in mind that the default timeslot size for some T1
    controllers is 56kbps. That took me about 30 minutes to figure out will
    installing one! You set the timeslot size with

    service-module t1 timeslots 1-24 speed 64

    Although you've probably figured it out, one side needs to provide the
    clocking, and the other side receives clocking from the line.

    To configure one side to provide clocking, use

    service-module t1 clock source internal.

    The default is to receive clocking from the line.
    Mark Williams, Apr 26, 2006
    #10
  11. Chris

    Chris Guest

    Mark Williams wrote:
    > "show controller t1" works with other integrated CSU/DSUs, like the
    > VWICs. Use "show service-module s0/0" for yours.
    >
    > Also keep in mind that the default timeslot size for some T1
    > controllers is 56kbps. That took me about 30 minutes to figure out will
    > installing one! You set the timeslot size with
    >
    > service-module t1 timeslots 1-24 speed 64
    >
    > Although you've probably figured it out, one side needs to provide the
    > clocking, and the other side receives clocking from the line.
    >
    > To configure one side to provide clocking, use
    >
    > service-module t1 clock source internal.
    >
    > The default is to receive clocking from the line.


    Great, thanks Mark! That "show service-module" command worked a treat,
    it gives me good information. One problem is that I didn't do a good
    job of crimping the crossover cable, it's easily to knock out which
    causes CD errors. So, I'll re-do that.

    I actually used "service-module t1 timeslots all"; and according to
    "show service-module" it's using all 24 channels @ 64K to give me
    1536K, which seems right to me. But thanks for the heads-up!


    Chris
    Chris, Apr 26, 2006
    #11
  12. Chris

    clubfoot Guest

    Chris

    If you are having problems with the wires not crimping in tight then you
    might want to check to see if you have the correct type of RJ-45 end. They
    come in two flavors, solid wire ends and stranded wire ends. If you look
    from the side of the connector and the part of the pins that contacts the
    wires inside is just pointed or kind of "U" shaped then it is probably for
    stranded wire, the type used for patch cables. If however, they have two
    slits or thus three fingers then they are for probably for solid wire, the
    type used for punch down blocks or for runs between the wiring closet,
    through the walls and eventually to the jack. Using one type of connector
    for the other type of wire will usually test the limits of your CRC counter.
    I tried to find a web link that shows pictures of the different types of
    connectors but all I could come up with was sites that talked about them and
    would not show them. Here is one...
    http://www.zytrax.com/tech/layer_1/cables/tech_lan.htm

    Hope this helps you keep your CRC's down.


    "Chris" <> wrote in message
    news:...
    > Mark Williams wrote:
    >> "show controller t1" works with other integrated CSU/DSUs, like the
    >> VWICs. Use "show service-module s0/0" for yours.
    >>
    >> Also keep in mind that the default timeslot size for some T1
    >> controllers is 56kbps. That took me about 30 minutes to figure out will
    >> installing one! You set the timeslot size with
    >>
    >> service-module t1 timeslots 1-24 speed 64
    >>
    >> Although you've probably figured it out, one side needs to provide the
    >> clocking, and the other side receives clocking from the line.
    >>
    >> To configure one side to provide clocking, use
    >>
    >> service-module t1 clock source internal.
    >>
    >> The default is to receive clocking from the line.

    >
    > Great, thanks Mark! That "show service-module" command worked a treat,
    > it gives me good information. One problem is that I didn't do a good
    > job of crimping the crossover cable, it's easily to knock out which
    > causes CD errors. So, I'll re-do that.
    >
    > I actually used "service-module t1 timeslots all"; and according to
    > "show service-module" it's using all 24 channels @ 64K to give me
    > 1536K, which seems right to me. But thanks for the heads-up!
    >
    >
    > Chris
    >
    clubfoot, Apr 27, 2006
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Philip Herlihy
    Replies:
    0
    Views:
    4,595
    Philip Herlihy
    Jul 1, 2004
  2. M&MCon

    2620XM and 2621XM

    M&MCon, Mar 20, 2006, in forum: Cisco
    Replies:
    4
    Views:
    1,339
    M&MCon
    Mar 21, 2006
  3. Dimble Dumble
    Replies:
    13
    Views:
    971
    Dimble Dumble
    Jul 3, 2005
  4. Replies:
    5
    Views:
    473
  5. swpa
    Replies:
    15
    Views:
    1,560
    bod43
    Sep 22, 2009
Loading...

Share This Page