PIX Firewall 501 & Exchange Server 2003

Discussion in 'Cisco' started by User, Apr 12, 2004.

  1. User

    User Guest

    I am new to PIX firewalls and trying to let OWA/Exchange access
    through it. What I have now is the 66.XX.XX.86 as the outside IP on
    the PIX, and 192.168.1.250 as the inside. The IP on the Exchange
    server right behind it is 192.168.1.111. What am I missing that will
    not give me access remotely to the Exchange OWA? Thank you.


    Config Below:

    PIX Version 6.3(1)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password XXXXXXXXXXX encrypted
    passwd XXXXXXXXXXXXXX encrypted
    hostname mypixfirewall
    domain-name mydomain.com
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol ils 389
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    names
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 66.XX.XX.86 255.255.255.248
    ip address inside 192.168.1.250 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    global (inside) 2 192.168.1.111
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    route outside 0.0.0.0 0.0.0.0 66.XX.XX.81 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.1.2-192.168.1.129 inside
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    terminal width 80
    Cryptochecksum:dlkfjasdlfjasdlf;kjasdflkasgf
    : end
    User, Apr 12, 2004
    #1
    1. Advertising

  2. User

    Chad Mahoney Guest

    (User) wrote in message news:<>...
    > I am new to PIX firewalls and trying to let OWA/Exchange access
    > through it. What I have now is the 66.XX.XX.86 as the outside IP on
    > the PIX, and 192.168.1.250 as the inside. The IP on the Exchange
    > server right behind it is 192.168.1.111. What am I missing that will
    > not give me access remotely to the Exchange OWA? Thank you.
    >
    >
    > Config Below:
    >
    > PIX Version 6.3(1)
    > interface ethernet0 auto
    > interface ethernet1 100full
    > nameif ethernet0 outside security0
    > nameif ethernet1 inside security100
    > enable password XXXXXXXXXXX encrypted
    > passwd XXXXXXXXXXXXXX encrypted
    > hostname mypixfirewall
    > domain-name mydomain.com
    > fixup protocol ftp 21
    > fixup protocol h323 h225 1720
    > fixup protocol h323 ras 1718-1719
    > fixup protocol http 80
    > fixup protocol ils 389
    > fixup protocol rsh 514
    > fixup protocol rtsp 554
    > fixup protocol sip 5060
    > fixup protocol sip udp 5060
    > fixup protocol skinny 2000
    > fixup protocol smtp 25
    > fixup protocol sqlnet 1521
    > names
    > pager lines 24
    > mtu outside 1500
    > mtu inside 1500
    > ip address outside 66.XX.XX.86 255.255.255.248
    > ip address inside 192.168.1.250 255.255.255.0
    > ip audit info action alarm
    > ip audit attack action alarm
    > pdm logging informational 100
    > pdm history enable
    > arp timeout 14400
    > global (outside) 1 interface
    > global (inside) 2 192.168.1.111
    > nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    > route outside 0.0.0.0 0.0.0.0 66.XX.XX.81 1
    > timeout xlate 0:05:00
    > timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    > 1:00:00
    > timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    > timeout uauth 0:05:00 absolute
    > aaa-server TACACS+ protocol tacacs+
    > aaa-server RADIUS protocol radius
    > aaa-server LOCAL protocol local
    > http server enable
    > http 192.168.1.0 255.255.255.0 inside
    > no snmp-server location
    > no snmp-server contact
    > snmp-server community public
    > no snmp-server enable traps
    > floodguard enable
    > telnet timeout 5
    > ssh timeout 5
    > console timeout 0
    > dhcpd address 192.168.1.2-192.168.1.129 inside
    > dhcpd lease 3600
    > dhcpd ping_timeout 750
    > dhcpd auto_config outside
    > terminal width 80
    > Cryptochecksum:dlkfjasdlfjasdlf;kjasdflkasgf
    > : end



    Hi,

    A few things you need to do, first are you using the external pix IP
    as the IP of the exchange external? Probally not so I would remove the
    statement global (inside) 2 192.168.1.111. then I would create a
    static translation from your internal exchange server to a public IP:
    static (inside,outside) 66.XX.XX.8? 192.168.1.111 netmask
    255.255.255.255
    then create an access-list rule to allow incoming requests to that IP
    and to the port needed:
    access-list incoming_request permit tcp any host 66.XX.XX.8? eq www
    log
    then apply that access-list to an interface:

    access-group incoming_request in interface outside.

    Just a question though, if you do not have any rules in the posted
    config to allow incoming requests, how are you receiving mail?


    hth,

    Chad
    Chad Mahoney, Apr 13, 2004
    #2
    1. Advertising

  3. User

    Chris Gumm Guest

    Are you using https? I have a simlar setup but I am using https. Here is how
    mine is configed.

    PIX Version 6.3(3)
    interface ethernet0 10baset
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    clock timezone EST -5
    clock summer-time EDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol ils 389
    fixup protocol pptp 1723
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 200 permit tcp any any eq smtp
    access-list 200 permit tcp any any eq www
    access-list 200 permit tcp any any eq pptp
    access-list 200 permit tcp any any eq https
    pager lines 24
    logging on
    logging timestamp
    logging buffered debugging
    logging trap informational
    logging history debugging
    mtu outside 1500
    mtu inside 1500
    ip address outside OUTSIDE
    ip address inside INSIDE
    ip verify reverse-path interface outside
    ip audit info action alarm
    ip audit attack action alarm
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 INSIDE 0 0
    static (inside,outside) tcp interface smtp INSIDE HOST IP smtp netmask
    255.255.255.255 0 0
    static (inside,outside) tcp interface www INSIDE HOST IP www netmask
    255.255.255.255 0 0
    static (inside,outside) tcp interface pptp INSIDE HOST IP pptp netmask
    255.255.255.255 0 0
    static (inside,outside) tcp interface https INSIDE HOST IP https netmask
    255.255.255.255 0 0
    access-group 200 in interface outside
    route outside 0.0.0.0 0.0.0.0 DEFAULT 1



    "User" <> wrote in message
    news:...
    > I am new to PIX firewalls and trying to let OWA/Exchange access
    > through it. What I have now is the 66.XX.XX.86 as the outside IP on
    > the PIX, and 192.168.1.250 as the inside. The IP on the Exchange
    > server right behind it is 192.168.1.111. What am I missing that will
    > not give me access remotely to the Exchange OWA? Thank you.
    >
    >
    > Config Below:
    >
    > PIX Version 6.3(1)
    > interface ethernet0 auto
    > interface ethernet1 100full
    > nameif ethernet0 outside security0
    > nameif ethernet1 inside security100
    > enable password XXXXXXXXXXX encrypted
    > passwd XXXXXXXXXXXXXX encrypted
    > hostname mypixfirewall
    > domain-name mydomain.com
    > fixup protocol ftp 21
    > fixup protocol h323 h225 1720
    > fixup protocol h323 ras 1718-1719
    > fixup protocol http 80
    > fixup protocol ils 389
    > fixup protocol rsh 514
    > fixup protocol rtsp 554
    > fixup protocol sip 5060
    > fixup protocol sip udp 5060
    > fixup protocol skinny 2000
    > fixup protocol smtp 25
    > fixup protocol sqlnet 1521
    > names
    > pager lines 24
    > mtu outside 1500
    > mtu inside 1500
    > ip address outside 66.XX.XX.86 255.255.255.248
    > ip address inside 192.168.1.250 255.255.255.0
    > ip audit info action alarm
    > ip audit attack action alarm
    > pdm logging informational 100
    > pdm history enable
    > arp timeout 14400
    > global (outside) 1 interface
    > global (inside) 2 192.168.1.111
    > nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    > route outside 0.0.0.0 0.0.0.0 66.XX.XX.81 1
    > timeout xlate 0:05:00
    > timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    > 1:00:00
    > timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    > timeout uauth 0:05:00 absolute
    > aaa-server TACACS+ protocol tacacs+
    > aaa-server RADIUS protocol radius
    > aaa-server LOCAL protocol local
    > http server enable
    > http 192.168.1.0 255.255.255.0 inside
    > no snmp-server location
    > no snmp-server contact
    > snmp-server community public
    > no snmp-server enable traps
    > floodguard enable
    > telnet timeout 5
    > ssh timeout 5
    > console timeout 0
    > dhcpd address 192.168.1.2-192.168.1.129 inside
    > dhcpd lease 3600
    > dhcpd ping_timeout 750
    > dhcpd auto_config outside
    > terminal width 80
    > Cryptochecksum:dlkfjasdlfjasdlf;kjasdflkasgf
    > : end
    Chris Gumm, Apr 13, 2004
    #3
  4. User

    User Guest

    (Chad Mahoney) wrote in message news:<>...
    > (User) wrote in message news:<>...
    > > I am new to PIX firewalls and trying to let OWA/Exchange access
    > > through it. What I have now is the 66.XX.XX.86 as the outside IP on
    > > the PIX, and 192.168.1.250 as the inside. The IP on the Exchange
    > > server right behind it is 192.168.1.111. What am I missing that will
    > > not give me access remotely to the Exchange OWA? Thank you.
    > >
    > >
    > > Config Below:
    > >
    > > PIX Version 6.3(1)
    > > interface ethernet0 auto
    > > interface ethernet1 100full
    > > nameif ethernet0 outside security0
    > > nameif ethernet1 inside security100
    > > enable password XXXXXXXXXXX encrypted
    > > passwd XXXXXXXXXXXXXX encrypted
    > > hostname mypixfirewall
    > > domain-name mydomain.com
    > > fixup protocol ftp 21
    > > fixup protocol h323 h225 1720
    > > fixup protocol h323 ras 1718-1719
    > > fixup protocol http 80
    > > fixup protocol ils 389
    > > fixup protocol rsh 514
    > > fixup protocol rtsp 554
    > > fixup protocol sip 5060
    > > fixup protocol sip udp 5060
    > > fixup protocol skinny 2000
    > > fixup protocol smtp 25
    > > fixup protocol sqlnet 1521
    > > names
    > > pager lines 24
    > > mtu outside 1500
    > > mtu inside 1500
    > > ip address outside 66.XX.XX.86 255.255.255.248
    > > ip address inside 192.168.1.250 255.255.255.0
    > > ip audit info action alarm
    > > ip audit attack action alarm
    > > pdm logging informational 100
    > > pdm history enable
    > > arp timeout 14400
    > > global (outside) 1 interface
    > > global (inside) 2 192.168.1.111
    > > nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    > > route outside 0.0.0.0 0.0.0.0 66.XX.XX.81 1
    > > timeout xlate 0:05:00
    > > timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    > > 1:00:00
    > > timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    > > timeout uauth 0:05:00 absolute
    > > aaa-server TACACS+ protocol tacacs+
    > > aaa-server RADIUS protocol radius
    > > aaa-server LOCAL protocol local
    > > http server enable
    > > http 192.168.1.0 255.255.255.0 inside
    > > no snmp-server location
    > > no snmp-server contact
    > > snmp-server community public
    > > no snmp-server enable traps
    > > floodguard enable
    > > telnet timeout 5
    > > ssh timeout 5
    > > console timeout 0
    > > dhcpd address 192.168.1.2-192.168.1.129 inside
    > > dhcpd lease 3600
    > > dhcpd ping_timeout 750
    > > dhcpd auto_config outside
    > > terminal width 80
    > > Cryptochecksum:dlkfjasdlfjasdlf;kjasdflkasgf
    > > : end

    >
    >
    > Hi,
    >
    > A few things you need to do, first are you using the external pix IP
    > as the IP of the exchange external? Probally not so I would remove the
    > statement global (inside) 2 192.168.1.111. then I would create a
    > static translation from your internal exchange server to a public IP:
    > static (inside,outside) 66.XX.XX.8? 192.168.1.111 netmask
    > 255.255.255.255
    > then create an access-list rule to allow incoming requests to that IP
    > and to the port needed:
    > access-list incoming_request permit tcp any host 66.XX.XX.8? eq www
    > log
    > then apply that access-list to an interface:
    >
    > access-group incoming_request in interface outside.
    >
    > Just a question though, if you do not have any rules in the posted
    > config to allow incoming requests, how are you receiving mail?
    >
    >
    > hth,
    >
    > Chad


    We are using 66.XX.XX.86 for the PIX outside, 192.168.1.250 for the
    PIX inside, and 192.168.1.111 for the static server IP. We went
    through setting up through the wizard, the NAT wouldn't work and gave
    back the error the outside couldn't have the same subnet mask as the
    inside. The outside subnet was 255.255.255.248, and the inside is
    255.255.255.0. I can't understand why that work if they are a class C
    subnet. The PAT would work though and we could get the internet on
    that server, but nothing could get in.

    Also, we only receive mail once we unplug the PIX. It is ok for now as
    this is just a test server, and will plug the PIX into the production
    server once it's configured properly. Thank you both for your
    help/suggestions, I will try them now.

    Nathan
    User, Apr 13, 2004
    #4
  5. User

    User Guest

    "Chris Gumm" <> wrote in message news:<407bffb4$0$73082$>...
    > Are you using https? I have a simlar setup but I am using https. Here is how
    > mine is configed.
    >
    > PIX Version 6.3(3)
    > interface ethernet0 10baset
    > interface ethernet1 100full
    > nameif ethernet0 outside security0
    > nameif ethernet1 inside security100
    > clock timezone EST -5
    > clock summer-time EDT recurring
    > fixup protocol dns maximum-length 512
    > fixup protocol ftp 21
    > fixup protocol h323 h225 1720
    > fixup protocol h323 ras 1718-1719
    > fixup protocol http 80
    > fixup protocol ils 389
    > fixup protocol pptp 1723
    > fixup protocol rsh 514
    > fixup protocol rtsp 554
    > fixup protocol sip 5060
    > fixup protocol sip udp 5060
    > fixup protocol skinny 2000
    > fixup protocol smtp 25
    > fixup protocol sqlnet 1521
    > fixup protocol tftp 69
    > names
    > access-list 200 permit tcp any any eq smtp
    > access-list 200 permit tcp any any eq www
    > access-list 200 permit tcp any any eq pptp
    > access-list 200 permit tcp any any eq https
    > pager lines 24
    > logging on
    > logging timestamp
    > logging buffered debugging
    > logging trap informational
    > logging history debugging
    > mtu outside 1500
    > mtu inside 1500
    > ip address outside OUTSIDE
    > ip address inside INSIDE
    > ip verify reverse-path interface outside
    > ip audit info action alarm
    > ip audit attack action alarm
    > pdm logging informational 100
    > pdm history enable
    > arp timeout 14400
    > global (outside) 1 interface
    > nat (inside) 1 INSIDE 0 0
    > static (inside,outside) tcp interface smtp INSIDE HOST IP smtp netmask
    > 255.255.255.255 0 0
    > static (inside,outside) tcp interface www INSIDE HOST IP www netmask
    > 255.255.255.255 0 0
    > static (inside,outside) tcp interface pptp INSIDE HOST IP pptp netmask
    > 255.255.255.255 0 0
    > static (inside,outside) tcp interface https INSIDE HOST IP https netmask
    > 255.255.255.255 0 0
    > access-group 200 in interface outside
    > route outside 0.0.0.0 0.0.0.0 DEFAULT 1
    >
    >
    >
    > "User" <> wrote in message
    > news:...
    > > I am new to PIX firewalls and trying to let OWA/Exchange access
    > > through it. What I have now is the 66.XX.XX.86 as the outside IP on
    > > the PIX, and 192.168.1.250 as the inside. The IP on the Exchange
    > > server right behind it is 192.168.1.111. What am I missing that will
    > > not give me access remotely to the Exchange OWA? Thank you.
    > >
    > >
    > > Config Below:
    > >
    > > PIX Version 6.3(1)
    > > interface ethernet0 auto
    > > interface ethernet1 100full
    > > nameif ethernet0 outside security0
    > > nameif ethernet1 inside security100
    > > enable password XXXXXXXXXXX encrypted
    > > passwd XXXXXXXXXXXXXX encrypted
    > > hostname mypixfirewall
    > > domain-name mydomain.com
    > > fixup protocol ftp 21
    > > fixup protocol h323 h225 1720
    > > fixup protocol h323 ras 1718-1719
    > > fixup protocol http 80
    > > fixup protocol ils 389
    > > fixup protocol rsh 514
    > > fixup protocol rtsp 554
    > > fixup protocol sip 5060
    > > fixup protocol sip udp 5060
    > > fixup protocol skinny 2000
    > > fixup protocol smtp 25
    > > fixup protocol sqlnet 1521
    > > names
    > > pager lines 24
    > > mtu outside 1500
    > > mtu inside 1500
    > > ip address outside 66.XX.XX.86 255.255.255.248
    > > ip address inside 192.168.1.250 255.255.255.0
    > > ip audit info action alarm
    > > ip audit attack action alarm
    > > pdm logging informational 100
    > > pdm history enable
    > > arp timeout 14400
    > > global (outside) 1 interface
    > > global (inside) 2 192.168.1.111
    > > nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    > > route outside 0.0.0.0 0.0.0.0 66.XX.XX.81 1
    > > timeout xlate 0:05:00
    > > timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    > > 1:00:00
    > > timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    > > timeout uauth 0:05:00 absolute
    > > aaa-server TACACS+ protocol tacacs+
    > > aaa-server RADIUS protocol radius
    > > aaa-server LOCAL protocol local
    > > http server enable
    > > http 192.168.1.0 255.255.255.0 inside
    > > no snmp-server location
    > > no snmp-server contact
    > > snmp-server community public
    > > no snmp-server enable traps
    > > floodguard enable
    > > telnet timeout 5
    > > ssh timeout 5
    > > console timeout 0
    > > dhcpd address 192.168.1.2-192.168.1.129 inside
    > > dhcpd lease 3600
    > > dhcpd ping_timeout 750
    > > dhcpd auto_config outside
    > > terminal width 80
    > > Cryptochecksum:dlkfjasdlfjasdlf;kjasdflkasgf
    > > : end



    This helped a lot. I had a brain fart and new something was missing.
    The first initial login took over a minute, but now it happens
    instantly. Once we get the VPN setup correctly, we will be good to go
    thanks to you guys!

    Nathan
    User, Apr 13, 2004
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Exclusive
    Replies:
    2
    Views:
    2,634
    chris
    Apr 7, 2006
  2. =?Utf-8?B?VG9tIERpZw==?=

    Help with Server 2003 x64 and Exchange 2003 install - deploy block

    =?Utf-8?B?VG9tIERpZw==?=, Mar 20, 2006, in forum: Windows 64bit
    Replies:
    2
    Views:
    1,012
    Charlie Russel - MVP
    Mar 20, 2006
  3. =?Utf-8?B?am9zdWU=?=
    Replies:
    3
    Views:
    968
    =?Utf-8?B?U2xpY2tERFNB?=
    Aug 15, 2007
  4. Ozzie
    Replies:
    1
    Views:
    587
    Wayne McGlinn
    Nov 30, 2004
  5. Juan
    Replies:
    3
    Views:
    2,112
Loading...

Share This Page