PIX 501 -- site to site and remote user VPNs

Discussion in 'Cisco' started by BobLaubleau, Sep 12, 2006.

  1. BobLaubleau

    BobLaubleau

    Joined:
    Sep 12, 2006
    Messages:
    2
    Greetings,

    I have a PIX 501 (IOS 6.3) that currently accepts VPN connections from remote VPN clients. I'd like to setup a site to site VPN between this 501 and another 501. I'm following the steps in this document: http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094761.shtml

    However, when I finalize this configuration, the clients are unable to connect via VPN. I'm not too familiar with VPN setup (obviously) and could really use some help here. Forgive me if this has been covered, but i was unable to find my answer searching.

    What am I doing wrong?

    TIA
    BobLaubleau, Sep 12, 2006
    #1
    1. Advertising

  2. BobLaubleau

    BobLaubleau

    Joined:
    Sep 12, 2006
    Messages:
    2
    Here's the confing I'm having problems with. There are different isakmp policies and transform sets, so I don't see where the conflict is. This is as far as i made it since the remote VPN stopped working, never tested the site to site. Can anyone help?

    PIX Version 6.3(4)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    ...
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list vpnaccess_splitTunnelAcl permit ip 192.168.15.0 255.255.255.0 any
    access-list inside_outbound_nat0_acl permit ip 192.168.15.0 255.255.255.0 192.168.15.192 255.255.255
    .224
    access-list outside_cryptomap_dyn_20 permit ip any 192.168.15.192 255.255.255.224
    ...
    access-list 101 permit ip 192.168.15.0 255.255.255.0 192.168.16.0 255.255.255.0
    pager lines 24
    logging on
    logging monitor notifications
    mtu outside 1500
    mtu inside 1500
    ip address outside
    ip address inside 192.168.15.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool Internal 192.168.15.201-192.168.15.210 mask 255.255.255.0
    pdm location 192.168.15.10 255.255.255.255 inside
    pdm location 192.168.15.11 255.255.255.255 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list 101
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp ... 2953 192.168.15.11 2953 netmask 255.255.255.255 0 0
    access-group inbound in interface outside
    route outside 0.0.0.0 0.0.0.0 ... 1
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server RADIUS (inside) host 192.168.15.10 ... timeout 5
    aaa-server LOCAL protocol local
    http server enable
    http 192.168.15.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set springs esp-3des esp-md5-hmac
    crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map client authentication RADIUS
    crypto map transam 1 ipsec-isakmp
    crypto map transam 1 match address 101
    crypto map transam 1 set transform-set springs
    ! Incomplete
    crypto map transam interface outside
    isakmp enable outside
    isakmp policy 1 authentication pre-share
    isakmp policy 1 encryption 3des
    isakmp policy 1 hash md5
    isakmp policy 1 group 1
    isakmp policy 1 lifetime 14400
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    vpngroup vpnaccess address-pool Internal
    vpngroup vpnaccess dns-server 192.168.15.10 192.168.15.11
    vpngroup vpnaccess default-domain ...
    vpngroup vpnaccess split-tunnel vpnaccess_splitTunnelAcl
    vpngroup vpnaccess idle-time 1800
    vpngroup vpnaccess password ********
    telnet 192.168.15.0 255.255.255.0 inside
    telnet timeout 5
    ssh 192.168.15.0 255.255.255.0 inside
    ssh timeout 5
    management-access inside
    console timeout 0
    terminal width 80
    : end
    BobLaubleau, Sep 12, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Walter Roberson

    Re: PIX 501 - Two VPNs between same hosts

    Walter Roberson, Jul 11, 2003, in forum: Cisco
    Replies:
    0
    Views:
    916
    Walter Roberson
    Jul 11, 2003
  2. awade@gulfstatesmanufacturers.com

    Is it possible to have two VPNs share the same IP address on pix 501

    awade@gulfstatesmanufacturers.com, May 10, 2006, in forum: Cisco
    Replies:
    1
    Views:
    1,686
  3. ikkemij@xs4all.nl

    Remote access VPNs from remote location to ASA

    ikkemij@xs4all.nl, Jun 30, 2006, in forum: Cisco
    Replies:
    2
    Views:
    913
    Walter Roberson
    Jul 1, 2006
  4. drhopkins@cox.net

    PIX 501 Site-to-Site VPN and Remote Access VPN

    drhopkins@cox.net, Nov 14, 2006, in forum: Cisco
    Replies:
    1
    Views:
    627
    Walter Roberson
    Nov 14, 2006
  5. Jeff
    Replies:
    5
    Views:
    974
Loading...

Share This Page