Pix 501 Configuration

Discussion in 'Cisco' started by cdonner, Sep 6, 2004.

  1. cdonner

    cdonner Guest

    This is my configuration:

    External DHCP-assigned IP
    DSL Router (static NAT for 10.10.2.2)
    10.10.2.1
    |
    |
    10.10.2.2
    PIX 501
    10.10.1.101
    |
    |
    10.10.1.109
    Web Server (Port 80)

    I want to allow access from the outside world to my webserver. The webserver
    runs on port 80 internally, but externally the port should be mapped to
    8081. The port mapping is just an additional twist, the problem does not go
    away even when I run the webserver on port 8081 and don't map the port. The
    problem is that I don't seem to be able to get in. I don't even see packets
    from the requesting client arriving on the outside interface with "debug
    packet". Am I supposed to see such packets even when the firewall does not
    allow them in? I would assume so.
    Before I installed the Pix, I had the DSL Router configured for static NAT
    directly to my Web server's address. This has been working for some time. It
    is possible that the problem is with the router, but I don't believe so and
    I would like to run the PIX configuration by someone who can take a look and
    let me know if I got it right. The relevant lines are highlighted with the
    <--------------------- arrow.

    Thanks.


    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password <....> encrypted
    passwd <....> encrypted
    hostname pixfirewall
    domain-name <....>
    clock timezone EST -5
    clock summer-time EDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 100 permit icmp any any echo-reply
    access-list 100 permit icmp any any time-exceeded
    access-list 100 permit icmp any any unreachable
    access-list 100 permit icmp any any
    access-list 101 permit tcp any host 10.10.2.2 eq 8081
    <---------------------
    pager lines 24
    logging on
    logging buffered errors
    logging trap notifications
    mtu outside 1500
    mtu inside 1500
    ip address outside 10.10.2.2 255.255.255.0
    ip address inside 10.10.1.101 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 10.10.1.109 255.255.255.255 inside
    pdm location 10.10.1.171 255.255.255.255 inside
    pdm location 10.10.2.2 255.255.255.255 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    global (inside) 2 interface
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp 10.10.1.109 www 10.10.2.2 8081 netmask
    255.255.255.255 0 0 <---------------------
    access-group 101 in interface outside <---------------------
    route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 10.10.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    telnet 10.10.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd address 10.10.1.170-10.10.1.199 inside
    dhcpd dns 10.10.2.1 10.10.2.1
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd domain <....>.
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80
    Cryptochecksum:<....>
    : end
    [OK]
    cdonner, Sep 6, 2004
    #1
    1. Advertising

  2. cdonner

    CCUE Guest

    Testing

    "cdonner" <> wrote in message
    news:eek:nO_c.1206$Gi5.299@trndny05...
    > This is my configuration:
    >
    > External DHCP-assigned IP
    > DSL Router (static NAT for 10.10.2.2)
    > 10.10.2.1
    > |
    > |
    > 10.10.2.2
    > PIX 501
    > 10.10.1.101
    > |
    > |
    > 10.10.1.109
    > Web Server (Port 80)
    >
    > I want to allow access from the outside world to my webserver. The

    webserver
    > runs on port 80 internally, but externally the port should be mapped to
    > 8081. The port mapping is just an additional twist, the problem does not

    go
    > away even when I run the webserver on port 8081 and don't map the port.

    The
    > problem is that I don't seem to be able to get in. I don't even see

    packets
    > from the requesting client arriving on the outside interface with "debug
    > packet". Am I supposed to see such packets even when the firewall does not
    > allow them in? I would assume so.
    > Before I installed the Pix, I had the DSL Router configured for static NAT
    > directly to my Web server's address. This has been working for some time.

    It
    > is possible that the problem is with the router, but I don't believe so

    and
    > I would like to run the PIX configuration by someone who can take a look

    and
    > let me know if I got it right. The relevant lines are highlighted with the
    > <--------------------- arrow.
    >
    > Thanks.
    >
    >
    > PIX Version 6.3(3)
    > interface ethernet0 auto
    > interface ethernet1 100full
    > nameif ethernet0 outside security0
    > nameif ethernet1 inside security100
    > enable password <....> encrypted
    > passwd <....> encrypted
    > hostname pixfirewall
    > domain-name <....>
    > clock timezone EST -5
    > clock summer-time EDT recurring
    > fixup protocol dns maximum-length 512
    > fixup protocol ftp 21
    > fixup protocol h323 h225 1720
    > fixup protocol h323 ras 1718-1719
    > fixup protocol http 80
    > fixup protocol rsh 514
    > fixup protocol rtsp 554
    > fixup protocol sip 5060
    > fixup protocol sip udp 5060
    > fixup protocol skinny 2000
    > fixup protocol smtp 25
    > fixup protocol sqlnet 1521
    > fixup protocol tftp 69
    > names
    > access-list 100 permit icmp any any echo-reply
    > access-list 100 permit icmp any any time-exceeded
    > access-list 100 permit icmp any any unreachable
    > access-list 100 permit icmp any any
    > access-list 101 permit tcp any host 10.10.2.2 eq 8081
    > <---------------------
    > pager lines 24
    > logging on
    > logging buffered errors
    > logging trap notifications
    > mtu outside 1500
    > mtu inside 1500
    > ip address outside 10.10.2.2 255.255.255.0
    > ip address inside 10.10.1.101 255.255.255.0
    > ip audit info action alarm
    > ip audit attack action alarm
    > pdm location 10.10.1.109 255.255.255.255 inside
    > pdm location 10.10.1.171 255.255.255.255 inside
    > pdm location 10.10.2.2 255.255.255.255 inside
    > pdm logging informational 100
    > pdm history enable
    > arp timeout 14400
    > global (outside) 1 interface
    > global (inside) 2 interface
    > nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    > static (inside,outside) tcp 10.10.1.109 www 10.10.2.2 8081 netmask
    > 255.255.255.255 0 0 <---------------------
    > access-group 101 in interface outside <---------------------
    > route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    > timeout xlate 0:05:00
    > timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    > 1:00:00
    > timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    > timeout uauth 0:05:00 absolute
    > aaa-server TACACS+ protocol tacacs+
    > aaa-server RADIUS protocol radius
    > aaa-server LOCAL protocol local
    > http server enable
    > http 10.10.1.0 255.255.255.0 inside
    > no snmp-server location
    > no snmp-server contact
    > snmp-server community public
    > no snmp-server enable traps
    > floodguard enable
    > telnet 10.10.1.0 255.255.255.0 inside
    > telnet timeout 5
    > ssh timeout 5
    > console timeout 0
    > dhcpd address 10.10.1.170-10.10.1.199 inside
    > dhcpd dns 10.10.2.1 10.10.2.1
    > dhcpd lease 3600
    > dhcpd ping_timeout 750
    > dhcpd domain <....>.
    > dhcpd auto_config outside
    > dhcpd enable inside
    > terminal width 80
    > Cryptochecksum:<....>
    > : end
    > [OK]
    >
    >
    CCUE, Sep 6, 2004
    #2
    1. Advertising

  3. cdonner

    PES Guest

    "cdonner" <> wrote in message
    news:eek:nO_c.1206$Gi5.299@trndny05...
    > This is my configuration:
    >
    > External DHCP-assigned IP
    > DSL Router (static NAT for 10.10.2.2)
    > 10.10.2.1
    > |
    > |
    > 10.10.2.2
    > PIX 501
    > 10.10.1.101
    > |
    > |
    > 10.10.1.109
    > Web Server (Port 80)
    >
    > I want to allow access from the outside world to my webserver. The
    > webserver runs on port 80 internally, but externally the port should be
    > mapped to 8081. The port mapping is just an additional twist, the problem
    > does not go away even when I run the webserver on port 8081 and don't map
    > the port. The problem is that I don't seem to be able to get in. I don't
    > even see packets from the requesting client arriving on the outside
    > interface with "debug packet". Am I supposed to see such packets even when
    > the firewall does not allow them in? I would assume so.
    > Before I installed the Pix, I had the DSL Router configured for static NAT
    > directly to my Web server's address. This has been working for some time.
    > It is possible that the problem is with the router, but I don't believe so
    > and I would like to run the PIX configuration by someone who can take a
    > look and let me know if I got it right. The relevant lines are highlighted
    > with the
    > <--------------------- arrow.
    >
    > Thanks.
    >
    >
    > PIX Version 6.3(3)
    > interface ethernet0 auto
    > interface ethernet1 100full
    > nameif ethernet0 outside security0
    > nameif ethernet1 inside security100
    > enable password <....> encrypted
    > passwd <....> encrypted
    > hostname pixfirewall
    > domain-name <....>
    > clock timezone EST -5
    > clock summer-time EDT recurring
    > fixup protocol dns maximum-length 512
    > fixup protocol ftp 21
    > fixup protocol h323 h225 1720
    > fixup protocol h323 ras 1718-1719
    > fixup protocol http 80
    > fixup protocol rsh 514
    > fixup protocol rtsp 554
    > fixup protocol sip 5060
    > fixup protocol sip udp 5060
    > fixup protocol skinny 2000
    > fixup protocol smtp 25
    > fixup protocol sqlnet 1521
    > fixup protocol tftp 69
    > names
    > access-list 100 permit icmp any any echo-reply
    > access-list 100 permit icmp any any time-exceeded
    > access-list 100 permit icmp any any unreachable
    > access-list 100 permit icmp any any
    > access-list 101 permit tcp any host 10.10.2.2 eq 8081
    > <---------------------
    > pager lines 24
    > logging on
    > logging buffered errors
    > logging trap notifications
    > mtu outside 1500
    > mtu inside 1500
    > ip address outside 10.10.2.2 255.255.255.0
    > ip address inside 10.10.1.101 255.255.255.0
    > ip audit info action alarm
    > ip audit attack action alarm
    > pdm location 10.10.1.109 255.255.255.255 inside
    > pdm location 10.10.1.171 255.255.255.255 inside
    > pdm location 10.10.2.2 255.255.255.255 inside
    > pdm logging informational 100
    > pdm history enable
    > arp timeout 14400
    > global (outside) 1 interface
    > global (inside) 2 interface
    > nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    > static (inside,outside) tcp 10.10.1.109 www 10.10.2.2 8081 netmask
    > 255.255.255.255 0 0 <---------------------


    Assuming 10.10.1.109 is your web server, your static is backwards.

    Try:

    static (inside,outside) tcp 10.10.2.2 8081 10.10.1.109 www netmask
    255.255.255.255 0 0

    Make sure you do a "clear xlate".

    > access-group 101 in interface outside <---------------------
    > route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    > timeout xlate 0:05:00
    > timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    > 1:00:00
    > timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    > timeout uauth 0:05:00 absolute
    > aaa-server TACACS+ protocol tacacs+
    > aaa-server RADIUS protocol radius
    > aaa-server LOCAL protocol local
    > http server enable
    > http 10.10.1.0 255.255.255.0 inside
    > no snmp-server location
    > no snmp-server contact
    > snmp-server community public
    > no snmp-server enable traps
    > floodguard enable
    > telnet 10.10.1.0 255.255.255.0 inside
    > telnet timeout 5
    > ssh timeout 5
    > console timeout 0
    > dhcpd address 10.10.1.170-10.10.1.199 inside
    > dhcpd dns 10.10.2.1 10.10.2.1
    > dhcpd lease 3600
    > dhcpd ping_timeout 750
    > dhcpd domain <....>.
    > dhcpd auto_config outside
    > dhcpd enable inside
    > terminal width 80
    > Cryptochecksum:<....>
    > : end
    > [OK]
    >
    PES, Sep 6, 2004
    #3
  4. cdonner

    mh Guest

    Try using capture command to ensure the packet are being received on
    the PIX outside interface
    mh, Sep 6, 2004
    #4
  5. cdonner

    cdonner Guest

    Thanks for your feedback.
    Since it is still not working, I have a few more questions.

    a. clear xlate does not seem to have any effect. It does not revoke the
    static translations rules. As a matter of fact, the Pix 501 help does not
    show me the xlate command.

    b. I see different configurations when I enter 'show config' and when I
    select "File/Show running configuration in new window" in PDM. How come?
    Specifically, the telnet command line interpreter always shows me the same
    old translation rules.

    c. When I typed in your version of the static command in the telnet window,
    it was accepted without error. When I run 'show config', however, I don't
    see the new rule. I don't see it in PDM either. When I tried to repeat the
    static command, I get

    pixfirewall(config)# static (inside,outside) tcp 10.10.2.2 8081 10.10.1.109
    80$
    ERROR: duplicate of existing static

    tcp from inside:10.10.1.109/80 to outside:10.10.2.2/8081 netmask
    255.255.255.255
    Usage: [no] static [(real_ifc, mapped_ifc)]
    {<mapped_ip>|interface}
    {<real_ip> [netmask <mask>]} | {access-list <acl_name>}
    [dns] [norandomseq] [<max_conns> [<emb_lim>]]
    [no] static [(real_ifc, mapped_ifc)] {tcp|udp}
    {<mapped_ip>|interface} <mapped_port>
    {<real_ip> <real_port> [netmask <mask>]} |
    {access-list <acl_name>}
    [dns] [norandomseq] [<max_conns> [<emb_lim>]]

    This is expected, but it still confuses me, because it seems it is
    complaining about an existing inside-outside mapping, but I thought I needed
    a mapping from outside to inside. What's wrong with that?

    Thanks for any additional input.
    c ( a t ) d o n n e r s d o t c o m


    "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in message
    news:413c6746$...
    >
    > "cdonner" <> wrote in message
    > news:eek:nO_c.1206$Gi5.299@trndny05...
    >> This is my configuration:
    >>
    >> External DHCP-assigned IP
    >> DSL Router (static NAT for 10.10.2.2)
    >> 10.10.2.1
    >> |
    >> |
    >> 10.10.2.2
    >> PIX 501
    >> 10.10.1.101
    >> |
    >> |
    >> 10.10.1.109
    >> Web Server (Port 80)
    >>
    >> I want to allow access from the outside world to my webserver. The
    >> webserver runs on port 80 internally, but externally the port should be
    >> mapped to 8081. The port mapping is just an additional twist, the problem
    >> does not go away even when I run the webserver on port 8081 and don't map
    >> the port. The problem is that I don't seem to be able to get in. I don't
    >> even see packets from the requesting client arriving on the outside
    >> interface with "debug packet". Am I supposed to see such packets even
    >> when the firewall does not allow them in? I would assume so.
    >> Before I installed the Pix, I had the DSL Router configured for static
    >> NAT directly to my Web server's address. This has been working for some
    >> time. It is possible that the problem is with the router, but I don't
    >> believe so and I would like to run the PIX configuration by someone who
    >> can take a look and let me know if I got it right. The relevant lines are
    >> highlighted with the
    >> <--------------------- arrow.
    >>
    >> Thanks.
    >>
    >>
    >> PIX Version 6.3(3)
    >> interface ethernet0 auto
    >> interface ethernet1 100full
    >> nameif ethernet0 outside security0
    >> nameif ethernet1 inside security100
    >> enable password <....> encrypted
    >> passwd <....> encrypted
    >> hostname pixfirewall
    >> domain-name <....>
    >> clock timezone EST -5
    >> clock summer-time EDT recurring
    >> fixup protocol dns maximum-length 512
    >> fixup protocol ftp 21
    >> fixup protocol h323 h225 1720
    >> fixup protocol h323 ras 1718-1719
    >> fixup protocol http 80
    >> fixup protocol rsh 514
    >> fixup protocol rtsp 554
    >> fixup protocol sip 5060
    >> fixup protocol sip udp 5060
    >> fixup protocol skinny 2000
    >> fixup protocol smtp 25
    >> fixup protocol sqlnet 1521
    >> fixup protocol tftp 69
    >> names
    >> access-list 100 permit icmp any any echo-reply
    >> access-list 100 permit icmp any any time-exceeded
    >> access-list 100 permit icmp any any unreachable
    >> access-list 100 permit icmp any any
    >> access-list 101 permit tcp any host 10.10.2.2 eq 8081
    >> <---------------------
    >> pager lines 24
    >> logging on
    >> logging buffered errors
    >> logging trap notifications
    >> mtu outside 1500
    >> mtu inside 1500
    >> ip address outside 10.10.2.2 255.255.255.0
    >> ip address inside 10.10.1.101 255.255.255.0
    >> ip audit info action alarm
    >> ip audit attack action alarm
    >> pdm location 10.10.1.109 255.255.255.255 inside
    >> pdm location 10.10.1.171 255.255.255.255 inside
    >> pdm location 10.10.2.2 255.255.255.255 inside
    >> pdm logging informational 100
    >> pdm history enable
    >> arp timeout 14400
    >> global (outside) 1 interface
    >> global (inside) 2 interface
    >> nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    >> static (inside,outside) tcp 10.10.1.109 www 10.10.2.2 8081 netmask
    >> 255.255.255.255 0 0 <---------------------

    >
    > Assuming 10.10.1.109 is your web server, your static is backwards.
    >
    > Try:
    >
    > static (inside,outside) tcp 10.10.2.2 8081 10.10.1.109 www netmask
    > 255.255.255.255 0 0
    >
    > Make sure you do a "clear xlate".
    >
    >> access-group 101 in interface outside <---------------------
    >> route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    >> timeout xlate 0:05:00
    >> timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    >> 1:00:00
    >> timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    >> timeout uauth 0:05:00 absolute
    >> aaa-server TACACS+ protocol tacacs+
    >> aaa-server RADIUS protocol radius
    >> aaa-server LOCAL protocol local
    >> http server enable
    >> http 10.10.1.0 255.255.255.0 inside
    >> no snmp-server location
    >> no snmp-server contact
    >> snmp-server community public
    >> no snmp-server enable traps
    >> floodguard enable
    >> telnet 10.10.1.0 255.255.255.0 inside
    >> telnet timeout 5
    >> ssh timeout 5
    >> console timeout 0
    >> dhcpd address 10.10.1.170-10.10.1.199 inside
    >> dhcpd dns 10.10.2.1 10.10.2.1
    >> dhcpd lease 3600
    >> dhcpd ping_timeout 750
    >> dhcpd domain <....>.
    >> dhcpd auto_config outside
    >> dhcpd enable inside
    >> terminal width 80
    >> Cryptochecksum:<....>
    >> : end
    >> [OK]
    >>

    >
    >
    cdonner, Sep 6, 2004
    #5
  6. cdonner

    PES Guest

    "cdonner" <> wrote in message
    news:To2%c.10143$Cr5.5443@trndny08...
    > Thanks for your feedback.
    > Since it is still not working, I have a few more questions.
    >
    > a. clear xlate does not seem to have any effect. It does not revoke the
    > static translations rules. As a matter of fact, the Pix 501 help does not
    > show me the xlate command.
    >


    It only clears the translation table for rebuild. I.E. Show xlate.

    > b. I see different configurations when I enter 'show config' and when I
    > select "File/Show running configuration in new window" in PDM. How come?
    > Specifically, the telnet command line interpreter always shows me the same
    > old translation rules.


    show config and file Show running config is different. Show config is
    startup config. You would only see changes here if you had made changes
    then done a write mem.

    >
    > c. When I typed in your version of the static command in the telnet
    > window, it was accepted without error. When I run 'show config', however,
    > I don't see the new rule. I don't see it in PDM either. When I tried to
    > repeat the static command, I get


    write mem

    I would also recommend deleting the old one out by predicating it with "NO".


    >
    > pixfirewall(config)# static (inside,outside) tcp 10.10.2.2 8081
    > 10.10.1.109 80$
    > ERROR: duplicate of existing static
    >
    > tcp from inside:10.10.1.109/80 to outside:10.10.2.2/8081 netmask
    > 255.255.255.255
    > Usage: [no] static [(real_ifc, mapped_ifc)]
    > {<mapped_ip>|interface}
    > {<real_ip> [netmask <mask>]} | {access-list <acl_name>}
    > [dns] [norandomseq] [<max_conns> [<emb_lim>]]
    > [no] static [(real_ifc, mapped_ifc)] {tcp|udp}
    > {<mapped_ip>|interface} <mapped_port>
    > {<real_ip> <real_port> [netmask <mask>]} |
    > {access-list <acl_name>}
    > [dns] [norandomseq] [<max_conns> [<emb_lim>]]
    >
    > This is expected, but it still confuses me, because it seems it is
    > complaining about an existing inside-outside mapping, but I thought I
    > needed a mapping from outside to inside. What's wrong with that?
    >


    The mappings are bidirectional for the port address pair. Early pixes used
    only one to one statics. If you look at this being the root of the command
    it makes more sense.

    > Thanks for any additional input.
    > c ( a t ) d o n n e r s d o t c o m
    >
    >
    > "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in
    > message news:413c6746$...
    >>
    >> "cdonner" <> wrote in message
    >> news:eek:nO_c.1206$Gi5.299@trndny05...
    >>> This is my configuration:
    >>>
    >>> External DHCP-assigned IP
    >>> DSL Router (static NAT for 10.10.2.2)
    >>> 10.10.2.1
    >>> |
    >>> |
    >>> 10.10.2.2
    >>> PIX 501
    >>> 10.10.1.101
    >>> |
    >>> |
    >>> 10.10.1.109
    >>> Web Server (Port 80)
    >>>
    >>> I want to allow access from the outside world to my webserver. The
    >>> webserver runs on port 80 internally, but externally the port should be
    >>> mapped to 8081. The port mapping is just an additional twist, the
    >>> problem does not go away even when I run the webserver on port 8081 and
    >>> don't map the port. The problem is that I don't seem to be able to get
    >>> in. I don't even see packets from the requesting client arriving on the
    >>> outside interface with "debug packet". Am I supposed to see such packets
    >>> even when the firewall does not allow them in? I would assume so.
    >>> Before I installed the Pix, I had the DSL Router configured for static
    >>> NAT directly to my Web server's address. This has been working for some
    >>> time. It is possible that the problem is with the router, but I don't
    >>> believe so and I would like to run the PIX configuration by someone who
    >>> can take a look and let me know if I got it right. The relevant lines
    >>> are highlighted with the
    >>> <--------------------- arrow.
    >>>
    >>> Thanks.
    >>>
    >>>
    >>> PIX Version 6.3(3)
    >>> interface ethernet0 auto
    >>> interface ethernet1 100full
    >>> nameif ethernet0 outside security0
    >>> nameif ethernet1 inside security100
    >>> enable password <....> encrypted
    >>> passwd <....> encrypted
    >>> hostname pixfirewall
    >>> domain-name <....>
    >>> clock timezone EST -5
    >>> clock summer-time EDT recurring
    >>> fixup protocol dns maximum-length 512
    >>> fixup protocol ftp 21
    >>> fixup protocol h323 h225 1720
    >>> fixup protocol h323 ras 1718-1719
    >>> fixup protocol http 80
    >>> fixup protocol rsh 514
    >>> fixup protocol rtsp 554
    >>> fixup protocol sip 5060
    >>> fixup protocol sip udp 5060
    >>> fixup protocol skinny 2000
    >>> fixup protocol smtp 25
    >>> fixup protocol sqlnet 1521
    >>> fixup protocol tftp 69
    >>> names
    >>> access-list 100 permit icmp any any echo-reply
    >>> access-list 100 permit icmp any any time-exceeded
    >>> access-list 100 permit icmp any any unreachable
    >>> access-list 100 permit icmp any any
    >>> access-list 101 permit tcp any host 10.10.2.2 eq 8081
    >>> <---------------------
    >>> pager lines 24
    >>> logging on
    >>> logging buffered errors
    >>> logging trap notifications
    >>> mtu outside 1500
    >>> mtu inside 1500
    >>> ip address outside 10.10.2.2 255.255.255.0
    >>> ip address inside 10.10.1.101 255.255.255.0
    >>> ip audit info action alarm
    >>> ip audit attack action alarm
    >>> pdm location 10.10.1.109 255.255.255.255 inside
    >>> pdm location 10.10.1.171 255.255.255.255 inside
    >>> pdm location 10.10.2.2 255.255.255.255 inside
    >>> pdm logging informational 100
    >>> pdm history enable
    >>> arp timeout 14400
    >>> global (outside) 1 interface
    >>> global (inside) 2 interface
    >>> nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    >>> static (inside,outside) tcp 10.10.1.109 www 10.10.2.2 8081 netmask
    >>> 255.255.255.255 0 0 <---------------------

    >>
    >> Assuming 10.10.1.109 is your web server, your static is backwards.
    >>
    >> Try:
    >>
    >> static (inside,outside) tcp 10.10.2.2 8081 10.10.1.109 www netmask
    >> 255.255.255.255 0 0
    >>
    >> Make sure you do a "clear xlate".
    >>
    >>> access-group 101 in interface outside <---------------------
    >>> route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    >>> timeout xlate 0:05:00
    >>> timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    >>> 1:00:00
    >>> timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    >>> timeout uauth 0:05:00 absolute
    >>> aaa-server TACACS+ protocol tacacs+
    >>> aaa-server RADIUS protocol radius
    >>> aaa-server LOCAL protocol local
    >>> http server enable
    >>> http 10.10.1.0 255.255.255.0 inside
    >>> no snmp-server location
    >>> no snmp-server contact
    >>> snmp-server community public
    >>> no snmp-server enable traps
    >>> floodguard enable
    >>> telnet 10.10.1.0 255.255.255.0 inside
    >>> telnet timeout 5
    >>> ssh timeout 5
    >>> console timeout 0
    >>> dhcpd address 10.10.1.170-10.10.1.199 inside
    >>> dhcpd dns 10.10.2.1 10.10.2.1
    >>> dhcpd lease 3600
    >>> dhcpd ping_timeout 750
    >>> dhcpd domain <....>.
    >>> dhcpd auto_config outside
    >>> dhcpd enable inside
    >>> terminal width 80
    >>> Cryptochecksum:<....>
    >>> : end
    >>> [OK]
    >>>

    >>
    >>

    >
    >
    PES, Sep 6, 2004
    #6
  7. cdonner

    cdonner Guest

    I appologize for my ignorance. I am learning as fast as I can. I was
    struggling with getting outbound traffic to work again after I had done a
    'reset firewall to default factory configuration'. I found this odd, since
    it worked when I first plugged it in. I finally found the missing 'route'
    statement and it is now working again.
    I am reading through the configuration guides on the Cisco website and can't
    find anything wrong anymore.
    Because I confused running and startup, the configuration that I included in
    my initial posting was not the right one. Here is what is currently active
    and, needless to say, I still can't get to the .109 box from the outside. I
    am actually now trying this from within my 10.10.2.x network, not really
    from the outside through the DSL router.

    This is what I captured on the outside interface:

    17:56:07.311446 arp reply 10.10.2.2 is-at 0:11:bb:e3:fc:41
    17:56:07.311690 10.10.2.199.1802 > 10.10.1.109.8081: S
    247213797:247213797(0) win 65535 <mss 1460,nop,nop,sackOK>
    17:56:10.312636 10.10.2.199.1802 > 10.10.1.109.8081: S
    247213797:247213797(0) win 65535 <mss 1460,nop,nop,sackOK>

    I don't see anything from 10.10.2.199 on the inside interface, though.

    Hint: I added 2 lines from Cisco's "Two Interfaces with NAT - Basic"
    Configuration that are supposed to allow inbound and outbound pings, but
    only outbound pings work.

    Thanks again. I don't know what I would do without this group.

    Building configuration...
    : Saved
    :
    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password <....> encrypted
    passwd <....> encrypted
    hostname pixfirewall
    domain-name <....>
    clock timezone EST -5
    clock summer-time EDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 101 permit tcp any host 10.10.2.2 eq 8081
    access-list acl_grp permit icmp any any
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 10.10.2.2 255.255.255.0
    ip address inside 10.10.1.101 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 10.10.1.109 255.255.255.255 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp 10.10.2.2 8081 10.10.1.109 www netmask
    255.255.255.255 0 0
    access-group 101 in interface outside
    access-group acl_grp in interface outside
    route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 10.10.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    telnet 10.10.1.0 255.255.255.0 inside
    telnet timeout 50
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 10.10.1.0 255.255.255.0 inside
    ssh timeout 30
    console timeout 0
    dhcpd address 10.10.1.170-10.10.1.199 inside
    dhcpd dns 10.10.2.1 10.10.2.1
    dhcpd lease 36000
    dhcpd ping_timeout 750
    dhcpd domain <....>
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80
    Cryptochecksum:76ac95c4c1c90d0ec39ac1bd20dd649f
    : end
    [OK]




    "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in message
    news:413cd175$...
    >
    > "cdonner" <> wrote in message
    > news:To2%c.10143$Cr5.5443@trndny08...
    >> Thanks for your feedback.
    >> Since it is still not working, I have a few more questions.
    >>
    >> a. clear xlate does not seem to have any effect. It does not revoke the
    >> static translations rules. As a matter of fact, the Pix 501 help does not
    >> show me the xlate command.
    >>

    >
    > It only clears the translation table for rebuild. I.E. Show xlate.
    >
    >> b. I see different configurations when I enter 'show config' and when I
    >> select "File/Show running configuration in new window" in PDM. How come?
    >> Specifically, the telnet command line interpreter always shows me the
    >> same old translation rules.

    >
    > show config and file Show running config is different. Show config is
    > startup config. You would only see changes here if you had made changes
    > then done a write mem.
    >
    >>
    >> c. When I typed in your version of the static command in the telnet
    >> window, it was accepted without error. When I run 'show config', however,
    >> I don't see the new rule. I don't see it in PDM either. When I tried to
    >> repeat the static command, I get

    >
    > write mem
    >
    > I would also recommend deleting the old one out by predicating it with
    > "NO".
    >
    >
    >>
    >> pixfirewall(config)# static (inside,outside) tcp 10.10.2.2 8081
    >> 10.10.1.109 80$
    >> ERROR: duplicate of existing static
    >>
    >> tcp from inside:10.10.1.109/80 to outside:10.10.2.2/8081 netmask
    >> 255.255.255.255
    >> Usage: [no] static [(real_ifc, mapped_ifc)]
    >> {<mapped_ip>|interface}
    >> {<real_ip> [netmask <mask>]} | {access-list <acl_name>}
    >> [dns] [norandomseq] [<max_conns> [<emb_lim>]]
    >> [no] static [(real_ifc, mapped_ifc)] {tcp|udp}
    >> {<mapped_ip>|interface} <mapped_port>
    >> {<real_ip> <real_port> [netmask <mask>]} |
    >> {access-list <acl_name>}
    >> [dns] [norandomseq] [<max_conns> [<emb_lim>]]
    >>
    >> This is expected, but it still confuses me, because it seems it is
    >> complaining about an existing inside-outside mapping, but I thought I
    >> needed a mapping from outside to inside. What's wrong with that?
    >>

    >
    > The mappings are bidirectional for the port address pair. Early pixes
    > used only one to one statics. If you look at this being the root of the
    > command it makes more sense.
    >
    >> Thanks for any additional input.
    >> c ( a t ) d o n n e r s d o t c o m
    >>
    >>
    >> "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in
    >> message news:413c6746$...
    >>>
    >>> "cdonner" <> wrote in message
    >>> news:eek:nO_c.1206$Gi5.299@trndny05...
    >>>> This is my configuration:
    >>>>
    >>>> External DHCP-assigned IP
    >>>> DSL Router (static NAT for 10.10.2.2)
    >>>> 10.10.2.1
    >>>> |
    >>>> |
    >>>> 10.10.2.2
    >>>> PIX 501
    >>>> 10.10.1.101
    >>>> |
    >>>> |
    >>>> 10.10.1.109
    >>>> Web Server (Port 80)
    >>>>
    >>>> I want to allow access from the outside world to my webserver. The
    >>>> webserver runs on port 80 internally, but externally the port should be
    >>>> mapped to 8081. The port mapping is just an additional twist, the
    >>>> problem does not go away even when I run the webserver on port 8081 and
    >>>> don't map the port. The problem is that I don't seem to be able to get
    >>>> in. I don't even see packets from the requesting client arriving on the
    >>>> outside interface with "debug packet". Am I supposed to see such
    >>>> packets even when the firewall does not allow them in? I would assume
    >>>> so.
    >>>> Before I installed the Pix, I had the DSL Router configured for static
    >>>> NAT directly to my Web server's address. This has been working for some
    >>>> time. It is possible that the problem is with the router, but I don't
    >>>> believe so and I would like to run the PIX configuration by someone who
    >>>> can take a look and let me know if I got it right. The relevant lines
    >>>> are highlighted with the
    >>>> <--------------------- arrow.
    >>>>
    >>>> Thanks.
    >>>>
    >>>>
    >>>> PIX Version 6.3(3)
    >>>> interface ethernet0 auto
    >>>> interface ethernet1 100full
    >>>> nameif ethernet0 outside security0
    >>>> nameif ethernet1 inside security100
    >>>> enable password <....> encrypted
    >>>> passwd <....> encrypted
    >>>> hostname pixfirewall
    >>>> domain-name <....>
    >>>> clock timezone EST -5
    >>>> clock summer-time EDT recurring
    >>>> fixup protocol dns maximum-length 512
    >>>> fixup protocol ftp 21
    >>>> fixup protocol h323 h225 1720
    >>>> fixup protocol h323 ras 1718-1719
    >>>> fixup protocol http 80
    >>>> fixup protocol rsh 514
    >>>> fixup protocol rtsp 554
    >>>> fixup protocol sip 5060
    >>>> fixup protocol sip udp 5060
    >>>> fixup protocol skinny 2000
    >>>> fixup protocol smtp 25
    >>>> fixup protocol sqlnet 1521
    >>>> fixup protocol tftp 69
    >>>> names
    >>>> access-list 100 permit icmp any any echo-reply
    >>>> access-list 100 permit icmp any any time-exceeded
    >>>> access-list 100 permit icmp any any unreachable
    >>>> access-list 100 permit icmp any any
    >>>> access-list 101 permit tcp any host 10.10.2.2 eq 8081
    >>>> <---------------------
    >>>> pager lines 24
    >>>> logging on
    >>>> logging buffered errors
    >>>> logging trap notifications
    >>>> mtu outside 1500
    >>>> mtu inside 1500
    >>>> ip address outside 10.10.2.2 255.255.255.0
    >>>> ip address inside 10.10.1.101 255.255.255.0
    >>>> ip audit info action alarm
    >>>> ip audit attack action alarm
    >>>> pdm location 10.10.1.109 255.255.255.255 inside
    >>>> pdm location 10.10.1.171 255.255.255.255 inside
    >>>> pdm location 10.10.2.2 255.255.255.255 inside
    >>>> pdm logging informational 100
    >>>> pdm history enable
    >>>> arp timeout 14400
    >>>> global (outside) 1 interface
    >>>> global (inside) 2 interface
    >>>> nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    >>>> static (inside,outside) tcp 10.10.1.109 www 10.10.2.2 8081 netmask
    >>>> 255.255.255.255 0 0 <---------------------
    >>>
    >>> Assuming 10.10.1.109 is your web server, your static is backwards.
    >>>
    >>> Try:
    >>>
    >>> static (inside,outside) tcp 10.10.2.2 8081 10.10.1.109 www netmask
    >>> 255.255.255.255 0 0
    >>>
    >>> Make sure you do a "clear xlate".
    >>>
    >>>> access-group 101 in interface outside <---------------------
    >>>> route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    >>>> timeout xlate 0:05:00
    >>>> timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    >>>> 1:00:00
    >>>> timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    >>>> timeout uauth 0:05:00 absolute
    >>>> aaa-server TACACS+ protocol tacacs+
    >>>> aaa-server RADIUS protocol radius
    >>>> aaa-server LOCAL protocol local
    >>>> http server enable
    >>>> http 10.10.1.0 255.255.255.0 inside
    >>>> no snmp-server location
    >>>> no snmp-server contact
    >>>> snmp-server community public
    >>>> no snmp-server enable traps
    >>>> floodguard enable
    >>>> telnet 10.10.1.0 255.255.255.0 inside
    >>>> telnet timeout 5
    >>>> ssh timeout 5
    >>>> console timeout 0
    >>>> dhcpd address 10.10.1.170-10.10.1.199 inside
    >>>> dhcpd dns 10.10.2.1 10.10.2.1
    >>>> dhcpd lease 3600
    >>>> dhcpd ping_timeout 750
    >>>> dhcpd domain <....>.
    >>>> dhcpd auto_config outside
    >>>> dhcpd enable inside
    >>>> terminal width 80
    >>>> Cryptochecksum:<....>
    >>>> : end
    >>>> [OK]
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    cdonner, Sep 6, 2004
    #7
  8. cdonner

    PES Guest

    "cdonner" <> wrote in message
    news:1j5%c.5850$wF4.983@trndny09...
    >I appologize for my ignorance. I am learning as fast as I can. I was
    >struggling with getting outbound traffic to work again after I had done a
    >'reset firewall to default factory configuration'. I found this odd, since
    >it worked when I first plugged it in. I finally found the missing 'route'
    >statement and it is now working again.
    > I am reading through the configuration guides on the Cisco website and
    > can't find anything wrong anymore.
    > Because I confused running and startup, the configuration that I included
    > in my initial posting was not the right one. Here is what is currently
    > active and, needless to say, I still can't get to the .109 box from the
    > outside. I am actually now trying this from within my 10.10.2.x network,
    > not really from the outside through the DSL router.


    You cannot test the current version of pix this way. The ASA will not let
    packets loop through the architecture. Any packet that arives at an
    interface must go out another interface, to the fw itself or be dropped.
    Also reading through the config, the only thing I see wrong is two acl's are
    bound to the outside interface. I don't know how this is possible. I would
    remove the invalid one (access-group acl_grp in interface outside)

    >
    > This is what I captured on the outside interface:
    >
    > 17:56:07.311446 arp reply 10.10.2.2 is-at 0:11:bb:e3:fc:41
    > 17:56:07.311690 10.10.2.199.1802 > 10.10.1.109.8081: S
    > 247213797:247213797(0) win 65535 <mss 1460,nop,nop,sackOK>
    > 17:56:10.312636 10.10.2.199.1802 > 10.10.1.109.8081: S
    > 247213797:247213797(0) win 65535 <mss 1460,nop,nop,sackOK>
    >
    > I don't see anything from 10.10.2.199 on the inside interface, though.


    Pix ASA architecture prohibits this. It would be nice for this to be
    optional in PIX os 7.

    >
    > Hint: I added 2 lines from Cisco's "Two Interfaces with NAT - Basic"
    > Configuration that are supposed to allow inbound and outbound pings, but
    > only outbound pings work.


    1). Add all of the entries for an interface to the same acl.

    and in your case

    2). You are only using a single IP address. Therefore, you cannot redirect
    the pings. That said, an inbound echo is sent the external ip of the pix
    itself. To permit that, you would do icmp permit any outside (or a variant,
    depending on your goal).

    >
    > Thanks again. I don't know what I would do without this group.
    >
    > Building configuration...
    > : Saved
    > :
    > PIX Version 6.3(3)
    > interface ethernet0 auto
    > interface ethernet1 100full
    > nameif ethernet0 outside security0
    > nameif ethernet1 inside security100
    > enable password <....> encrypted
    > passwd <....> encrypted
    > hostname pixfirewall
    > domain-name <....>
    > clock timezone EST -5
    > clock summer-time EDT recurring
    > fixup protocol dns maximum-length 512
    > fixup protocol ftp 21
    > fixup protocol h323 h225 1720
    > fixup protocol h323 ras 1718-1719
    > fixup protocol http 80
    > fixup protocol rsh 514
    > fixup protocol rtsp 554
    > fixup protocol sip 5060
    > fixup protocol sip udp 5060
    > fixup protocol skinny 2000
    > fixup protocol smtp 25
    > fixup protocol sqlnet 1521
    > fixup protocol tftp 69
    > names
    > access-list 101 permit tcp any host 10.10.2.2 eq 8081
    > access-list acl_grp permit icmp any any
    > pager lines 24
    > mtu outside 1500
    > mtu inside 1500
    > ip address outside 10.10.2.2 255.255.255.0
    > ip address inside 10.10.1.101 255.255.255.0
    > ip audit info action alarm
    > ip audit attack action alarm
    > pdm location 10.10.1.109 255.255.255.255 inside
    > pdm logging informational 100
    > pdm history enable
    > arp timeout 14400
    > global (outside) 1 interface
    > nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    > static (inside,outside) tcp 10.10.2.2 8081 10.10.1.109 www netmask
    > 255.255.255.255 0 0
    > access-group 101 in interface outside
    > access-group acl_grp in interface outside
    > route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    > timeout xlate 0:05:00
    > timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    > 1:00:00
    > timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    > timeout uauth 0:05:00 absolute
    > aaa-server TACACS+ protocol tacacs+
    > aaa-server RADIUS protocol radius
    > aaa-server LOCAL protocol local
    > http server enable
    > http 10.10.1.0 255.255.255.0 inside
    > no snmp-server location
    > no snmp-server contact
    > snmp-server community public
    > no snmp-server enable traps
    > floodguard enable
    > telnet 10.10.1.0 255.255.255.0 inside
    > telnet timeout 50
    > ssh 0.0.0.0 0.0.0.0 outside
    > ssh 10.10.1.0 255.255.255.0 inside
    > ssh timeout 30
    > console timeout 0
    > dhcpd address 10.10.1.170-10.10.1.199 inside
    > dhcpd dns 10.10.2.1 10.10.2.1
    > dhcpd lease 36000
    > dhcpd ping_timeout 750
    > dhcpd domain <....>
    > dhcpd auto_config outside
    > dhcpd enable inside
    > terminal width 80
    > Cryptochecksum:76ac95c4c1c90d0ec39ac1bd20dd649f
    > : end
    > [OK]
    >
    >
    >
    >
    > "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in
    > message news:413cd175$...
    >>
    >> "cdonner" <> wrote in message
    >> news:To2%c.10143$Cr5.5443@trndny08...
    >>> Thanks for your feedback.
    >>> Since it is still not working, I have a few more questions.
    >>>
    >>> a. clear xlate does not seem to have any effect. It does not revoke the
    >>> static translations rules. As a matter of fact, the Pix 501 help does
    >>> not show me the xlate command.
    >>>

    >>
    >> It only clears the translation table for rebuild. I.E. Show xlate.
    >>
    >>> b. I see different configurations when I enter 'show config' and when I
    >>> select "File/Show running configuration in new window" in PDM. How come?
    >>> Specifically, the telnet command line interpreter always shows me the
    >>> same old translation rules.

    >>
    >> show config and file Show running config is different. Show config is
    >> startup config. You would only see changes here if you had made changes
    >> then done a write mem.
    >>
    >>>
    >>> c. When I typed in your version of the static command in the telnet
    >>> window, it was accepted without error. When I run 'show config',
    >>> however, I don't see the new rule. I don't see it in PDM either. When I
    >>> tried to repeat the static command, I get

    >>
    >> write mem
    >>
    >> I would also recommend deleting the old one out by predicating it with
    >> "NO".
    >>
    >>
    >>>
    >>> pixfirewall(config)# static (inside,outside) tcp 10.10.2.2 8081
    >>> 10.10.1.109 80$
    >>> ERROR: duplicate of existing static
    >>>
    >>> tcp from inside:10.10.1.109/80 to outside:10.10.2.2/8081 netmask
    >>> 255.255.255.255
    >>> Usage: [no] static [(real_ifc, mapped_ifc)]
    >>> {<mapped_ip>|interface}
    >>> {<real_ip> [netmask <mask>]} | {access-list <acl_name>}
    >>> [dns] [norandomseq] [<max_conns> [<emb_lim>]]
    >>> [no] static [(real_ifc, mapped_ifc)] {tcp|udp}
    >>> {<mapped_ip>|interface} <mapped_port>
    >>> {<real_ip> <real_port> [netmask <mask>]} |
    >>> {access-list <acl_name>}
    >>> [dns] [norandomseq] [<max_conns> [<emb_lim>]]
    >>>
    >>> This is expected, but it still confuses me, because it seems it is
    >>> complaining about an existing inside-outside mapping, but I thought I
    >>> needed a mapping from outside to inside. What's wrong with that?
    >>>

    >>
    >> The mappings are bidirectional for the port address pair. Early pixes
    >> used only one to one statics. If you look at this being the root of the
    >> command it makes more sense.
    >>
    >>> Thanks for any additional input.
    >>> c ( a t ) d o n n e r s d o t c o m
    >>>
    >>>
    >>> "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in
    >>> message news:413c6746$...
    >>>>
    >>>> "cdonner" <> wrote in message
    >>>> news:eek:nO_c.1206$Gi5.299@trndny05...
    >>>>> This is my configuration:
    >>>>>
    >>>>> External DHCP-assigned IP
    >>>>> DSL Router (static NAT for 10.10.2.2)
    >>>>> 10.10.2.1
    >>>>> |
    >>>>> |
    >>>>> 10.10.2.2
    >>>>> PIX 501
    >>>>> 10.10.1.101
    >>>>> |
    >>>>> |
    >>>>> 10.10.1.109
    >>>>> Web Server (Port 80)
    >>>>>
    >>>>> I want to allow access from the outside world to my webserver. The
    >>>>> webserver runs on port 80 internally, but externally the port should
    >>>>> be mapped to 8081. The port mapping is just an additional twist, the
    >>>>> problem does not go away even when I run the webserver on port 8081
    >>>>> and don't map the port. The problem is that I don't seem to be able to
    >>>>> get in. I don't even see packets from the requesting client arriving
    >>>>> on the outside interface with "debug packet". Am I supposed to see
    >>>>> such packets even when the firewall does not allow them in? I would
    >>>>> assume so.
    >>>>> Before I installed the Pix, I had the DSL Router configured for static
    >>>>> NAT directly to my Web server's address. This has been working for
    >>>>> some time. It is possible that the problem is with the router, but I
    >>>>> don't believe so and I would like to run the PIX configuration by
    >>>>> someone who can take a look and let me know if I got it right. The
    >>>>> relevant lines are highlighted with the
    >>>>> <--------------------- arrow.
    >>>>>
    >>>>> Thanks.
    >>>>>
    >>>>>
    >>>>> PIX Version 6.3(3)
    >>>>> interface ethernet0 auto
    >>>>> interface ethernet1 100full
    >>>>> nameif ethernet0 outside security0
    >>>>> nameif ethernet1 inside security100
    >>>>> enable password <....> encrypted
    >>>>> passwd <....> encrypted
    >>>>> hostname pixfirewall
    >>>>> domain-name <....>
    >>>>> clock timezone EST -5
    >>>>> clock summer-time EDT recurring
    >>>>> fixup protocol dns maximum-length 512
    >>>>> fixup protocol ftp 21
    >>>>> fixup protocol h323 h225 1720
    >>>>> fixup protocol h323 ras 1718-1719
    >>>>> fixup protocol http 80
    >>>>> fixup protocol rsh 514
    >>>>> fixup protocol rtsp 554
    >>>>> fixup protocol sip 5060
    >>>>> fixup protocol sip udp 5060
    >>>>> fixup protocol skinny 2000
    >>>>> fixup protocol smtp 25
    >>>>> fixup protocol sqlnet 1521
    >>>>> fixup protocol tftp 69
    >>>>> names
    >>>>> access-list 100 permit icmp any any echo-reply
    >>>>> access-list 100 permit icmp any any time-exceeded
    >>>>> access-list 100 permit icmp any any unreachable
    >>>>> access-list 100 permit icmp any any
    >>>>> access-list 101 permit tcp any host 10.10.2.2 eq 8081
    >>>>> <---------------------
    >>>>> pager lines 24
    >>>>> logging on
    >>>>> logging buffered errors
    >>>>> logging trap notifications
    >>>>> mtu outside 1500
    >>>>> mtu inside 1500
    >>>>> ip address outside 10.10.2.2 255.255.255.0
    >>>>> ip address inside 10.10.1.101 255.255.255.0
    >>>>> ip audit info action alarm
    >>>>> ip audit attack action alarm
    >>>>> pdm location 10.10.1.109 255.255.255.255 inside
    >>>>> pdm location 10.10.1.171 255.255.255.255 inside
    >>>>> pdm location 10.10.2.2 255.255.255.255 inside
    >>>>> pdm logging informational 100
    >>>>> pdm history enable
    >>>>> arp timeout 14400
    >>>>> global (outside) 1 interface
    >>>>> global (inside) 2 interface
    >>>>> nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    >>>>> static (inside,outside) tcp 10.10.1.109 www 10.10.2.2 8081 netmask
    >>>>> 255.255.255.255 0 0 <---------------------
    >>>>
    >>>> Assuming 10.10.1.109 is your web server, your static is backwards.
    >>>>
    >>>> Try:
    >>>>
    >>>> static (inside,outside) tcp 10.10.2.2 8081 10.10.1.109 www netmask
    >>>> 255.255.255.255 0 0
    >>>>
    >>>> Make sure you do a "clear xlate".
    >>>>
    >>>>> access-group 101 in interface outside <---------------------
    >>>>> route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    >>>>> timeout xlate 0:05:00
    >>>>> timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    >>>>> 1:00:00
    >>>>> timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    >>>>> timeout uauth 0:05:00 absolute
    >>>>> aaa-server TACACS+ protocol tacacs+
    >>>>> aaa-server RADIUS protocol radius
    >>>>> aaa-server LOCAL protocol local
    >>>>> http server enable
    >>>>> http 10.10.1.0 255.255.255.0 inside
    >>>>> no snmp-server location
    >>>>> no snmp-server contact
    >>>>> snmp-server community public
    >>>>> no snmp-server enable traps
    >>>>> floodguard enable
    >>>>> telnet 10.10.1.0 255.255.255.0 inside
    >>>>> telnet timeout 5
    >>>>> ssh timeout 5
    >>>>> console timeout 0
    >>>>> dhcpd address 10.10.1.170-10.10.1.199 inside
    >>>>> dhcpd dns 10.10.2.1 10.10.2.1
    >>>>> dhcpd lease 3600
    >>>>> dhcpd ping_timeout 750
    >>>>> dhcpd domain <....>.
    >>>>> dhcpd auto_config outside
    >>>>> dhcpd enable inside
    >>>>> terminal width 80
    >>>>> Cryptochecksum:<....>
    >>>>> : end
    >>>>> [OK]
    >>>>>
    >>>>
    >>>>
    >>>
    >>>

    >>
    >>

    >
    >
    PES, Sep 6, 2004
    #8
  9. cdonner

    cdonner Guest

    I just added a switch to my outside subnet and I am working from there. My
    workstation gets the IP address from the router's DHCP server. The router
    does not care, and why should the firewall? The router knows what its subnet
    is and directs packets accordingly. I can access the outside box frm the
    inside fine, just not the other way. Essentially, I have the Two Interfaces
    with NAT - Advanced configuration depicted at
    http://www.cisco.com/en/US/products...on_guide_chapter09186a008008cd40.html#1020102.
    Can you explain why you think this does not work?

    Thanks c.


    "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in message
    news:...
    >
    > "cdonner" <> wrote in message
    > news:1j5%c.5850$wF4.983@trndny09...
    >>I appologize for my ignorance. I am learning as fast as I can. I was
    >>struggling with getting outbound traffic to work again after I had done a
    >>'reset firewall to default factory configuration'. I found this odd, since
    >>it worked when I first plugged it in. I finally found the missing 'route'
    >>statement and it is now working again.
    >> I am reading through the configuration guides on the Cisco website and
    >> can't find anything wrong anymore.
    >> Because I confused running and startup, the configuration that I included
    >> in my initial posting was not the right one. Here is what is currently
    >> active and, needless to say, I still can't get to the .109 box from the
    >> outside. I am actually now trying this from within my 10.10.2.x network,
    >> not really from the outside through the DSL router.

    >
    > You cannot test the current version of pix this way. The ASA will not let
    > packets loop through the architecture. Any packet that arives at an
    > interface must go out another interface, to the fw itself or be dropped.
    > Also reading through the config, the only thing I see wrong is two acl's
    > are bound to the outside interface. I don't know how this is possible. I
    > would remove the invalid one (access-group acl_grp in interface outside)
    >
    >>
    >> This is what I captured on the outside interface:
    >>
    >> 17:56:07.311446 arp reply 10.10.2.2 is-at 0:11:bb:e3:fc:41
    >> 17:56:07.311690 10.10.2.199.1802 > 10.10.1.109.8081: S
    >> 247213797:247213797(0) win 65535 <mss 1460,nop,nop,sackOK>
    >> 17:56:10.312636 10.10.2.199.1802 > 10.10.1.109.8081: S
    >> 247213797:247213797(0) win 65535 <mss 1460,nop,nop,sackOK>
    >>
    >> I don't see anything from 10.10.2.199 on the inside interface, though.

    >
    > Pix ASA architecture prohibits this. It would be nice for this to be
    > optional in PIX os 7.
    >
    >>
    >> Hint: I added 2 lines from Cisco's "Two Interfaces with NAT - Basic"
    >> Configuration that are supposed to allow inbound and outbound pings, but
    >> only outbound pings work.

    >
    > 1). Add all of the entries for an interface to the same acl.
    >
    > and in your case
    >
    > 2). You are only using a single IP address. Therefore, you cannot
    > redirect the pings. That said, an inbound echo is sent the external ip of
    > the pix itself. To permit that, you would do icmp permit any outside (or
    > a variant, depending on your goal).
    >
    >>
    >> Thanks again. I don't know what I would do without this group.
    >>
    >> Building configuration...
    >> : Saved
    >> :
    >> PIX Version 6.3(3)
    >> interface ethernet0 auto
    >> interface ethernet1 100full
    >> nameif ethernet0 outside security0
    >> nameif ethernet1 inside security100
    >> enable password <....> encrypted
    >> passwd <....> encrypted
    >> hostname pixfirewall
    >> domain-name <....>
    >> clock timezone EST -5
    >> clock summer-time EDT recurring
    >> fixup protocol dns maximum-length 512
    >> fixup protocol ftp 21
    >> fixup protocol h323 h225 1720
    >> fixup protocol h323 ras 1718-1719
    >> fixup protocol http 80
    >> fixup protocol rsh 514
    >> fixup protocol rtsp 554
    >> fixup protocol sip 5060
    >> fixup protocol sip udp 5060
    >> fixup protocol skinny 2000
    >> fixup protocol smtp 25
    >> fixup protocol sqlnet 1521
    >> fixup protocol tftp 69
    >> names
    >> access-list 101 permit tcp any host 10.10.2.2 eq 8081
    >> access-list acl_grp permit icmp any any
    >> pager lines 24
    >> mtu outside 1500
    >> mtu inside 1500
    >> ip address outside 10.10.2.2 255.255.255.0
    >> ip address inside 10.10.1.101 255.255.255.0
    >> ip audit info action alarm
    >> ip audit attack action alarm
    >> pdm location 10.10.1.109 255.255.255.255 inside
    >> pdm logging informational 100
    >> pdm history enable
    >> arp timeout 14400
    >> global (outside) 1 interface
    >> nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    >> static (inside,outside) tcp 10.10.2.2 8081 10.10.1.109 www netmask
    >> 255.255.255.255 0 0
    >> access-group 101 in interface outside
    >> access-group acl_grp in interface outside
    >> route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    >> timeout xlate 0:05:00
    >> timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    >> 1:00:00
    >> timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    >> timeout uauth 0:05:00 absolute
    >> aaa-server TACACS+ protocol tacacs+
    >> aaa-server RADIUS protocol radius
    >> aaa-server LOCAL protocol local
    >> http server enable
    >> http 10.10.1.0 255.255.255.0 inside
    >> no snmp-server location
    >> no snmp-server contact
    >> snmp-server community public
    >> no snmp-server enable traps
    >> floodguard enable
    >> telnet 10.10.1.0 255.255.255.0 inside
    >> telnet timeout 50
    >> ssh 0.0.0.0 0.0.0.0 outside
    >> ssh 10.10.1.0 255.255.255.0 inside
    >> ssh timeout 30
    >> console timeout 0
    >> dhcpd address 10.10.1.170-10.10.1.199 inside
    >> dhcpd dns 10.10.2.1 10.10.2.1
    >> dhcpd lease 36000
    >> dhcpd ping_timeout 750
    >> dhcpd domain <....>
    >> dhcpd auto_config outside
    >> dhcpd enable inside
    >> terminal width 80
    >> Cryptochecksum:76ac95c4c1c90d0ec39ac1bd20dd649f
    >> : end
    >> [OK]
    >>
    >>



    <truncated the rest>
    cdonner, Sep 7, 2004
    #9
  10. cdonner

    PES Guest

    "cdonner" <> wrote in message
    news:p48%c.11742$Cr5.5484@trndny08...
    >I just added a switch to my outside subnet and I am working from there. My
    >workstation gets the IP address from the router's DHCP server. The router
    >does not care, and why should the firewall? The router knows what its
    >subnet is and directs packets accordingly.


    If you are talking about the inability of the pix to reroute packets through
    the same interface, it just cannot currently do that. It is the
    architecture of the pix. Any packet arriving on one interface cannot leave
    the same interface. In my opinion the Pix is not and should not be
    considered a router. This group has varying opininions on whether or not it
    should be considered a router and it has be discussed in the past.

    > I can access the outside box frm the inside fine, just not the other way.
    > Essentially, I have the Two Interfaces with NAT - Advanced configuration
    > depicted at

    http://www.cisco.com/en/US/products...on_guide_chapter09186a008008cd40.html#1020102.
    > Can you explain why you think this does not work?
    >


    Can you post your configuration as it is currently. The document that you
    reference is sound. For inbound communication to work, you need a static
    and an access-list. I'm not sure what you cannot access now from the
    outside. Your previous configuration and question was pointing port 8081 to
    the port 80 on a web server. As stated previously, that requires a static
    and a nat. You also questioned sending an ICMP echo to the same address.
    This address is the address of the interface (you cannot static icmp's to an
    internal host unless you create a one to one translation). As long as you
    are sending icmp echo's to an interface on the pix, you need to enable it to
    receive that type of icmp on the interface. It has absolutely nothing to do
    with acl's which check packets going through the pix. The command to do
    this is "icmp permit any outside".

    >
    >
    > "PES" <NO*SPAMpestewartREMOVE**SUCKS> wrote in
    > message news:...
    >>
    >> "cdonner" <> wrote in message
    >> news:1j5%c.5850$wF4.983@trndny09...
    >>>I appologize for my ignorance. I am learning as fast as I can. I was
    >>>struggling with getting outbound traffic to work again after I had done a
    >>>'reset firewall to default factory configuration'. I found this odd,
    >>>since it worked when I first plugged it in. I finally found the missing
    >>>'route' statement and it is now working again.
    >>> I am reading through the configuration guides on the Cisco website and
    >>> can't find anything wrong anymore.
    >>> Because I confused running and startup, the configuration that I
    >>> included in my initial posting was not the right one. Here is what is
    >>> currently active and, needless to say, I still can't get to the .109 box
    >>> from the outside. I am actually now trying this from within my 10.10.2.x
    >>> network, not really from the outside through the DSL router.

    >>
    >> You cannot test the current version of pix this way. The ASA will not
    >> let packets loop through the architecture. Any packet that arives at an
    >> interface must go out another interface, to the fw itself or be dropped.
    >> Also reading through the config, the only thing I see wrong is two acl's
    >> are bound to the outside interface. I don't know how this is possible.
    >> I would remove the invalid one (access-group acl_grp in interface
    >> outside)
    >>
    >>>
    >>> This is what I captured on the outside interface:
    >>>
    >>> 17:56:07.311446 arp reply 10.10.2.2 is-at 0:11:bb:e3:fc:41
    >>> 17:56:07.311690 10.10.2.199.1802 > 10.10.1.109.8081: S
    >>> 247213797:247213797(0) win 65535 <mss 1460,nop,nop,sackOK>
    >>> 17:56:10.312636 10.10.2.199.1802 > 10.10.1.109.8081: S
    >>> 247213797:247213797(0) win 65535 <mss 1460,nop,nop,sackOK>
    >>>
    >>> I don't see anything from 10.10.2.199 on the inside interface, though.

    >>
    >> Pix ASA architecture prohibits this. It would be nice for this to be
    >> optional in PIX os 7.
    >>
    >>>
    >>> Hint: I added 2 lines from Cisco's "Two Interfaces with NAT - Basic"
    >>> Configuration that are supposed to allow inbound and outbound pings, but
    >>> only outbound pings work.

    >>
    >> 1). Add all of the entries for an interface to the same acl.
    >>
    >> and in your case
    >>
    >> 2). You are only using a single IP address. Therefore, you cannot
    >> redirect the pings. That said, an inbound echo is sent the external ip
    >> of the pix itself. To permit that, you would do icmp permit any outside
    >> (or a variant, depending on your goal).
    >>
    >>>
    >>> Thanks again. I don't know what I would do without this group.
    >>>
    >>> Building configuration...
    >>> : Saved
    >>> :
    >>> PIX Version 6.3(3)
    >>> interface ethernet0 auto
    >>> interface ethernet1 100full
    >>> nameif ethernet0 outside security0
    >>> nameif ethernet1 inside security100
    >>> enable password <....> encrypted
    >>> passwd <....> encrypted
    >>> hostname pixfirewall
    >>> domain-name <....>
    >>> clock timezone EST -5
    >>> clock summer-time EDT recurring
    >>> fixup protocol dns maximum-length 512
    >>> fixup protocol ftp 21
    >>> fixup protocol h323 h225 1720
    >>> fixup protocol h323 ras 1718-1719
    >>> fixup protocol http 80
    >>> fixup protocol rsh 514
    >>> fixup protocol rtsp 554
    >>> fixup protocol sip 5060
    >>> fixup protocol sip udp 5060
    >>> fixup protocol skinny 2000
    >>> fixup protocol smtp 25
    >>> fixup protocol sqlnet 1521
    >>> fixup protocol tftp 69
    >>> names
    >>> access-list 101 permit tcp any host 10.10.2.2 eq 8081
    >>> access-list acl_grp permit icmp any any
    >>> pager lines 24
    >>> mtu outside 1500
    >>> mtu inside 1500
    >>> ip address outside 10.10.2.2 255.255.255.0
    >>> ip address inside 10.10.1.101 255.255.255.0
    >>> ip audit info action alarm
    >>> ip audit attack action alarm
    >>> pdm location 10.10.1.109 255.255.255.255 inside
    >>> pdm logging informational 100
    >>> pdm history enable
    >>> arp timeout 14400
    >>> global (outside) 1 interface
    >>> nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    >>> static (inside,outside) tcp 10.10.2.2 8081 10.10.1.109 www netmask
    >>> 255.255.255.255 0 0
    >>> access-group 101 in interface outside
    >>> access-group acl_grp in interface outside
    >>> route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    >>> timeout xlate 0:05:00
    >>> timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    >>> 1:00:00
    >>> timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    >>> timeout uauth 0:05:00 absolute
    >>> aaa-server TACACS+ protocol tacacs+
    >>> aaa-server RADIUS protocol radius
    >>> aaa-server LOCAL protocol local
    >>> http server enable
    >>> http 10.10.1.0 255.255.255.0 inside
    >>> no snmp-server location
    >>> no snmp-server contact
    >>> snmp-server community public
    >>> no snmp-server enable traps
    >>> floodguard enable
    >>> telnet 10.10.1.0 255.255.255.0 inside
    >>> telnet timeout 50
    >>> ssh 0.0.0.0 0.0.0.0 outside
    >>> ssh 10.10.1.0 255.255.255.0 inside
    >>> ssh timeout 30
    >>> console timeout 0
    >>> dhcpd address 10.10.1.170-10.10.1.199 inside
    >>> dhcpd dns 10.10.2.1 10.10.2.1
    >>> dhcpd lease 36000
    >>> dhcpd ping_timeout 750
    >>> dhcpd domain <....>
    >>> dhcpd auto_config outside
    >>> dhcpd enable inside
    >>> terminal width 80
    >>> Cryptochecksum:76ac95c4c1c90d0ec39ac1bd20dd649f
    >>> : end
    >>> [OK]
    >>>
    >>>

    >
    >
    > <truncated the rest>
    >
    PES, Sep 7, 2004
    #10
  11. cdonner

    cdonner Guest

    It is working now. I am not exactly sure which change did the trick,
    probably a combination of things.
    First off all, while trying to connect from my outside subnet, I used the
    inside IP address instead of the outside interface IP.
    Second, changing the outside IP in the static command to 'interface' was
    essential.
    Third, I had played around with the NAT configuration in the DSL router and
    forgotten to change the rule back to what it was supposed to be.

    Thanks again. Here is the working configuration:

    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password [....] encrypted
    passwd [....] encrypted
    hostname pixfirewall
    domain-name [....]
    clock timezone EST -5
    clock summer-time EDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 101 permit tcp any host 10.10.2.2 eq 8081
    access-list 101 permit icmp any any
    access-list 101 permit tcp any host 10.10.2.2 eq 5900
    access-list 101 permit tcp any host 10.10.2.2 eq ssh
    access-list 101 permit tcp any host 10.10.2.2 eq https
    access-list 101 permit tcp any host 10.10.2.2 eq 444
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside 10.10.2.2 255.255.255.0
    ip address inside 10.10.1.101 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 10.10.1.109 255.255.255.255 inside
    pdm logging informational 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp interface 8081 10.10.1.109 www netmask
    255.255.255.255 0 0
    static (inside,outside) tcp interface 5900 10.10.1.109 5900 netmask
    255.255.255.255 0 0
    static (inside,outside) tcp interface https 10.10.1.110 https netmask
    255.255.255.255 0 0
    static (inside,outside) tcp interface 444 10.10.1.111 https netmask
    255.255.255.255 0 0
    access-group 101 in interface outside
    route outside 0.0.0.0 0.0.0.0 10.10.2.1 1
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 10.10.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    telnet 10.10.1.0 255.255.255.0 inside
    telnet timeout 50
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 10.10.1.0 255.255.255.0 inside
    ssh timeout 30
    console timeout 0
    dhcpd address 10.10.1.170-10.10.1.199 inside
    dhcpd dns 10.10.2.1 10.10.2.1
    dhcpd lease 36000
    dhcpd ping_timeout 750
    dhcpd domain [....]
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80
    : end
    cdonner, Sep 8, 2004
    #11
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Shawn Westerhoff

    Re: PIX 501 configuration headache

    Shawn Westerhoff, Oct 15, 2003, in forum: Cisco
    Replies:
    0
    Views:
    494
    Shawn Westerhoff
    Oct 15, 2003
  2. Walter Roberson

    Re: (newbie) PIX-501 Configuration scripts

    Walter Roberson, Feb 5, 2004, in forum: Cisco
    Replies:
    1
    Views:
    536
    Justin
    Feb 5, 2004
  3. Brian P Flounders

    PIX 501 configuration help: T1 with IP range

    Brian P Flounders, Jun 7, 2004, in forum: Cisco
    Replies:
    0
    Views:
    590
    Brian P Flounders
    Jun 7, 2004
  4. Andre
    Replies:
    7
    Views:
    682
    Andre
    Feb 20, 2005
  5. cdoc

    Cisco pix 501 vs 501-50

    cdoc, May 19, 2006, in forum: Cisco
    Replies:
    6
    Views:
    621
    Walter Roberson
    May 20, 2006
Loading...

Share This Page