Pictures Don't Load in Firefox

Discussion in 'Firefox' started by ~ narnia ~, Dec 23, 2005.

  1. ~ narnia ~

    ~ narnia ~ Guest

    I'm using Firefox 1.5. When I go to catalog websites and click on a
    selection, the picture doesn't load. For example, if I go to Gap.com
    and click on an item, everything on the page loads except for the
    picture of the item.

    Is there a setting I should change in Firefox so I can view pictures?

    Thanks!
    ~ narnia ~, Dec 23, 2005
    #1
    1. Advertising

  2. ~ narnia ~

    gwtc Guest

    ~ narnia ~ wrote:
    > I'm using Firefox 1.5. When I go to catalog websites and click on a
    > selection, the picture doesn't load. For example, if I go to Gap.com
    > and click on an item, everything on the page loads except for the
    > picture of the item.
    >
    > Is there a setting I should change in Firefox so I can view pictures?
    >
    > Thanks!

    check the following: Tools, Options, Content, and make sure that "Load
    Images" is checked and "for the originating web site only" is unchecked.

    Does this solve your problem?
    gwtc, Dec 23, 2005
    #2
    1. Advertising

  3. ~ narnia ~

    ~ narnia ~ Guest

    On Thu, 22 Dec 2005 19:40:30 -0800, gwtc
    <> wrote:

    >~ narnia ~ wrote:
    >> I'm using Firefox 1.5. When I go to catalog websites and click on a
    >> selection, the picture doesn't load. For example, if I go to Gap.com
    >> and click on an item, everything on the page loads except for the
    >> picture of the item.
    >>
    >> Is there a setting I should change in Firefox so I can view pictures?
    >>
    >> Thanks!

    >check the following: Tools, Options, Content, and make sure that "Load
    >Images" is checked and "for the originating web site only" is unchecked.
    >
    >Does this solve your problem?


    Thanks, but I did have those selections :-(
    ~ narnia ~, Dec 23, 2005
    #3
  4. ~ narnia ~

    Jason L © Guest

    Jason L ©, Dec 23, 2005
    #4
  5. ~ narnia ~

    Stubby Guest

    Jason L © wrote:
    > You have to have your javascript enabled for viewing that site. Make sure
    > the enable java and javascript boxes are selected in Options>Content.
    > Gap.com explains what you need to view their site:
    > http://www.gap.com/customerService/info.do?cid=2334
    >
    >

    But doesn't that permit viruses on your machine?
    Stubby, Dec 23, 2005
    #5
  6. ~ narnia ~

    Jason L © Guest

    "Stubby" <> wrote in message
    news:eek:...
    > Jason L © wrote:
    >> You have to have your javascript enabled for viewing that site. Make sure
    >> the enable java and javascript boxes are selected in Options>Content.
    >> Gap.com explains what you need to view their site:
    >> http://www.gap.com/customerService/info.do?cid=2334

    > But doesn't that permit viruses on your machine?


    Firefox has fixed many security flaws for javascript and doesn't use
    Microsoft's Java VM, but I would recommend using an anti-virus on any
    machine. The two things that are not supported are VBScript and ActiveX
    which are the reasons for many of IE's security holes. If you are wary, I
    would turn it on just for the sites you know are safe.
    Try these extensions:

    NoScript - Extra protection for your Firefox: NoScript allows JavaScript,
    Java (and other plugins) only for trusted domains of your choice (e.g. your
    home-banking web site).
    https://addons.mozilla.org/extensions/moreinfo.php?id=722&application=firefox

    QuickJava - Allows quick enable and disable of Java and Javascript from
    statusbar.
    https://addons.mozilla.org/extensions/moreinfo.php?id=1237&application=firefox
    Jason L ©, Dec 23, 2005
    #6
  7. ~ narnia ~

    ~ narnia ~ Guest

    On Fri, 23 Dec 2005 09:27:26 -0500, "Jason L ©"
    <> wrote:

    >
    >You have to have your javascript enabled for viewing that site. Make sure
    >the enable java and javascript boxes are selected in Options>Content.
    >Gap.com explains what you need to view their site:
    >http://www.gap.com/customerService/info.do?cid=2334


    Have both Java and JavaScript enabled. Maybe I should just uninstall
    and reinstall Firefox.
    ~ narnia ~, Dec 23, 2005
    #7
  8. ~ narnia ~

    Tony Raven Guest

    Jason L © wrote:
    >
    > NoScript - Extra protection for your Firefox: NoScript allows JavaScript,
    > Java (and other plugins) only for trusted domains of your choice (e.g. your
    > home-banking web site).
    > https://addons.mozilla.org/extensions/moreinfo.php?id=722&application=firefox
    >


    I use NoScript but its a pain to be honest. Not because of NoScript but
    because there are virtually no sites that don't use javascript and I
    spend most of my time allowing domains to get the pages or links to
    work. Mind you seeing which other domains are trying to run script on
    many pages provides the incentive to go through with the hassle.


    --
    Tony

    "The best way I know of to win an argument is to start by being in the
    right."
    - Lord Hailsham
    Tony Raven, Dec 23, 2005
    #8
  9. ~ narnia ~

    gwtc Guest

    ~ narnia ~ wrote:

    > On Fri, 23 Dec 2005 09:27:26 -0500, "Jason L ©"
    > <> wrote:
    >
    >
    >>You have to have your javascript enabled for viewing that site. Make sure
    >>the enable java and javascript boxes are selected in Options>Content.
    >>Gap.com explains what you need to view their site:
    >>http://www.gap.com/customerService/info.do?cid=2334

    >
    >
    > Have both Java and JavaScript enabled. Maybe I should just uninstall
    > and reinstall Firefox.
    >
    >

    stop uninstalling and reinstalling. That won't solve your problem.
    The problem is within your profile, a setting somewhere. Your profile
    is located in a different location than the program directory. When
    you uninstall, all you're doing is removing the program, not the profile.

    Take a look here: in the address bar type in about:config and look
    for this entry:

    dom.disable_image_src_set

    if its set to true, double click on it and change it to false.

    Does this help?
    gwtc, Dec 23, 2005
    #9
  10. ~ narnia ~

    ~ narnia ~ Guest

    On Fri, 23 Dec 2005 10:10:45 -0800, gwtc
    <> wrote:

    >~ narnia ~ wrote:
    >
    >> On Fri, 23 Dec 2005 09:27:26 -0500, "Jason L ©"
    >> <> wrote:
    >>
    >>
    >>>You have to have your javascript enabled for viewing that site. Make sure
    >>>the enable java and javascript boxes are selected in Options>Content.
    >>>Gap.com explains what you need to view their site:
    >>>http://www.gap.com/customerService/info.do?cid=2334

    >>
    >>
    >> Have both Java and JavaScript enabled. Maybe I should just uninstall
    >> and reinstall Firefox.
    >>
    >>

    >stop uninstalling and reinstalling. That won't solve your problem.
    >The problem is within your profile, a setting somewhere. Your profile
    >is located in a different location than the program directory. When
    >you uninstall, all you're doing is removing the program, not the profile.
    >
    >Take a look here: in the address bar type in about:config and look
    >for this entry:
    >
    >dom.disable_image_src_set
    >
    >if its set to true, double click on it and change it to false.
    >
    >Does this help?


    That did it - thanks a million!
    ~ narnia ~, Dec 23, 2005
    #10
  11. gwtc wrote:
    > ~ narnia ~ wrote:
    >
    >> On Fri, 23 Dec 2005 09:27:26 -0500, "Jason L ©"
    >> <> wrote:
    >>
    >>
    >>> You have to have your javascript enabled for viewing that site. Make
    >>> sure the enable java and javascript boxes are selected in
    >>> Options>Content. Gap.com explains what you need to view their site:
    >>> http://www.gap.com/customerService/info.do?cid=2334

    >>
    >>
    >> Have both Java and JavaScript enabled. Maybe I should just uninstall
    >> and reinstall Firefox.
    >>
    >>

    > stop uninstalling and reinstalling. That won't solve your problem. The
    > problem is within your profile, a setting somewhere. Your profile is
    > located in a different location than the program directory. When you
    > uninstall, all you're doing is removing the program, not the profile.
    >
    > Take a look here: in the address bar type in about:config and look for
    > this entry:
    >
    > dom.disable_image_src_set
    >
    > if its set to true, double click on it and change it to false.
    >
    > Does this help?



    Good call, gwtc!

    For further reference, this pref was not hidden in 1.0.7, it could be
    changed in the UI as part of the advanced javascript settings. For some
    reason it was taken out.

    There is a helpful extension, Configuration Mania:

    http://members.lycos.co.uk/toolbarpalette/

    This adds back the capability to change prefs in the UI, through
    Tools>>Configuration Mania.

    note the extension creator is Japanese, and the English dialog window
    has some eccentric entries. This particular pref is under the Security
    tab, Javascript, More advanced. Disable Chaging Images. That's what it
    says.

    More to the point though, it works.

    Lee
    Leonidas Jones, Dec 24, 2005
    #11
  12. ~ narnia ~

    gwtc Guest

    Leonidas Jones wrote:

    > gwtc wrote:
    >
    >>~ narnia ~ wrote:
    >>
    >>
    >>>On Fri, 23 Dec 2005 09:27:26 -0500, "Jason L ©"
    >>><> wrote:
    >>>
    >>>
    >>>
    >>>>You have to have your javascript enabled for viewing that site. Make
    >>>>sure the enable java and javascript boxes are selected in
    >>>>Options>Content. Gap.com explains what you need to view their site:
    >>>>http://www.gap.com/customerService/info.do?cid=2334
    >>>
    >>>
    >>>Have both Java and JavaScript enabled. Maybe I should just uninstall
    >>>and reinstall Firefox.
    >>>
    >>>

    >>
    >>stop uninstalling and reinstalling. That won't solve your problem. The
    >>problem is within your profile, a setting somewhere. Your profile is
    >>located in a different location than the program directory. When you
    >>uninstall, all you're doing is removing the program, not the profile.
    >>
    >>Take a look here: in the address bar type in about:config and look for
    >>this entry:
    >>
    >>dom.disable_image_src_set
    >>
    >>if its set to true, double click on it and change it to false.
    >>
    >>Does this help?

    >
    >
    >
    > Good call, gwtc!
    >
    > For further reference, this pref was not hidden in 1.0.7, it could be
    > changed in the UI as part of the advanced javascript settings. For some
    > reason it was taken out.
    >
    > There is a helpful extension, Configuration Mania:
    >
    > http://members.lycos.co.uk/toolbarpalette/
    >
    > This adds back the capability to change prefs in the UI, through
    > Tools>>Configuration Mania.
    >
    > note the extension creator is Japanese, and the English dialog window
    > has some eccentric entries. This particular pref is under the Security
    > tab, Javascript, More advanced. Disable Chaging Images. That's what it
    > says.
    >
    > More to the point though, it works.
    >
    > Lee
    >
    >
    >

    it seems the developers have left out a lot of things from the older
    version.
    gwtc, Dec 24, 2005
    #12
  13. Tony Raven wrote:

    > Jason L © wrote:
    >
    >>
    >> NoScript - Extra protection for your Firefox: NoScript allows
    >> JavaScript, Java (and other plugins) only for trusted domains of your
    >> choice (e.g. your home-banking web site).
    >> https://addons.mozilla.org/extensions/moreinfo.php?id=722&application=firefox
    >>
    >>

    >
    > I use NoScript but its a pain to be honest. Not because of NoScript
    > but because there are virtually no sites that don't use javascript and
    > I spend most of my time allowing domains to get the pages or links to
    > work. Mind you seeing which other domains are trying to run script on
    > many pages provides the incentive to go through with the hassle.
    >
    >

    Javascript is quite safe to use. Tho there were some 'exploits'
    reported, there has never been a case where they were used.

    Show me one site (just one) that uses a javascript exploit (other than a
    proof of concept) and I will show you a site that will be closed within
    the day. Fear of javascript is simply fear of possibilities.

    I have run for over 10 years on the internet, always with javascript
    enabled, on both windows and macs. And I go to many 'unsavoury' sites in
    the course of testing for others, I also visit each and every spam site
    I am sent, yet to date, not one problem. My advice? Turn on javascript
    and dont worry about it.
    Moz Champion (Dan), Dec 24, 2005
    #13
  14. ~ narnia ~

    Tony Raven Guest

    Moz Champion (Dan) wrote:
    >
    > I have run for over 10 years on the internet, always with javascript
    > enabled, on both windows and macs. And I go to many 'unsavoury'
    > sites in the course of testing for others, I also visit each and
    > every spam site I am sent, yet to date, not one problem. My advice?
    > Turn on javascript and dont worry about it.


    Perhaps you're right but I still feel uncomfortable seeing all the
    extraneous javascripts like Doubleclick that you find running on many sites

    --
    Tony

    "The best way I know of to win an argument is to start by being in the
    right."
    - Lord Hailsham
    Tony Raven, Dec 24, 2005
    #14
  15. ~ narnia ~

    Z Guest

    Moz Champion (Dan) wrote:
    > Javascript is quite safe to use. Tho there were some 'exploits'
    > reported, there has never been a case where they were used.


    And, IMO, there will be more exploits in the future.

    From May of this year:

    Two vulnerabilities in the popular Firefox browser have been rated
    "extremely critical" because exploit code is now available to take
    advantage of them." Security firm Secunia reported the vulnerabilities...

    "As interim fixes, Mozilla is encouraging users to either deactivate
    JavaScript or to set the brower to not accept installation of additional
    software, such as extensions or themes. Mozilla also plans to release a
    security update called Firefox 1.0.4."
    Z, Dec 25, 2005
    #15
  16. Z wrote:
    > Moz Champion (Dan) wrote:
    >> Javascript is quite safe to use. Tho there were some 'exploits'
    >> reported, there has never been a case where they were used.

    >
    > And, IMO, there will be more exploits in the future.
    >
    > From May of this year:
    >
    > Two vulnerabilities in the popular Firefox browser have been rated
    > "extremely critical" because exploit code is now available to take
    > advantage of them." Security firm Secunia reported the vulnerabilities...
    >
    > "As interim fixes, Mozilla is encouraging users to either deactivate
    > JavaScript or to set the brower to not accept installation of additional
    > software, such as extensions or themes. Mozilla also plans to release a
    > security update called Firefox 1.0.4."


    As I recall though, there were no reports of an actual use of the
    exploit for malicious purposes, only that it was possible, and even so,
    was quickly fixed.

    I agree with Dan, disabling javascript on full time basis in not
    necessary. It simply disables many web sites.

    However, I would certainly not criticize you for being too safe.

    Lee
    Leonidas Jones, Dec 25, 2005
    #16
  17. Tony Raven wrote:

    > Moz Champion (Dan) wrote:
    >
    >>
    >> I have run for over 10 years on the internet, always with javascript
    >> enabled, on both windows and macs. And I go to many 'unsavoury'
    >> sites in the course of testing for others, I also visit each and
    >> every spam site I am sent, yet to date, not one problem. My advice?
    >> Turn on javascript and dont worry about it.

    >
    >
    > Perhaps you're right but I still feel uncomfortable seeing all the
    > extraneous javascripts like Doubleclick that you find running on many
    > sites
    >

    Then dont visit those sites <g>
    Moz Champion (Dan), Dec 25, 2005
    #17
  18. Z wrote:

    > Moz Champion (Dan) wrote:
    >
    >> Javascript is quite safe to use. Tho there were some 'exploits'
    >> reported, there has never been a case where they were used.

    >
    >
    > And, IMO, there will be more exploits in the future.
    >
    > From May of this year:
    >
    > Two vulnerabilities in the popular Firefox browser have been rated
    > "extremely critical" because exploit code is now available to take
    > advantage of them." Security firm Secunia reported the vulnerabilities...
    >
    > "As interim fixes, Mozilla is encouraging users to either deactivate
    > JavaScript or to set the brower to not accept installation of additional
    > software, such as extensions or themes. Mozilla also plans to release a
    > security update called Firefox 1.0.4."


    And those exploits were never used, tho its well known that the majority
    of users dont upgrade. 'Extremely critical' or not, if there are no
    sites using the method to adversely affect the product, then why worry
    about such?

    Its really strange. I can recall several instances when a 'extremely
    critical' vulnerability was found in both IE and Netscape 4x. Microsoft
    released a patch to fix, and Netscape rolled out a new version, and the
    'exploit' was never heard of again. Yet, even two year after, over 60%
    of internet users were still using versions that didnt have the fix.

    These two vulnerabilities you note, never used (aside from a proof of
    concept), yet look around in various newsgroups, you can still find
    people using Firefox 1.0.3 or less. The current version of Firefox is
    1.5, and there were three more point releases AFTER the one that fixed
    those two vulnerabilites.

    In 99 percent of 'exploits' once the 'fix' is available, then its never
    used. Any website that attempted to use such would be shut down by its
    host pdq

    Note. There are literally over twenty thousand viruses that can be
    contacted via the use of exe programs, you see them in email almost all
    the time. Find ONE example where such is available on the web, just
    ONE. You cant, because the site wouldnt last a week (a day in most
    cases). Yet there are there, the POSSIBILITY exists, yet exe programs
    are quite common for download. You are 'afraid' or 'uncomfortable' with
    javascript because there MIGHT be something untoward in the future, yet
    you fully ACCEPT downloading exe files, even tho there are over twenty
    thousand examples of bad ones available?

    Once again, I have been on the internet for almost 10 years, runing both
    macs and windows, with javasctipt enabled. I visit every spam site I
    have received in the last 5 years, and go to many 'unsavoury' sites in
    the course of testing for others. Yet in all that time I have yet to get
    any 'malware' (trojans, viruses, backdoor programs, etc) on any of my
    machines. I have yet to see ANY javasctipt exploit that is to fear or
    even feel uncomfortable about.
    Moz Champion (Dan), Dec 25, 2005
    #18
  19. ~ narnia ~

    Jason L © Guest

    I agree. I don't worry about javascript and always leave it enabled. Kudos
    to those who want to use NoScript etc. but I don't find it necessary.
    Jason L ©, Dec 27, 2005
    #19
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    1
    Views:
    2,296
    Vincent C Jones
    Nov 21, 2005
  2. jimmie
    Replies:
    1
    Views:
    688
    The-Wisest-One
    Feb 26, 2006
  3. Ralph Fox
    Replies:
    0
    Views:
    565
    Ralph Fox
    Jul 14, 2008
  4. Richard
    Replies:
    1
    Views:
    527
    ~misfit~
    Jul 14, 2008
  5. fashion t shirts seller
    Replies:
    0
    Views:
    1,088
    fashion t shirts seller
    Jun 13, 2011
Loading...

Share This Page