PHP Session not timing out

Discussion in 'NZ Computing' started by Andrew Sableton, Nov 24, 2003.

  1. nick wrote:

    > Hi PHP experts out there,
    >
    > My site is hosted on iserve's unix server and I've just switched my
    > site's usual session data dir to one of the site's subdir instead of
    > the server's default - session_save_path(mypath).
    >
    > Since then the session doesn't seem to timeout. I've tried:
    > define("MAX_IDLE_TIME", 10);
    > ini_set("session.gc_maxlifetime", 600);
    >
    > but without success.



    If your timers are as far out of sync as the clock on the machine you
    posted from, then perhaps it will take a minimum of 3 days to time out. :->


    > Date: Tue, 25 Nov 2003 01:06:15 +1300


    > NNTP-Posting-Date: Sat, 22 Nov 2003 01:08:02 NZDT
    Andrew Sableton, Nov 24, 2003
    #1
    1. Advertising

  2. Andrew Sableton

    nick Guest

    Nice try, but I've visited the site from at least 3 other machines
    with the same problem.

    On Mon, 24 Nov 2003 06:21:46 GMT, Andrew Sableton <>
    wrote:

    >nick wrote:
    >
    >> Hi PHP experts out there,
    >>
    >> My site is hosted on iserve's unix server and I've just switched my
    >> site's usual session data dir to one of the site's subdir instead of
    >> the server's default - session_save_path(mypath).
    >>
    >> Since then the session doesn't seem to timeout. I've tried:
    >> define("MAX_IDLE_TIME", 10);
    >> ini_set("session.gc_maxlifetime", 600);
    >>
    >> but without success.

    >
    >
    >If your timers are as far out of sync as the clock on the machine you
    >posted from, then perhaps it will take a minimum of 3 days to time out. :->
    >
    >
    >> Date: Tue, 25 Nov 2003 01:06:15 +1300

    >
    >> NNTP-Posting-Date: Sat, 22 Nov 2003 01:08:02 NZDT

    >
    >
    >
    >
    >
    >
    >
    nick, Nov 24, 2003
    #2
    1. Advertising

  3. Andrew Sableton

    nick Guest

    Hi PHP experts out there,

    My site is hosted on iserve's unix server and I've just switched my
    site's usual session data dir to one of the site's subdir instead of
    the server's default - session_save_path(mypath).

    Since then the session doesn't seem to timeout. I've tried:
    define("MAX_IDLE_TIME", 10);
    ini_set("session.gc_maxlifetime", 600);

    but without success.

    Can the session timeout only be controlled from the server
    (php.ini...)? If not, what are my options?

    Also anyone able to post to php.* or alt.php newsgroups? I've been
    trying to post to it but nobody ever reply.

    Thanks,
    Nick.
    nick, Nov 24, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. E.C.

    PHP: Session/redirect puzzle

    E.C., Nov 11, 2003, in forum: NZ Computing
    Replies:
    9
    Views:
    785
  2. raviraj joshi
    Replies:
    0
    Views:
    639
    raviraj joshi
    Jul 4, 2009
  3. EVS
    Replies:
    0
    Views:
    1,875
  4. infocus
    Replies:
    0
    Views:
    885
    infocus
    Jul 19, 2010
  5. EVS
    Replies:
    0
    Views:
    1,721
Loading...

Share This Page