Peer to peer wifi setup

Discussion in 'Wireless Networking' started by Patrick Page, Sep 12, 2004.

  1. Patrick Page

    Patrick Page Guest

    I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520 PCI
    Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G wireless
    adapter). The wireless adapters connect with excellent signal strength and
    talk to each other, but I can't see any resources from either computer. The
    desktop shows all its shared resources and the laptop in My Network Places;
    the laptop shows only its own shared resources. The error messages indicate
    the roadblock is administrator permission, but this is a ptop network. Help!
    TIA!

    --
    All mail sent by me is virus-checked with NAV.
    Patrick S. Page
    Morongo Valley, CA
    760-363-0062
     
    Patrick Page, Sep 12, 2004
    #1
    1. Advertising

  2. Patrick Page

    Tee Guest

    "Patrick Page" <> wrote in message
    news:%...
    > I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520 PCI
    > Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G

    wireless
    > adapter). The wireless adapters connect with excellent signal strength and
    > talk to each other, but I can't see any resources from either computer.

    The
    > desktop shows all its shared resources and the laptop in My Network

    Places;
    > the laptop shows only its own shared resources. The error messages

    indicate
    > the roadblock is administrator permission, but this is a ptop network.

    Help!
    > TIA!


    One of three things I can think of (I went through this hell a while back):

    1. Check the connection properties for your adapters on both machines &
    compare. I found that my desktop didn't have some of the same
    services/clients/protocols "installed" as the laptop did and it was the
    laptop that worked in my case. I clicked the install button and installed
    every one of those items listed and that worked like a charm.

    2. Try mapping a network drive to the laptop. Get the laptop's address, on
    the desktop right click on My Computer and select Map Network Drive.

    3. Did you setup a network environment? The two most common that Windows
    does is Workgroup and MSHome. If you have each computer join a network
    environment (just make sure you don't do workgroup on one and mshome on the
    other) then they should be able to see each other. I had problems with this
    too until I installed all those clients/services/protocols in the properties
    section of my connection device.

    --
    Tara
     
    Tee, Sep 12, 2004
    #2
    1. Advertising

  3. In article <#>, "Patrick Page"
    <> wrote:
    >I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520 PCI
    >Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G wireless
    >adapter). The wireless adapters connect with excellent signal strength and
    >talk to each other, but I can't see any resources from either computer. The
    >desktop shows all its shared resources and the laptop in My Network Places;
    >the laptop shows only its own shared resources. The error messages indicate
    >the roadblock is administrator permission, but this is a ptop network. Help!
    >TIA!


    These tips should help you get everything working:

    1. Make sure that a firewall isn't blocking access:

    1a. Permanently disable the XP HE SP1 Internet Connection Firewall on
    the LAN connection.

    1b. If the XP HE SP2 Windows Firewall is enabled, make sure that the
    exception for File and Printer Sharing is turned on.

    1c. If you've installed a third-party firewall program, configure it
    to allow access by other computers on the LAN. Disable XP's built-in
    firewalls if you've installed a third-part firewall.

    2. Use only one protocol for File and Printer Sharing. If the network
    needs more than one protocol, unbind File and Printer Sharing from all
    but one of them. Details here:

    Windows XP Network Protocols
    http://www.practicallynetworked.com/sharing/xp/network_protocols.htm

    3. Make sure that NetBIOS over TCP/IP is enabled on both computers.
    Details here:

    Enable NetBIOS Over TCP/IP (NetBT)
    http://www.practicallynetworked.com/sharing/troubleshoot/netbt.htm

    4. Run "ipconfig /all" on both computers and look at the "Node Type"
    at the beginning of the output. If it says "Peer-to-Peer" (which
    should actually be "Point-to-Point") that's the problem. It means
    that the computer only uses a WINS server, which isn't available on a
    peer-to-peer network, for NetBIOS name resolution.

    If that's the case, run the registry editor, open this key:

    HLM\System\CurrentControlSet\Services\Netbt\Parameters

    and delete these values if they're present:

    NodeType
    DhcpNodeType

    Reboot, then try network access again.

    If that doesn't fix it, open that registry key again, create a DWORD
    value called "NodeType", and set it to 1 for "Broadcast" or 4 for
    "Mixed".

    For details, see these Microsoft Knowledge Base articles:

    Default Node Type for Microsoft Clients
    http://support.microsoft.com/default.aspx?scid=kb;en-us;160177

    TCP/IP and NBT Configuration Parameters for Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;314053
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional Program
    http://mvp.support.microsoft.com
     
    Steve Winograd [MVP], Sep 12, 2004
    #3
  4. Patrick Page

    Jeff Guest

    Tia,

    Try accessing the computer directly by IP address. Open a windows browser,
    such as My Computer, and type in "\\" followed by the IP address of the
    other computer. Something like "\\168.192.3.30" That will often fix the
    problem when all else seems to be set up correctly.

    Jeff


    "Steve Winograd [MVP]" <> wrote in message
    news:...
    > In article <#>, "Patrick Page"
    > <> wrote:
    >>I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520 PCI
    >>Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G
    >>wireless
    >>adapter). The wireless adapters connect with excellent signal strength and
    >>talk to each other, but I can't see any resources from either computer.
    >>The
    >>desktop shows all its shared resources and the laptop in My Network
    >>Places;
    >>the laptop shows only its own shared resources. The error messages
    >>indicate
    >>the roadblock is administrator permission, but this is a ptop network.
    >>Help!
    >>TIA!

    >
    > These tips should help you get everything working:
    >
    > 1. Make sure that a firewall isn't blocking access:
    >
    > 1a. Permanently disable the XP HE SP1 Internet Connection Firewall on
    > the LAN connection.
    >
    > 1b. If the XP HE SP2 Windows Firewall is enabled, make sure that the
    > exception for File and Printer Sharing is turned on.
    >
    > 1c. If you've installed a third-party firewall program, configure it
    > to allow access by other computers on the LAN. Disable XP's built-in
    > firewalls if you've installed a third-part firewall.
    >
    > 2. Use only one protocol for File and Printer Sharing. If the network
    > needs more than one protocol, unbind File and Printer Sharing from all
    > but one of them. Details here:
    >
    > Windows XP Network Protocols
    > http://www.practicallynetworked.com/sharing/xp/network_protocols.htm
    >
    > 3. Make sure that NetBIOS over TCP/IP is enabled on both computers.
    > Details here:
    >
    > Enable NetBIOS Over TCP/IP (NetBT)
    > http://www.practicallynetworked.com/sharing/troubleshoot/netbt.htm
    >
    > 4. Run "ipconfig /all" on both computers and look at the "Node Type"
    > at the beginning of the output. If it says "Peer-to-Peer" (which
    > should actually be "Point-to-Point") that's the problem. It means
    > that the computer only uses a WINS server, which isn't available on a
    > peer-to-peer network, for NetBIOS name resolution.
    >
    > If that's the case, run the registry editor, open this key:
    >
    > HLM\System\CurrentControlSet\Services\Netbt\Parameters
    >
    > and delete these values if they're present:
    >
    > NodeType
    > DhcpNodeType
    >
    > Reboot, then try network access again.
    >
    > If that doesn't fix it, open that registry key again, create a DWORD
    > value called "NodeType", and set it to 1 for "Broadcast" or 4 for
    > "Mixed".
    >
    > For details, see these Microsoft Knowledge Base articles:
    >
    > Default Node Type for Microsoft Clients
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;160177
    >
    > TCP/IP and NBT Configuration Parameters for Windows XP
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;314053
    > --
    > Best Wishes,
    > Steve Winograd, MS-MVP (Windows Networking)
    >
    > Please post any reply as a follow-up message in the news group
    > for everyone to see. I'm sorry, but I don't answer questions
    > addressed directly to me in E-mail or news groups.
    >
    > Microsoft Most Valuable Professional Program
    > http://mvp.support.microsoft.com
     
    Jeff, Sep 13, 2004
    #4
  5. Patrick Page

    Patrick Page Guest

    1. I already disabled the firewalls on both machines.

    2. I already disabled Zone Alarm.

    3. TCPIP is the only protocol being used.

    4. I enabled NetBIOS over TCPIP. Note that the instructions are covered by
    the example on the web site.

    5. I found no references to either flavor of PtoP or NodeType. Below are the
    Ipconfig results:

    The desktop shows: Description: ...; Physical address: ...; DHCP enabled:
    No; IP Address: 192.168.30.1; Subnet Mask: 255.255.255.0; Default Gateway:
    ( none shown)

    The notebook shows: Description: ...; Physical address: ...; Dhcp enabled:
    Yes; Auto configuration enabled: Yes; IP address:192.168.0.220 Subnet Mask:
    255.255.255.0; Default gateway: 192.168.0.1 Dhcp server: 192.168.0.1 DNS
    servers: 192.168.0.1 Lease obtained: ... Lease expires: ...

    I hope the above gives you some clues. Many thanks!
    --
    All mail sent by me is virus-checked with NAV.
    Patrick S. Page
    Morongo Valley, CA
    760-363-0062
    "Steve Winograd [MVP]" <> wrote in message
    news:...
    | In article <#>, "Patrick Page"
    | <> wrote:
    | >I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520 PCI
    | >Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G
    wireless
    | >adapter). The wireless adapters connect with excellent signal strength
    and
    | >talk to each other, but I can't see any resources from either computer.
    The
    | >desktop shows all its shared resources and the laptop in My Network
    Places;
    | >the laptop shows only its own shared resources. The error messages
    indicate
    | >the roadblock is administrator permission, but this is a ptop network.
    Help!
    | >TIA!
    |
    | These tips should help you get everything working:
    |
    | 1. Make sure that a firewall isn't blocking access:
    |
    | 1a. Permanently disable the XP HE SP1 Internet Connection Firewall on
    | the LAN connection.
    |
    | 1b. If the XP HE SP2 Windows Firewall is enabled, make sure that the
    | exception for File and Printer Sharing is turned on.
    |
    | 1c. If you've installed a third-party firewall program, configure it
    | to allow access by other computers on the LAN. Disable XP's built-in
    | firewalls if you've installed a third-part firewall.
    |
    | 2. Use only one protocol for File and Printer Sharing. If the network
    | needs more than one protocol, unbind File and Printer Sharing from all
    | but one of them. Details here:
    |
    | Windows XP Network Protocols
    | http://www.practicallynetworked.com/sharing/xp/network_protocols.htm
    |
    | 3. Make sure that NetBIOS over TCP/IP is enabled on both computers.
    | Details here:
    |
    | Enable NetBIOS Over TCP/IP (NetBT)
    | http://www.practicallynetworked.com/sharing/troubleshoot/netbt.htm
    |
    | 4. Run "ipconfig /all" on both computers and look at the "Node Type"
    | at the beginning of the output .IfitsaysPeer-to-Peerwhich
    | should actually be "Point-to-Point") that's the problem. It means
    | that the computer only uses a WINS server, which isn't available on a
    | peer-to-peer network, for NetBIOS name resolution.
    |
    | If that's the case, run the registry editor, open this key:
    |
    | HLM\System\CurrentControlSet\Services\Netbt\Parameters
    |
    | and delete these values if they're present:
    |
    | NodeType
    | DhcpNodeType
    |
    | Reboot, then try network access again.
    |
    | If that doesn't fix it, open that registry key again, create a DWORD
    | value called "NodeType", and set it to 1 for "Broadcast" or 4 for
    | "Mixed".
    |
    | For details, see these Microsoft Knowledge Base articles:
    |
    | Default Node Type for Microsoft Clients
    | http://support.microsoft.com/default.aspx?scid=kb;en-us;160177
    |
    | TCP/IP and NBT Configuration Parameters for Windows XP
    | http://support.microsoft.com/default.aspx?scid=kb;en-us;314053
    | --
    | Best Wishes,
    | Steve Winograd, MS-MVP (Windows Networking)
    |
    | Please post any reply as a follow-up message in the news group
    | for everyone to see. I'm sorry, but I don't answer questions
    | addressed directly to me in E-mail or news groups.
    |
    | Microsoft Most Valuable Professional Program
    | http://mvp.support.microsoft.com
     
    Patrick Page, Sep 13, 2004
    #5
  6. Patrick Page

    Patrick Page Guest

    See comments below. Many thanks! But still no joy.

    --
    All mail sent by me is virus-checked with NAV.
    Patrick S. Page
    Morongo Valley, CA
    760-363-0062
    "Tee" <> wrote in message
    news:...
    | "Patrick Page" <> wrote in message
    | news:%...
    | > I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520 PCI
    | > Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G
    | wireless
    | > adapter). The wireless adapters connect with excellent signal strength
    and
    | > talk to each other, but I can't see any resources from either computer.
    | The
    | > desktop shows all its shared resources and the laptop in My Network
    | Places;
    | > the laptop shows only its own shared resources. The error messages
    | indicate
    | > the roadblock is administrator permission, but this is a ptop network.
    | Help!
    | > TIA!
    |
    | One of three things I can think of (I went through this hell a while
    back):
    |
    | 1. Check the connection properties for your adapters on both machines &
    | compare. I found that my desktop didn't have some of the same
    | services/clients/protocols "installed" as the laptop did and it was the
    | laptop that worked in my case. I clicked the install button and installed
    | every one of those items listed and that worked like a charm.

    I removed the Aegis protocol from the laptop, but no help.
    |
    | 2. Try mapping a network drive to the laptop. Get the laptop's address,
    on
    | the desktop right click on My Computer and select Map Network Drive.

    The desktop is still inaccessible (Properties unavailable).
    |
    | 3. Did you setup a network environment? The two most common that Windows
    | does is Workgroup and MSHome. If you have each computer join a network
    | environment (just make sure you don't do workgroup on one and mshome on
    the
    | other) then they should be able to see each other. I had problems with
    this
    | too until I installed all those clients/services/protocols in the
    properties
    | section of my connection device.
    |
    |
    Both are assigned to mshome.

    --
    | Tara
    |
    |
     
    Patrick Page, Sep 13, 2004
    #6
  7. Patrick Page

    Patrick Page Guest

    No joy here either.

    --
    All mail sent by me is virus-checked with NAV.
    Patrick S. Page
    Morongo Valley, CA
    760-363-0062
    "Jeff" <> wrote in message
    news:%...
    | Tia,
    |
    | Try accessing the computer directly by IP address. Open a windows browser,
    | such as My Computer, and type in "\\" followed by the IP address of the
    | other computer. Something like "\\168.192.3.30" That will often fix the
    | problem when all else seems to be set up correctly.
    |
    | Jeff
    |
    |
    | "Steve Winograd [MVP]" <> wrote in message
    | news:...
    | > In article <#>, "Patrick Page"
    | > <> wrote:
    | >>I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520 PCI
    | >>Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G
    | >>wireless
    | >>adapter). The wireless adapters connect with excellent signal strength
    and
    | >>talk to each other, but I can't see any resources from either computer.
    | >>The
    | >>desktop shows all its shared resources and the laptop in My Network
    | >>Places;
    | >>the laptop shows only its own shared resources. The error messages
    | >>indicate
    | >>the roadblock is administrator permission, but this is a ptop network.
    | >>Help!
    | >>TIA!
    | >
    | > These tips should help you get everything working:
    | >
    | > 1. Make sure that a firewall isn't blocking access:
    | >
    | > 1a. Permanently disable the XP HE SP1 Internet Connection Firewall on
    | > the LAN connection.
    | >
    | > 1b. If the XP HE SP2 Windows Firewall is enabled, make sure that the
    | > exception for File and Printer Sharing is turned on.
    | >
    | > 1c. If you've installed a third-party firewall program, configure it
    | > to allow access by other computers on the LAN. Disable XP's built-in
    | > firewalls if you've installed a third-part firewall.
    | >
    | > 2. Use only one protocol for File and Printer Sharing. If the network
    | > needs more than one protocol, unbind File and Printer Sharing from all
    | > but one of them. Details here:
    | >
    | > Windows XP Network Protocols
    | > http://www.practicallynetworked.com/sharing/xp/network_protocols.htm
    | >
    | > 3. Make sure that NetBIOS over TCP/IP is enabled on both computers.
    | > Details here:
    | >
    | > Enable NetBIOS Over TCP/IP (NetBT)
    | > http://www.practicallynetworked.com/sharing/troubleshoot/netbt.htm
    | >
    | > 4. Run "ipconfig /all" on both computers and look at the "Node Type"
    | > at the beginning of the output .IfitsaysPeer-to-Peerwhich
    | > should actually be "Point-to-Point") that's the problem. It means
    | > that the computer only uses a WINS server, which isn't available on a
    | > peer-to-peer network, for NetBIOS name resolution.
    | >
    | > If that's the case, run the registry editor, open this key:
    | >
    | > HLM\System\CurrentControlSet\Services\Netbt\Parameters
    | >
    | > and delete these values if they're present:
    | >
    | > NodeType
    | > DhcpNodeType
    | >
    | > Reboot, then try network access again.
    | >
    | > If that doesn't fix it, open that registry key again, create a DWORD
    | > value called "NodeType", and set it to 1 for "Broadcast" or 4 for
    | > "Mixed".
    | >
    | > For details, see these Microsoft Knowledge Base articles:
    | >
    | > Default Node Type for Microsoft Clients
    | > http://support.microsoft.com/default.aspx?scid=kb;en-us;160177
    | >
    | > TCP/IP and NBT Configuration Parameters for Windows XP
    | > http://support.microsoft.com/default.aspx?scid=kb;en-us;314053
    | > --
    | > Best Wishes,
    | > Steve Winograd, MS-MVP (Windows Networking)
    | >
    | > Please post any reply as a follow-up message in the news group
    | > for everyone to see. I'm sorry, but I don't answer questions
    | > addressed directly to me in E-mail or news groups.
    | >
    | > Microsoft Most Valuable Professional Program
    | > http://mvp.support.microsoft.com
    |
    |
     
    Patrick Page, Sep 13, 2004
    #7
  8. In article <>, "Patrick Page"
    <> wrote:
    >1. I already disabled the firewalls on both machines.
    >
    >2. I already disabled Zone Alarm.
    >
    >3. TCPIP is the only protocol being used.
    >
    >4. I enabled NetBIOS over TCPIP. Note that the instructions are covered by
    >the example on the web site.
    >
    >5. I found no references to either flavor of PtoP or NodeType. Below are the
    >Ipconfig results:
    >
    >The desktop shows: Description: ...; Physical address: ...; DHCP enabled:
    >No; IP Address: 192.168.30.1; Subnet Mask: 255.255.255.0; Default Gateway:
    >( none shown)
    >
    >The notebook shows: Description: ...; Physical address: ...; Dhcp enabled:
    >Yes; Auto configuration enabled: Yes; IP address:192.168.0.220 Subnet Mask:
    >255.255.255.0; Default gateway: 192.168.0.1 Dhcp server: 192.168.0.1 DNS
    >servers: 192.168.0.1 Lease obtained: ... Lease expires: ...
    >
    >I hope the above gives you some clues. Many thanks!


    If the IP addresses that you listed are right, they're causing the
    problem. With a 255.255.255.0 subnet mask, 192.168.30.1 and
    192.168.0.1 are in different subnets. so the computers can't
    communicate with each other.

    Ipconfig on the desktop shows that the IP address was assigned
    manually. I recommend changing it to assign an IP address
    automatically. Then, the desktop will get a 192.168.0.x IP address
    just like the notebook, and they'll be able to communicate.
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional Program
    http://mvp.support.microsoft.com
     
    Steve Winograd [MVP], Sep 13, 2004
    #8
  9. Patrick Page

    Patrick Page Guest

    Steve, a thousand thanks! That was it.

    --
    All mail sent by me is virus-checked with NAV.
    Patrick S. Page
    Morongo Valley, CA
    760-363-0062
    "Steve Winograd [MVP]" <> wrote in message
    news:...
    | In article <>, "Patrick Page"
    | <> wrote:
    | >1. I already disabled the firewalls on both machines.
    | >
    | >2. I already disabled Zone Alarm.
    | >
    | >3. TCPIP is the only protocol being used.
    | >
    | >4. I enabled NetBIOS over TCPIP. Note that the instructions are covered
    by
    | >the example on the web site.
    | >
    | >5. I found no references to either flavor of PtoP or NodeType. Below are
    the
    | >Ipconfig results:
    | >
    | >The desktop shows: Description: ...; Physical address: ...; DHCP enabled:
    | >No; IP Address: 192.168.30.1; Subnet Mask: 255.255.255.0; Default
    Gateway:
    | >( none shown)
    | >
    | >The notebook shows: Description: ...; Physical address: ...; Dhcp
    enabled:
    | >Yes; Auto configuration enabled: Yes; IP address:192.168.0.220 Subnet
    Mask:
    | >255.255.255.0; Default gateway: 192.168.0.1 Dhcp server: 192.168.0.1 DNS
    | >servers: 192.168.0.1 Lease obtained: ... Lease expires: ...
    | >
    | >I hope the above gives you some clues. Many thanks!
    |
    | If the IP addresses that you listed are right, they're causing the
    | problem. With a 255.255.255.0 subnet mask, 192.168.30.1 and
    | 192.168.0.1 are in different subnets. so the computers can't
    | communicate with each other.
    |
    | Ipconfig on the desktop shows that the IP address was assigned
    | manually. I recommend changing it to assign an IP address
    | automatically. Then, the desktop will get a 192.168.0.x IP address
    | just like the notebook, and they'll be able to communicate.
    | --
    | Best Wishes,
    | Steve Winograd, MS-MVP (Windows Networking)
    |
    | Please post any reply as a follow-up message in the news group
    | for everyone to see. I'm sorry, but I don't answer questions
    | addressed directly to me in E-mail or news groups.
    |
    | Microsoft Most Valuable Professional Program
    | http://mvp.support.microsoft.com
     
    Patrick Page, Sep 13, 2004
    #9
  10. Patrick Page

    Patrick Page Guest

    Oops! I spoke too soon. I still can't access any resources across the
    connection.
    --
    All mail sent by me is virus-checked with NAV.
    Patrick S. Page
    Morongo Valley, CA
    760-363-0062
    "Steve Winograd [MVP]" <> wrote in message
    news:...
    | In article <>, "Patrick Page"
    | <> wrote:
    | >1. I already disabled the firewalls on both machines.
    | >
    | >2. I already disabled Zone Alarm.
    | >
    | >3. TCPIP is the only protocol being used.
    | >
    | >4. I enabled NetBIOS over TCPIP. Note that the instructions are covered
    by
    | >the example on the web site.
    | >
    | >5. I found no references to either flavor of PtoP or NodeType. Below are
    the
    | >Ipconfig results:
    | >
    | >The desktop shows: Description: ...; Physical address: ...; DHCP enabled:
    | >No; IP Address: 192.168.30.1; Subnet Mask: 255.255.255.0; Default
    Gateway:
    | >( none shown)
    | >
    | >The notebook shows: Description: ...; Physical address: ...; Dhcp
    enabled:
    | >Yes; Auto configuration enabled: Yes; IP address:192.168.0.220 Subnet
    Mask:
    | >255.255.255.0; Default gateway: 192.168.0.1 Dhcp server: 192.168.0.1 DNS
    | >servers: 192.168.0.1 Lease obtained: ... Lease expires: ...
    | >
    | >I hope the above gives you some clues. Many thanks!
    |
    | If the IP addresses that you listed are right, they're causing the
    | problem. With a 255.255.255.0 subnet mask, 192.168.30.1 and
    | 192.168.0.1 are in different subnets. so the computers can't
    | communicate with each other.
    |
    | Ipconfig on the desktop shows that the IP address was assigned
    | manually. I recommend changing it to assign an IP address
    | automatically. Then, the desktop will get a 192.168.0.x IP address
    | just like the notebook, and they'll be able to communicate.
    | --
    | Best Wishes,
    | Steve Winograd, MS-MVP (Windows Networking)
    |
    | Please post any reply as a follow-up message in the news group
    | for everyone to see. I'm sorry, but I don't answer questions
    | addressed directly to me in E-mail or news groups.
    |
    | Microsoft Most Valuable Professional Program
    | http://mvp.support.microsoft.com
     
    Patrick Page, Sep 13, 2004
    #10
  11. Patrick Page

    Patrick Page Guest

    New ipconfig results: The desktop shows:
    Description: ...; Physical address: ...; DHCP enabled: Yes;
    Autoconfiguration enabled: Yes; IP Address: 4.11.130.172; Subnet Mask:
    255.255.248.0; Default Gateway: 4.11.128.1; DHCP Server: 209.244.7.5; DNS
    Servers 4.2.2.65 4.2.2.5 4.2.2.6; Lease obtained: ...
    --
    All mail sent by me is virus-checked with NAV.
    Patrick S. Page
    Morongo Valley, CA
    760-363-0062
    "Steve Winograd [MVP]" <> wrote in message
    news:...
    | In article <>, "Patrick Page"
    | <> wrote:
    | >1. I already disabled the firewalls on both machines.
    | >
    | >2. I already disabled Zone Alarm.
    | >
    | >3. TCPIP is the only protocol being used.
    | >
    | >4. I enabled NetBIOS over TCPIP. Note that the instructions are covered
    by
    | >the example on the web site.
    | >
    | >5. I found no references to either flavor of PtoP or NodeType. Below are
    the
    | >Ipconfig results:
    | >
    | >The desktop shows: Description: ...; Physical address: ...; DHCP enabled:
    | >No; IP Address: 192.168.30.1; Subnet Mask: 255.255.255.0; Default
    Gateway:
    | >( none shown)
    | >
    | >The notebook shows: Description: ...; Physical address: ...; Dhcp
    enabled:
    | >Yes; Auto configuration enabled: Yes; IP address:192.168.0.220 Subnet
    Mask:
    | >255.255.255.0; Default gateway: 192.168.0.1 Dhcp server: 192.168.0.1 DNS
    | >servers: 192.168.0.1 Lease obtained: ... Lease expires: ...
    | >
    | >I hope the above gives you some clues. Many thanks!
    |
    | If the IP addresses that you listed are right, they're causing the
    | problem. With a 255.255.255.0 subnet mask, 192.168.30.1 and
    | 192.168.0.1 are in different subnets. so the computers can't
    | communicate with each other.
    |
    | Ipconfig on the desktop shows that the IP address was assigned
    | manually. I recommend changing it to assign an IP address
    | automatically. Then, the desktop will get a 192.168.0.x IP address
    | just like the notebook, and they'll be able to communicate.
    | --
    | Best Wishes,
    | Steve Winograd, MS-MVP (Windows Networking)
    |
    | Please post any reply as a follow-up message in the news group
    | for everyone to see. I'm sorry, but I don't answer questions
    | addressed directly to me in E-mail or news groups.
    |
    | Microsoft Most Valuable Professional Program
    | http://mvp.support.microsoft.com
     
    Patrick Page, Sep 13, 2004
    #11
  12. In article <e#>, "Patrick Page"
    <> wrote:
    >>>>>I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520 PCI
    >>>>>Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G wireless
    >>>>>adapter). The wireless adapters connect with excellent signal strength and
    >>>>>talk to each other, but I can't see any resources from either computer. The
    >>>>>desktop shows all its shared resources and the laptop in My Network Places;
    >>>>>the laptop shows only its own shared resources. The error messages indicate
    >>>>>the roadblock is administrator permission, but this is a ptop network. Help!
    >>>>>TIA!

    >|>
    >| >Ipconfig results:
    >| >
    >| >The desktop shows: Description: ...; Physical address: ...; DHCP enabled:
    >| >No; IP Address: 192.168.30.1; Subnet Mask: 255.255.255.0; Default
    >Gateway:
    >| >( none shown)
    >| >
    >| >The notebook shows: Description: ...; Physical address: ...; Dhcp
    >enabled:
    >| >Yes; Auto configuration enabled: Yes; IP address:192.168.0.220 Subnet
    >Mask:
    >| >255.255.255.0; Default gateway: 192.168.0.1 Dhcp server: 192.168.0.1 DNS
    >| >servers: 192.168.0.1 Lease obtained: ... Lease expires: ...
    >| >
    >| >I hope the above gives you some clues. Many thanks!
    >|
    >| If the IP addresses that you listed are right, they're causing the
    >| problem. With a 255.255.255.0 subnet mask, 192.168.30.1 and
    >| 192.168.0.1 are in different subnets. so the computers can't
    >| communicate with each other.
    >|
    >| Ipconfig on the desktop shows that the IP address was assigned
    >| manually. I recommend changing it to assign an IP address
    >| automatically. Then, the desktop will get a 192.168.0.x IP address
    >| just like the notebook, and they'll be able to communicate.
    >
    >New ipconfig results: The desktop shows:
    >Description: ...; Physical address: ...; DHCP enabled: Yes;
    >Autoconfiguration enabled: Yes; IP Address: 4.11.130.172; Subnet Mask:
    >255.255.248.0; Default Gateway: 4.11.128.1; DHCP Server: 209.244.7.5; DNS
    >Servers 4.2.2.65 4.2.2.5 4.2.2.6; Lease obtained: ...


    It seems that I don't understand your setup, Patrick.

    The desktop has a public IP address assigned by Verizon DSL. The
    laptop has a private IP address assigned by an Internet sharing device
    of some sort -- it could be a home broadband router, or it could be
    that the desktop has enabled Internet Connection Sharing on a DSL
    connection.

    Does the desktop have more than one network connection? What exactly
    appears in the Network Connections folder? Is there a wireless one
    (connecting to the laptop) and a wired and/or PPPoE one (connecting to
    DSL)?

    Do you have a wireless router? If so, how does each computer connect
    to it: wired or wireless?

    Do you have an external DSL modem? If so, what does it plug into? If
    it plugs into a home broadband router, make sure that it's plugged
    into the router's WAN (Internet) port, not into a LAN port.
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional Program
    http://mvp.support.microsoft.com
     
    Steve Winograd [MVP], Sep 13, 2004
    #12
  13. Patrick Page

    Patrick Page Guest

    Thanks for your patience, Steve. The desktop has a simple DSL connection to
    Verizon and a wireless adapter through which I want to give my laptop
    internet access and be able to share files and printers. The laptop has a
    wireless adapter and a disabled ethernet adapter. No router anywhere in the
    picture. Both adapters are set to acquire IP addresses automatically. The
    c: drives on both systems are set for simple file sharing. The laptop now
    shows Node Type: Mixed; IP Routing enabled: No; WINS proxy enabled: No.

    --
    All mail sent by me is virus-checked with NAV.
    Patrick S. Page
    Morongo Valley, CA
    760-363-0062
    "Steve Winograd [MVP]" <> wrote in message
    news:...
    | In article <e#>, "Patrick Page"
    | <> wrote:
    | >>>>>I'm trying to network my desktop running XP HE SP2 (Dlink DWL G520
    PCI
    | >>>>>Wireless adapter) with my laptop running XP HE SP1 (Atheros AR5004G
    wireless
    | >>>>>adapter). The wireless adapters connect with excellent signal
    strength and
    | >>>>>talk to each other, but I can't see any resources from either
    computer. The
    | >>>>>desktop shows all its shared resources and the laptop in My Network
    Places;
    | >>>>>the laptop shows only its own shared resources. The error messages
    indicate
    | >>>>>the roadblock is administrator permission, but this is a ptop
    network. Help!
    | >>>>>TIA!
    | >|>
    | >| >Ipconfig results:
    | >| >
    | >| >The desktop shows: Description: ...; Physical address: ...; DHCP
    enabled:
    | >| >No; IP Address: 192.168.30.1; Subnet Mask: 255.255.255.0; Default
    | >Gateway:
    | >| >( none shown)
    | >| >
    | >| >The notebook shows: Description: ...; Physical address: ...; Dhcp
    | >enabled:
    | >| >Yes; Auto configuration enabled: Yes; IP address:192.168.0.220 Subnet
    | >Mask:
    | >| >255.255.255.0; Default gateway: 192.168.0.1 Dhcp server: 192.168.0.1
    DNS
    | >| >servers: 192.168.0.1 Lease obtained: ... Lease expires: ...
    | >| >
    | >| >I hope the above gives you some clues. Many thanks!
    | >|
    | >| If the IP addresses that you listed are right, they're causing the
    | >| problem. With a 255.255.255.0 subnet mask, 192.168.30.1 and
    | >| 192.168.0.1 are in different subnets. so the computers can't
    | >| communicate with each other.
    | >|
    | >| Ipconfig on the desktop shows that the IP address was assigned
    | >| manually. I recommend changing it to assign an IP address
    | >| automatically. Then, the desktop will get a 192.168.0.x IP address
    | >| just like the notebook, and they'll be able to communicate.
    | >
    | >New ipconfig results: The desktop shows:
    | >Description: ...; Physical address: ...; DHCP enabled: Yes;
    | >Autoconfiguration enabled: Yes; IP Address: 4.11.130.172; Subnet Mask:
    | >255.255.248.0; Default Gateway: 4.11.128.1; DHCP Server: 209.244.7.5; DNS
    | >Servers 4.2.2.65 4.2.2.5 4.2.2.6; Lease obtained: ...
    |
    | It seems that I don't understand your setup, Patrick.
    |
    | The desktop has a public IP address assigned by Verizon DSL. The
    | laptop has a private IP address assigned by an Internet sharing device
    | of some sort -- it could be a home broadband router, or it could be
    | that the desktop has enabled Internet Connection Sharing on a DSL
    | connection.
    |
    | Does the desktop have more than one network connection? What exactly
    | appears in the Network Connections folder? Is there a wireless one
    | (connecting to the laptop) and a wired and/or PPPoE one (connecting to
    | DSL)?
    |
    | Do you have a wireless router? If so, how does each computer connect
    | to it: wired or wireless?
    |
    | Do you have an external DSL modem? If so, what does it plug into? If
    | it plugs into a home broadband router, make sure that it's plugged
    | into the router's WAN (Internet) port, not into a LAN port.
    | --
    | Best Wishes,
    | Steve Winograd, MS-MVP (Windows Networking)
    |
    | Please post any reply as a follow-up message in the news group
    | for everyone to see. I'm sorry, but I don't answer questions
    | addressed directly to me in E-mail or news groups.
    |
    | Microsoft Most Valuable Professional Program
    | http://mvp.support.microsoft.com
     
    Patrick Page, Sep 13, 2004
    #13
  14. In article <>, "Patrick Page"
    <> wrote:
    >Thanks for your patience, Steve. The desktop has a simple DSL connection to
    >Verizon and a wireless adapter through which I want to give my laptop
    >internet access and be able to share files and printers. The laptop has a
    >wireless adapter and a disabled ethernet adapter. No router anywhere in the
    >picture. Both adapters are set to acquire IP addresses automatically. The
    >c: drives on both systems are set for simple file sharing. The laptop now
    >shows Node Type: Mixed; IP Routing enabled: No; WINS proxy enabled: No.


    You're welcome, Patrick. Thanks for the details of your setup.

    You need to set up an Ad-hoc wireless network between the desktop and
    laptop computers and enable Internet Connection Sharing on the
    desktop's DSL (PPPoE) connection. Barb Bowman has written a web page
    that should help you get everything working:

    Making the Wireless Home Network Connection in Windows XP Without a
    Router
    http://www.microsoft.com/windowsxp/using/networking/expert/bowman_02april08.mspx

    Do you have an external DSL modem? If so, your network setup would be
    simpler and more reliable if you got a wireless router, connected the
    DSL modem to its WAN port, and connected the computers to it using
    either a wired or wireless connection.
    --
    Best Wishes,
    Steve Winograd, MS-MVP (Windows Networking)

    Please post any reply as a follow-up message in the news group
    for everyone to see. I'm sorry, but I don't answer questions
    addressed directly to me in E-mail or news groups.

    Microsoft Most Valuable Professional Program
    http://mvp.support.microsoft.com
     
    Steve Winograd [MVP], Sep 13, 2004
    #14
  15. Patrick Page

    Patrick Page Guest

    Thanks again. I've ordered a router as you suggested, but am eager to get
    connected now. I followed Barb Bowman's instructions (very clear), but find
    an obstacle at this step:
    *******************************************************************************************************************************
    Sharing the Connection
    Now that a successful ad hoc wireless network has been created, we'll set up
    Internet Connection Sharing.

    1.
    Open Network Connections on the host computer. (Click Start, click
    Control Panel, click Switch to classic view, and then click Network
    Connections.

    2.
    Click the connection to be shared, and under Network Tasks, click
    Change settings of this connection.

    3.
    On the Advanced tab, select the Allow other network users to connect
    through this computer's Internet connection check box.

    4.
    If you are not using a third party firewall and have not already set up
    the Internet Connection Firewall (ICF), be sure to check the box enabling
    this feature. (Read more about why to enable ICF in an earlier column, Don't
    Let the Defense Rest.)

    5.
    Finally, optionally enable the setting to let other users control or
    enable this connection.


    After completing ICS configuration, the Network Connection window on the
    host computer will display the original wired Ethernet connection and
    display the status as Shared as well as Enabled. The Network Connection
    window on the client computer will display the connection on the host as an
    Internet Gateway.

    ****************************************************************************************************************************

    This is where the trouble begins:

    The DSL connection simply appears as "Local Area Connection" with no status
    of Shared or Enabled, and the client does not see the Internet Gateway.


    --
    All mail sent by me is virus-checked with NAV.
    Patrick S. Page
    Morongo Valley, CA
    760-363-0062
    "Steve Winograd [MVP]" <> wrote in message
    news:...
    | In article <>, "Patrick Page"
    | <> wrote:
    | >Thanks for your patience, Steve. The desktop has a simple DSL connection
    to
    | >Verizon and a wireless adapter through which I want to give my laptop
    | >internet access and be able to share files and printers. The laptop has a
    | >wireless adapter and a disabled ethernet adapter. No router anywhere in
    the
    | >picture. Both adapters are set to acquire IP addresses automatically.
    The
    | >c: drives on both systems are set for simple file sharing. The laptop now
    | >shows Node Type: Mixed; IP Routing enabled: No; WINS proxy enabled: No.
    |
    | You're welcome, Patrick. Thanks for the details of your setup.
    |
    | You need to set up an Ad-hoc wireless network between the desktop and
    | laptop computers and enable Internet Connection Sharing on the
    | desktop's DSL (PPPoE) connection. Barb Bowman has written a web page
    | that should help you get everything working:
    |
    | Making the Wireless Home Network Connection in Windows XP Without a
    | Router
    |
    http://www.microsoft.com/windowsxp/using/networking/expert/bowman_02april08.mspx
    |
    | Do you have an external DSL modem? If so, your network setup would be
    | simpler and more reliable if you got a wireless router, connected the
    | DSL modem to its WAN port, and connected the computers to it using
    | either a wired or wireless connection.
    | --
    | Best Wishes,
    | Steve Winograd, MS-MVP (Windows Networking)
    |
    | Please post any reply as a follow-up message in the news group
    | for everyone to see. I'm sorry, but I don't answer questions
    | addressed directly to me in E-mail or news groups.
    |
    | Microsoft Most Valuable Professional Program
    | http://mvp.support.microsoft.com
     
    Patrick Page, Sep 13, 2004
    #15
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Doug A Moller

    Need help with peer to peer no hub network

    Doug A Moller, Jun 23, 2004, in forum: Wireless Networking
    Replies:
    3
    Views:
    5,812
  2. =?Utf-8?B?QmlsbEM=?=

    peer to peer linking and sharing

    =?Utf-8?B?QmlsbEM=?=, Aug 23, 2004, in forum: Wireless Networking
    Replies:
    2
    Views:
    725
    =?Utf-8?B?QmlsbEM=?=
    Aug 23, 2004
  3. =?Utf-8?B?TWFya28=?=

    Trouble installing the peer-to-peer component

    =?Utf-8?B?TWFya28=?=, Dec 27, 2004, in forum: Wireless Networking
    Replies:
    1
    Views:
    2,331
  4. =?Utf-8?B?U2ltb24=?=

    Extended Peer to Peer Setup.

    =?Utf-8?B?U2ltb24=?=, Aug 25, 2006, in forum: Wireless Networking
    Replies:
    1
    Views:
    453
    Jack \(MVP-Networking\).
    Aug 25, 2006
  5. mdb

    strange setup for small peer to peer

    mdb, Jan 10, 2007, in forum: Wireless Networking
    Replies:
    1
    Views:
    447
    Jack \(MVP-Networking\).
    Jan 10, 2007
Loading...

Share This Page