OSPF routes not in routing table

Discussion in 'Cisco' started by spork, Jun 10, 2006.

  1. spork

    spork Guest

    Hi all,

    I'm still mostly a n00b when it comes to OSPF, but I've been using it
    in a fairly basic fashion for a number of years. I'm really stuck on
    this one, since I have a similar config going on another router and
    it's working as I'd expect it to.

    Hardware/Software Details: 1721 w/12.3(11)T5 IP BASE software, one T1
    WIC, one ADSL WIC

    Goal: both the T1 and ADSL lines come back to the same 7206. The T1 is
    frame converted to ATM at the dslam and long story short, that
    conversion doesn't let me see if the T1 is up or down from the 7206
    side, so I'm running OSPF. ADSL is a backup line. I want OSPF to
    advertise the LAN block on the 1721 back to the 7206 and the 7206 to
    advertise default to the 1721.

    Problem: Both routers are in area 0, and both see each other as
    neighbors. The 7206 has the 1721s loopback, serial ints and LAN ints
    in it's OSPF db and routing table. The 1721 has routes (including
    default) in the ospf db, but not in the routing table.

    Brief config snippets from both:

    7206:
    router ospf 1
    router-id 10.10.111.1
    log-adjacency-changes
    area 0 authentication message-digest
    passive-interface default
    no passive-interface ATM2/0.10246 <- ADSL
    no passive-interface ATM2/0.10248 <- T1
    no passive-interface ATM4/0.12655
    no passive-interface FastEthernet5/0.1
    network 10.10.104.0 0.0.0.255 area 0 <-T1 interface
    network 10.10.110.0 0.0.0.255 area 0 <-ADSL interface
    network 10.10.111.1 0.0.0.0 area 0
    network 10.10.111.8 0.0.0.7 area 0
    network 10.10.111.24 0.0.0.7 area 0
    default-information originate always
    !

    1721:
    router ospf 1
    router-id 10.10.111.254
    log-adjacency-changes
    redistribute connected subnets
    passive-interface default
    no passive-interface ATM0.1
    no passive-interface Serial0.1
    network 10.10.104.248 0.0.0.0 area 0 <-T1 interface
    network 10.10.108.16 0.0.0.15 area 0 <-LAN
    network 10.10.110.10 0.0.0.0 area 0 <-ADSL interface
    !

    So no problems on the 7206 side, I see all the routes I need to see.
    On the 1721 though:

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    C 10.10.104.0/24 is directly connected, Serial0.1
    10.10.111.0/32 is subnetted, 1 subnets
    C 10.10.111.254 is directly connected, Loopback0
    C 10.10.110.0/24 is directly connected, ATM0.1
    10.10.108.0/28 is subnetted, 1 subnets
    C 10.10.108.16 is directly connected, FastEthernet0
    S* 0.0.0.0/0 is directly connected, Serial0.1

    And if I drop that static default route, no ospf default route jumps in
    to take it's place.

    Here's the 1721 ospf database, you can see it's receiving a default:

    Infinia#sh ip ospf database

    OSPF Router with ID (10.10.111.254) (Process ID 1)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link
    count
    10.10.111.1 10.10.111.1 50 0x800016A8 0x001E53 9
    10.10.111.3 10.10.111.3 1461 0x800030B0 0x00F546 18
    10.10.111.254 10.10.111.254 629 0x80000012 0x00BB60 5

    Type-5 AS External Link States

    Link ID ADV Router Age Seq# Checksum Tag
    0.0.0.0 10.10.111.1 312 0x8000CC1B 0x00089D 1
    10.10.111.254 10.10.111.254 629 0x80000002 0x003C1B 0
    Infinia#

    So what am I missing here? I have a few other sites with similar
    configs and I have no problem getting a default route. In fact, other
    than the IOS version on those, there's really no difference. Is this a
    bug, or am I just not getting something fundamental here?

    Thanks,

    Charles
    spork, Jun 10, 2006
    #1
    1. Advertising

  2. spork

    Merv Guest

    OSPF message authentication is configured on 7206 but is not configured
    on 1721.


    For the OSPF process, "network 10.0.0.0 0.255.255.255 area 0" would
    suffice.


    Why is redistribute connected subnets command being used on 1721?
    Merv, Jun 10, 2006
    #2
    1. Advertising

  3. spork

    spork Guest

    Merv wrote:
    > OSPF message authentication is configured on 7206 but is not configured
    > on 1721.


    I must have missed it in the cut and paste - the routers are both using
    md5 keys, and the session is up.

    > For the OSPF process, "network 10.0.0.0 0.255.255.255 area 0" would
    > suffice.
    >
    >
    > Why is redistribute connected subnets command being used on 1721?


    I am most interested in getting the LAN route back to the 7206.

    Thanks,

    Charles
    spork, Jun 10, 2006
    #3
  4. spork

    Merv Guest

    Post the 1721's OSPF database and routing table after the OSPF
    authentication issue has been addressed.

    Post the output of "show ip ospf database router" from the 1721.
    Merv, Jun 10, 2006
    #4
  5. spork

    Merv Guest

    The "redistribute connected subnets" command maybe causing an issue
    with the forwarding address as it is installing an external in the
    1721's OSPF database

    For testing purpose, pull that command.
    Merv, Jun 10, 2006
    #5
  6. spork

    spork Guest

    Merv wrote:
    > Post the 1721's OSPF database and routing table after the OSPF
    > authentication issue has been addressed.
    >
    > Post the output of "show ip ospf database router" from the 1721.


    OK, the authentication line was in there. I removed "redistribute
    connected subnets" as well, and then for good measure went ahead and
    cleared the ospf routing process. Still no default showing up (or any
    other routes via ospf).

    Here's the output of "sh ip ospf database router", it's pretty long...

    I also noticed this little weirdness in the first few entries that
    struck me as odd:

    "(Link Data) Router Interface address: 0.0.6.214"

    Thanks again for all your help...

    Charles


    Infinia#sh ip ospf database router

    OSPF Router with ID (10.10.111.254) (Process ID 1)

    Router Link States (Area 0)

    Adv Router is not-reachable
    LS age: 536
    Options: (No TOS-capability, DC)
    LS Type: Router Links
    Link State ID: 10.10.111.1
    Advertising Router: 10.10.111.1
    LS Seq Number: 800016C7
    Checksum: 0xDF72
    Length: 132
    AS Boundary Router
    Number of Links: 9

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.110.1
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1
    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 10.10.111.254
    (Link Data) Router Interface address: 0.0.6.214
    Number of TOS metrics: 0
    TOS 0 Metrics: 2

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.104.1
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 10.10.111.254
    (Link Data) Router Interface address: 0.0.6.215
    Number of TOS metrics: 0
    TOS 0 Metrics: 33

    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 10.10.111.3
    (Link Data) Router Interface address: 10.10.111.25
    Number of TOS metrics: 0
    TOS 0 Metrics: 65
    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.111.24
    (Link Data) Network Mask: 255.255.255.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 65

    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 10.10.111.3
    (Link Data) Router Interface address: 10.10.111.13
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.111.12
    (Link Data) Network Mask: 255.255.255.252
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.111.1
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Adv Router is not-reachable
    LS age: 150
    Options: (No TOS-capability, DC)
    LS Type: Router Links
    Link State ID: 10.10.111.3
    Advertising Router: 10.10.111.3
    LS Seq Number: 800030D0
    Checksum: 0xB566
    Length: 240
    AS Boundary Router
    Number of Links: 18

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.112.0
    (Link Data) Network Mask: 255.255.255.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.107.208
    (Link Data) Network Mask: 255.255.255.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 10.10.111.1
    (Link Data) Router Interface address: 10.10.111.26
    Number of TOS metrics: 0
    TOS 0 Metrics: 65

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.111.24
    (Link Data) Network Mask: 255.255.255.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 65

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.107.232
    (Link Data) Network Mask: 255.255.255.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.107.240
    (Link Data) Network Mask: 255.255.255.240
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.118.128
    (Link Data) Network Mask: 255.255.255.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.111.16
    (Link Data) Network Mask: 255.255.255.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 10.10.111.1
    (Link Data) Router Interface address: 10.10.111.14
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.111.12
    (Link Data) Network Mask: 255.255.255.252
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.111.3
    (Link Data) Network Mask: 255.255.255.255
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.107.80
    (Link Data) Network Mask: 255.255.255.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.107.228
    (Link Data) Network Mask: 255.255.255.252
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.107.204
    (Link Data) Network Mask: 255.255.255.252
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.107.224
    (Link Data) Network Mask: 255.255.255.252
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.107.72
    (Link Data) Network Mask: 255.255.255.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 1

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.107.64
    (Link Data) Network Mask: 255.255.255.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 1
    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.107.0
    (Link Data) Network Mask: 255.255.255.192
    Number of TOS metrics: 0
    TOS 0 Metrics: 1


    LS age: 1053
    Options: (No TOS-capability, DC)
    LS Type: Router Links
    Link State ID: 10.10.111.254
    Advertising Router: 10.10.111.254
    LS Seq Number: 80000031
    Checksum: 0x7D7F
    Length: 84
    AS Boundary Router
    Number of Links: 5

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.108.16
    (Link Data) Network Mask: 255.255.255.240
    Number of TOS metrics: 0
    TOS 0 Metrics: 1
    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 10.10.111.1
    (Link Data) Router Interface address: 10.10.110.10
    Number of TOS metrics: 0
    TOS 0 Metrics: 130

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.110.0
    (Link Data) Network Mask: 255.255.255.0
    Number of TOS metrics: 0
    TOS 0 Metrics: 130

    Link connected to: another Router (point-to-point)
    (Link ID) Neighboring Router ID: 10.10.111.1
    (Link Data) Router Interface address: 10.10.104.248
    Number of TOS metrics: 0
    TOS 0 Metrics: 65

    Link connected to: a Stub Network
    (Link ID) Network/subnet number: 10.10.104.0
    (Link Data) Network Mask: 255.255.255.0
    Number of TOS metrics: 0
    TOS 0 Metrics: 65

    Infinia#
    spork, Jun 10, 2006
    #6
  7. spork

    Merv Guest

    It looks like the LSA's are not be installed in the 1721's routing
    table because the LSA are flagged "Adv Router is not-reachable". There
    are several causes of this and you need to work thru to find out which
    one is occuring in your case.

    see Cisco doc "Why Are Some OSPF Routes in the Database but Not in the
    Routing Table?"
    http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009481a.shtml


    Please post the complete configue for the 1721 and the 7206 interface
    config connected to the 1721.

    Also post the config and the interface config for a comparable site
    that is working along with IOS version on the remote site along with
    "sh ip ospf database router" for the working site.
    Merv, Jun 11, 2006
    #7
  8. spork

    Merv Guest

    Check that the IP addressing for the T1 and the ADSL link on the 1721
    are not reversed.
    Merv, Jun 11, 2006
    #8
  9. spork

    Merv Guest

    Merv wrote:
    > Check that the IP addressing for the T1 and the ADSL link on the 1721
    > are not reversed.


    Post the output of "show ip ospf interface" for both the T1 and the
    ADSL link on the 7206 and the 1721 routers
    Merv, Jun 11, 2006
    #9
  10. spork

    Merv Guest

    any joy ?
    Merv, Jun 12, 2006
    #10
  11. spork

    spork Guest

    Merv wrote:
    > any joy ?


    Working on it. :)

    Thanks for the public one-on-one troubleshooting...

    I think I can probably fix this by altering the config to use a
    dedicated /30 on each link. Right now both links are atm subifs on the
    7206 and each interface uses an "ip unnumbered loopback X", which seems
    like it may be causing the "adv router not reachable" issue. This
    looks like it's addressed in that CCO doc you linked - I need to parse
    that more carefully. I'm going to try futzing and then post back. But
    in the meantime I'll put everything you asked for in here for the
    archives.

    sample non-working config (note that my cvs config puller removes the
    md5 keys):

    7206-

    interface ATM2/0.10246 point-to-point
    ip unnumbered Loopback7
    ip ospf authentication message-digest
    ! ip ospf message-digest-key 1 md5 <removed>
    ip ospf mtu-ignore
    pvc 0/10246
    encapsulation aal5snap
    !
    interface Loopback7
    description loopback for 10.10.110.0/24 sdsl
    ip address 10.10.110.1 255.255.255.255
    !
    ip route 10.10.110.10 255.255.255.255 ATM2/0.10246

    1721-

    interface ATM0.1 point-to-point
    ip address 10.10.110.10 255.255.255.0
    ip ospf authentication message-digest
    ! ip ospf message-digest-key 1 md5 7 <removed>
    ip ospf network point-to-point
    ip ospf mtu-ignore
    pvc 0/35
    encapsulation aal5snap
    !

    And now an example of a working config which uses numbered interfaces.
    Note that since there's no SDSL WIC that works with Nokia dslams this
    is bridged:

    7206-

    interface ATM4/0.12655 point-to-point
    bandwidth 1536
    ip address 10.10.111.25 255.255.255.248 (using a /29 so I have an IP
    for bridge mgmt)
    ip ospf authentication message-digest
    ! ip ospf message-digest-key 1 md5 <removed>
    ip ospf mtu-ignore
    atm route-bridged ip
    pvc 0/12655
    abr 1536 1536
    encapsulation aal5snap
    !

    3640-

    interface FastEthernet0/0.3
    description vlan 3 - sdsl to level3 circid -
    bandwidth 1536
    encapsulation dot1Q 3
    ip address 10.10.111.26 255.255.255.248
    no ip proxy-arp
    ip ospf authentication message-digest
    ! ip ospf message-digest-key 1 md5 <removed>
    ip ospf network point-to-point
    ip ospf mtu-ignore


    Next up, requested ospf db from the working site:

    router-568#sh ip ospf database

    OSPF Router with ID (10.10.111.3) (Process ID 1)

    Router Link States (Area 0)

    Link ID ADV Router Age Seq# Checksum Link
    count
    10.10.111.1 10.10.111.1 80 0x80001721 0x002ACD 9
    10.10.111.3 10.10.111.3 985 0x80003129 0x0002C0 18
    10.10.111.254 10.10.111.254 39 0x8000008B 0x00C8D9 5

    Type-5 AS External Link States

    Link ID ADV Router Age Seq# Checksum Tag
    0.0.0.0 10.10.111.1 80 0x8000CC94 0x001517 1
    router-568#sh ip route ospf
    10.10.104.0/24 is variably subnetted, 2 subnets, 2 masks
    O 10.10.104.0/24 [110/68] via 10.10.111.13, 2d19h,
    FastEthernet0/0.2
    O 10.10.104.1/32 [110/2] via 10.10.111.13, 2d19h,
    FastEthernet0/0.2
    10.10.111.0/24 is variably subnetted, 5 subnets, 3 masks
    O 10.10.111.1/32 [110/2] via 10.10.111.13, 2d19h,
    FastEthernet0/0.2
    10.10.110.0/24 is variably subnetted, 2 subnets, 2 masks
    O 10.10.110.0/24

    (FE 0/0.2 is a 10Mb metro ether line, FE 0/0.3 is a 1.5Mb SDSL line
    terminated on a bridge)

    As to the post regarding numbering, it is correct.

    Lastly, the interface info for both the 7206 and 1721 (note that the
    network types match):

    7206-

    router-l3t#sh ip ospf interface atm 2/0.10246
    ATM2/0.10246 is up, line protocol is up
    Internet Address 0.0.0.0/0, Area 0
    Process ID 1, Router ID 10.10.111.1, Network Type POINT_TO_POINT,
    Cost: 2
    Transmit Delay is 1 sec, State POINT_TO_POINT,
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
    Index 306/306, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 2, maximum is 2
    Last flood scan time is 0 msec, maximum is 0 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.10.111.254
    Suppress hello for 0 neighbor(s)
    Message digest authentication enabled
    Youngest key id is 1

    1721-

    Infinia#sh ip ospf interface serial 0.1
    Serial0.1 is up, line protocol is up
    Internet Address 10.10.104.248/24, Area 0
    Process ID 1, Router ID 10.10.111.254, Network Type POINT_TO_POINT,
    Cost: 65 Transmit Delay is 1 sec, State POINT_TO_POINT,
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
    Supports Link-local Signaling (LLS)
    Index 1/1, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 1, maximum is 1
    Last flood scan time is 0 msec, maximum is 4 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 10.10.111.1
    Suppress hello for 0 neighbor(s)
    Message digest authentication enabled
    Youngest key id is 1

    I think that's all the info... I need to investigate this unnumbered
    issue, I think that will take me somewhere.

    Thanks for all your help!

    Charles
    spork, Jun 13, 2006
    #11
  12. spork

    spork Guest

    spork wrote:
    > Merv wrote:
    > > any joy ?


    Yes!

    http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009481a.shtml#r4

    It was the numbered+unnumbered issue linked above. Should have posted
    my interface configs right off the bat, sorry about that. I'm so used
    to the unnumbered stuff since 99.999% of our lines are setup that
    way... habit.

    Infinia#sh ip route ospf | inc 0.0.0.0
    O*E2 0.0.0.0/0 [110/1] via 10.10.111.221, 00:01:54, Serial0.1

    Now I just have to clean things up and I think this is all good to go.

    One more question, for a site like this where it's just two lines with
    one backing the other up, should I just look at setting up another
    area? This is a pretty rare config for us, so I'm tempted to leave it
    as-is, and I've never played with stub areas or NSSA's... Any opinions
    on that?

    Thanks again for all the help Merv,

    Charles
    spork, Jun 13, 2006
    #12
  13. spork

    Merv Guest

    For one site I would not worry about setting up another area.

    I would encourage you to simpify you network statments to one.
    Merv, Jun 13, 2006
    #13
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Joachim Krais
    Replies:
    2
    Views:
    14,844
    Andre Beck
    Nov 23, 2003
  2. John Ramsden
    Replies:
    0
    Views:
    814
    John Ramsden
    Jul 24, 2004
  3. zher
    Replies:
    2
    Views:
    8,857
  4. casatirider
    Replies:
    3
    Views:
    1,703
  5. Replies:
    2
    Views:
    702
Loading...

Share This Page