OSPF not advertising a network

Discussion in 'Cisco' started by Pete Mainwaring, Jul 29, 2004.

  1. We have an OSPF problem where one subnet (and only one) is not being
    advertised. We originally spotted the problem from another (non-Cisco
    router), but looking at the OSPF database on both our Catalyst 6509
    MSFC's would seem to confirm the problem.

    This is a snip of the OSPF database on one of the 6509 MSFCs showing a
    few of the Link Ids that appear, minus the 10.96.25.0 network.

    Link ID ADV Router Age Seq# Checksum
    10.96.0.253 207.129.103.11 1140 0x80003716 0xCEBC
    10.96.1.253 207.129.103.11 1140 0x80003714 0xC7C4
    10.96.2.253 207.129.103.11 1140 0x80003714 0xBCCE
    ...
    <snip>
    ...
    10.96.23.253 207.129.103.11 1140 0x80003221 0xC9A4
    10.96.24.253 207.129.103.11 1140 0x80000FFF 0x6A47
    10.96.26.253 207.129.103.11 1140 0x8000160F 0x2178
    ...
    <snip>
    ...

    The corresponding parts of the config (with irrelevant config commands
    removed) look like this:-

    <snip>
    ...
    interface Vlan103
    ip address 10.96.0.253 255.255.255.0
    standby 1 priority 200 preempt
    standby 1 ip 10.96.0.254
    !
    interface Vlan104
    ip address 10.96.1.253 255.255.255.0
    standby 1 priority 250 preempt
    standby 1 ip 10.96.1.254
    !
    interface Vlan105
    ip address 10.96.2.253 255.255.255.0
    standby 1 priority 200 preempt
    standby 1 ip 10.96.2.254
    ...
    <snip>
    ...
    interface Vlan123
    ip address 10.96.23.253 255.255.255.0
    standby 1 priority 250 preempt
    standby 1 ip 10.96.23.254
    ...
    <snip>
    ...
    interface Vlan126
    ip address 10.96.24.253 255.255.255.0
    standby 1 priority 200 preempt
    standby 1 ip 10.96.24.254
    ...
    <snip>
    ...
    interface Vlan128
    ip address 10.96.25.253 255.255.255.0
    standby 1 priority 200 preempt
    standby 1 ip 10.96.25.254
    ...
    <snip>
    ...
    interface Vlan131
    ip address 10.96.26.253 255.255.255.0
    standby 1 priority 250 preempt
    standby 1 ip 10.96.26.254
    !
    <snip>
    ...
    <snip>
    ...
    router ospf 1
    area 0.0.0.3 stub
    network 0.0.0.0 255.255.255.255 area 0.0.0.3
    maximum-paths 1

    The MSFC on the other 6509 has similar config settings (with correct
    standby priorities etc.).

    I can't work out why this network isn't being advertised.

    Any ideas?

    Thanks,

    Pete
    Pete Mainwaring, Jul 29, 2004
    #1
    1. Advertising

  2. Pete Mainwaring

    PJML Guest

    Pete Mainwaring wrote:

    > We have an OSPF problem where one subnet (and only one) is not being
    > advertised. We originally spotted the problem from another (non-Cisco
    > router), but looking at the OSPF database on both our Catalyst 6509
    > MSFC's would seem to confirm the problem.
    >
    > This is a snip of the OSPF database on one of the 6509 MSFCs showing a
    > few of the Link Ids that appear, minus the 10.96.25.0 network.


    You do have "ip subnet-zero" as well as "ip classless"
    set don't you?
    PJML, Jul 29, 2004
    #2
    1. Advertising

  3. In article <>,
    Pete Mainwaring <> wrote:
    >We have an OSPF problem where one subnet (and only one) is not being
    >advertised. We originally spotted the problem from another (non-Cisco
    >router), but looking at the OSPF database on both our Catalyst 6509
    >MSFC's would seem to confirm the problem.
    >
    >This is a snip of the OSPF database on one of the 6509 MSFCs showing a
    >few of the Link Ids that appear, minus the 10.96.25.0 network.
    >


    At the risk of sounding silly, you did verify that the VLAN is
    actually UP/UP and should be advertised?

    --
    Vincent C Jones, Consultant Expert advice and a helping hand
    Networking Unlimited, Inc. for those who want to manage and
    Tenafly, NJ Phone: 201 568-7810 control their networking destiny
    http://www.networkingunlimited.com
    Vincent C Jones, Jul 29, 2004
    #3
  4. Pete Mainwaring

    Hansang Bae Guest

    > Pete Mainwaring wrote:
    > > We have an OSPF problem where one subnet (and only one) is not being
    > > advertised. We originally spotted the problem from another (non-Cisco
    > > router), but looking at the OSPF database on both our Catalyst 6509
    > > MSFC's would seem to confirm the problem.
    > >
    > > This is a snip of the OSPF database on one of the 6509 MSFCs showing a
    > > few of the Link Ids that appear, minus the 10.96.25.0 network.

    [snip: on vlan in 6509 is not showing up in the ospf database)

    In article <41090761$>, back says...
    > You do have "ip subnet-zero" as well as "ip classless"
    > set don't you?



    Why would that matter? it's not all zero subnet and "ip classless"
    affects forwarding behavior.

    My two guess in order of likelyhood:

    1) VLAN 128 is not up/up. I.E. you have no ports active on in that
    VLAN.
    2) Your use of "network 0.0.0.0 255.255.255.255" may be causing you
    grief. I had some issue with earlier versions when using this
    statement.


    --

    hsb

    "Somehow I imagined this experience would be more rewarding" Calvin
    *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    ********************************************************************
    Due to the volume of email that I receive, I may not not be able to
    reply to emails sent to my account. Please post a followup instead.
    ********************************************************************
    Hansang Bae, Jul 30, 2004
    #4
  5. (Vincent C Jones) wrote in message news:<cebitj$62j$>...
    > In article <>,
    > Pete Mainwaring <> wrote:
    > >We have an OSPF problem where one subnet (and only one) is not being
    > >advertised. We originally spotted the problem from another (non-Cisco
    > >router), but looking at the OSPF database on both our Catalyst 6509
    > >MSFC's would seem to confirm the problem.
    > >
    > >This is a snip of the OSPF database on one of the 6509 MSFCs showing a
    > >few of the Link Ids that appear, minus the 10.96.25.0 network.
    > >

    >
    > At the risk of sounding silly, you did verify that the VLAN is
    > actually UP/UP and should be advertised?


    "ip classless" and "ip subnet-zero" are both set and the VLAN is
    working. I can ping devices in the 10.96.25.0 subnet from my PC which
    is on a different subnet. The only place that we are unable to reach
    the 10.96.25.0 subnet from are the non-Cisco routers (because there is
    no entry in their routing tables). I could add static routes on the
    non-Cisco routers to get round the problem, but it should be there via
    OSPF.

    The VLAN in question does show up if I do a "show ip ospf interface",
    but all the parameters look the same as the other VLANs, for example
    the 10.96.24.0 subnet (which is being advertised) :-

    Vlan126 is up, line protocol is up
    Internet Address 10.96.24.252/24, Area 0.0.0.3
    Process ID 1, Router ID 10.96.7.3, Network Type BROADCAST, Cost: 1
    Transmit Delay is 1 sec, State BDR, Priority 1
    Designated Router (ID) 207.129.103.11, Interface address
    10.96.24.253
    Backup Designated router (ID) 10.96.7.3, Interface address
    10.96.24.252
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
    Index 29/29, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 3, maximum is 31
    Last flood scan time is 0 msec, maximum is 4 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 207.129.103.11 (Designated Router)
    Suppress hello for 0 neighbor(s)
    Vlan128 is up, line protocol is up
    Internet Address 10.96.25.252/24, Area 0.0.0.3
    Process ID 1, Router ID 10.96.7.3, Network Type BROADCAST, Cost: 1
    Transmit Delay is 1 sec, State BDR, Priority 1
    Designated Router (ID) 207.129.103.11, Interface address
    10.96.25.253
    Backup Designated router (ID) 10.96.7.3, Interface address
    10.96.25.252
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
    Index 31/31, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 3, maximum is 31
    Last flood scan time is 0 msec, maximum is 4 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 207.129.103.11 (Designated Router)
    Suppress hello for 0 neighbor(s)

    I'm still stumped!!

    Pete
    Pete Mainwaring, Jul 30, 2004
    #5
  6. (Vincent C Jones) wrote in message news:<cebitj$62j$>...
    > In article <>,
    > Pete Mainwaring <> wrote:
    > >We have an OSPF problem where one subnet (and only one) is not being
    > >advertised. We originally spotted the problem from another (non-Cisco
    > >router), but looking at the OSPF database on both our Catalyst 6509
    > >MSFC's would seem to confirm the problem.
    > >
    > >This is a snip of the OSPF database on one of the 6509 MSFCs showing a
    > >few of the Link Ids that appear, minus the 10.96.25.0 network.
    > >

    >
    > At the risk of sounding silly, you did verify that the VLAN is
    > actually UP/UP and should be advertised?


    "ip classless" and "ip subnet-zero" are both set and the VLAN is
    working. I can ping devices in the 10.96.25.0 subnet from my PC which
    is on a different subnet. The only place that we are unable to reach
    the 10.96.25.0 subnet from are the non-Cisco routers (because there is
    no entry in their routing tables). I could add static routes on the
    non-Cisco routers to get round the problem, but it should be there via
    OSPF.

    The VLAN in question does show up if I do a "show ip ospf interface",
    but all the parameters look the same as the other VLANs, for example
    the 10.96.24.0 subnet (which is being advertised) :-

    Vlan126 is up, line protocol is up
    Internet Address 10.96.24.252/24, Area 0.0.0.3
    Process ID 1, Router ID 10.96.7.3, Network Type BROADCAST, Cost: 1
    Transmit Delay is 1 sec, State BDR, Priority 1
    Designated Router (ID) 207.129.103.11, Interface address
    10.96.24.253
    Backup Designated router (ID) 10.96.7.3, Interface address
    10.96.24.252
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:02
    Index 29/29, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 3, maximum is 31
    Last flood scan time is 0 msec, maximum is 4 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 207.129.103.11 (Designated Router)
    Suppress hello for 0 neighbor(s)
    Vlan128 is up, line protocol is up
    Internet Address 10.96.25.252/24, Area 0.0.0.3
    Process ID 1, Router ID 10.96.7.3, Network Type BROADCAST, Cost: 1
    Transmit Delay is 1 sec, State BDR, Priority 1
    Designated Router (ID) 207.129.103.11, Interface address
    10.96.25.253
    Backup Designated router (ID) 10.96.7.3, Interface address
    10.96.25.252
    Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
    Index 31/31, flood queue length 0
    Next 0x0(0)/0x0(0)
    Last flood scan length is 3, maximum is 31
    Last flood scan time is 0 msec, maximum is 4 msec
    Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 207.129.103.11 (Designated Router)
    Suppress hello for 0 neighbor(s)

    I'm still stumped!!

    Pete
    Pete Mainwaring, Jul 30, 2004
    #6
  7. Pete Mainwaring

    supernet Guest

    Upgrade IOS

    "Pete Mainwaring" <> wrote in message
    news:...
    > We have an OSPF problem where one subnet (and only one) is not being
    > advertised. We originally spotted the problem from another (non-Cisco
    > router), but looking at the OSPF database on both our Catalyst 6509
    > MSFC's would seem to confirm the problem.
    >
    > This is a snip of the OSPF database on one of the 6509 MSFCs showing a
    > few of the Link Ids that appear, minus the 10.96.25.0 network.
    >
    > Link ID ADV Router Age Seq# Checksum
    > 10.96.0.253 207.129.103.11 1140 0x80003716 0xCEBC
    > 10.96.1.253 207.129.103.11 1140 0x80003714 0xC7C4
    > 10.96.2.253 207.129.103.11 1140 0x80003714 0xBCCE
    > ..
    > <snip>
    > ..
    > 10.96.23.253 207.129.103.11 1140 0x80003221 0xC9A4
    > 10.96.24.253 207.129.103.11 1140 0x80000FFF 0x6A47
    > 10.96.26.253 207.129.103.11 1140 0x8000160F 0x2178
    > ..
    > <snip>
    > ..
    >
    > The corresponding parts of the config (with irrelevant config commands
    > removed) look like this:-
    >
    > <snip>
    > ..
    > interface Vlan103
    > ip address 10.96.0.253 255.255.255.0
    > standby 1 priority 200 preempt
    > standby 1 ip 10.96.0.254
    > !
    > interface Vlan104
    > ip address 10.96.1.253 255.255.255.0
    > standby 1 priority 250 preempt
    > standby 1 ip 10.96.1.254
    > !
    > interface Vlan105
    > ip address 10.96.2.253 255.255.255.0
    > standby 1 priority 200 preempt
    > standby 1 ip 10.96.2.254
    > ..
    > <snip>
    > ..
    > interface Vlan123
    > ip address 10.96.23.253 255.255.255.0
    > standby 1 priority 250 preempt
    > standby 1 ip 10.96.23.254
    > ..
    > <snip>
    > ..
    > interface Vlan126
    > ip address 10.96.24.253 255.255.255.0
    > standby 1 priority 200 preempt
    > standby 1 ip 10.96.24.254
    > ..
    > <snip>
    > ..
    > interface Vlan128
    > ip address 10.96.25.253 255.255.255.0
    > standby 1 priority 200 preempt
    > standby 1 ip 10.96.25.254
    > ..
    > <snip>
    > ..
    > interface Vlan131
    > ip address 10.96.26.253 255.255.255.0
    > standby 1 priority 250 preempt
    > standby 1 ip 10.96.26.254
    > !
    > <snip>
    > ..
    > <snip>
    > ..
    > router ospf 1
    > area 0.0.0.3 stub
    > network 0.0.0.0 255.255.255.255 area 0.0.0.3
    > maximum-paths 1
    >
    > The MSFC on the other 6509 has similar config settings (with correct
    > standby priorities etc.).
    >
    > I can't work out why this network isn't being advertised.
    >
    > Any ideas?
    >
    > Thanks,
    >
    > Pete
    supernet, Jul 30, 2004
    #7
  8. "supernet" <> wrote in message news:<>...
    > Upgrade IOS
    >


    That is a good idea - the version we are running is a bit old. Is this
    a problem you have seen before on older versions of IOS?

    Pete
    Pete Mainwaring, Aug 2, 2004
    #8
  9. Hansang Bae <> wrote in message news:<>...
    > > Pete Mainwaring wrote:
    > > > We have an OSPF problem where one subnet (and only one) is not being
    > > > advertised. We originally spotted the problem from another (non-Cisco
    > > > router), but looking at the OSPF database on both our Catalyst 6509
    > > > MSFC's would seem to confirm the problem.
    > > >
    > > > This is a snip of the OSPF database on one of the 6509 MSFCs showing a
    > > > few of the Link Ids that appear, minus the 10.96.25.0 network.

    > [snip: on vlan in 6509 is not showing up in the ospf database)
    >
    > In article <41090761$>, back says...
    > > You do have "ip subnet-zero" as well as "ip classless"
    > > set don't you?

    >
    >
    > Why would that matter? it's not all zero subnet and "ip classless"
    > affects forwarding behavior.
    >
    > My two guess in order of likelyhood:
    >
    > 1) VLAN 128 is not up/up. I.E. you have no ports active on in that
    > VLAN.
    > 2) Your use of "network 0.0.0.0 255.255.255.255" may be causing you
    > grief. I had some issue with earlier versions when using this
    > statement.
    >
    >
    > --
    >
    > hsb
    >
    > "Somehow I imagined this experience would be more rewarding" Calvin
    > *************** USE ROT13 TO SEE MY EMAIL ADDRESS ****************
    > ********************************************************************
    > Due to the volume of email that I receive, I may not not be able to
    > reply to emails sent to my account. Please post a followup instead.
    > ********************************************************************


    The IOS version could well be the problem as we are running a fairly
    old version. We will have to get it upgraded I think.

    Thanks,

    Pete
    Pete Mainwaring, Aug 2, 2004
    #9
  10. "supernet" <> wrote in message news:<>...
    > Upgrade IOS
    >

    Problem solved. Did a shut/no shut on the VLAN and its now there. I'll
    still look to upgrade the IOS though.

    Pete
    Pete Mainwaring, Aug 2, 2004
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. E.Finlayson
    Replies:
    0
    Views:
    1,581
    E.Finlayson
    Sep 10, 2004
  2. Replies:
    3
    Views:
    856
  3. steve_nsi
    Replies:
    2
    Views:
    6,862
    James Harris
    Dec 27, 2005
  4. Replies:
    4
    Views:
    800
  5. ve7eje
    Replies:
    4
    Views:
    5,169
    Patrick M. Hausen
    Mar 22, 2010
Loading...

Share This Page