ospf configuration

Discussion in 'Cisco' started by CREAM, May 18, 2010.

  1. CREAM

    CREAM Guest

    Hi, I'm trying to get this ospf to work on my network. I can't seem to
    get it. I would really appreciate a correct config on the ospf. Please
    look at it.



    hostname Lima_RT1
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$6jwG$jI1JKhcN1nQRaOhD3gPz50
    !
    no aaa new-model
    !
    resource policy
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip cef
    !
    !
    no ip dhcp use vrf connected
    !
    ip dhcp pool 88
    network 172.20.13.0 255.255.255.240
    !
    ip dhcp pool 19
    network 172.20.12.0 255.255.255.0
    !
    ip dhcp pool 17
    network 172.20.8.0 255.255.252.0
    !
    ip dhcp pool 11
    network 172.20.0.0 255.255.248.0
    !
    !
    !
    username LIMA_RT2 password 0 cisco
    !
    !
    !
    interface Loopback0
    ip address 10.0.2.1 255.255.255.255
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.11
    encapsulation dot1Q 11
    ip address 172.20.0.1 255.255.248.0
    no snmp trap link-status
    !
    interface FastEthernet0/0.17
    encapsulation dot1Q 17
    ip address 172.20.8.2 255.255.252.0
    no snmp trap link-status
    !
    interface FastEthernet0/0.19
    encapsulation dot1Q 14
    ip address 172.20.12.1 255.255.255.0
    no snmp trap link-status
    !
    interface FastEthernet0/0.88
    encapsulation dot1Q 88 native
    ip address 172.20.13.1 255.255.255.240
    ip access-group 115 in
    no snmp trap link-status
    !
    interface FastEthernet0/0.195
    !
    interface FastEthernet0/0.196
    !
    interface FastEthernet0/0.197
    !
    interface FastEthernet0/0.198
    !
    interface FastEthernet0/1
    ip address 192.168.254.253 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    ip address 172.0.255.2 255.255.255.252
    encapsulation frame-relay
    shutdown
    no fair-queue
    clockrate 125000
    !
    interface Serial0/0/0.201 point-to-point
    ip access-group 101 in
    ip access-group 101 out
    !
    interface Serial0/0/0.202 point-to-point
    ip address 172.0.255.13 255.255.255.252
    !
    interface Serial0/0/0.203 point-to-point
    ip address 172.0.255.17 255.255.255.252
    !
    interface Serial0/0/1
    ip address 172.0.255.33 255.255.255.252
    encapsulation ppp
    clockrate 64000
    ppp authentication chap
    !
    router ospf 1
    log-adjacency-changes
    network 172.0.255.0 0.0.0.3 area 0
    network 172.0.255.12 0.0.0.3 area 0
    network 172.0.255.16 0.0.0.3 area 0
    network 172.0.255.32 0.0.0.3 area 0
    network 172.20.0.0 0.0.7.255 area 0
    network 172.20.12.0 0.0.0.3 area 0
    network 172.20.13.0 0.0.0.15 area 0
    !
    ip classless
    !
    ip http server
    !
    access-list 102 permit tcp host 172.20.0.2 host 192.168.254.254 eq ftp
    access-list 102 deny tcp host 172.20.0.2 host 192.168.254.254 eq
    5190
    access-list 102 deny tcp host 172.20.0.2 host 192.168.254.254 eq
    5050
    access-list 102 permit tcp host 172.20.0.2 host 192.168.254.254 eq www
    access-list 103 permit tcp host 172.20.8.2 host 192.168.254.254 eq www
    access-list 103 deny tcp host 172.20.8.2 host 192.168.254.254 eq
    5050
    access-list 103 permit tcp host 172.20.8.2 host 192.168.254.254 eq ftp
    access-list 103 permit tcp host 172.20.12.2 host 192.168.254.254 eq
    www
    access-list 103 deny tcp host 172.20.8.2 host 192.168.254.254 eq
    5190
    access-list 106 permit tcp host 172.20.12.2 host 192.168.254.254 eq
    ftp
    access-list 106 permit tcp host 172.20.12.2 host 192.168.254.254
    access-list 106 deny tcp host 172.20.12.2 host 192.168.254.254 eq
    5190
    access-list 106 deny tcp host 172.20.12.2 host 192.168.254.254 eq
    5050
    !
    control-plane
    !
    banner motd ^CCWelcome to RT1 ^C
    !
    line con 0
    password cisco
    login
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    scheduler allocate 20000 1000
    end
     
    CREAM, May 18, 2010
    #1
    1. Advertising

  2. CREAM

    Brian V Guest

    "CREAM" <> wrote in message
    news:...
    > Hi, I'm trying to get this ospf to work on my network. I can't seem to
    > get it. I would really appreciate a correct config on the ospf. Please
    > look at it.
    >
    >
    >
    > hostname Lima_RT1
    > !
    > boot-start-marker
    > boot-end-marker
    > !
    > enable secret 5 $1$6jwG$jI1JKhcN1nQRaOhD3gPz50
    > !
    > no aaa new-model
    > !
    > resource policy
    > !
    > mmi polling-interval 60
    > no mmi auto-configure
    > no mmi pvc
    > mmi snmp-timeout 180
    > ip subnet-zero
    > ip cef
    > !
    > !
    > no ip dhcp use vrf connected
    > !
    > ip dhcp pool 88
    > network 172.20.13.0 255.255.255.240
    > !
    > ip dhcp pool 19
    > network 172.20.12.0 255.255.255.0
    > !
    > ip dhcp pool 17
    > network 172.20.8.0 255.255.252.0
    > !
    > ip dhcp pool 11
    > network 172.20.0.0 255.255.248.0
    > !
    > !
    > !
    > username LIMA_RT2 password 0 cisco
    > !
    > !
    > !
    > interface Loopback0
    > ip address 10.0.2.1 255.255.255.255
    > !
    > interface FastEthernet0/0
    > no ip address
    > duplex auto
    > speed auto
    > !
    > interface FastEthernet0/0.11
    > encapsulation dot1Q 11
    > ip address 172.20.0.1 255.255.248.0
    > no snmp trap link-status
    > !
    > interface FastEthernet0/0.17
    > encapsulation dot1Q 17
    > ip address 172.20.8.2 255.255.252.0
    > no snmp trap link-status
    > !
    > interface FastEthernet0/0.19
    > encapsulation dot1Q 14
    > ip address 172.20.12.1 255.255.255.0
    > no snmp trap link-status
    > !
    > interface FastEthernet0/0.88
    > encapsulation dot1Q 88 native
    > ip address 172.20.13.1 255.255.255.240
    > ip access-group 115 in
    > no snmp trap link-status
    > !
    > interface FastEthernet0/0.195
    > !
    > interface FastEthernet0/0.196
    > !
    > interface FastEthernet0/0.197
    > !
    > interface FastEthernet0/0.198
    > !
    > interface FastEthernet0/1
    > ip address 192.168.254.253 255.255.255.0
    > duplex auto
    > speed auto
    > !
    > interface Serial0/0/0
    > ip address 172.0.255.2 255.255.255.252
    > encapsulation frame-relay
    > shutdown
    > no fair-queue
    > clockrate 125000
    > !
    > interface Serial0/0/0.201 point-to-point
    > ip access-group 101 in
    > ip access-group 101 out
    > !
    > interface Serial0/0/0.202 point-to-point
    > ip address 172.0.255.13 255.255.255.252
    > !
    > interface Serial0/0/0.203 point-to-point
    > ip address 172.0.255.17 255.255.255.252
    > !
    > interface Serial0/0/1
    > ip address 172.0.255.33 255.255.255.252
    > encapsulation ppp
    > clockrate 64000
    > ppp authentication chap
    > !
    > router ospf 1
    > log-adjacency-changes
    > network 172.0.255.0 0.0.0.3 area 0
    > network 172.0.255.12 0.0.0.3 area 0
    > network 172.0.255.16 0.0.0.3 area 0
    > network 172.0.255.32 0.0.0.3 area 0
    > network 172.20.0.0 0.0.7.255 area 0
    > network 172.20.12.0 0.0.0.3 area 0
    > network 172.20.13.0 0.0.0.15 area 0
    > !
    > ip classless
    > !
    > ip http server
    > !
    > access-list 102 permit tcp host 172.20.0.2 host 192.168.254.254 eq ftp
    > access-list 102 deny tcp host 172.20.0.2 host 192.168.254.254 eq
    > 5190
    > access-list 102 deny tcp host 172.20.0.2 host 192.168.254.254 eq
    > 5050
    > access-list 102 permit tcp host 172.20.0.2 host 192.168.254.254 eq www
    > access-list 103 permit tcp host 172.20.8.2 host 192.168.254.254 eq www
    > access-list 103 deny tcp host 172.20.8.2 host 192.168.254.254 eq
    > 5050
    > access-list 103 permit tcp host 172.20.8.2 host 192.168.254.254 eq ftp
    > access-list 103 permit tcp host 172.20.12.2 host 192.168.254.254 eq
    > www
    > access-list 103 deny tcp host 172.20.8.2 host 192.168.254.254 eq
    > 5190
    > access-list 106 permit tcp host 172.20.12.2 host 192.168.254.254 eq
    > ftp
    > access-list 106 permit tcp host 172.20.12.2 host 192.168.254.254
    > access-list 106 deny tcp host 172.20.12.2 host 192.168.254.254 eq
    > 5190
    > access-list 106 deny tcp host 172.20.12.2 host 192.168.254.254 eq
    > 5050
    > !
    > control-plane
    > !
    > banner motd ^CCWelcome to RT1 ^C
    > !
    > line con 0
    > password cisco
    > login
    > line aux 0
    > line vty 0 4
    > password cisco
    > login
    > !
    > scheduler allocate 20000 1000
    > end


    nothing wrong with it on this router, what do all the other routers configs
    look like?
     
    Brian V, May 18, 2010
    #2
    1. Advertising

  3. CREAM

    Shurik Guest

    try to enable the logging in buffer and add the line "deny ip any any
    log" in the end of every ACL. Then look "sh logg". Probably ACLs deny
    OSPF.
     
    Shurik, May 20, 2010
    #3
  4. CREAM

    Shurik Guest

    and try to change the line (network 172.20.12.0 0.0.0.3 area 0 ) on
    the (network 172.20.12.0 0.0.0.255 area 0)
     
    Shurik, May 20, 2010
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. E.Finlayson
    Replies:
    0
    Views:
    1,639
    E.Finlayson
    Sep 10, 2004
  2. Replies:
    2
    Views:
    600
    kunal trivedi
    Apr 9, 2005
  3. jester
    Replies:
    1
    Views:
    1,792
    Vivek
    Dec 20, 2005
  4. Replies:
    4
    Views:
    821
  5. Ruchi22

    OSPF to routers configuration

    Ruchi22, Nov 27, 2011, in forum: Cisco
    Replies:
    0
    Views:
    953
    Ruchi22
    Nov 27, 2011
Loading...

Share This Page