OSPF and Static routes convergence

Discussion in 'Cisco' started by maher, Dec 21, 2004.

  1. maher

    maher Guest

    Hi there,

    My network is running OSPF and static route for ISDN connection for each
    sites. Basically, I have redundancy whereby when the primary link is
    down at site(s), ISDN connection will take over, and when the primary
    link is back in action again, the ISDN will disconnect automatically.
    This is the config under router ospf and static routes:

    !
    router ospf 100
    log-adjacency-changes
    network 10.0.0.0 0.0.0.255 area 0
    !
    ip route 192.168.0.0 255.255.255.0 172.168.1.1 150
    ip route 192.168.1.0 255.255.255.0 172.168.1.2 150
    ip route 192.168.2.0 255.255.255.0 172.168.1.3 150
    !

    From my understanding, when the routes see ospf, it will prefer to use
    ospf rather than static becuase the static route AD is 150 compared to
    OSPF 110.

    However, due to some changes made by my college, I noticed that under
    router ospf 100, there is command "redistribute static subnet"

    !
    router ospf 100
    log-adjacency-changes
    redistribute static subnet
    network 10.0.0.0 0.0.0.255 area 0
    !
    ip route 192.168.0.0 255.255.255.0 172.168.1.1 150
    ip route 192.168.1.0 255.255.255.0 172.168.1.2 150
    ip route 192.168.2.0 255.255.255.0 172.168.1.3 150

    From this config, when the primary link down, ISDN will take over but
    when is primary is back online, it still prefer the routes for static.
    For such, I need to clear static routes for each site(s) connected.

    It seems that the routes is still prefer to use static routes.It is
    because of the command or the AD in static routes defined?

    thanks in advance.

    maher
    maher, Dec 21, 2004
    #1
    1. Advertising

  2. maher

    Ben Guest

    maher wrote:
    > Hi there,
    >
    > My network is running OSPF and static route for ISDN connection for each
    > sites. Basically, I have redundancy whereby when the primary link is
    > down at site(s), ISDN connection will take over, and when the primary
    > link is back in action again, the ISDN will disconnect automatically.
    > This is the config under router ospf and static routes:
    >
    > !
    > router ospf 100
    > log-adjacency-changes
    > network 10.0.0.0 0.0.0.255 area 0
    > !
    > ip route 192.168.0.0 255.255.255.0 172.168.1.1 150
    > ip route 192.168.1.0 255.255.255.0 172.168.1.2 150
    > ip route 192.168.2.0 255.255.255.0 172.168.1.3 150
    > !
    >
    > From my understanding, when the routes see ospf, it will prefer to use
    > ospf rather than static becuase the static route AD is 150 compared to
    > OSPF 110.
    >
    > However, due to some changes made by my college, I noticed that under
    > router ospf 100, there is command "redistribute static subnet"
    >
    > !
    > router ospf 100
    > log-adjacency-changes
    > redistribute static subnet
    > network 10.0.0.0 0.0.0.255 area 0
    > !
    > ip route 192.168.0.0 255.255.255.0 172.168.1.1 150
    > ip route 192.168.1.0 255.255.255.0 172.168.1.2 150
    > ip route 192.168.2.0 255.255.255.0 172.168.1.3 150
    >
    > From this config, when the primary link down, ISDN will take over but
    > when is primary is back online, it still prefer the routes for static.
    > For such, I need to clear static routes for each site(s) connected.
    >
    > It seems that the routes is still prefer to use static routes.It is
    > because of the command or the AD in static routes defined?
    >
    > thanks in advance.
    >
    > maher


    Hi Maher,

    Is the administrative distance of 150 being carried into OSPF? (show ip
    route when the ISDN links are active)

    Ben
    Ben, Dec 22, 2004
    #2
    1. Advertising

  3. maher

    JNCIP#0136 Guest

    Hello,

    Is Your next-hop 172.168.1.1 by any chance indirect and therefore being
    resolved via OSPF when primary link is back UP?
    I would suggest to nail down the static route by telling the router that
    next-hop needs to be resolved via BRI/Dialer interface only:
    ip route 192.168.0.0 255.255.255.0 Dialer0 172.168.1.1 150
    For more info see http://www.cisco.com/warp/public/105/ip_static_routes.html
    HTH,
    Cheers
    Alex

    "maher" <> wrote in message
    news:cq9enr$bm7$...
    > Hi there,
    >
    > My network is running OSPF and static route for ISDN connection for each
    > sites. Basically, I have redundancy whereby when the primary link is
    > down at site(s), ISDN connection will take over, and when the primary
    > link is back in action again, the ISDN will disconnect automatically.
    > This is the config under router ospf and static routes:
    >
    > !
    > router ospf 100
    > log-adjacency-changes
    > network 10.0.0.0 0.0.0.255 area 0
    > !
    > ip route 192.168.0.0 255.255.255.0 172.168.1.1 150
    > ip route 192.168.1.0 255.255.255.0 172.168.1.2 150
    > ip route 192.168.2.0 255.255.255.0 172.168.1.3 150
    > !
    >
    > From my understanding, when the routes see ospf, it will prefer to use
    > ospf rather than static becuase the static route AD is 150 compared to
    > OSPF 110.
    >
    > However, due to some changes made by my college, I noticed that under
    > router ospf 100, there is command "redistribute static subnet"
    >
    > !
    > router ospf 100
    > log-adjacency-changes
    > redistribute static subnet
    > network 10.0.0.0 0.0.0.255 area 0
    > !
    > ip route 192.168.0.0 255.255.255.0 172.168.1.1 150
    > ip route 192.168.1.0 255.255.255.0 172.168.1.2 150
    > ip route 192.168.2.0 255.255.255.0 172.168.1.3 150
    >
    > From this config, when the primary link down, ISDN will take over but
    > when is primary is back online, it still prefer the routes for static.
    > For such, I need to clear static routes for each site(s) connected.
    >
    > It seems that the routes is still prefer to use static routes.It is
    > because of the command or the AD in static routes defined?
    >
    > thanks in advance.
    >
    > maher
    JNCIP#0136, Dec 22, 2004
    #3
  4. maher

    Ben Guest

    JNCIP#0136 wrote:
    > Hello,
    >
    > Is Your next-hop 172.168.1.1 by any chance indirect and therefore being
    > resolved via OSPF when primary link is back UP?
    > I would suggest to nail down the static route by telling the router that
    > next-hop needs to be resolved via BRI/Dialer interface only:
    > ip route 192.168.0.0 255.255.255.0 Dialer0 172.168.1.1 150
    > For more info see http://www.cisco.com/warp/public/105/ip_static_routes.html
    > HTH,
    > Cheers
    > Alex
    >
    > "maher" <> wrote in message
    > news:cq9enr$bm7$...
    >
    >>Hi there,
    >>
    >>My network is running OSPF and static route for ISDN connection for each
    >>sites. Basically, I have redundancy whereby when the primary link is
    >>down at site(s), ISDN connection will take over, and when the primary
    >>link is back in action again, the ISDN will disconnect automatically.
    >>This is the config under router ospf and static routes:
    >>
    >>!
    >>router ospf 100
    >>log-adjacency-changes
    >>network 10.0.0.0 0.0.0.255 area 0
    >>!
    >>ip route 192.168.0.0 255.255.255.0 172.168.1.1 150
    >>ip route 192.168.1.0 255.255.255.0 172.168.1.2 150
    >>ip route 192.168.2.0 255.255.255.0 172.168.1.3 150
    >>!
    >>
    >> From my understanding, when the routes see ospf, it will prefer to use
    >>ospf rather than static becuase the static route AD is 150 compared to
    >>OSPF 110.
    >>
    >>However, due to some changes made by my college, I noticed that under
    >>router ospf 100, there is command "redistribute static subnet"
    >>
    >>!
    >>router ospf 100
    >>log-adjacency-changes
    >>redistribute static subnet
    >>network 10.0.0.0 0.0.0.255 area 0
    >>!
    >>ip route 192.168.0.0 255.255.255.0 172.168.1.1 150
    >>ip route 192.168.1.0 255.255.255.0 172.168.1.2 150
    >>ip route 192.168.2.0 255.255.255.0 172.168.1.3 150
    >>
    >> From this config, when the primary link down, ISDN will take over but
    >>when is primary is back online, it still prefer the routes for static.
    >>For such, I need to clear static routes for each site(s) connected.
    >>
    >>It seems that the routes is still prefer to use static routes.It is
    >>because of the command or the AD in static routes defined?
    >>
    >>thanks in advance.
    >>
    >>maher

    >
    >
    >

    That's a very good point
    Ben, Dec 23, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. E.Finlayson
    Replies:
    0
    Views:
    1,535
    E.Finlayson
    Sep 10, 2004
  2. Wi-Fi and RFID Convergence

    , Jul 23, 2006, in forum: Wireless Networking
    Replies:
    0
    Views:
    477
  3. Replies:
    3
    Views:
    852
  4. German R

    Routes received by BGP and OSPF

    German R, Feb 5, 2007, in forum: Cisco
    Replies:
    1
    Views:
    432
    Thrill5
    Feb 6, 2007
  5. philbo30
    Replies:
    3
    Views:
    1,015
Loading...

Share This Page