Opening all links in tabs

Discussion in 'Firefox' started by FoxWolfie Galen, Dec 8, 2005.

  1. How do I get Firefox 1.5 to open all links in tabs, and never as a new
    window? These are never shockwave generated links, as all shockwave is
    blocked on my system. These are links that open in tabs when using version
    1.0.7, but open in a new window when using version 1.5. As far as I can
    tell, all tab-related settings are the same. I use no tab-related
    extensions in either version, other than UndoCloseTab.

    A good example of such a link would be on eBay. Go to any item page. Scroll
    down to just below the user's description to a section called "Shipping,
    payment details and return policy." Many, but not all, sellers will have a
    calculate shipping form with a "calculate" button on the right side of the
    screen. This is not the same as clicking on the "calculate shipping costs"
    link nearer to the top of the page, which does open in a new tab.

    Version 1.0.7 did as I desired without the need for an extension.

    Any ideas?
    --
    FoxWolfie
     
    FoxWolfie Galen, Dec 8, 2005
    #1
    1. Advertising

  2. FoxWolfie Galen

    gwtc Guest

    FoxWolfie Galen wrote:

    > How do I get Firefox 1.5 to open all links in tabs, and never as a new
    > window? These are never shockwave generated links, as all shockwave is
    > blocked on my system. These are links that open in tabs when using version
    > 1.0.7, but open in a new window when using version 1.5. As far as I can
    > tell, all tab-related settings are the same. I use no tab-related
    > extensions in either version, other than UndoCloseTab.
    >
    > A good example of such a link would be on eBay. Go to any item page. Scroll
    > down to just below the user's description to a section called "Shipping,
    > payment details and return policy." Many, but not all, sellers will have a
    > calculate shipping form with a "calculate" button on the right side of the
    > screen. This is not the same as clicking on the "calculate shipping costs"
    > link nearer to the top of the page, which does open in a new tab.
    >
    > Version 1.0.7 did as I desired without the need for an extension.
    >
    > Any ideas?

    in the address bar type in about:config and when it comes up look for
    the entry of:

    browser.tabs.opentabfor.windowopen

    Do you have it? If yes, and its set to True, then double click on it
    and change it to false.

    If no, then select any entry, then do a right click, and select New,
    Boolean, and in the first box enter the above, and in the next box
    enter false. You may have to restart FF for this to work.
     
    gwtc, Dec 8, 2005
    #2
    1. Advertising

  3. On Wed, 07 Dec 2005 19:34:13 -0800, gwtc
    <> wrote:

    > FoxWolfie Galen wrote:


    > > How do I get Firefox 1.5 to open all links in tabs, and never as a new
    > > window? These are never shockwave generated links, as all shockwave is
    > > blocked on my system. These are links that open in tabs when using
    > > version 1.0.7, but open in a new window when using version 1.5. As far
    > > as I can tell, all tab-related settings are the same. I use no
    > > tab-related extensions in either version, other than UndoCloseTab.


    > > A good example of such a link would be on eBay. Go to any item page.
    > > Scroll down to just below the user's description to a section called
    > > "Shipping, payment details and return policy." Many, but not all,
    > > sellers will have a calculate shipping form with a "calculate" button
    > > on the right side of the screen. This is not the same as clicking on
    > > the "calculate shipping costs" link nearer to the top of the page,
    > > which does open in a new tab.


    > > Version 1.0.7 did as I desired without the need for an extension.
    > > Any ideas?


    > in the address bar type in about:config and when it comes up look for
    > the entry of:


    > browser.tabs.opentabfor.windowopen


    > Do you have it? If yes, and its set to True, then double click on it
    > and change it to false.


    > If no, then select any entry, then do a right click, and select New,
    > Boolean, and in the first box enter the above, and in the next box
    > enter false. You may have to restart FF for this to work.


    Still no luck with this. The entry did not exist, so I added it, then
    closed and restarted Firefox. I still get new windows with the same links
    that result in new tabs under 1.0.7. I also brought up the about:config in
    version 1.0.7 and that entry did not exist there either, even though I
    always get new tabs there.

    My Firefox 1.0.7 and 1.5 both use their own profiles to avoid interfering
    with each other. Restarting 1.5 in safe mode still does not make it work.
    Restarting 1.0.7 in safe mode does not prevent that version from working.

    ....

    Ok, I've been browsing through documentation on the about:config options
    thanks to google. It appears that the "browser.tabs.opentabfor.windowopen"
    option is deprecated and has no function in the latest versions of Firefox.
    I located something else that solved my problem. I set an option called
    "browser.link.open_newwindow.restriction" to 0. All links now open in tabs,
    just as they did in 1.0.7. I check my Firefox 1.0.7, and this option was
    indeed set to 0. Everything is wonderful now.

    Here is the info on the option I changed. It was set to 2, and I changed it
    to 0.

    browser.link.open_newwindow.restriction

    0 = Redirect all window.open calls to new tabs without exception.

    1 = Do not divert any window.open calls (allow JavaScript to open new
    windows).

    2 = Redirect all window.open calls to new tabs unless the new window
    specifies how it should be displayed. (Default)

    Caveats

    * browser.link.open_newwindow must be set to 3 (redirect links opening
    in new windows to tabs) for this preference to have an effect.

    * Until recently, the default of this preference was 0.
    --
    FoxWolfie
     
    FoxWolfie Galen, Dec 8, 2005
    #3
  4. FoxWolfie Galen

    gwtc Guest

    FoxWolfie Galen wrote:

    > On Wed, 07 Dec 2005 19:34:13 -0800, gwtc
    > <> wrote:
    >
    >
    >>FoxWolfie Galen wrote:

    >
    >
    >>>How do I get Firefox 1.5 to open all links in tabs, and never as a new
    >>>window? These are never shockwave generated links, as all shockwave is
    >>>blocked on my system. These are links that open in tabs when using
    >>>version 1.0.7, but open in a new window when using version 1.5. As far
    >>>as I can tell, all tab-related settings are the same. I use no
    >>>tab-related extensions in either version, other than UndoCloseTab.

    >
    >
    >>>A good example of such a link would be on eBay. Go to any item page.
    >>>Scroll down to just below the user's description to a section called
    >>>"Shipping, payment details and return policy." Many, but not all,
    >>>sellers will have a calculate shipping form with a "calculate" button
    >>>on the right side of the screen. This is not the same as clicking on
    >>>the "calculate shipping costs" link nearer to the top of the page,
    >>>which does open in a new tab.

    >
    >
    >>>Version 1.0.7 did as I desired without the need for an extension.
    >>>Any ideas?

    >
    >
    >>in the address bar type in about:config and when it comes up look for
    >>the entry of:

    >
    >
    >>browser.tabs.opentabfor.windowopen

    >
    >
    >>Do you have it? If yes, and its set to True, then double click on it
    >>and change it to false.

    >
    >
    >>If no, then select any entry, then do a right click, and select New,
    >>Boolean, and in the first box enter the above, and in the next box
    >>enter false. You may have to restart FF for this to work.

    >
    >
    > Still no luck with this. The entry did not exist, so I added it, then
    > closed and restarted Firefox. I still get new windows with the same links
    > that result in new tabs under 1.0.7. I also brought up the about:config in
    > version 1.0.7 and that entry did not exist there either, even though I
    > always get new tabs there.
    >
    > My Firefox 1.0.7 and 1.5 both use their own profiles to avoid interfering
    > with each other. Restarting 1.5 in safe mode still does not make it work.
    > Restarting 1.0.7 in safe mode does not prevent that version from working.
    >
    > ...
    >
    > Ok, I've been browsing through documentation on the about:config options
    > thanks to google. It appears that the "browser.tabs.opentabfor.windowopen"
    > option is deprecated and has no function in the latest versions of Firefox.
    > I located something else that solved my problem. I set an option called
    > "browser.link.open_newwindow.restriction" to 0. All links now open in tabs,
    > just as they did in 1.0.7. I check my Firefox 1.0.7, and this option was
    > indeed set to 0. Everything is wonderful now.
    >
    > Here is the info on the option I changed. It was set to 2, and I changed it
    > to 0.
    >
    > browser.link.open_newwindow.restriction
    >
    > 0 = Redirect all window.open calls to new tabs without exception.
    >
    > 1 = Do not divert any window.open calls (allow JavaScript to open new
    > windows).
    >
    > 2 = Redirect all window.open calls to new tabs unless the new window
    > specifies how it should be displayed. (Default)
    >
    > Caveats
    >
    > * browser.link.open_newwindow must be set to 3 (redirect links opening
    > in new windows to tabs) for this preference to have an effect.
    >
    > * Until recently, the default of this preference was 0.

    thats the trouble with the developers. They have one program (1.0.7),
    then they come out with a new program (1.5) and change everything.
    What works in the old version doesn't work in the new one. They went
    and changed the freaken coding.
     
    gwtc, Dec 8, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Danny Colyer
    Replies:
    3
    Views:
    851
  2. Karl S
    Replies:
    1
    Views:
    565
  3. me
    Replies:
    3
    Views:
    627
  4. Nick Westaway

    Opening New Tabs

    Nick Westaway, Jan 5, 2005, in forum: Firefox
    Replies:
    4
    Views:
    713
    graeme@invalid
    Jan 8, 2005
  5. S.Rodgers
    Replies:
    13
    Views:
    1,749
    Doug G
    Dec 16, 2005
Loading...

Share This Page