Olympus C-730 UZ black screen

Discussion in 'Digital Photography' started by wackoid, Oct 25, 2004.

  1. wackoid

    wackoid Guest

    I have a year old Olympus C-730UZ which till recently had been serving
    me really well. However, a few days ago when I powered on the camera,
    all I could see was a black screen. I am able to go into the setup
    menu and everything else seems to work except being able to take
    pictures!!! Has anybody experienced this? What could be the issue? Any
    help will be appreciated. Thanks.
     
    wackoid, Oct 25, 2004
    #1
    1. Advertising

  2. wackoid

    SleeperMan Guest

    wackoid wrote:
    > I have a year old Olympus C-730UZ which till recently had been serving
    > me really well. However, a few days ago when I powered on the camera,
    > all I could see was a black screen. I am able to go into the setup
    > menu and everything else seems to work except being able to take
    > pictures!!! Has anybody experienced this? What could be the issue? Any
    > help will be appreciated. Thanks.


    hmmm...probably dead sensor or dead chip...
    in short, dead camera...
    I guess it's not under warranty any more? In any case, it's worthed to ask
    at the service what's up and if it's worthed to repair.

    BTW...you didn't forgot to take off lens cap, did ya...? :)
     
    SleeperMan, Oct 25, 2004
    #2
    1. Advertising

  3. wackoid

    TRRushing Guest

    In article <>,
    (wackoid) wrote:

    > I have a year old Olympus C-730UZ which till recently had been serving
    > me really well. However, a few days ago when I powered on the camera,
    > all I could see was a black screen. I am able to go into the setup
    > menu and everything else seems to work except being able to take
    > pictures!!! Has anybody experienced this? What could be the issue? Any
    > help will be appreciated. Thanks.


    When that happened to me fresh batteries did the trjck.

    --
    --
    troy rushing <>
     
    TRRushing, Oct 25, 2004
    #3
  4. wackoid

    wackoid Guest

    My first impression was also regarding the lens cap :) but I double
    checked. I will be taking it to the service center and see what could
    be the problem. I have an extended warranty and the camera is still
    under warranty so I might just be ok (touchwood ! ) Thanks.
    Atul

    "SleeperMan" <> wrote in message news:<Hx5fd.4750$>...
    > wackoid wrote:
    > > I have a year old Olympus C-730UZ which till recently had been serving
    > > me really well. However, a few days ago when I powered on the camera,
    > > all I could see was a black screen. I am able to go into the setup
    > > menu and everything else seems to work except being able to take
    > > pictures!!! Has anybody experienced this? What could be the issue? Any
    > > help will be appreciated. Thanks.

    >
    > hmmm...probably dead sensor or dead chip...
    > in short, dead camera...
    > I guess it's not under warranty any more? In any case, it's worthed to ask
    > at the service what's up and if it's worthed to repair.
    >
    > BTW...you didn't forgot to take off lens cap, did ya...? :)
     
    wackoid, Oct 26, 2004
    #4
  5. SleeperMan wrote:

    > wackoid wrote:
    >
    >>I have a year old Olympus C-730UZ which till recently had been serving
    >>me really well. However, a few days ago when I powered on the camera,
    >>all I could see was a black screen. I am able to go into the setup
    >>menu and everything else seems to work except being able to take
    >>pictures!!! Has anybody experienced this? What could be the issue? Any
    >>help will be appreciated. Thanks.

    >
    >
    > hmmm...probably dead sensor or dead chip...
    > in short, dead camera...
    > I guess it's not under warranty any more? In any case, it's worthed to ask
    > at the service what's up and if it's worthed to repair.
    >
    > BTW...you didn't forgot to take off lens cap, did ya...? :)
    >
    >

    What is "worthed" ???
     
    Jack-of-the-Dust, Oct 26, 2004
    #5
  6. wackoid

    SleeperMan Guest

    Jack-of-the-Dust wrote:
    > SleeperMan wrote:
    >
    >> wackoid wrote:
    >>
    >>> I have a year old Olympus C-730UZ which till recently had been
    >>> serving me really well. However, a few days ago when I powered on
    >>> the camera, all I could see was a black screen. I am able to go
    >>> into the setup menu and everything else seems to work except being
    >>> able to take pictures!!! Has anybody experienced this? What could
    >>> be the issue? Any help will be appreciated. Thanks.

    >>
    >>
    >> hmmm...probably dead sensor or dead chip...
    >> in short, dead camera...
    >> I guess it's not under warranty any more? In any case, it's worthed
    >> to ask at the service what's up and if it's worthed to repair.
    >>
    >> BTW...you didn't forgot to take off lens cap, did ya...? :)
    >>
    >>

    > What is "worthed" ???


    Oooops....i guess correct phrase would be "worthy"...right?
     
    SleeperMan, Oct 26, 2004
    #6
  7. wackoid

    SleeperMan Guest

    wackoid wrote:
    > My first impression was also regarding the lens cap :) but I double
    > checked. I will be taking it to the service center and see what could
    > be the problem. I have an extended warranty and the camera is still
    > under warranty so I might just be ok (touchwood ! ) Thanks.
    > Atul
    >


    good for you...
     
    SleeperMan, Oct 26, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Barry Parker

    Opinions on the Olympus C-730 Please.

    Barry Parker, Jul 13, 2003, in forum: Digital Photography
    Replies:
    9
    Views:
    475
    Barry Parker
    Jul 16, 2003
  2. Siddhartha Jain

    Kodak 6340/6440 vs Sony P72/P8 vs Olympus C 730/740

    Siddhartha Jain, Nov 28, 2003, in forum: Digital Photography
    Replies:
    3
    Views:
    625
    Siddhartha Jain
    Dec 2, 2003
  3. Tech Guy

    Differences between Olympus 730 and 740?

    Tech Guy, Jan 1, 2004, in forum: Digital Photography
    Replies:
    1
    Views:
    320
    Michael Meissner
    Jan 2, 2004
  4. Stuart Norris

    Remote Control for Olympus C-730

    Stuart Norris, Jan 3, 2004, in forum: Digital Photography
    Replies:
    1
    Views:
    507
    Hogleg44/40
    Jan 3, 2004
  5. wackoid

    Olympus C-730 UZ black screen

    wackoid, Oct 25, 2004, in forum: Digital Photography
    Replies:
    1
    Views:
    268
Loading...

Share This Page