Obscure file association puzzle

Discussion in 'Computer Support' started by Terry Pinnell, Aug 28, 2007.

  1. This is an odd one: when I d-click an AVI file in a Win XP folder, one
    of my other programs called Bulk Rename Utility (BRU) loads!

    It's obviously arisen because of something I've been doing this
    morning. I loaded a later version of VirtualDub, and re-associated AVI
    files with the new version. But I screwed up somehow and got into a
    mess. I eventually deleted the type AVI in Tools > Folder Options >
    File Types and added it back. But now it's disappeared from the list
    of file types. I can use 'Open With' OK, but get this bizarre
    behaviour when d-clicking.

    Any idea why BRU should have taken over please? More important, how
    can I fix? I should add that I also have a program called OpenExpert
    for managing my Open With results. (It lets me add as many extensions
    as I want, unlike XP which limits me to about 6 I think). But that
    seems to be working OK. It's just the basic association that has
    somehow got corrupted.

    --
    Terry, West Sussex, UK
    Terry Pinnell, Aug 28, 2007
    #1
    1. Advertising

  2. Terry Pinnell

    thanatoid Guest

    Terry Pinnell <> wrote in
    news::

    > This is an odd one: when I d-click an AVI file in a Win XP
    > folder, one of my other programs called Bulk Rename Utility
    > (BRU) loads!
    >
    > It's obviously arisen because of something I've been doing
    > this morning. I loaded a later version of VirtualDub, and
    > re-associated AVI files with the new version. But I screwed
    > up somehow and got into a mess. I eventually deleted the
    > type AVI in Tools > Folder Options > File Types and added
    > it back. But now it's disappeared from the list of file
    > types. I can use 'Open With' OK, but get this bizarre
    > behaviour when d-clicking.
    >
    > Any idea why BRU should have taken over please? More
    > important, how can I fix? I should add that I also have a
    > program called OpenExpert for managing my Open With
    > results. (It lets me add as many extensions as I want,
    > unlike XP which limits me to about 6 I think). But that
    > seems to be working OK. It's just the basic association
    > that has somehow got corrupted.


    I have never used anything beyond 98SE but I think the principle
    remains the same.

    I have found that, there being a finite combination of 3 or 4
    letters, many programs use the same file extension for some of
    their files, which have NOTHING to do with each other. For
    instance, not that I can give you a concrete one because I just
    don't remember, some PageMaker filters could use the same
    extension as a music editing program EQ settings or a picture
    database file.

    The computer being very stupid (remember, all it does is count
    0's and 1's, just very fast) can not tell the difference. The
    file extension is the only thing it has to go by. To make
    matters worse, those assholes at MS have decided the average
    user doesn't need to see the extensions and pretty but confusing
    and wasteful icons are enough - so the first thing I always do
    when I am in any situation is to switch that stupid default off,
    so you CAN see all the file extensions. (I won't even get into
    the security problems this has caused, enough has been said
    about that.)

    Since the computer sees the extension, it will open it with
    (usually) the last program that opened a file with that
    extension (and there could be more than two, even). Many
    programs automatically, without even asking you, associate file
    extensions "with themselves" every time you run them without any
    concern for the problem we are discussing.

    I have always believed that it is better to start a program and
    THEN open the file you want to work with. If you did that with
    all your files, you would not have the problem you have.

    So I feel the only solution for you may be to simply open the
    program first instead of clicking on the file in Explorer or
    whatever you use as a file manager. It takes a little more time
    but I have thought about this and I really don't think there is
    any way around it unless software writers come to an agreement
    about 5 digit file extensions and establish a central database
    to make sure nobody uses one that is already in use. Of course,
    we will be flying by flapping our ears before that happens.






    --
    "This is not nuclear. This is just a test."
    - illyria
    thanatoid, Aug 28, 2007
    #2
    1. Advertising

  3. Terry Pinnell

    ded Guest

    "Terry Pinnell" <> wrote in message
    news:...
    > This is an odd one: when I d-click an AVI file in a Win XP folder, one
    > of my other programs called Bulk Rename Utility (BRU) loads!
    >
    > It's obviously arisen because of something I've been doing this
    > morning. I loaded a later version of VirtualDub, and re-associated AVI
    > files with the new version. But I screwed up somehow and got into a
    > mess. I eventually deleted the type AVI in Tools > Folder Options >
    > File Types and added it back. But now it's disappeared from the list
    > of file types. I can use 'Open With' OK, but get this bizarre
    > behaviour when d-clicking.
    >
    > Any idea why BRU should have taken over please? More important, how
    > can I fix? I should add that I also have a program called OpenExpert
    > for managing my Open With results. (It lets me add as many extensions
    > as I want, unlike XP which limits me to about 6 I think). But that
    > seems to be working OK. It's just the basic association that has
    > somehow got corrupted.
    >
    > --
    > Terry, West Sussex, UK


    You have to be logged on as administrator to change file associations
    that a third party application has taken control of, then re-associate
    AVI with WMP, then try re-associating AVI with the newly installed
    version of VirtualDub, which maybe a corrupt install?
    Or, as it was this morning, uninstall VirtualDub and try a system restore
    point prior to the mess.
    ded, Aug 28, 2007
    #3
  4. "ded" <> wrote:

    >
    >"Terry Pinnell" <> wrote in message
    >news:...
    >> This is an odd one: when I d-click an AVI file in a Win XP folder, one
    >> of my other programs called Bulk Rename Utility (BRU) loads!
    >>
    >> It's obviously arisen because of something I've been doing this
    >> morning. I loaded a later version of VirtualDub, and re-associated AVI
    >> files with the new version. But I screwed up somehow and got into a
    >> mess. I eventually deleted the type AVI in Tools > Folder Options >
    >> File Types and added it back. But now it's disappeared from the list
    >> of file types. I can use 'Open With' OK, but get this bizarre
    >> behaviour when d-clicking.
    >>
    >> Any idea why BRU should have taken over please? More important, how
    >> can I fix? I should add that I also have a program called OpenExpert
    >> for managing my Open With results. (It lets me add as many extensions
    >> as I want, unlike XP which limits me to about 6 I think). But that
    >> seems to be working OK. It's just the basic association that has
    >> somehow got corrupted.
    >>
    >> --
    >> Terry, West Sussex, UK

    >
    >You have to be logged on as administrator to change file associations
    >that a third party application has taken control of, then re-associate
    >AVI with WMP, then try re-associating AVI with the newly installed
    >version of VirtualDub, which maybe a corrupt install?
    >Or, as it was this morning, uninstall VirtualDub and try a system restore
    >point prior to the mess.
    >


    Thanks.

    "Newbie Coder" <> wrote:

    >Terry,
    >
    >If you can use OPEN WITH then instead of selecting an application from the list
    >click BROWSE instead. Now locate an application you know to work with AVI files,
    >select it & tick the box ALWAYS USE THIS APPLICATION... & then you should get a
    >Desktop refresh & be back to normal. If not, please post back


    Happily I managed to fix it after several attempts, reboots, etc.
    Basically I think I removed it from File Types and added it back. This
    was my second attempt to do that. First time didn't work, maybe
    because I didn't enter a 'Type', or add "%1" after the executable, or
    enter 'Topic' into the System box (whatever that means). Or none of
    those reasons. But anyway this time thankfully it did work, and I can
    d-click AVIs and get VirtualDub opening again.

    That Open With + 'always use' approach unfortunately no longer works
    for me. Maybe because of OpenExpert. However, I've also found that
    sometimes you can't use it anyway, because it's greyed and/or the
    program you're trying to associate already *appears* to be associated.
    IYKWIM.

    In general, I'm underwhelmed with the way Windows handles file
    associations. This is by no means the first bizarre issue I've had.

    The author of BRU confirms it's nothing directly to do with BRU, just
    a Win XP screw-up. Why it latched onto BRU I'll never know!

    I suppose I could also have tackled this with the ASSOC tool I
    described in my recent post 'File association quirks', but glad I
    didn't have to resort to that (or a system restore).

    --
    Terry, West Sussex, UK
    Terry Pinnell, Aug 28, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. zeeeej
    Replies:
    1
    Views:
    433
    Hendrik Maryns
    Apr 24, 2006
  2. KING B MAN
    Replies:
    58
    Views:
    1,279
    Becky
    Apr 21, 2004
  3. Borkin

    Obscure DVD trivia question

    Borkin, Apr 13, 2005, in forum: DVD Video
    Replies:
    0
    Views:
    369
    Borkin
    Apr 13, 2005
  4. -Lost
    Replies:
    3
    Views:
    803
  5. sk

    A puzzle to puzzle you

    sk, Jul 17, 2004, in forum: A+ Certification
    Replies:
    1
    Views:
    613
    Geoff
    Jul 17, 2004
Loading...

Share This Page